Porovnání dvou tabulek a vyhledání chybějících záznamů

Můžete porovnat dvě tabulky a identifikovat záznamy v jedné tabulce, které nemají odpovídající záznamy v druhé tabulce. Nejjednodušší způsob, jak tyto záznamy identifikovat, je použití Průvodce vyhledávacím dotazem na chybějící záznamy. Jakmile průvodce vytvoří dotaz, můžete jeho návrh upravit – přidat nebo odebrat pole, nebo přidat spojení mezi tabulkami (k označení polí, jejichž hodnoty si mají odpovídat). Můžete také chybějící záznamy vyhledat pomocí vlastního dotazu, který si vytvoříte bez průvodce.

Tento článek popisuje, jak spustit a používat Průvodce vyhledávacím dotazem na chybějící záznamy, jak změnit výstup tohoto průvodce a jak vytvořit vlastní dotaz pro vyhledání chybějících záznamů.

Poznámka : Průvodce vyhledávacím dotazem na chybějící záznamy není podporovaný ve webových aplikacích pro Access ani webových databázích.

V tomto článku

Kdy mám hledat chybějící záznamy?

Použití Průvodce vyhledávacím dotazem na chybějící záznamy k porovnání dvou tabulek

Vytvoření a úprava vyhledávacího dotazu na chybějící záznamy pro porovnání podle více než jednoho pole

Vytvoření vlastního dotazu pro vyhledání chybějících záznamů

Kdy mám hledat chybějící záznamy?

Zde jsou dvě běžné situace, ve kterých je užitečné porovnat dvě tabulky a vyhledat chybějící záznamy. V závislosti na konkrétní situaci může být vyhledání chybějících záznamů prvním z několika kroků, které je potřeba provést. Tento článek popisuje pouze vyhledání chybějících záznamů.

  • Jednu tabulku můžete použít k uložení dat týkajících se určité věci (například výrobku) a druhou k uložení dat určitých činností (například objednávek).    

    V šabloně databáze Northwind jsou například data o výrobcích uložena v tabulce Výrobky. Data o tom, které výrobky jsou zahrnuty do jednotlivých objednávek, jsou v tabulce Rozpis objednávek. Vzhledem k tomu, že v tabulce Výrobky nejsou standardně žádná data o objednávkách, není možné ze samotné tabulky Výrobky určit, které výrobky nebyly nikdy prodány. Tyto informace nelze zjistit ani ze samotné tabulky Rozpis objednávek, protože ta obsahuje pouze data o výrobcích, které byly prodány. Je proto potřeba tyto dvě tabulky porovnat, a tak zjistit, které výrobky nebyly nikdy prodány.

    Pokud chcete zobrazit seznam objektů z první tabulky, pro které neexistují žádné odpovídající akce v druhé tabulce, můžete použít vyhledávací dotaz na chybějící záznamy.

  • Máte dvě tabulky, které obsahují překrývající se, nadbytečné nebo konfliktní informace, a chcete je sloučit do jedné tabulky.    

    Předpokládejme například, že máte jednu tabulku s názvem Zákazníci a druhou s názvem Klienti. Tabulky jsou téměř shodné, avšak jedna nebo obě obsahují určité záznamy, které v druhé tabulce chybí. Chcete-li tyto tabulky sloučit, je nutné určit, které záznamy jsou jedinečné pro jednu nebo druhou tabulku.

    Pokud řešíte podobnou situaci, mohou být metody popsané v tomto článku užitečné, bude ale pravděpodobně nutné provést další kroky. Pomocí Průvodce vyhledávacím dotazem na chybějící záznamy můžete identifikovat chybějící záznamy, ale pokud chcete načíst sloučenou sadu záznamů, vytvořte pomocí výsledků sjednocovací dotaz. Pokud víte, jak psát příkazy jazyka SQL (Structured Query Language), pak se obejdete i bez Průvodce vyhledávacím dotazem na chybějící záznamy – sjednocovací dotaz můžete napsat ručně.

    Problém s překrývajícími se, nadbytečnými nebo konfliktními informacemi můžete často vyřešit vyhledáním duplicitních dat ve dvou nebo více tabulkách.

Další informace o sjednocovacích dotazech nebo o vyhledávání, skrývání či odstraňování duplicitních dat zobrazíte, když kliknete na odkazy v části Viz také.

Poznámka : V příkladech v tomto článku se používá databáze vytvořená pomocí šablony databáze Northwind.

Postup nastavení databáze Northwind

  1. Na kartě Soubor klikněte na Nový. Pokud používáte Access 2007, klikněte na tlačítko Microsoft Office Obrázek tlačítka a pak na Nová.

  2. V závislosti na vaší verzi Accessu vyhledáte databázi Northwind buď pomocí vyhledávacího pole, nebo tak, že v levém podokně kliknete v části Kategorie šablon na Místní šablony.

  3. V části Místní šablony klikněte na Ukázková databáze Northwind 2007 a potom klikněte na Vytvořit.

  4. Podle pokynů na stránce Northwind Traders (na kartě objektu Úvodní obrazovka) otevřete databázi a potom zavřete přihlašovací dialogové okno.

Začátek stránky

Použití Průvodce vyhledávacím dotazem na chybějící záznamy k porovnání dvou tabulek

  1. Na kartě Vytvoření klikněte ve skupině Dotazy na Průvodce dotazem. Poznámka: Pokud používáte Access 2007, na kartě Vytvoření klikněte ve skupině Jiné na Průvodce dotazem.

    Skupina Dotazy na pásu karet Accessu zobrazuje dvě možnosti: Průvodce dotazem a Návrh dotazu
  2. V dialogovém okně Nový dotaz poklikejte na položku Průvodce vyhledávacím dotazem na chybějící záznamy.

  3. Na první stránce průvodce vyberte tabulku s chybějícími záznamy a poté klikněte na tlačítko Další. Chcete-li například zobrazit seznam výrobků Northwind, které nebyly nikdy prodány, vyberte tabulku Výrobky.

    V dialogovém okně Průvodce vyhledávacím dotazem na chybějící záznamy vyberte tabulku nebo dotaz.
  4. Na druhé stránce vyberte tabulku, která je v relaci, a klikněte na tlačítko Další. V tomto příkladu vyberte tabulku Rozpis objednávek.

    V dialogovém okně Průvodce vyhledávacím dotazem na chybějící záznamy vyberte tabulku nebo dotaz se souvisejícími záznamy.
  5. Na třetí stránce vyberte pole, která vytváří relaci mezi tabulkami, klikněte na tlačítko < = > a poté na tlačítko Další. Z každé tabulky můžete zvolit pouze jedno pole. V našem příkladu vyberte pole Kód z tabulky Výrobky a pole Kód výrobku z tabulky Rozpis objednávek. Zkontrolujte text v poli Odpovídající pole a ověřte, zda jsou porovnávána správná pole.

    V dialogovém okně Průvodce vyhledávacím dotazem na chybějící záznamy vyberte v tabulkách odpovídající pole.

    Pole Kód a Kód výrobku mohou již být vybrána z důvodu existujících relací předdefinovaných v šabloně.

  6. Na čtvrté stránce poklikejte na pole, která chcete zobrazit z první tabulky, a poté klikněte na tlačítko Další. V tomto příkladu vyberte pole Kód a Název výrobku.

    V dialogovém okně Průvodce vyhledávacím dotazem na chybějící záznamy vyberte pole, která chcete zahrnout do výstupu dotazu.
  7. Na páté stránce můžete zobrazit výsledky nebo upravit návrh dotazu. V tomto příkladu klikněte na přepínač Zobrazit výsledky. Přijměte navržený název dotazu a klikněte na tlačítko Dokončit.

    V dialogovém okně Průvodce vyhledávacím dotazem na chybějící záznamy zadejte název dotazu na chybějící záznamy.

    Může se stát, že budete chtít úpravou návrhu dotazu přidat další kritéria, změnit pořadí řazení, případně nebo přidat nebo odebrat pole. Další informace o úpravě vyhledávacího dotazu na chybějící záznamy najdete v následující části. Další obecné informace o vytváření a úpravě dotazů pak zobrazíte, když kliknete na odkazy v části Viz také.

Začátek stránky

Vytvoření a úprava vyhledávacího dotazu na chybějící záznamy pro porovnání podle více než jednoho pole

  1. Na kartě Vytvoření klikněte ve skupině Dotazy na Průvodce dotazem. Poznámka: Pokud používáte Access 2007, na kartě Vytvoření klikněte ve skupině Jiné na Průvodce dotazem.

  2. V dialogovém okně Nový dotaz poklikejte na položku Průvodce vyhledávacím dotazem na chybějící záznamy.

  3. Na první stránce průvodce vyberte tabulku s chybějícími záznamy a poté klikněte na tlačítko Další. Chcete-li například zobrazit seznam výrobků Northwind, které nebyly nikdy prodány, vyberte tabulku Výrobky.

  4. Na druhé stránce vyberte tabulku, která je v relaci, a klikněte na tlačítko Další. V tomto příkladu vyberte tabulku Rozpis objednávek.

  5. Na třetí stránce vyberte pole, která vytváří relaci mezi tabulkami, klikněte na < = > a pak klikněte na Další. Z každé tabulky můžete zvolit pouze jedno pole. V našem příkladu vyberte pole Kód z tabulky Výrobky a pole Kód výrobku z tabulky Rozpis objednávek. Zkontrolujte text v poli Odpovídající pole a ověřte, zda jsou porovnávána správná pole. Zbývající pole můžete spárovat po dokončení průvodce.

    Pole Kód a Kód výrobku mohou již být vybrána z důvodu existujících relací předdefinovaných v šabloně.

  6. Na čtvrté stránce poklikejte na pole, která chcete zobrazit z první tabulky, a poté klikněte na tlačítko Další. V tomto příkladu vyberte pole Kód a Název výrobku.

  7. Na páté stránce klikněte na Změnit návrh a potom na Dokončit.

    Dotaz se otevře v návrhovém zobrazení.

  8. V návrhové mřížce dotazu jsou dvě tabulky spojené v polích, které jste určili na třetí stránce průvodce (v tomto příkladu Kód a Kód výrobku). Vytvořte spojení pro každou zbývající dvojici souvisejících polí přetažením z první tabulky (tabulka s chybějícími záznamy) do druhé tabulky. V tomto příkladu tedy přetažením pole Ceníková cena z tabulky Výrobky na pole Cena za kus v tabulce Rozpis objednávek.

  9. Poklikáním na spojení (čára spojující pole) zobrazíte dialogové okno Vlastnosti spojení. U každého spojení zvolte možnost, která zahrnuje všechny záznamy z tabulky Výrobky, a pak klikněte na OK.

    V návrhové mřížce dotazu má každé spojení na jednom konci šipku.

    Typ spojení je označen stylem čáry.

    1. Spojením, které vytvoříte mezi poli Ceníková cena a Cena za kus, se omezí výstup z obou tabulek. Ve výsledcích dotazu jsou zahrnuty pouze záznamy s odpovídajícími daty v polích v obou tabulkách.

    2. Po úpravě vlastností spojení bude toto spojení omezovat pouze tabulku, na kterou ukazuje šipka. Ve výsledcích dotazu budou zahrnuty všechny záznamy v tabulce, ze které šipka vychází.

    Poznámka : Zkontrolujte, zda všechny šipky na spojeních směřují stejným směrem.

  10. U tabulky se souvisejícími záznamy (v tomto příkladu tabulka Rozpis objednávek) poklikejte na každé pole propojené s první tabulkou s výjimkou pole, které jste vybrali na třetí stránce průvodce (v tomto případě pole Kód výrobku). U každého z těchto polí zrušte zaškrtnutí políčka v řádku Zobrazit a zadejte hodnotu Is Null do řádku Kritéria.

  11. Dále můžete přidat kritéria do dalších polí dotazu nebo vytvořit počítaná pole založená na hodnotách z první tabulky.

  12. Na kartě Návrh klikněte ve skupině Výsledky na tlačítko Spustit.

    Dotaz vrátí názvy výrobků, které nejsou součástí žádných existujících objednávek.

Začátek stránky

Vytvoření vlastního dotazu pro vyhledání chybějících záznamů

  1. Na kartě Vytvoření klikněte ve skupině Dotazy na Návrh dotazu. Poznámka: Pokud používáte Access 2007, na kartě Vytvoření klikněte ve skupině Jiné na Návrh dotazu.

  2. V dialogovém okně Zobrazit tabulku poklikejte na tabulku, která obsahuje chybějící záznamy, a poté poklikejte na tabulku se souvisejícími záznamy.

  3. Zavřete dialogové okno Zobrazit tabulku.

  4. V návrhové mřížce dotazu by měly mít tyto dvě tabulky čáry, kterým se říká spojení a které tyto tabulky spojují pomocí souvisejících polí. Pokud spojení chybí, vytvořte je přetažením každého souvisejícího pole z první tabulky (tabulka s chybějícími záznamy) do druhé tabulky (tabulka se souvisejícími záznamy).

  5. Když poklikáte na spojení, otevře se dialogové okno Vlastnosti spojení. U každého spojení vyberte možnost 2 a potom klikněte na OK.

    V návrhové mřížce dotazu se spojení změní tak, že mají na jednom konci šipku.

    Poznámka : Zkontrolujte, jestli všechna spojení směřují stejným směrem. Dotaz se nespustí, pokud tomu tak není, a nemusí se spustit, pokud některé spojení nemá šipku. Spojení by měla směřovat od tabulky s chybějícími záznamy.

  6. V tabulce s chybějícími záznamy poklikejte na pole, která se mají dotazem vrátit.

    Případně zadejte kritéria pro některá z těchto polí nebo vytvořte počítaná pole.

  7. U tabulky se souvisejícími záznamy poklikejte na každé pole, které je spojeno s první tabulkou. U každého z těchto polí zrušte zaškrtnutí políčka v řádku Zobrazit a do řádku Kritéria zadejte hodnotu Is Null.

  8. Na kartě Návrh klikněte ve skupině Výsledky na tlačítko Spustit.

Začátek stránky

Viz taky

Vytvoření jednoduchého výběrového dotazu

Vyhledání duplicitních záznamů pomocí dotazu

Sloučení několika dotazů do jednoho výsledku pomocí sjednocovacího dotazu

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×