Přidání spojnic mezi obrazce ve Visiu

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Visio usnadňuje spojování obrazců ve výkresu. Automatické spojování spojuje obrazce při přidávání a existující obrazce můžete spojit pomocí nástroje Spojnice.

Toto téma obsahuje následující části:

Typy připojení

Spojnice může mít s obrazcem jeden ze dvou typů spojení: bodové spojení nebo dynamické propojení. Bodové spojení zachovává spojnici připevněnou k určitému bodu na obrazci, a to i v případě, že je tento obrazec přesunut nebo otočen. Dynamické spojení umožňuje spojnici měnit umístění na obrazci tak, aby se spojnice při přesouvání nebo otáčení obrazce přesouvala ke spojovacímu bodu na obrazci, který se nachází nejblíže původnímu bodu spojnice.

V následujícím diagramu má obrazec A bodové spojení s obrazcem C. Kdykoli se tak obrazec C přesune, spojnice z obrazce A zůstane připojená ke stejnému bodu na obrazci C. Naopak obrazec B má s obrazcem C dynamické spojení a spojnice z obrazce B se přesouvá na spojovací bod, který je na obrazci C nejblíže.

A má bodové spojení s C, ale B má dynamické spojení s C.

Na každém konci spojnice můžete mít kterýkoliv z uvedených typů spojení. Pokud ke spojení obrazců použijete funkci automatického spojení, budou mít oba konce dynamické spojení. V případě ručního vybírání místa, kde má být spojnice připojená k obrazci, můžete určit typ připojení. Další informace o určení a změně typu připojení najdete v části Spojení obrazců, které už jsou na stránce dále v tomto tématu.

Automatické spojení přidávaných obrazců

Jednou z možností spojení obrazců je nechat je ve Visiu spojovat automaticky při přidávání obrazců do výkresu. To je vhodné zejména při vytváření vývojového diagramu.

Pomocí následujícího postupu přidáte do výkresu obrazec, který aplikace Visio automaticky spojí s existujícím obrazcem.

Poznámka : Před použitím následujícího postupu zkontrolujte, že je funkce automatického spojení aktivní. Na kartě Zobrazení ve skupině Vizuální pomůcky ověřte, že je zaškrtnuté políčko Automaticky připojit.

Přidání obrazce a jeho automatické připojení ke stávajícímu obrazci
  1. Pokud na stránce ještě nejsou žádné obrazce, přetáhněte na ni obrazec z okna Obrazce.

  2. Podržte ukazatel myši na obrazci, dokud se kolem něj nezobrazí šipky pro automatické spojení.

    Když je funkce automatického spojení aktivní, najeďte myší na obrazec, aby se zobrazily šipky spojení.

    Pokud se nezobrazí šipky pro automatické spojení, zkontrolujte na kartě Zobrazení, jestli je zaškrtnuté políčko Automaticky připojit.

  3. Podržte ukazatel myši nad šipkou v tom směru, kam chcete přidat obrazec.

    Když na šipku automatického spojení najedete myší, zobrazí se panel nástrojů s obrazci, které můžete přidat.

    Zobrazí se minipanel nástrojů obsahující první čtyři rychlé obrazce, které jsou momentálně ve vzorníku Rychlé obrazce. Pokud nastavíte ukazatel myši na obrazec na panelu nástrojů, Visio zobrazí náhled tohoto obrazce na stránce.

  4. Klikněte na obrazec, který chcete přidat.

  5. Pokud chcete pokračovat, přejděte myší na šipku automatického připojení na nově přidaném obrazci a přidejte jiný obrazec, který bude také automaticky připojen.

    Když na nově přidaný obrazec najedete myší, zobrazí se šipky automatického spojení pro přidání dalšího obrazce.

Poznámka : Pokud chcete použít jiný obrazec z obrazců na minipanelu nástrojů, přetáhněte obrazec, který chcete, z okna Obrazce na místo na stránce. Když budete chtít obrazec připojit, použijte metodu popsanou v části Spojení obrazců, které už jsou na stránce dále v tomto tématu.

Spojení obrazců, které už jsou na stránce

Samozřejmě můžete spojit obrazce, které jsou už ve výkresu, a to pomocí funkce automatického spojení, nebo pomocí nástroje Spojnice.

Ke spojování obrazců můžete použít jeden ze dvou typů spojení: bodové spojení nebo dynamické spojení. Další informace o těchto typech spojení najdete v části Typy připojení dříve v tomto tématu.

Pokud chcete vytvořit připojení, nechejte spojnici připevněnou k určitému bodu na obrazci, přetáhněte ukazatel myši ze spojovacího bodu na prvním obrazci do spojovacího bodu na druhém obrazci. Jakmile jsou obrazce propojeny, koncové body spojnice zezelenají.

Přichycením spojnice k určitému bodu na obrazci připevníte spojnici k tomuto bodu.
Přichycením spojnice k určitému bodu na obrazci připevníte spojnici k tomuto bodu.

Pokud chcete vytvořit dynamické spojení, aby se mohla spojnice přesouvat automaticky na nejbližší body na obrazci, umístěte nástroj Spojnice na střed prvního obrazce tak, aby se kolem obrazce zobrazil zelený rámeček. Podržte tlačítko myši stisknuté a přetáhněte ukazatel myši na střed druhého obrazce. Jakmile se kolem druhého obrazce zobrazí zelený rámeček, tlačítko myši uvolněte.

Přichycením spojnice k obrazci umožníte dynamické přesouvání spojnice k bodům na obrazci.
Přichycením spojnice k obrazci umožníte dynamické přesouvání spojnice k bodům na obrazci.

Spojení existujících obrazců pomocí funkce automatického spojení

  1. Podržte ukazatel myši nad obrazcem, dokud se kolem něj nezobrazí šipky pro automatické spojení.

    Když je funkce automatického spojení aktivní, najeďte myší na obrazec, aby se zobrazily šipky spojení.
  2. Klikněte na šipku pro automatické spojení, přetáhněte ji na jiný obrazec a umístěte koncový bod spojnice na střed obrazce dynamického spojení nebo na určitý spojovací bod na obrazci pro bodové spojení.

    Náhled obrazce se zobrazí, když podržíte ukazatel myši na šipce automatického spojení, přičemž ale můžete obrazec ignorovat. Po přetažení spojnice do cílového místa zmizí.

Spojení obrazců pomocí nástroje Spojnice
  1. Na kartě Domů klikněte ve skupinovém rámečku Nástroje na položku Spojnice.

    Nástroj Spojnice spojuje obrazce s bodovým spojením na každém konci.
  2. Klikněte na obrazec a přetáhněte spojnici na jiný obrazec.

  3. Potom na kartě Domů klikněte ve skupině Nástroje na tlačítko Ukazatel.

Rychlé úkoly

Úkol

Akce

Změna typu spojnice na pravoúhlý, přímý a zakřivený

Klikněte pravým tlačítkem myši na spojnici a pak v místní nabídce klikněte na typ spojnice: pravoúhlý, přímý a zakřivený.

Zarovnání obrazců a sjednocení jejich mezer tak, aby byly spojnice čisté

Vyberte všechny obrazce, které chcete vyrovnat, a pak klikněte na kartě Domů ve skupině Uspořádat na Zarovnat > Automatické zarovnání nebo Umístění > Automatické mezery. Více obrazců můžete vybrat stisknutím klávesy Ctrl a kliknutím na všechny požadované obrazce nebo pomocí některé z možností Vybrat na kartě Domů ve skupině Úpravy.

Změna spojení z dynamického na bodové nebo naopak

Vyberte spojnici a přetáhněte její koncový bod mimo obrazec. Poté umístěte konektor na určitý bod bodového spojení nebo na střed obrazce dynamického spojení.

Zapnutí či vypnutí funkce automatického spojení

Funkci automatického spojení můžete aktivovat a deaktivovat ve všech výkresech Visia, nebo také jenom v aktivním výkresu.

Zapnutí nebo vypnutí funkce automatického spojení v aktivním diagramu
  • Na kartě Zobrazení zaškrtněte ve skupinovém rámečku Vizuální pomůcky políčko Automaticky připojit.

    Zaškrtnutím nebo zrušením zaškrtnutí políčka Automaticky připojit na kartě Zobrazení můžete aktivovat nebo deaktivovat funkci automatického spojení.

Poznámka : Pokud zaškrtávací políčko Automaticky připojit není dostupné, zkontrolujte pomocí následujícího postupu, jestli není funkce automatického spojení vypnuta pro všechny diagramy.

Zapnutí nebo vypnutí funkce automatického spojení ve všech diagramech
  1. Klikněte na kartu Soubor a pak na tlačítko Možnosti.

  2. V dialogovém okně Možnosti aplikace Visio klikněte na Upřesnit.

  3. Ve skupinovém rámečku Možnosti úprav zaškrtnutím políčka Povolit automatické spojení zapnete funkci automatického spojení. Pokud chcete funkci automatického spojení vypnout, zaškrtnutí tohoto políčka zrušte.

    Zaškrtnutím nebo zrušením zaškrtnutí políčka Povolit automatické spojení můžete aktivovat nebo deaktivovat funkci automatického spojení pro všechny diagramy a výkresy.
  4. Klikněte na tlačítko OK.

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Byly tyto informace užitečné?

Výborně! Je ještě něco dalšího, co byste nám chtěli dát vědět?

Jak bychom ho mohli vylepšit?

Děkujeme vám za zpětnou vazbu.

×