Přechod na aplikaci Access 2010

Základní informace

Přechod na aplikaci Access 2010 z předchozí verze Pokud jste zkušeným uživatelem aplikace Access, je tento kurz určen vám. Tento kurz vysvětluje,jak přejít na aplikaci Access 2010 z předchozí verze. Dozvíte se, jak v aplikaci Access 2010 provádět známé úkoly, jako je používání existujících databází, vytváření nových databází, vytváření tabulek nebo vytváření a úpravy formulářů a sestav.

Po dokončení tohoto kurzu budete schopni:

  • Používat zobrazení Backstage k otvírání existujících databází a vytváření nových databází

  • Uložit existující databázi jako soubor aplikace Access 2010

  • Používat pás karet k otvírání návrhového zobrazení tabulek, formulářů, sestav a dotazů

  • Používat zobrazení rozložení k úpravám formulářů a sestav

  • Používat zobrazení rozložení k seskupování dat v sestavách

Tento kurz obsahuje:

  • Jednu lekci určenou pro práci vlastním tempem

  • Krátký test na konci lekce. Test není hodnocen.

  • Stručnou referenční kartu, kterou si můžete na konci kurzu vytisknout

V tomto kurzu se předpokládá, že máte s aplikací Access alespoň střední úroveň zkušeností – vytvořili jste několik databází a rozumíte základům návrhu databáze a relací mezi tabulkami. Pokud s aplikací Access začínáte, přejděte k článku Začínáme s aplikací Access 2010.

Offline verze (71,1 MB)

Začínáme s aplikací Access 2010

Your browser does not support video. Install Microsoft Silverlight, Adobe Flash Player, or Internet Explorer 9.

Začínáme v navigačním podokně

Your browser does not support video. Install Microsoft Silverlight, Adobe Flash Player, or Internet Explorer 9.

Seznámení s pásem karet

Your browser does not support video. Install Microsoft Silverlight, Adobe Flash Player, or Internet Explorer 9.

Použití souborů z předchozích verzí aplikace Access

Your browser does not support video. Install Microsoft Silverlight, Adobe Flash Player, or Internet Explorer 9.

Začínáme rychle se šablonami a webovými databázemi

Your browser does not support video. Install Microsoft Silverlight, Adobe Flash Player, or Internet Explorer 9.

Rychlý návrh v zobrazení rozložení

Your browser does not support video. Install Microsoft Silverlight, Adobe Flash Player, or Internet Explorer 9.

Doporučené kroky praktického cvičení

Pokud máte určité zkušenosti s aplikací Access 2003 nebo dřívější – vytvořili jste několik malých databází nebo i více, je tento kurz určen pro vás. Zde jsou některé doporučené způsoby, jak můžete procvičit to, co jste uviděli v kurzu.

Důležité:    K provedení těchto kroků je nutné mít v počítači nainstalovanou aplikaci Access 2010 a je vyžadováno připojení k Internetu.

Vytvoření nové prázdné databáze

K provedení těchto kroků můžete použít některé z vlastních schémat databáze.

  1. Spusťte aplikaci Access 2010. Automaticky se spustí v zobrazení Backstage.

  2. Klikněte na kartu Nový. Je vybrána šablona Prázdná databáze.

  3. Na pravé straně karty zadejte do pole Název souboru název nové databáze.

  4. Chcete-li, můžete kliknout na ikonu složky umístěnou vpravo od pole Název souboru.

    Tím se otevře dialogové okno Nový databázový soubor, ve kterém můžete zvolit jiné umístění nové databáze.

  5. Klikněte na tlačítko Vytvořit.

    Databáze se otevře a zobrazí se prázdná tabulka v zobrazení Datový list, abyste mohli přidávat pole.

Přidání polí do tabulky

Aplikace Access nabízí několik způsobů, jak přidávat pole do tabulky. Zde jsou některé nejobvyklejší.

  1. Pokud je tabulka otevřena v zobrazení Datový list, ujistěte se, že jste na kartě Pole (pokud ne, klikněte na ni).

  2. Ve skupině Přidat a odstranit otevřete seznam Další pole.

  3. V dolní části seznamu klikněte v části Rychlé zahájení na položku Název.
    Seznam Další pole

  4. Vpravo od nových polí klikněte na záhlaví prázdného pole (s nápisem Kliknutím přidat) a potom opakováním kroku 4 přidejte do tabulky pole AdresaaTelefon .

  5. Klikněte pravým tlačítkem myši na záhlaví prázdného pole (s nápisem Kliknutím přidat) a v zobrazeném seznamu vyberte položku Memo.

    Tím se přidá nové pole, nastaví jeho datový typ a umožní přepsání názvu pole v záhlaví.

  6. V záhlaví pole zadejte název Komentáře a kliknutím mimo záhlaví potvrďte provedené změny.

Navigace v navigačním podokně

Poznámka:    K provedení těchto kroků potřebujete připojení k Internetu. Začněte tím, že stáhnete ukázkovou databázi Northwind. Provedete to tak, že kliknete na kartu Nový a potom kliknete na položku Ukázkové šablony. Projevte důvěru k této databázi (na žlutém panelu zpráv klikněte na možnost Povolit obsah) a přihlaste se k ní.

  1. Navigační podokno je v této šabloně zavřené, otevřete je proto kliknutím na dvojitou šipku.

    Tlačítko k otevření nebo zavření navigačního podokna

  2. V navigačním podokně klikněte na panel Sestavy, a rozbalte tak tuto skupinu.

    Všimněte si, že je ve skupině zobrazena celá řada zástupců objektů databáze. Tak poznáte, že se díváte na vlastní kategorii či skupinu.

  3. Klikněte na panel v horní části navigačního podokna (s nápisem Northwind Traders) a pak klikněte na položku Typ objektu. Nyní vidíte seznam typů objektů v databázi.

  4. Klikněte na typ Formuláře, pravým tlačítkem myši klikněte na název formuláře Seznam zákazníků a poté klikněte na položku Zobrazení rozložení.

  5. Kliknutím na panel skupiny Tabulky tuto skupinu rozbalte a dvakrát klikněte na název tabulky Zákazníci.

  6. Pravým tlačítkem myši klikněte na panel v horní části navigačního podokna a klikněte na položku Panel hledání.

    Chcete-li, aby se Panel hledání opět objevil, zopakujte tento krok.

  7. Při viditelném Panelu hledání rozbalte všechny skupiny a do Panelu hledání pomalu napište slovo zákazník. Všimněte si, jak aplikace Access během psaní filtruje seznam objektů.

Navigace na pásu karet

Vyzkoušejte tyto kroky u databáze, jako je Northwind.

  • Otevřete některou tabulku v zobrazení Datový list a všimněte si, které kontextové karty se objeví. Prozkoumejte tyto karty a zjistěte, jaké příkazy obsahují.

  • Otevřete některý dotaz v návrhovém zobrazení a všimněte si, které kontextové karty se objeví. Prozkoumejte tyto karty a zjistěte, jaké příkazy obsahují.

  • Otevřete některý formulář v zobrazení rozložení a všimněte si, které kontextové karty se objeví. Prozkoumejte také tyto karty.

Prémiové kroky

  1. Při otevřeném libovolném objektu databáze a zobrazené kartě Domů stiskněte klávesu ALT.

    Zobrazí se Popisy s klávesovými zkratkami.

    Popisy s klávesovými zkratkami

    Aplikace Access nabízí popisy s klávesovými zkratkami pro všechny karty pásu karet a také pro příkazy na jednotlivých kartách.

  2. Stiskněte znovu klávesu ALT a všimněte si, že popisy s klávesovými zkratkami zmizí.

  3. Stisknutím klávesové zkratky ALT+V přejděte na kartu Vytvoření.

    Protože jste z karty Domů přešli pomocí klávesové zkratky na kartu Vytvoření, aplikace Access zobrazí popisy s klávesovými zkratkami pro všechny příkazy na kartě Vytvoření.

  4. Stiskněte klávesu ALT ještě jednou a všimněte si, že popisy s klávesovými zkratkami zmizí.

  5. Nyní stiskněte klávesy ALT+V a všimněte si, že se popisy s klávesovými zkratkami pro všechny příkazy znovu objeví.

    Pokud nechtěně zavřete popisy s klávesovými zkratkami pro danou kartu, můžete je znovu zobrazit tak, že stisknete klávesu ALT a písmeno odpovídající této kartě.

  6. Stisknutím kláves ND spusťte návrháře dotazu.

  7. Při otevřeném návrháři dotazu můžete stisknutím kláves ALT+Ů přejít na kartu Domů.

    Všimněte si, že popisy s klávesovými zkratkami pro zakázané (šedé) příkazy jsou také zakázány.

Publikování webové databáze

Začněte tím, že stáhnete některou z šablon webových databází, například šablonu Webová databáze majetku. Provedete to tak, že kliknete na kartu Nový a potom kliknete na položku Ukázkové šablony. Projevte důvěru k této databázi (na žlutém panelu zpráv klikněte na možnost Povolit obsah) a přihlaste se k ní.

  1. V zobrazení Backstage klikněte na kartu Uložit a publikovat.

  2. Klikněte na položku Publikovat na webu služby Access Services.

  3. Klikněte na tlačítko Spustit kontrolu kompatibility.

  4. Kliknutím na tlačítko Ano povolte zavření všech otevřených objektů a nechte proběhnout kontrolu kompatibility.

    Pokud kontrola kompatibility nenajde žádné problémy nebo zobrazí pouze upozornění, je databáze připravena k publikování.

  5. Zadejte adresu URL serveru a název webu. Adresu URL získáte od správce systému.

  6. Klikněte na položku Publikovat na webu služby Access Services.

    Je třeba počkat, než skončí proces publikování a než server dokončí zpracování nového webu.

  7. Spusťte prohlížeč, přejděte na web, otevřete formulář Aktuální majetek a zadejte nějaká data.

Změna webové databáze a uložení změn na web

  1. Otevřete v aplikaci Access webovou databázi Majetek.

  2. Otevřete formulář Hlavní v zobrazení rozložení.

  3. Klikněte ve formuláři pravým tlačítkem myši na kartu Začínáme, klikněte na příkaz Odstranit a stisknutím kláves CTRL+S uložte provedené změny.

  4. Kliknutím na kartu Soubor přejděte do zobrazení Backstage.

  5. Na kartě Informace klikněte na tlačítko Synchronizovat vše – provedené změny se zapíší (uloží) na web.

    Tlačítko Synchronizovat vše

Vyzkoušejte se

Projděte si následující test a přesvědčte se, zda dobře chápete prezentované informace. Vaše odpovědi jsou soukromé a nejsou hodnoceny.

Pomocí návrhového zobrazení lze měnit formuláře a sestavy ve webové databázi.

Ano

Nesprávná odpověď. Návrhové zobrazení lze používat pouze pro formuláře a sestavy, které nechcete publikovat ve službách Access Services. U webové databáze se k vytváření a úpravám formulářů a sestav používá zobrazení rozložení.

Ne

Správně. Chcete-li změnit formuláře nebo sestavy ve webové databázi, můžete použít zobrazení rozložení, nikoli návrhové zobrazení.

Po otevření databáze aplikace Access 97 v aplikaci Access 2010 je možné zadávat data a provádět změny návrhu.

Ano

Zkuste to znovu. Pokud otevřete databázi aplikace Access 97 v aplikaci Access 2010, můžete pouze číst data.

Ne

Přesně tak. Můžete pouze číst data. Chcete-li provádět více akcí, uložte soubor ve formátu souboru aplikace Access 2010.

Webovou databázi lze publikovat na libovolný webový server.

Ano

Nesprávná odpověď. Webové databáze můžete publikovat pouze na server SharePoint, na kterém běží služby Access Services.

Ne

Správná odpověď. Na serveru SharePoint 2010 musí běžet služby Access Services.

V navigačním podokně otevřete formulář pro zadávání dat takto:

Kliknete na formulář pravým tlačítkem myši a potom kliknete na příkaz Návrhové zobrazení.

To není správná odpověď. Pokud byste to udělali, otevřeli byste formulář kvůli změnám návrhu, nikoli pro běžné použití.

Dvakrát kliknete na formulář.

Zasloužíte si pochvalu. Mohli byste také kliknout na objekt pravým tlačítkem a potom kliknout na příkaz Otevřít.

Nepoužijete navigační podokno. Použijete pás karet – příkaz Otevřít na kartě Domů.

Zkuste to znovu. K otvírání objektů za účelem použití se rozhodně používá navigační podokno.

Pokud soubor MDB uložíte v novém formátu souborů (jako soubor ACCDB), můžete tento nový soubor otevřít v aplikaci Access 2003.

Ano

Zkuste to znovu. Soubory ACCDB nelze otevřít v aplikaci 2003.

Ne

Správně. Soubory ACCDB lze otevřít pouze v aplikaci Access 2007 nebo Access 2010. Pamatujte také na to, že funkce specifické pro aplikaci Access 2010 nebudou v aplikaci Access 2007 fungovat.

Váš názor

Karta Rychlá reference

Další školení

První v sérii pro začátečníky.

Návrh tabulek nové databáze

Viz také

Přizpůsobení pásu karet

Sešit s mapováním pásu karet aplikace Access

Zobrazení a skrytí navigačního podokna

Dialogové okno Možnosti navigace

Video: Změny šablon aplikace Access 2010

Video: Použití šablony Webová databáze majetku

Převod databáze aplikace Access 2010 do dřívějšího formátu souboru

Video: Úvod k rozložením aplikace Access 2010

Které zobrazení mám použít – zobrazení rozložení nebo návrhové zobrazení?

Orientace v zobrazení Backstage

  • Aplikace Access 2010 je po spuštění v zobrazení Backstage. Do zobrazení Backstage a zpět můžete přejít kliknutím na kartu Soubor.

  • Databázi můžete otevřít kliknutím na její název v nabídce Soubor nebo po kliknutí na kartu Naposledy otevřené.

  • Na kartě Nový můžete vytvořit novou databázi – prázdnou nebo založenou na některé z šablon.

  • Na kartě Uložit a publikovat můžete uložit databázi v jiném formátu souboru, zabalit a podepsat databázi, kompilovat databázi do spustitelného souboru nebo ji publikovat na server SharePoint 2010, na kterém běží služby Access Services.

  • Kliknutím na tlačítko Možnosti otevřete dialogové okno Možnosti aplikace Access, ve kterém lze nastavit různé možnosti pro databáze i pro samotnou aplikaci Access.

Vytvoření nové prázdné databáze

  1. Dvakrát klikněte na požadovanou šablonu.

  2. Přijměte výchozí název nebo zadejte lepší.

  3. Klikněte na tlačítko Vytvořit.

Používání navigačního podokna

  • Chcete-li některý objekt otevřít a začít používat, dvakrát na něj klikněte.

  • Chcete-li u některého objektu provádět změny návrhu nebo objekt exportovat, přejmenovat či otevřít jeho seznam vlastností, klikněte na něj pravým tlačítkem.

Změna zobrazení kategorií objektů v podokně

  1. Klikněte na panel v horní části podokna. Otevře se seznam kategorií a skupin.

  2. Vyberte některou kategorii v horní polovině seznamu nebo skupinu v dolní polovině.

Nastavení možností podokna

  • Klikněte pravým tlačítkem myši na panel v horní části podokna a poté klikněte na příkaz Možnosti navigace.

Hledání objektů

  1. Pokud není zobrazen Panel hledání, klikněte pravým tlačítkem myši na panel v horní části navigačního podokna a potom klikněte na příkaz Panel hledání.

  2. Zadejte do pole Hledat celý název objektu nebo jeho část. Během psaní názvu se filtruje seznam objektů v podokně.

Odstranění vzájemného zakrývání dokumentů databáze

  1. V zobrazení Backstage klikněte na tlačítko Možnosti.

  2. Klikněte na možnost Aktuální databáze.

  3. Vyberte možnost Dokumenty s kartami a zaškrtněte políčko Zobrazit karty dokumentů.

  4. Provedené změny se projeví po zavření a opětovném otevření databáze.

Používání pásu karet

  • Pás karet není statický – mění se v závislosti na objektu, který má fokus, a v závislosti na prováděném úkolu.

  • Příkazy jsou na pásu karet umístěny na kartách, které jsou rozděleny do skupin.

  • Karta Domů obsahuje nejčastěji používané příkazy.

  • Další prvek rozhraní – panel nástrojů Rychlý přístup, který naleznete v levém horním rohu okna aplikace Access, obsahuje nejčastěji používané příkazy. Panel nástrojů Rychlý přístup zůstává stejný bez ohledu na právě používanou kartu pásu karet.

  • Panel nástrojů Rychlý přístup a pás karet můžete přizpůsobit svým potřebám.

Používání popisů s klávesovými zkratkami

  • Stisknutím klávesy ALT zobrazíte popisy klávesových zkratek pro všechny karty pásu karet. Stisknutím klávesy ALT a písmene přiřazeného ke kartě se dostanete na příslušnou kartu.

  • Pokud přejdete na kartu pomocí její klávesové zkratky, zobrazí se popisy klávesových zkratek pro všechny příkazy na této kartě. Chcete-li některý příkaz použít, stačí stisknout příslušné číslo, písmeno či více písmen. Pokud popisy klávesových zkratek pro příkazy na kartě zmizí, stiskněte klávesu ALT a písmeno odpovídající dané kartě.

Přizpůsobení panelu nástrojů Rychlý přístup

  1. Kliknutím na šipku na pravé straně panelu nástrojů Rychlý přístup otevřete nabídku příkazů.

  2. Vyberte příkaz, který chcete do panelu nástrojů Rychlý přístup přidat.

  3. Pokud není požadovaný příkaz v nabídce uveden, klikněte na položku Další příkazy. Otevřete tak dialogové okno Možnosti aplikace Access.

  4. Přidejte požadované příkazy z levého podokna do pravého podokna.

Přizpůsobení pásu karet

Pokud přizpůsobíte pás karet, budou provedené změny platit pro aplikaci Access, nikoli pro jednotlivou databázi.

Důležité:    Pokud umístíte příkaz na vlastní kartu či do vlastní skupiny pásu karet, přeruší se propojení mezi příkazem a jeho tématem nápovědy vyvolávaným pomocí klávesy F1.

  1. Kliknutím na kartu Soubor přejděte do zobrazení Backstage a potom klikněte na tlačítko Možnosti.

  2. Klikněte na položku Přizpůsobit pás karet.

  3. Pod pravým podoknem klikněte na tlačítko Nová karta, Nová skupina nebo Přejmenovat v závislosti na tom, jakou akci chcete provést.

  4. V pravém podokně zadejte název karty nebo skupiny.

  5. Pokud vytváříte novou kartu nebo skupinu, vyberte v levém podokně požadovaný příkaz a přesuňte ho do pravého podokna tím, že na něj dvakrát kliknete nebo že kliknete na tlačítko Přidat.

Pravidla používání souborů z předchozích verzí aplikace Access

  • Databáze vytvořené v aplikacích Access 2000, Access 2002 nebo Access 2003 lze otevřít v aplikaci Access 2010, ale některé funkce nebude možné používat, například okno Databáze nebo replikaci.

  • Soubory aplikace Access 97 lze otevřít v aplikaci Access 2010, bude však možné pouze zobrazit objekty a přidávat záznamy. Pokud nepřevedete databázi do formátu aplikace Access 2010, nebude možné uložit žádné změny návrhu.

  • Jakmile starší databázi uložíte jako soubor ACCDB, bude možné ji používat pouze v aplikaci Access 2007 nebo Access 2010.

  • Pokud databázi aplikace Access 2010 otevřete v aplikaci Access 2007, nebudete moci používat funkce specifické pro aplikaci Access 2010.

Používání šablon a webových databází

Aplikace Access nabízí dvě třídy šablon – místní a online. Místní šablony se nainstalují do počítače při instalaci aplikace Access. Online šablony jsou k dispozici, pokud máte připojení k Internetu.

Používání online šablon

  1. V zobrazení Backstage klikněte na kartě Nový na tlačítko Ukázkové šablony nebo na některou z kategorií šablon v části Šablony na webu Office.com.

  2. Dejte nové databázi název, v případě potřeby zvolte umístění a kliknutím na tlačítko Vytvořit nebo Stáhnout stáhněte a otevřete šablonu.

  3. Povolte zablokovaný obsah a začněte zadávat data nebo změňte šablonu podle potřeby.

Publikování webové databáze

  1. V zobrazení Backstage klikněte na kartu Uložit a publikovat (není-li vybrána) a potom klikněte na položku Publikovat na webu služby Access Services.

  2. Klikněte na tlačítko Spustit kontrolu kompatibility.

  3. Kliknutím na tlačítko Ano povolte zavření všech otevřených objektů a nechte proběhnout kontrolu kompatibility.

  4. Pokud nebudou nalezeny žádné problémy, je databáze připravena k publikování.

  5. Zadejte adresu URL serveru a název webu.

  6. Klikněte na položku Publikovat na webu služby Access Services.
    Po dokončení procesu publikování se z tabulek v databázi stanou seznamy služby SharePoint a formuláře budou vypadat a chovat se stejně jako v aplikaci Access.

Používání zobrazení rozložení

Zobrazení rozložení představuje vizuální prostředí sloužící v aplikaci Access 2010 k návrhu formulářů a sestav. Je to jediné prostředí, které umožňuje návrh formulářů a sestav ve webové databázi.

Používání zobrazení rozložení

  • V navigačním podokně klikněte pravým tlačítkem myši na některý formulář nebo sestavu a pak klikněte na příkaz Zobrazení rozložení.
    – nebo –
    U otevřeného formuláře nebo sestavy klikněte pravým tlačítkem na kartu dokumentu a poté klikněte na příkaz Zobrazení rozložení.

Některé rychlé změny, které lze provádět v zobrazení rozložení

  • Vyberte jeden ovládací prvek nebo popisek a jeho přetažením změňte velikost všech ovládacích prvků nebo popisků v daném sloupci.

  • Vyberte některý popisek, klikněte na kartu Formát a pomocí příkazů na této kartě změňte písmo, barvu písma nebo zarovnání textu.

  • Stiskněte a podržte klávesu CTRL, vyberte více popisků a nastavte jejich formát.

  • Chcete-li provádět globální změny v rozložení, klikněte na volič rozložení (křížek v levém horním rohu rozložení). Vyberte například celé rozložení. Na kartě Návrh klikněte na tlačítko Seznamvlastností. Otevře se seznam vlastností pro vybrané prvky formuláře. Nastavte jinou výšku ovládacích prvků.

Přidávání polí do rozložení a přesouvání ovládacích prvků

  1. Na kartě Návrh klikněte na tlačítko Přidat existující pole.

  2. Přetáhněte požadovaná pole ze seznamu polí do rozložení.

  3. Podle potřeby můžete přetáhnout ovládací prvky nezávisle na jejich popiscích a umístit je na požadované místo. Cílové umístění indikuje oranžový pruh.

Seskupování a řazení dat v sestavách

  1. Na kartě Návrh klikněte na tlačítko Seskupit a seřadit.

  2. V podokně Skupina, řazení a součet klikněte na příkaz Přidat skupinu a pak klikněte na pole, pro které chcete seskupit data. Změna se projeví okamžitě.
    Můžete přidat maximálně sedm úrovní seskupení.

Použít na: Access 2010



Byly tyto informace užitečné?

Ano Ne

Jak ji můžeme vylepšit?

255 zbývajících znaků

Pokud si chcete chránit soukromí, nedávejte do zpětné vazby kontaktní informace. Ohodnoťte aplikaci zásady ochrany osobních údajů.

Děkujeme vám za zpětnou vazbu.

Zdroje technické podpory

Změnit jazyk