Přidání tlačítka pro přepnutí zobrazení

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

V aplikaci Microsoft Office InfoPath můžete vytvořit různá zobrazení téže šablony formuláře. Zobrazení je alternativním způsobem prezentace dat v šabloně formuláře. Při vyplňování formulářů založených na vaší šabloně formuláře mohou uživatelé zobrazení přepínat a vybrat si množství dat zobrazených ve formuláři. V šabloně formuláře zprávy o stavu například můžete vytvořit souhrnné zobrazení a podrobné zobrazení. Uživatelé si poté mohou zvolit, které zobrazení chtějí, podle typu potřebných informací.

Zobrazení jsou často navržený pro práci s pravidly. Pravidla umožňují automatizaci některých úkolů v šabloně formuláře v odpovědi na události nebo akce, které iniciuje uživatelem vyplňující formulář. Například Tento článek popisuje, jak můžete tlačítko Vložit v šabloně formuláře a potom vytvořit pravidlo, které kombinace kláves vymění zobrazení po kliknutí na toto tlačítko.

V tomto článku

Krok 1: Vložení tlačítka každé zobrazení

Krok 2: Vytvořte pravidlo, které kombinace kláves vymění zobrazení

Krok 3: Testování uživatelské prostředí

Krok 1: Vložení tlačítka každé zobrazení

Poznámka : Pokud chcete provést následující postup, musíte mít šablony formuláře s dvěma existující zobrazení. Odkazy na další informace o vytváření zobrazení naleznete v části Viz také.

  1. V nabídce Zobrazit klikněte na Spravovat zobrazení.

  2. V seznamu Vyberte zobrazení klikněte na zobrazení, které chcete přidat tlačítko pro.

  3. V šabloně formuláře umístěte kurzor na místo, kam chcete vložit tlačítko.

  4. Klepněte v nabídce Vložit na příkaz Další ovládací prvky nebo stiskněte klávesovou zkratku ALT+I a pak klávesu D.

  5. Ve skupinovém rámečku ovládací prvky v podokně úloh ovládací prvky na tlačítko.

  6. V šabloně formuláře poklepejte na tlačítko, které jste právě vložili.

  7. Klepněte na kartu Obecné.

  8. Do pole Popisek zadejte text, který se má zobrazit na tlačítko a potom klikněte na OK.

  9. V nabídce Zobrazit klikněte na Spravovat zobrazení.

  10. V seznamu Vyberte zobrazení klikněte na název druhého zobrazení.

  11. Kroky 3 až 8 přidejte tlačítko druhého zobrazení.

Začátek stránky

Krok 2: Vytvořte pravidlo, které kombinace kláves vymění zobrazení

Po přidání tlačítka do jednotlivých zobrazení v šabloně formuláře, je potřeba vytvořit pravidla, která přepnutí zobrazení, když uživatelé kliknou těchto tlačítek.

  1. V nabídce Zobrazit klikněte na Spravovat zobrazení.

  2. V seznamu Vyberte zobrazení klikněte na zobrazení, kterým chcete pracovat s.

  3. V šabloně formuláře poklikejte na tlačítko, které jste vložili předchozího postupu.

  4. Klepněte na kartu Obecné.

  5. V rozevíracím seznamu Akce klepněte na položku Pravidla a vlastní kód.

  6. Klepněte na tlačítko Pravidla.

  7. V dialogovém okně Pravidla klepněte na tlačítko Přidat.

  8. Do pole název zadejte název pravidla, například Přepnout do zobrazení 2. Zobrazí se tento název při práci s obrázky zobrazení v režimu návrhu. Název je však neuvidí osobami vyplňující formulář.

  9. Klepněte na tlačítko Přidat akci.

  10. V rozevíracím seznamu Akce klepněte na položku Přepnout zobrazení.

  11. V rozevíracím seznamu Zobrazit, klepněte na zobrazení, do kterého chcete přepnout, a poté klepněte na tlačítko OK.

  12. Klepnutím na tlačítko OK zavřete všechna otevřená dialogová okna.

  13. V podokně úloh zobrazení v seznamu Vyberte zobrazení, klikněte na tlačítko druhého zobrazení.

  14. Kroky 3 až 12 vytvořit pravidlo pro tlačítko druhého zobrazení.

Začátek stránky

Krok 3: Testování uživatelské prostředí

Po přidání tlačítka do zobrazení a vytvořili potřebné pravidla, je vhodné otestovat šablony formuláře zajistit, že to funguje očekávaným způsobem.

  1. Změny můžete otestovat kliknutím na Náhled na panelu nástrojů Standardní nebo stisknutím kláves CTRL+SHIFT+B.

    Poznámka : Zobrazení, které jste pracovali ve většině naposledy je zobrazení, které se zobrazí v okně náhledu.

  2. Tlačítka pro přepnutí zobrazení funkčnost, klikněte na tlačítka, která jste vytvořili v předchozím postupu.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×