Přidání spojnic mezi obrazce ve Visiu

Přidání spojnic mezi obrazce ve Visiu

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Visio usnadňuje spojování obrazců ve výkresu. Automatické spojování spojuje obrazce při přidávání a existující obrazce můžete spojit pomocí nástroje Spojnice.

Typy připojení

Spojnice může mít s obrazcem jeden ze dvou typů spojení: bodové spojení nebo dynamické propojení. Bodové spojení zachovává spojnici připevněnou k určitému bodu na obrazci, a to i v případě, že je tento obrazec přesunut nebo otočen. Dynamické spojení umožňuje spojnici měnit umístění na obrazci tak, aby se spojnice při přesouvání nebo otáčení obrazce přesouvala ke spojovacímu bodu na obrazci, který se nachází nejblíže původnímu bodu spojnice.

V následujícím diagramu má obrazec A bodové spojení s obrazcem C. Kdykoli se tak obrazec C přesune, spojnice z obrazce A zůstane připojená ke stejnému bodu na obrazci C. Naopak obrazec B má s obrazcem C dynamické spojení a spojnice z obrazce B se přesouvá na spojovací bod, který je na obrazci C nejblíže.

A má bodové spojení s C, ale B má dynamické spojení s C.

Můžete mít obou typů připojení na obou koncích spojnice. Pokud spojení obrazců pomocí funkce automatického spojení, bude mít obou koncích dynamické spojení. Pokud vyberete ručně, kde je připojen spojnice k obrazci, můžete určit typ používaného připojení.

Automatické spojení přidávaných obrazců

Jednou z možností spojení obrazců je nechat je ve Visiu spojovat automaticky při přidávání obrazců do výkresu. To je vhodné zejména při vytváření vývojového diagramu.

Pomocí následujícího postupu přidáte do výkresu obrazec, který aplikace Visio automaticky spojí s existujícím obrazcem.

Poznámka : Před použitím následujícího postupu zkontrolujte, že je funkce automatického spojení aktivní. Na kartě Zobrazení ve skupině Vizuální pomůcky ověřte, že je zaškrtnuté políčko Automaticky připojit.

Informace o přidávání obrazců a automaticky připojila k na existující obrazec

  1. Pokud na stránce ještě nejsou žádné obrazce, přetáhněte na ni obrazec z okna Obrazce.

  2. Podržte ukazatel myši na obrazci, dokud se kolem něj nezobrazí šipky pro automatické spojení.

    Když je funkce automatického spojení aktivní, najeďte myší na obrazec, aby se zobrazily šipky spojení.

    Pokud se nezobrazí šipky pro automatické spojení, zkontrolujte na kartě Zobrazení, jestli je zaškrtnuté políčko Automaticky připojit.

  3. Podržte ukazatel myši nad šipkou v tom směru, kam chcete přidat obrazec.

    Když na šipku automatického spojení najedete myší, zobrazí se panel nástrojů s obrazci, které můžete přidat.

    Zobrazí se minipanel nástrojů obsahující první čtyři rychlé obrazce, které jsou momentálně ve vzorníku Rychlé obrazce. Pokud nastavíte ukazatel myši na obrazec na panelu nástrojů, Visio zobrazí náhled tohoto obrazce na stránce.

  4. Klikněte na obrazec, který chcete přidat.

  5. Pokud chcete pokračovat, přejděte myší na šipku automatického připojení na nově přidaném obrazci a přidejte jiný obrazec, který bude také automaticky připojen.

    Když na nově přidaný obrazec najedete myší, zobrazí se šipky automatického spojení pro přidání dalšího obrazce.

Poznámka : Pokud chcete obrazec jiné než prezentovat na minipanelu nástrojů, přetáhněte obrazec, který chcete z okna obrazce do požadované pozice na stránce. Připojení obrazci, použijte metodu popsané v následující části.

Spojení obrazců, které už jsou na stránce

Samozřejmě můžete spojit obrazce, které jsou už ve výkresu, a to pomocí funkce automatického spojení, nebo pomocí nástroje Spojnice.

Když se připojíte obrazce, můžete to udělat pomocí dva typy připojení: přejděte připojení nebo dynamické spojení. Další informace o těchto typů připojení najdete v článku typy připojenínad.

Pokud chcete vytvořit připojení, nechejte spojnici připevněnou k určitému bodu na obrazci, přetáhněte ukazatel myši ze spojovacího bodu na prvním obrazci do spojovacího bodu na druhém obrazci. Jakmile jsou obrazce propojeny, koncové body spojnice zezelenají.

Přichycením spojnice k určitému bodu na obrazci připevníte spojnici k tomuto bodu.
Přichycením spojnice k určitému bodu na obrazci připevníte spojnici k tomuto bodu.

Pokud chcete vytvořit dynamické spojení, aby se mohla spojnice přesouvat automaticky na nejbližší body na obrazci, umístěte nástroj Spojnice na střed prvního obrazce tak, aby se kolem obrazce zobrazil zelený rámeček. Podržte tlačítko myši stisknuté a přetáhněte ukazatel myši na střed druhého obrazce. Jakmile se kolem druhého obrazce zobrazí zelený rámeček, tlačítko myši uvolněte.

Přichycením spojnice k obrazci umožníte dynamické přesouvání spojnice k bodům na obrazci.
Přichycením spojnice k obrazci umožníte dynamické přesouvání spojnice k bodům na obrazci.

Připojení stávajícího obrazců pomocí funkce automatického spojení

  1. Podržte ukazatel myši nad obrazcem, dokud se kolem něj nezobrazí šipky pro automatické spojení.

    Když je funkce automatického spojení aktivní, najeďte myší na obrazec, aby se zobrazily šipky spojení.
  2. Klikněte na šipku pro automatické spojení, přetáhněte ji na jiný obrazec a umístěte koncový bod spojnice na střed obrazce dynamického spojení nebo na určitý spojovací bod na obrazci pro bodové spojení.

    Náhled obrazce se zobrazí, když podržíte ukazatel myši na šipce automatického spojení, přičemž ale můžete obrazec ignorovat. Po přetažení spojnice do cílového místa zmizí.

Spojování obrazců pomocí nástroje Spojnice

  1. Na kartě Domů klikněte ve skupinovém rámečku Nástroje na položku Spojnice.

    Nástroj Spojnice spojuje obrazce s bodovým spojením na každém konci.
  2. Klikněte na obrazec a přetáhněte spojnici na jiný obrazec.

  3. Potom na kartě Domů klikněte ve skupině Nástroje na tlačítko Ukazatel.

Rychlé úkoly

Úkol

Akce

Změna typu spojnice na pravoúhlý, přímý a zakřivený

Klikněte pravým tlačítkem myši na spojnici a pak v místní nabídce klikněte na typ spojnice: pravoúhlý, přímý a zakřivený.

Zarovnání obrazců a sjednocení jejich mezer tak, aby byly spojnice čisté

Vyberte všechny obrazce, které chcete vyrovnat, a pak klikněte na kartě Domů ve skupině Uspořádat na Zarovnat > Automatické zarovnání nebo Umístění > Automatické mezery. Více obrazců můžete vybrat stisknutím klávesy Ctrl a kliknutím na všechny požadované obrazce nebo pomocí některé z možností Vybrat na kartě Domů ve skupině Úpravy.

Změna spojení z dynamického na bodové nebo naopak

Vyberte spojnici a přetáhněte její koncový bod mimo obrazec. Poté umístěte konektor na určitý bod bodového spojení nebo na střed obrazce dynamického spojení.

Zapnutí či vypnutí funkce automatického spojení

Funkci automatického spojení můžete aktivovat a deaktivovat ve všech výkresech Visia, nebo také jenom v aktivním výkresu.

Zapnutí nebo vypnutí funkce automatického spojení v aktivním diagramu

  • Na kartě Zobrazení zaškrtněte ve skupinovém rámečku Vizuální pomůcky políčko Automaticky připojit.

    Zaškrtnutím nebo zrušením zaškrtnutí políčka Automaticky připojit na kartě Zobrazení můžete aktivovat nebo deaktivovat funkci automatického spojení.

Poznámka : Pokud zaškrtávací políčko Automaticky připojit není dostupné, zkontrolujte pomocí následujícího postupu, jestli není funkce automatického spojení vypnuta pro všechny diagramy.

Zapnutí nebo vypnutí funkce automatického spojení ve všech diagramech

  1. Klikněte na kartu Soubor a pak na tlačítko Možnosti.

  2. V dialogovém okně Možnosti aplikace Visio klikněte na Upřesnit.

  3. Ve skupinovém rámečku Možnosti úprav zaškrtnutím políčka Povolit automatické spojení zapnete funkci automatického spojení. Pokud chcete funkci automatického spojení vypnout, zaškrtnutí tohoto políčka zrušte.

    Zaškrtnutím nebo zrušením zaškrtnutí políčka Povolit automatické spojení můžete aktivovat nebo deaktivovat funkci automatického spojení pro všechny diagramy a výkresy.
  4. Klikněte na OK.

Viz taky

Přidání šipek, bodů či jiných zakončení čar ke spojnici

Přidání, přesunutí nebo odstranění spojovacích bodů pomocí nástroje spojovací bod

Automatické spojení přidávaných obrazců

Jednou z možností spojení obrazců je nechat je ve Visiu spojovat automaticky při přidávání obrazců do výkresu. To je vhodné zejména při vytváření vývojového diagramu.

Pomocí následujícího postupu přidáte do výkresu obrazec, který aplikace Visio automaticky spojí s existujícím obrazcem.

  1. Nejsou-li na stránce žádné obrazce, přetáhněte na ni počáteční obrazec z okna Obrazce.

  2. Podržte ukazatel myši na obrazci, dokud se kolem něj nezobrazí modré šipky pro automatické spojení.

  3. Podržte ukazatel myši nad šipkou v tom směru, kam chcete přidat obrazec.

    Zobrazí se minipanel nástrojů obsahující první čtyři rychlé obrazce, které jsou momentálně ve vzorníku Rychlé obrazce. Na stránce se zobrazí dynamický náhled obrazce vybraného ve vzorníku.

  4. Posunutím ukazatele na jednotlivé obrazce na miniaturním panelu nástrojů zobrazíte dynamický náhled každého obrazce na stránce.

  5. Klikněte na obrazec, který chcete přidat.

Požadujete-li jiný obrazec, odstraňte ukazatel myši ze šipky funkce automatického spojení a náhledy zmizí. Poté můžete přetáhnout požadovaný obrazec z okna Obrazce.

Rychlé úkoly

Úkol

Akce

Změna rychlých obrazců vzorníku

Otevřete vzorník a přetáhněte rychlé obrazce do požadovaného pořadí. Obrazce lze přetahovat do oblasti Rychlé obrazce i mimo ni.

Změna obrazců zobrazených v miniaturním panelu nástrojů

Ve vzorníku Rychlé obrazce vyberte obrazec ve skupině rychlých obrazců, který se má zobrazit na miniaturním panelu nástrojů. Tato skupina s vybranými obrazci se zobrazí na panelu nástrojů.

Dále můžete přetáhnout vzorník s obrazci, které chcete zobrazit jako první, přímo pod záhlaví Rychlé obrazce. Pořadí dalších vzorníků můžete změnit jejich přetažením v okně Obrazce nahoru nebo dolů. Ve vzorníku Rychlé obrazce budou zobrazeny ve stejném pořadí.

Spojení obrazců, které jsou již na stránce

Můžete se připojit obrazců, které jsou již ve výkresu, pomocí funkce automatického spojení nebo pomocí nástroje Spojnice.

Spojení obrazců pomocí funkce automatického spojení

  1. Podržte ukazatel myši na obrazec, dokud se kolem něj nezobrazí modré šipky pro automatické spojení.

  2. Klikněte na šipku pro automatické spojení, přetáhněte ji na jiný obrazec a umístěte koncový bod spojnice na střed obrazce dynamického spojení nebo na určitý spojovací bod bodového spojení.

    Dynamický náhled obrazce se zobrazí, podržíte-li ukazatel myši na modré šipce, přičemž však můžete obrazec ignorovat. Po přesunutí ukazatele myši náhled zmizí.

Spojení obrazců pomocí nástroje Spojnice

  1. Na kartě Domů klikněte ve skupinovém rámečku Nástroje na položku Spojnice.

  2. Klikněte na obrazec a přetáhněte spojnici na jiný obrazec.

Chcete-li ponechat spojnici připevněnou k určitému bodu na obrazci, přetáhněte ukazatel myši ze spojovacího bodu na prvním obrazci do spojovacího bodu na druhém obrazci. Koncové body spojnice zčervenají, jakmile jsou obrazce propojeny. Jedná se o tzv. bodové spojení.

Chcete-li při přesouvání obrazce umožnit pohyb spojnice kolem obrazce, umístěte nástroj Spojnice na střed prvního obrazce tak, aby se kolem obrazce zobrazil červený rámeček. Podržte tlačítko myši stisknuté a přetáhněte ukazatel myši na střed druhého obrazce. Jakmile se kolem druhého obrazce zobrazí červený rámeček, tlačítko myši uvolněte. Jedná se o tzv. dynamické spojení.

Rychlé úkoly

Úkol

Akce

Změna typu spojnice na pravoúhlý, přímý a zakřivený

Klikněte pravým tlačítkem myši na spojnici a poté v místní nabídce klikněte na typ spojnice.

Zarovnání obrazců a sjednocení jejich mezer tak, aby byly spojnice čisté

Výběr všech obrazců, které chcete zarovnat a potom na kartě Domů klikněte na Automatické zarovnání a mezery. Můžete vybrat více obrazců tak, že podržíte klávesu CTRL a klikněte na všechny nebo můžete použít jednu z možností, Vyberte.

Změna spojení z dynamického na bodové nebo naopak

Vyberte spojnici a přetáhněte její koncový bod mimo obrazec. Poté umístěte konektor na určitý bod bodového spojení nebo na střed obrazce dynamického spojení.

Zapnutí či vypnutí funkce automatického spojení

Funkci automatického spojení je možné zapnout nebo vypnout ve všech výkresech aplikace Visio, nebo pouze v aktivním výkresu.

Zapnutí či vypnutí funkce automatického spojení v aktivním diagramu

  • Na kartě Zobrazení zaškrtněte ve skupinovém rámečku Vizuální pomůcky políčko Automaticky připojit.

Není-li zaškrtávací políčko Automaticky připojit dostupné, zkontrolujte pomocí následujícího postupu, zda nebyla funkce automatického spojení vypnuta pro všechny diagramy.

Zapnutí či vypnutí funkce automatického spojení ve všech diagramech

  1. Klikněte na Soubor > Možnosti.

  2. Klikněte na kategorii Upřesnit.

  3. Ve skupinovém rámečku Možnosti úprav zaškrtnutím políčka Povolit automatické spojení zapnete funkci automatického spojení. Chcete-li funkci automatického spojení vypnout, zaškrtnutí tohoto políčka zrušte.

Viz také

Přidání šipek, bodů či jiných zakončení čar ke spojnici

Přidání, přesunutí nebo odstranění spojovacích bodů

Spojení obrazců pomocí funkce automatického spojení

Jednou z možností spojení obrazců je nechat je ve Visiu spojovat automaticky při přidávání obrazců do výkresu. To je vhodné zejména při vytváření vývojového diagramu.

Pomocí následujícího postupu přidáte do výkresu obrazec, který aplikace Visio automaticky spojí s existujícím obrazcem.

Použití funkce automatického spojení při přetahování obrazce na stránce

  1. Přetáhněte obrazec ze vzorníku na stránku výkresu a umístěte ho blízko jiného obrazce.

    Obrazec umístěný blízko jiného obrazce

  2. Držte tlačítko myši, přesuňte ukazatel nad modrým trojúhelníkem. Trojúhelník se změní tmavě modrý.

    Ukazatel nad modrým trojúhelníkem

  3. Uvolněte tlačítko myši. Obrazec je umístěn na stránku výkresu a spojnice je přidána a připevněna k oběma obrazcům.

    Klepnutím na modrý trojúhelník přidáte spojnici a připevníte ji k oběma obrazcům.

Tip : Pokud nejste spokojení, přetáhněte další obrazce, lze dosáhnout stejný výsledek první výběr obrazce ve vzorníku ukazatel přesunutý nad obrazec ve výkresu a potom klikněte na jednu modrým trojúhelníkem, které se zobrazí u daného obrazce.

Pomocí funkce automatického spojení obrazců již na stránce

  1. Umístěte ukazatel myši na obrazec, který chcete připojit z.

    Ukazatel přesunutý nad obrazec, ze kterého chcete spojení vytvořit

  2. Umístěte ukazatel nad modrým trojúhelníkem nejblíže k obrazci, který chcete Připojit.

    Ukazatel je umístěn na modrém trojúhelníku nejblíže k tvaru, který chcete připojit.

    Trojúhelník se změní tmavě modrý a červeným ohraničením se zobrazí kolem něj, který chcete připojit k.

    Poznámka : Pokud červeným ohraničením okolo obrazce, který chcete připojit k nezobrazí, může být příliš daleko obrazec. Přesunutí obrazce blíž a opakujte nebo pomocí nástroje Spojnice.

  3. Klepněte na modrý trojúhelník. Spojnice je přidána a připevněna k oběma obrazcům.

    Klepnutím na modrý trojúhelník přidáte spojnici a připevníte ji k oběma obrazcům.

Povolení nebo zakázání funkce automatického spojení

Můžete povolit nebo zakázat funkci automatického spojení ve všech výkresech aplikace Visio, nebo pouze v aktuálním výkresu. U všech výkresech:

  1. V nabídce Nástroje klikněte na Možnosti.

  2. Klikněte na kartu Obecné.

  3. V části Možnosti okna výkresu zaškrtněte políčko Povolit automatické spojení.

Pouze pro aktuální výkres:

  • Na panelu nástrojů Standardní klikněte na nástroje pro automatické spojení.

    Poznámka : Pokud kliknete na nástroj pro automatické spojení nepovoluje funkce automatického spojení, zkontrolujte, jestli že je zaškrtnuté políčko Povolit automatické spojení v dialogovém okně Možnosti.

Spojení obrazců pomocí nástroje Spojnice

Flexibilní způsoby přidání a připevnění spojnice je pomocí nástroje spojnice Obrázek tlačítka na panel nástrojů Standardní kreslit.

  1. Na panelu nástrojů Standardní klikněte na nástroj Spojnice Obrázek tlačítka .

  2. Proveďte jednu z následujících akcí:

    • Aby spojnice k určitému bodu na obrazci připevníte ji táhněte z bodu připojení Vzhled spojovacího bodu – modrý křížek na první obrazec do spojovacího bodu na druhý obrazec. Když připojení obrazců koncové body spojnice červeně. Je místo toho možnost spojení. U spojení spojnice připevněna k stejné spojovacích bodů obsah přesouvaných jeden z obrazců.

    • Pokud chcete, aby konektoru přejdete k nejbližšímu dostupné spojovací bod, umístěte nástroje spojnice středu na první obrazec červeným ohraničením se zobrazí kolem obrazce. Stiskněte tlačítko myši a tažením na střed na druhý obrazec. Když se zobrazí červeným ohraničením okolo na druhý obrazec, uvolněte tlačítko myši. Je místo toho možnost spojení typu obrazec k obrazci. U spojení typu obrazec k obrazci spojnice připevněna k obrazci přesunutím na nejbližší spojovací bod při přesunutí jedné z obrazce. Pokud existují žádné spojovací body, spojnice se přesune na nejbližší strany.

      Poznámka : Můžete taky vytvořit propojení mezi obrazci, kdy jeden konec spojnice je připojen k spojovacího bodu a druhou stranu spojnice je připojen k obrazci (nebo naopak).

  3. Když se budete chtít vrátit k běžným úpravám, klikněte na panelu nástrojů Standardní na nástroj Ukazatel Tlačítko Ukazatel .

    Poznámky : 

    • Pokud chcete přidat spojnici z jednoho obrazce k několika obrazcům, budete muset přidat více spojnic. neexistuje žádný "větvení" obrazce spojnice.

    • Pokud chcete vytvořit spojení a nedaří připevnit spojnici přesně na požadované místo, zkuste přichycení a připevnění nastavení:

    • V nabídce Nástroje klikněte na Přichytit a připevnit a potom na kartě Obecné vyberte požadované možnosti.

      Pokud připevníte geometrie obrazce, úchytu obrazce nebo vrchol obrazce, se automaticky přidá spojovací bod, pokud ještě neexistuje.

Viz také

Přidání šipek, bodů či jiných zakončení čar ke spojnici

Přidání, přesunutí nebo odstranění spojovacích bodů

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×