Přidání, odstranění nebo aktualizace souborů prostředků v šabloně formuláře

Důležité informace:  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Soubor prostředků je soubor, který se používá ke zobrazení dodatečných informací v šabloně formuláře. Při uložení nebo publikování šablony formuláře jsou v ní veškeré soubory prostředků obsaženy.

K šabloně formuláře je možné přidávat následující typy souborů prostředků:

Soubory HTML.     Soubory HTML lze použít pro zobrazení informací ve Vlastní podokno úloh.

Poznámka: Při přidávání souboru HTML jako souboru prostředků pro šablonu formuláře je třeba rovněž přidat veškeré soubory, které soubor HTML vyžaduje, například jiné soubory HTML, šablony stylů nebo grafické soubory.

Soubory XML.     Soubory XML lze použít v případě, že chcete ovládací prvky Seznam, Pole se seznamem nebo Rozevírací seznam zaplnit hodnotami. Pokud jsou data v seznamu, v poli se seznamem nebo v rozevíracím seznamu konstantní, lze tato data vložit do souboru XML a tento soubor pak přidat k šabloně formuláře jako soubor prostředků. Tento způsob je výhodnější než zaplňování ovládacích prvků hodnotami pomocí Datové připojení. Při použití souboru prostředků se formuláře založené na této šabloně formuláře spouští rychleji než formuláře používající k zaplnění ovládacích prvků datové připojení. Je to proto, že data v souboru prostředků jsou považována za součást šablony formuláře a nemusí se tedy spoléhat na datové připojení. Pokud šablona formuláře není nastavena na ukládání dat z vnějších zdrojů dat do formuláře, musí být formulář pro potřeby stažení důležitých dat připojen k síti. Zdrojový soubor datové připojení nevyžaduje, protože veškerá data jsou součástí formuláře.

Co chcete udělat?

Přidání souboru prostředků do šablony formuláře

Odebrání souboru prostředků z šablony formuláře

Aktualizace souboru prostředků v šabloně formuláře

Přidání souboru prostředků do šablony formuláře

  1. V nabídce Nástroje klepněte na příkaz Soubory prostředků.

  2. V dialogovém okně Soubory prostředků klepněte na tlačítko Přidat.

  3. V dialogovém okně Přidat soubor vyberte soubor, který chcete přidat.

Začátek stránky

Odebrání souboru prostředků z šablony formuláře

  1. V nabídce Nástroje klepněte na příkaz Soubory prostředků.

  2. Ze seznamu Soubory prostředků v šabloně formuláře v dialogovém okně Soubory prostředků vyberte soubor prostředků, který chcete z šablony formuláře odstranit.

  3. Klepněte na tlačítko Odebrat.

Začátek stránky

Aktualizace souboru prostředků v šabloně formuláře

Soubor prostředků lze v šabloně formuláře aktualizovat po jejím publikování. Příklad: Do souboru prostředků, který používáte k zaplnění ovládacího prvku Seznam na šabloně formuláře, chcete přidat nové položky nebo z něj chcete odstranit položky stávající. Chcete-li soubor prostředků aktualizovat, je třeba upravit kopii souboru prostředků a poté přidat aktualizovaný soubor prostředků do šablony formuláře. Když přidáváte aktualizovaný soubor prostředků, nahrazujete tím soubor stávající. Po přidání aktualizovaného souboru prostředků je třeba šablonu formuláře znovu publikovat. Uživatelům se pak při otevření nového prázdného formuláře založeného na této šabloně formuláře zobrazí data z nového souboru prostředků.

  1. Všechny potřebné změny proveďte v mstní kopii souboru prostředků.

    Tip: Pokud nemáte místní kopii souboru prostředků, můžete tuto kopii extrahovat z šablony formuláře. Další informace o extrahování souborů v šabloně formuláře lze nalézt v oddílu Viz také.

  2. V režimu návrhu aplikace InfoPath otevřete šablonu formuláře, ke které je soubor prostředků přiřazen.

  3. V nabídce Nástroje klepněte na příkaz Soubory prostředků.

  4. V dialogovém okně Soubory prostředků klepněte na tlačítko Přidat.

  5. V dialogovém okně Přidat soubor vyberte aktualizovaný soubor a poté klepněte na tlačítko OK.

  6. V dialogovém okně Microsoft Office InfoPath klepněte na položku Nahradit existující soubor a klepněte na tlačítko OK.

  7. V dialogovém okně Soubory prostředků klepněte na tlačítko OK.

  8. Chcete-li šablonu formuláře publikovat, klepněte v nabídce Soubor na příkaz Publikovat a postupujte podle pokynů Průvodce publikováním.

Začátek stránky

Poznámka: Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×