Přidání, odebrání a úprava sloupců knihoven a sloupců webu

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Při navrhování šablony formuláře aplikace Microsoft Office InfoPath můžete zvolit, zda chcete zobrazit data zadaná uživateli do konkrétních polí ve formuláři jako sloupce ve výchozím zobrazení knihoven dokumentů na webu Microsoft Windows SharePoint. Při návrhu šablony formuláře je možné zvolit, která pole použít jako sloupce, nebo specifikovat sloupce při publikování šablony formuláře v knihovně dokumentů.

V tomto článku:

Než začnete

Specifikace sloupců knihovny dokumentů při navrhování šablony formuláře

Specifikace sloupců knihovny dokumentů při publikaci šablony formuláře do nové knihovny dokumentů

Specifikace sloupců knihovny dokumentů při publikaci šablony formuláře do existující knihovny dokumentů

Než začnete

Po publikování šablony formuláře do knihovny dokumentů bude každý formulář, který je v dané knihovně dokumentů vytvořen, založen na této šabloně formuláře. Publikování šablony formuláře do knihovny dokumentů umožňuje rychle nasadit jednoúčelový formulář, například neformální průzkum preferencí týkajících se výběru restaurace pro týmový oběd.

Pokud publikování šablony formuláře na serveru, na kterém běží Windows SharePoint Services 3.0 můžete taky udělat takto:

Publikování šablony formuláře jako typu obsahu webu     Po publikování šablony formuláře jako typu obsahu webu umožníte uživatelům přiřadit více šablonách formulářů do jedné knihovny dokumentů nebo k přiřazení šablony formuláře do více knihoven v kolekci webů. Kolekce webů je sada webů na virtuálního serveru, které mají stejné vlastníka a sdílet nastavení správy. Jednotlivé kolekce webů obsahuje web nejvyšší úrovně a může obsahovat jedno nebo více podřízené weby. Může existovat více kolekcí webů na každém virtuálního serveru. Když chcete široce znovu použít informace nebo povolení kolekce dat z více formulářů na jednom místě pomocí typu obsahu webu.

Povolení uživatelům upravovat pole pomocí zobrazení datového listu    Vaše uživatelům přidat ani upravit data pole pomocí zobrazení datového listu nebo úpravy vlastností formuláře v knihovně dokumentů. To umožňuje přidat nebo aktualizovat data jedné nebo více formulářů bez skutečně otevření formuláře.

Poznámka : Zobrazení Datový list jsou povoleny ve webovém prohlížeči pouze pro uživatele, kteří mají Microsoft Office Access 2007 nainstalovaný.

Poznámka : Podpora pro knihovny a typy obsahu webu se liší podle toho, jestli je spuštěný serveru Microsoft Windows SharePoint Services 2.0 nebo Windows SharePoint Services 3.0. Proto požádejte správce serveru Pokud si nejste jisti, jakou verzi systému Windows SharePoint Services běží na serveru.

Začátek stránky

Specifikace sloupců knihovny dokumentů při navrhování šablony formuláře

  1. Otevřete šablonu formuláře.

  2. V nabídce Nástroje klepněte na příkaz Možnosti formuláře.

  3. Klepněte na příkaz Šíření vlastností.

  4. Proveďte některou z následujících akcí:

    • Chcete-li přidat sloupec, klepněte na tlačítko Přidat, klepněte na opakující se pole nebo skupinu, pro které chcete vytvořit sloupec, a pak zadejte název sloupce do pole Název sloupce.

      Poznámka : Jestliže k zobrazení dat v knihovně dokumentů zvolíte opakující se pole, můžete klepnutím na hodnotu v seznamu Funkce definovat, jakým způsobem chcete pole v knihovně dokumentů zobrazit. Je možné zvolit zobrazení první hodnoty v poli, poslední hodnoty v poli nebo počtu všech výskytů pole či zda mají být všechny hodnoty sloučeny.

    • Pokud chcete sloupec odebrat, klepněte na sloupec v seznamu a pak klepněte na tlačítko Odebrat.

    • Jestliže chcete sloupec upravit, klepněte na sloupec v seznamu, klepněte na tlačítko Změnit a pak proveďte požadované změny.

      Poznámka : Některé možnosti přidání, odebírání nebo úpravy sloupců jsou dostupné pouze při publikování na server SharePoint.

Začátek stránky

Specifikace sloupců knihovny dokumentů při publikaci šablony formuláře do nové knihovny dokumentů

  1. Uložte šablonu formuláře.

  2. V nabídce Soubor klikněte na příkaz Publikovat.

  3. V průvodci publikováním klepněte na možnost Na server SharePoint s nebo bez služby InfoPath Forms Services a klepněte na tlačítko Další.

  4. Do pole Zadejte umístění serveru služby SharePoint nebo InfoPath Forms Services zadejte umístění serveru SharePoint a klepněte na tlačítko Další.

  5. Na další stránce průvodce klepněte na možnost Knihovna dokumentů a pak klepněte na tlačítko Další.

    Poznámka : Pokud publikujete Šablona formuláře kompatibilní s prohlížečem na server SharePoint, nebude políčko Povolit vyplnění tohoto formuláře pomocí prohlížeče k dispozici. Chcete-li vytvořit Šablona formuláře s podporou prohlížeče, je třeba publikovat šablonu formuláře na server, který podporuje službu InfoPath Forms Services. Další informace o službě InfoPath Forms Services lze získat v části Viz také.

  6. Klepněte na položku Vytvořit novou knihovnu formulářů a klepněte na tlačítko Další.

  7. Zadejte název a popis knihovny dokumentů a klepněte na tlačítko Další.

    Název a popis šablony formuláře se zobrazí ve výchozím zobrazení knihovny formulářů.

  8. Proveďte některou z následujících akcí:

    Přidání sloupce

    1. Klepněte na tlačítko Přidat.

    2. Proveďte některou z následujících akcí:

      • Chcete-li přidat nový sloupec do knihovny dokumentů, vyberte pole s daty, která chcete zobrazit ve sloupci, ze seznamu Skupina sloupců webu vyberte možnost (Žádný: Vytvořit nový sloupec v této knihovně) a do pole Název sloupce zadejte požadovaný název sloupce.

      • Chcete-li použít již existující sloupec webu, vyberte ze seznamu Skupina sloupců webu příslušnou kategorii a ze seznamu Název sloupce vyberte požadovaný název.

        Poznámka : Jestliže k zobrazení dat v knihovně dokumentů zvolíte opakující se pole, můžete klepnutím na hodnotu v seznamu Funkce definovat, jakým způsobem chcete pole v knihovně dokumentů zobrazit. Je možné zvolit zobrazení první hodnoty v poli, poslední hodnoty v poli nebo počtu všech výskytů pole či zda mají být všechny hodnoty sloučeny.

        1. Pokud chcete uživatelům povolit přidávání nebo úpravy dat pro toto pole v zobrazení datového listu nebo pomocí úprav vlastností formuláře v knihovně dokumentů, zaškrtněte políčko Povolit uživatelům úpravu dat v tomto poli pomocí datového listu nebo stránky vlastností.

          Poznámka : Pokud chcete používat zobrazení datového listu, musí mít uživatelé Microsoft Office Access 2007 na svém počítači nainstalovanou.

    Odebrání sloupce

    1. V oblasti Název sloupce klepněte na název pole, jehož odpovídající sloupec chcete odebrat, a klepněte na tlačítko Odebrat.

    Úprava sloupce

    1. V podnabídce Název sloupce klepněte na název pole, jemuž odpovídající sloupec chcete upravit, a klepněte na tlačítko Upravit.

    2. Proveďte některou z následujících akcí:

      • Do pole Název sloupce zadejte nový název sloupce.

      • Ze seznamu Skupina sloupců webu vyberte kategorii a poté ze seznamu Název sloupce vyberte název.

        Poznámka : Jestliže k zobrazení dat v knihovně dokumentů zvolíte opakující se pole, můžete klepnutím na hodnotu v seznamu Funkce definovat, jakým způsobem chcete pole v knihovně dokumentů zobrazit. Je možné zvolit zobrazení první hodnoty v poli, poslední hodnoty v poli nebo počtu všech výskytů pole či zda mají být všechny hodnoty sloučeny.

        1. Pokud chcete uživatelům povolit přidávání nebo úpravy dat pro toto pole v zobrazení datového listu nebo pomocí úprav vlastností formuláře v knihovně dokumentů, zaškrtněte políčko Povolit uživatelům úpravu dat v tomto poli pomocí datového listu nebo stránky vlastností.

          Poznámka : Pokud chcete používat zobrazení datového listu, musí mít uživatelé Microsoft Office Access 2007 na svém počítači nainstalovanou.

  9. Po dokončení definování sloupců pro knihovnu klepněte na tlačítko Další.

  10. Na další straně průvodce ověřte, zda jsou uvedené informace správné a klepněte na tlačítko Publikovat.

Začátek stránky

Specifikace sloupců knihovny dokumentů při publikaci šablony formuláře do existující knihovny dokumentů

  1. Uložte šablonu formuláře

  2. V nabídce Soubor klikněte na příkaz Publikovat.

  3. V průvodci publikováním klepněte na možnost Na server SharePoint s nebo bez služby InfoPath Forms Services a klepněte na tlačítko Další.

  4. Do pole Zadejte umístění serveru služby SharePoint nebo InfoPath Forms Services zadejte umístění serveru SharePoint a klepněte na tlačítko Další.

  5. Na další stránce průvodce klepněte na možnost Knihovna dokumentů a pak klepněte na tlačítko Další.

    Poznámka : Pokud publikujete Šablona formuláře kompatibilní s prohlížečem na server SharePoint, nebude políčko Povolit vyplnění tohoto formuláře pomocí prohlížeče k dispozici. Chcete-li vytvořit Šablona formuláře s podporou prohlížeče, je třeba publikovat šablonu formuláře na server, který podporuje službu InfoPath Forms Services. Další informace o službě InfoPath Forms Services lze získat v části Viz také.

  6. Klepněte na možnost Aktualizovat šablonu formuláře v existující knihovně dokumentů a klepněte na knihovnu dokumentů, kterou chcete aktualizovat.

  7. Klepněte na tlačítko Další.

  8. Proveďte některou z následujících akcí:

    Přidání sloupce

    1. Klepněte na tlačítko Přidat.

    2. Proveďte některou z následujících akcí:

      • Chcete-li přidat nový sloupec do knihovny dokumentů, vyberte pole s daty, která chcete zobrazit ve sloupci, ze seznamu Skupina sloupců webu vyberte možnost (Žádný: Vytvořit nový sloupec v této knihovně) a do pole Název sloupce zadejte požadovaný název sloupce.

      • Chcete-li použít již existující sloupec knihovny dokumentů nebo sloupec webu, vyberte ze seznamu Skupina sloupců webu příslušnou kategorii a ze seznamu Název sloupce vyberte požadovaný název.

        Poznámka : Jestliže k zobrazení dat v knihovně dokumentů zvolíte opakující se pole, můžete klepnutím na hodnotu v seznamu Funkce definovat, jakým způsobem chcete pole v knihovně dokumentů zobrazit. Je možné zvolit zobrazení první hodnoty v poli, poslední hodnoty v poli nebo počtu všech výskytů pole či zda mají být všechny hodnoty sloučeny.

        1. Pokud chcete uživatelům povolit přidávání nebo úpravy dat pro toto pole v zobrazení datového listu nebo pomocí úprav vlastností formuláře v knihovně dokumentů, zaškrtněte políčko Povolit uživatelům úpravu dat v tomto poli pomocí datového listu nebo stránky vlastností.

          Poznámka : Pokud chcete používat zobrazení datového listu, musí mít uživatelé Microsoft Office Access 2007 na svém počítači nainstalovanou.

    Odebrání sloupce

    1. V oblasti Název sloupce klepněte na název pole, jehož odpovídající sloupec chcete odebrat, a klepněte na tlačítko Odebrat.

    Úprava sloupce

    1. V podnabídce Název sloupce klepněte na název pole, jemuž odpovídající sloupec chcete upravit, a klepněte na tlačítko Upravit.

    2. Proveďte některou z následujících akcí:

      • Do pole Název sloupce zadejte nový název sloupce.

      • Ze seznamu Skupina sloupců webu vyberte kategorii a poté ze seznamu Název sloupce vyberte název.

        Poznámka : Jestliže k zobrazení dat v knihovně dokumentů zvolíte opakující se pole, můžete klepnutím na hodnotu v seznamu Funkce definovat, jakým způsobem chcete pole v knihovně dokumentů zobrazit. Je možné zvolit zobrazení první hodnoty v poli, poslední hodnoty v poli nebo počtu všech výskytů pole či zda mají být všechny hodnoty sloučeny.

        1. Pokud chcete uživatelům povolit přidávání nebo úpravy dat pro toto pole v zobrazení datového listu nebo pomocí úprav vlastností formuláře v knihovně dokumentů, zaškrtněte políčko Povolit uživatelům úpravu dat v tomto poli pomocí datového listu nebo stránky vlastností.

          Poznámka : Pokud chcete používat zobrazení datového listu, musí mít uživatelé Microsoft Office Access 2007 na svém počítači nainstalovanou.

  9. Po dokončení definování sloupců pro knihovnu klepněte na tlačítko Další.

  10. Na další straně průvodce ověřte, zda jsou uvedené informace správné a klepněte na tlačítko Publikovat.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Sdílení Facebook Facebook Twitter Twitter E-mail E-mail

Byly tyto informace užitečné?

Výborně! Je ještě něco dalšího, co byste nám chtěli dát vědět?

Jak bychom ho mohli vylepšit?

Děkujeme vám za zpětnou vazbu.

×