Přidání datového připojení k webové službě

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Do šablony formuláře je možné přidat jedno či více sekundárních datových připojení, pomocí nichž lze získávat data z webové služby nebo je do ní odesílat.

V tomto článku

Přehled

Aspekty kompatibility:

Než začnete

Přidání datového připojení pro dotazy

Přidání datového připojení pro odesílání

Základní informace

Sekundární datové připojení je jakékoli datové připojení k externímu zdroji dat, které přidáte k šabloně formuláře. Toto datové připojení se liší od hlavního datového připojení, které se vytvoří, když navrhujete šablonu formuláře, ať už na základě databáze, webové služby nebo nastavení v knihovně připojení. Sekundární datové připojení se přidává pouze v případě, že nemůžete zadat dotaz na data nebo odesílat data přes hlavní datové připojení.

Pokud přidáte sekundárního datového připojení k šabloně formuláře získávání dat, Microsoft Office InfoPath vytvoří sekundární Zdroj dat s datová pole a skupiny, který odpovídá Schéma XML webové služby. Protože struktura dat v sekundární zdroj dat se musí shodovat schéma XML, nelze změnit existující pole nebo skupiny v sekundární zdroj dat. Po přidání připojení pro odesílání dat do šablony formuláře nakonfigurovat uživatelům povolit odesílání dat formuláře v šabloně formuláře a můžete nakonfigurovat možnosti odeslání formuláře založené na šabloně formuláře.

Začátek stránky

Aspekty kompatibility:

V Šablona formuláře kompatibilní s prohlížečem nelze datové připojení pro odesílání konfigurovat tak, aby uživatelům umožňovalo odesílat webové službě, která přijímá objekt Microsoft ADO.NET DataSet, kromě dat formuláře také informace o změnách. Informace o změnách se týkají úprav, které uživatel provedl v datech uložených v databázi. Databáze používá webovou službu pro připojení uživatelů k databázi. Prostředí ADO.NET může pomocí informací o změnách určit způsob aktualizace dat v databázi. Informujte se u správce webové služby, zda webová služba vyžaduje k aktualizaci databáze informace o změnách. Pokud ano, měli byste navrhnout šablonu formuláře, jejíž formuláře se budou vyplňovat pouze v aplikaci InfoPath.

Začátek stránky

Než začnete

Před přidáním sekundárního datového připojení do šablony formuláře je třeba získat od správce webové služby následující informace:

  • Umístění webové služby.

  • Ověření, že webová služba používá kódování stylu Document/Literal. Aplikace InfoPath může používat pouze webové služby se stylem Document/Literal.

  • Název operace webové služby, která bude odesílat data do formulářů založených na této šabloně formuláře nebo je z nich přijímat.

Začátek stránky

Přidání datového připojení pro dotazy

Chcete-li uživatelům umožnit získávat data z webové služby prostřednictvím šablony formuláře, je třeba provést v šabloně formuláře následující kroky:

  1. Přidejte sekundární datové připojení.

  2. Nakonfigurujte šablonu formuláře na používání sekundárního datového připojení.

Krok 1: Přidání sekundárního datového připojení

  1. V nabídce Nástroje klikněte na příkaz Datová připojení.

  2. V dialogovém okně Datová připojení klikněte na tlačítko Přidat.

  3. V Průvodci datovým připojením klikněte na možnost Vytvořit nové připojení k, pokračujte kliknutím na příkaz Přijímat data a na tlačítko Další.

  4. V části Odkud chcete data přijímat? klepněte na přepínač Webová služba a potom klepněte na tlačítko Další.

  5. Na další stránce průvodce zadejte umístění webové služby a pak klepněte na tlačítko Další.

    Poznámka : Pokud chcete hledat webové služby pomocí serveru univerzální popis zjišťování a hodnocení integrace UDDI (), klepněte na Hledat UDDI, zadejte adresu URL UDDI serveru, na kterém chcete hledat, určete, zda chcete najít poskytovatele nebo službu, která je k dispozici, zadejte klíčové slovo pro hledání a klikněte na Hledat. Webové služby, které odpovídají vaší klíčové slovo pro hledání se zobrazí v seznamu výsledků hledání. Vyberte webová služba, kterou chcete použít a klikněte na tlačítko OK.

  6. V seznamu Vyberte operaci na další stránce průvodce klepněte na operaci webové služby, která vrací data do formuláře, a potom klepněte na tlačítko Další.

  7. Jestliže Průvodce datovým připojením zjistí ve schématu webové služby neznámý prvek, budete na další stránce průvodce pravděpodobně vyzváni k zadání ukázkových hodnot jednotlivých parametrů, aby bylo možné určit, které skupiny nebo pole mají být přidány do hlavního zdroje dat.

    Postup

    1. V tabulce Parametry vyberte parametr a klepněte na možnost Nastavit ukázkovou hodnotu.

    2. Do pole Ukázková hodnota zadejte hodnotu, kterou by uživatel mohl použít pro toho pole, a klepněte na tlačítko OK.

    3. Opakujte tento postup u každého parametru v tabulce Parametry a klepněte na tlačítko Další.

    Technické podrobnosti

    Při konfigurování datového připojení k webové službě v Průvodci datovým připojením se aplikace Microsoft Office InfoPath připojí k webové službě a odešle požadavek na soubor WSDL (Web Service Description Language). Soubor WSDL obsahuje schéma používané webovou službou. Webová služba reaguje na požadavek tak, že tento soubor odešle aplikaci InfoPath. V aplikaci InfoPath jsou na základě informací v tomto souboru přidána příslušná pole a skupiny do sekundárního zdroje dat v šabloně formuláře. Pokud aplikace InfoPath najde v souboru WSDL neznámý typ prvku, určí definici tohoto prvku podle vzorových dat a přidá do sekundárního zdroje dat příslušná pole a skupiny.

  8. Chcete-li zajistit, aby byly výsledky dotazu k dispozici v případě, že není formulář připojen k síti, zaškrtněte políčko Uložit kopii dat do šablony formuláře.

    Poznámka zabezpečení : Zaškrtnutím tohoto políčka uložíte výsledky dotazu do šablony formuláře. Protože jsou data uložena v šabloně formuláře, jsou k dispozici ve formulářích, které uživatelé vyplňují, a to i v případě, že nemají počítače připojené k síti. Pokud z tohoto datového připojení získáváte citlivá data, budete pravděpodobně chtít tuto funkci zakázat a zabezpečit tak data pro případ ztráty nebo krádeže počítače.

  9. Klepněte na tlačítko Další.

  10. Na další stránce průvodce zadejte popisný název daného datového připojení pro dotazy.

  11. Chcete-li povolit, aby formuláře založené na této šabloně formuláře při otevření automaticky načetly data, zaškrtněte políčko Automaticky načíst data při otevření formuláře.

  12. Zkontrolujte správné informace v části Souhrn a potom klikněte na Dokončit.

  13. Klepněte na tlačítko Zavřít.

Krok 2: Konfigurace šablony formuláře na používání sekundárního datového připojení

Pokud přidáte datové připojení dotazu do šablony formuláře, bude u formulářů založených na této šabloně datové připojení standardně použito při otevření formuláře uživatelem. Šablonu formuláře lze nakonfigurovat také tak, aby používala datové připojení dotazu některým z následujících způsobů:

  • Přidat pravidlo    Můžete nakonfigurovat pravidlo, aby se při splnění podmínky obsažené v pravidle použilo datové připojení pro dotazy.

  • Přidat tlačítko    Do šablony formuláře můžete přidat tlačítko, na které mohou uživatelé kliknout a získat tak pomocí datového připojení pro dotazy požadovaná data.

  • Použít vlastní kód    Pokud nemůžete přidat pravidlo ani tlačítko, můžete k získání dat pomocí datového připojení pro dotazy použít vlastní kód. Tento kód musí vytvořit vývojář.

Přidání pravidla

Přidáním pravidla do šablony formuláře můžete prostřednictvím datového připojení pro dotazy získat data vždy, když je splněna podmínka daného pravidla. V následujícím postupu se předpokládá, že jste vytvořili datové připojení pro dotazy určené pro šablonu formuláře a že jste v této šabloně nakonfigurovali ovládací prvek pro zobrazení dat získaných prostřednictvím daného datového připojení.

  1. Pokud šablona formuláře obsahuje více zobrazení, klikněte v nabídce Zobrazit na název zobrazení a tak přejděte na zobrazení obsahující ovládací prvek, ve kterém chcete zobrazit data ze sekundárního zdroje dat.

  2. Poklepejte na ovládací prvek, ke kterému chcete přidat pravidlo.

  3. Klepněte na kartu Data.

  4. V části Ověření a pravidla klepněte na tlačítko Pravidla.

  5. V dialogovém okně Pravidla klepněte na tlačítko Přidat.

  6. Do pole Název zadejte název pravidla.

  7. Pokud chcete určit podmínku, za jaké bude pravidlo spuštěno, klepněte na tlačítko Nastavit podmínku a zadejte podmínku. Pravidlo bude spuštěno, když se podmínka splní. Pokud podmínku nenastavíte, bude pravidlo spuštěno pokaždé, když uživatel změní hodnotu v ovládacím prvku a následně odsune kurzor z daného ovládacího prvku.

  8. Klepněte na tlačítko Přidat akci.

  9. V rozevíracím seznamu Akce klepněte na položku Zadat dotaz pomocí datového připojení.

  10. V rozevíracím seznamu Datové připojení klepněte na datové připojení pro dotazy, které chcete použít, a postupným klepnutím na tlačítka OK zavřete všechna otevřená dialogová okna.

  11. Změny můžete otestovat kliknutím na Náhled na panelu nástrojů Standardní nebo stisknutím kláves CTRL+SHIFT+B.

Přidání tlačítka

Do šablony formuláře můžete přidat tlačítko umožňující uživatelům získat data prostřednictvím datového připojení pro dotazy. V následujícím postupu se předpokládá, že jste vytvořili datové připojení pro dotazy určené pro šablonu formuláře.

  1. Pokud šablona formuláře obsahuje více zobrazení, klikněte v nabídce Zobrazit na název zobrazení a tak přejděte na zobrazení obsahující ovládací prvek, ve kterém chcete zobrazit data ze sekundárního zdroje dat.

  2. Pokud není vidět podokno úloh Ovládací prvky, klikněte na Další ovládací prvky v nabídce Vložit nebo stiskněte klávesy ALT+I, C.

  3. Přetáhněte tlačítko do šablony formuláře.

  4. Poklepejte na tlačítko, které jste právě přidali do šablony formuláře.

  5. Klepněte na kartu Obecné.

  6. V rozevíracím seznamu Akce klepněte na položku Aktualizovat.

  7. Do pole Popisek zadejte název, který se má zobrazit na tlačítku v šabloně formuláře.

  8. Klepněte na tlačítko Nastavení.

  9. V dialogovém okně Aktualizovat klepněte na možnost Jeden sekundární zdroj dat.

  10. V seznamu Zvolte sekundární zdroj dat klepněte na sekundární zdroj dat přidružený k datovému připojení pro dotazy a potom postupným klepnutím na tlačítka OK zavřete všechna otevřená dialogová okna.

  11. Změny můžete otestovat kliknutím na Náhled na panelu nástrojů Standardní nebo stisknutím kláves CTRL+SHIFT+B.

Začátek stránky

Přidání datového připojení pro odesílání

Chcete-li uživatelům umožnit odesílat formuláře založené na šabloně formuláře do webové služby, přidejte do šablony formuláře sekundární datové připojení sloužící k odesílání dat a potom nakonfigurujte šablonu formuláře tak, aby umožňovala uživatelům odesílat data formuláře.

Krok 1: Přidání sekundárního datového připojení

  1. V nabídce Nástroje klikněte na příkaz Datová připojení.

  2. V dialogovém okně Datová připojení klikněte na tlačítko Přidat.

  3. V Průvodci datovým připojením klepněte na přepínač Vytvořit nové připojení k, na přepínač Odesílat data a potom na tlačítko Další.

  4. V části Jak chcete svá data odeslat? klepněte na přepínač Pro webovou službu a potom klepněte na tlačítko Další.

  5. Na další stránce průvodce zadejte umístění webové služby, do které budou uživatelé odesílat data, a pak klepněte na tlačítko Další.

    Poznámka : Pokud chcete hledat webové služby pomocí serveru univerzální popis zjišťování a hodnocení integrace UDDI (), klepněte na Hledat UDDI, zadejte adresu URL UDDI serveru, na kterém chcete hledat, určete, zda chcete najít poskytovatele nebo službu, která je k dispozici, zadejte klíčové slovo pro hledání a klikněte na Hledat. Webové služby, které odpovídají vaší klíčové slovo pro hledání se zobrazí v seznamu výsledků hledání. Vyberte webová služba, kterou chcete použít a klikněte na tlačítko OK.

  6. V seznamu Vyberte operaci klepněte na operaci webové služby, která bude přijímat data formuláře, a potom klepněte na tlačítko Další.

  7. Chcete-li na další stránce průvodce vybrat, jaká data z formuláře mají být pro jednotlivé parametry webové služby odeslána, proveďte jednu z následujících akcí:

    Odeslání dat v poli nebo skupině

    1. V seznamu Parametry vyberte parametr webové služby, který bude přijímat data z formuláře.

    2. V části Možnosti parametrů klepněte na možnost Pole nebo skupina.

    3. Klikněte na Upravit Vzhled tlačítka .

    4. V dialogovém okně Vybrat pole nebo skupinu klepněte na pole nebo skupinu, jejichž obsah chcete odeslat, a klepněte na tlačítko OK.

    5. V poli Zahrnout klepněte na položku Pouze text a podřízené prvky, pokud chcete odeslat pouze data v tomto poli a podřízené prvky pole nebo skupiny, nebo klepněte na položku Dílčí stromová struktura XML, včetně vybraného prvku, pokud chcete odeslat název pole, data v poli a podřízené prvky ve vybrané skupině nebo poli.

    Odeslání veškerých dat ve formuláři

    1. V seznamu Parametry vyberte parametr webové služby, který bude přijímat data z formuláře.

    2. Ve skupinovém rámečku Možnosti parametrů klepněte na možnost Celý formulář (dokument XML, včetně pokynů pro zpracování).

    Odeslání dat jako řetězce

    1. V seznamu Parametry vyberte parametr webové služby, který bude přijímat data z formuláře.

    2. Ve skupinovém rámečku Možnosti parametrů klepněte na možnost Celý formulář (dokument XML, včetně pokynů pro zpracování).

    3. Zaškrtněte políčko Odeslat data jako řetězec.

      Poznámka : Tato možnost se běžně používá pro odesílání dat s elektronickým podpisem. Ve většině případů toto políčko nemusí být zaškrtnuto.

    Technické poznámky k objektům ADO.NET DataSet

    Jestliže webová služba vyžaduje objekt ADO.NET DataSet, vyberte při konfiguraci tohoto datového připojení uzel datové sady. V případě, že pro datové připojení k webové službě vyžadující objekt ADO.NET DataSet použijete jiný typ uzlu, akce odeslání se nezdaří.

  8. Klepněte na tlačítko Další.

  9. Na další stránce průvodce zadejte název datového připojení pro odesílání.

  10. Zkontrolujte správné informace v části Souhrn a potom klikněte na Dokončit.

  11. Klepněte na tlačítko Zavřít.

Po přidání sekundárního datového připojení pro odesílání je třeba nakonfigurovat šablonu formuláře tak, aby uživatelům umožňovala odesílat data formuláře prostřednictvím tohoto datového připojení pro odesílání.

Krok 2: Povolení odesílání v šabloně formuláře

Pokud šablonu formuláře nakonfigurujete tak, aby uživatelům umožňovala odesílat data formuláře, přidá aplikace InfoPath na panel nástrojů Standardní formuláře tlačítko Odeslat a do nabídky Soubor formuláře příkaz Odeslat. Možnosti odesílání je možné u šablony formuláře také následujícími způsoby upravit:

  • lze změnit text zobrazený na tlačítku Odeslat a příkazu Odeslat,

  • lze změnit klávesovou zkratku pro tlačítko Odeslat a příkaz Odeslat,

  • lze vytvořit vlastní zprávy, které se uživatelům zobrazí při odeslání formulářů,

  • Výběr z možností, zda po odeslání formulář zavřít, nechat jej otevřený nebo zda otevřít nový nevyplněný formulář.

  • V nabídce Nástroje klikněte na Možnosti odeslání.

  • V dialogovém okně Možnosti odeslání zaškrtněte políčko Povolit uživatelům odeslat tento formulář, klepněte na možnost Odeslat data formuláře do jednoho umístění a v seznamu potom klepněte na položku Webová služba.

  • V seznamu Zvolte datové připojení pro odeslání klepněte na název datového připojení pro odesílání dat do webové služby vytvořeného v předchozích krocích.

    1. Chcete-li změnit název tlačítka Odeslat, které se zobrazuje na panelu nástrojů Standardní a příkazu Odeslat, který se zobrazuje v nabídce Soubor, když uživatelé vyplní formulář, zadejte nový název do pole Titulek v dialogovém okně Možnosti odeslání.

      Tip : Pokud chcete k tomuto tlačítku a příkazu přiřadit klávesovou zkratku, zadejte znak ampersandu (&) před znak, který chcete použít jako klávesovou zkratku. Chcete-li k tlačítku a příkazu Odeslat přiřadit například klávesovou zkratku ALT+D, zadejte O&deslat.

  • Pokud uživatelům při vyplňování formuláře nechcete povolit použití příkazu Odeslat ani tlačítka Odeslat na panelu nástrojů Standardní, zrušte zaškrtnutí políčka Zobrazit položku nabídky Odeslat a tlačítko Odeslat na panelu nástrojů.

    1. Ve výchozím nastavení zůstane formulář po odeslání otevřený a aplikace InfoPath zobrazí zprávu s informacemi o tom, zda byl formulář úspěšně odeslán. Jestliže chcete toto výchozí chování změnit, klepněte na tlačítko Upřesnit a proveďte jeden z následujících kroků:

      • Chcete-li po odeslání vyplněného formuláře uživatelem formulář zavřít nebo vytvořit nový prázdný formulář, klepněte na požadovanou možnost v rozevíracím seznamu Po odeslání.

      • Chcete-li vytvořit vlastní zprávu s informacemi o tom, zda byl formulář úspěšně odeslán, zaškrtněte políčko Použít vlastní zprávy a potom zadejte požadované zprávy do polí Při úspěchu a Při neúspěchu.

        Tip : Pomocí zprávy v poli Při neúspěchu uživatelům sdělte, co je třeba provést, pokud nelze formulář odeslat. Můžete uživatelům například navrhnout, aby uložili formulář a požádali o další pokyny jinou osobu.

      • Pokud nechcete, aby se po odeslání formuláře uživateli zobrazila zpráva, zrušte zaškrtnutí políčka Zobrazit zprávy o úspěšném nebo neúspěšném provedení.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×