Přidání datového připojení k seznamu nebo knihovně dokumentů služby SharePoint

Do šablony formuláře je možné přidat jedno či více sekundárních datových připojení, jejichž prostřednictvím lze získávat data ze seznamu či knihovny dokumentů nebo odesílat data do knihovny dokumentů na serveru se službou Microsoft Windows SharePoint Services.

V tomto článku

Základní informace

Než začnete

Přidání datového připojení pro dotazy

Přidání datového připojení pro odesílání

Základní informace

Sekundární datové připojení je jakékoli datové připojení k externímu zdroji dat, které přidáte k šabloně formuláře. Toto datové připojení se liší od hlavního datového připojení, které se vytvoří, když navrhujete šablonu formuláře, ať už na základě databáze, webové služby nebo nastavení v knihovně připojení. Sekundární datové připojení se přidává pouze v případě, že nemůžete zadat dotaz na data nebo odesílat data přes hlavní datové připojení.

Když do šablony formuláře sloužícího k zadávání dotazů na data přidáte sekundární datové připojení, vytvoří Microsoft Office InfoPath sekundární Zdroj dat s datovými poli a skupinami, které odpovídají způsobu uložení dat v seznamu nebo knihovně dokumentů. Relace mezi externím zdrojem dat a zdrojem dat v šabloně formuláře

Vzhledem k tomu, že struktura dat v sekundárním zdroji dat musí odpovídat způsobu uložení dat v seznamu nebo knihovně dokumentů, není možné měnit v sekundárním zdroji dat existující pole ani skupiny.

Datové připojení, které zadává dotazy na data v knihovně dokumentů nebo seznamu SharePointu, automaticky vrátí všechny položky z této knihovny dokumentů nebo seznamu. Pokud používáte datové připojení pro dotazy k načtení hodnot do ovládacího prvku seznamu, rozevíracího seznamu nebo pole se seznamem a daný ovládací prvek obsahuje příliš mnoho položek, případně chcete zobrazit jenom položky odpovídající zadaným kritériím, můžete počet položek v ovládacím prvku omezit pomocí filtru. Odkazy na další informace o filtrování dat zobrazených v ovládacím prvku najdete v oddíle Viz také.

U každého datového připojení pro dotazy je také možné nakonfigurovat ukládání příslušných výsledků a umožnit tak uživatelům získat přístup k daným datům v případě, že formulář není připojen k síti. V závislosti na charakteru dat může být vhodné zobrazovat výsledky dotazu pouze tehdy, jsou-li uživatelé připojeni k síti.

Poznámka zabezpečení : Jestliže používáte sekundární datové připojení k načtení citlivých dat z externího zdroje dat nebo ze seznamu, možná budete chtít tuto funkci zakázat z důvodu ochrany dat před zneužitím v případě, že by došlo ke ztrátě nebo odcizení počítače. Pokud funkci zakážete, budou data dostupná pouze v době připojení uživatele k síti.

Pokud přidáte datové připojení dotazu do šablony formuláře, bude u formulářů založených na této šabloně datové připojení standardně použito při otevření formuláře uživatelem. Šablonu formuláře lze nakonfigurovat také tak, aby používala datové připojení dotazu některým z následujících způsobů:

  • Přidat pravidlo    Můžete nakonfigurovat pravidlo, aby se při splnění podmínky obsažené v pravidle použilo datové připojení pro dotazy.

  • Přidat tlačítko    Do šablony formuláře můžete přidat tlačítko, na které mohou uživatelé kliknout a získat tak pomocí datového připojení pro dotazy požadovaná data.

  • Použít vlastní kód    Pokud nemůžete přidat pravidlo ani tlačítko, můžete k získání dat pomocí datového připojení pro dotazy použít vlastní kód. Tento kód musí vytvořit vývojář.

Pokud do šablony formuláře přidáte datové připojení pro odesílání, můžete ji nakonfigurovat tak, aby uživatelům umožňovala odesílat data formuláře, a také nakonfigurovat možnosti odesílání pro formuláře založené na dané šabloně.

Začátek stránky

Než začnete

Před přidáním sekundárního datového připojení do šablony formuláře je třeba získat od správce webu následující informace:

  • umístění webu služby SharePoint a potřebná oprávnění pro přístup k němu,

  • ověření, že je web nakonfigurován tak, aby uživatelé mohli získat data ze seznamu nebo knihovny dokumentů,

  • ověření, že můžete ukládat data ze seznamu nebo knihovny dokumentů do počítačů uživatelů pro použití v offline režimu.

Začátek stránky

Přidání datového připojení pro dotazy

Chcete-li uživatelům umožnit získávat data ze seznamu nebo knihovny dokumentů na webu, který je umístěn na serveru se službou Microsoft Windows SharePoint Services, je třeba provést v šabloně formuláře následující kroky:

  1. Přidejte sekundární datové připojení.

  2. Nakonfigurujte šablonu formuláře na používání sekundárního datového připojení.

Krok 1: Přidání sekundárního datového připojení

  1. V nabídce Nástroje klikněte na příkaz Datová připojení.

  2. V dialogovém okně Datová připojení klikněte na tlačítko Přidat.

  3. V Průvodci datovým připojením klikněte na možnost Vytvořit nové připojení k, pokračujte kliknutím na příkaz Přijímat data a na tlačítko Další.

  4. Na další stránce průvodce klikněte na položku Knihovna nebo seznam SharePoint a na tlačítko Další.

    Stránka v Průvodci datovým připojením pro určení sharepointového webu jako zdroje dat

  5. Na další stránce průvodce zadejte adresu URL webu služby SharePoint se seznamem nebo knihovnou dokumentů a klikněte na tlačítko Další. Chcete-li například použít seznam dokumentů na webu služby SharePoint s adresou URL http://www.adventureworks.com/EmployeeList, zadejte http://www.adventureworks.com/EmployeeList.

  6. V seznamu Vyberte seznam nebo knihovnu na další stránce průvodce klepněte na seznam nebo knihovnu, kterou chcete použít, a potom klepněte na tlačítko Další.

  7. Na další stránce průvodce zaškrtněte políčka vedle hodnot, které chcete přijímat. Pokud bude šablona formuláře publikována v knihovně dokumentů a chcete, aby formuláře založené na této šabloně získávaly metadata o formuláři, zaškrtněte políčko Zahrnout data pouze pro aktivní formulář.

  8. Klepněte na tlačítko Další.

  9. Chcete-li výsledky dotazu uložit se šablonou formuláře, zaškrtněte políčko Uložit kopii dat do šablony formuláře. Po zaškrtnutí tohoto políčka budou výsledky dotazu uloženy v šabloně formuláře. Vzhledem k tomu, že jsou data uložena v šabloně formuláře, budou uživatelům ve vyplňovaných formulářích k dispozici i v případě, že jejich počítače nejsou připojeny k síti.

    Poznámka zabezpečení : Zaškrtnutím tohoto políčka uložíte výsledky dotazu do šablony formuláře. Protože jsou data uložena v šabloně formuláře, jsou k dispozici ve formulářích, které uživatelé vyplňují, a to i v případě, že nemají počítače připojené k síti. Pokud z tohoto datového připojení získáváte citlivá data, budete pravděpodobně chtít tuto funkci zakázat a zabezpečit tak data pro případ ztráty nebo krádeže počítače.

  10. Klepněte na tlačítko Další.

  11. Do pole Zadejte název tohoto datového připojení na další stránce průvodce zadejte popisný název sekundárního datového připojení. Tento název se zobrazí v seznamu Zdroj dat v podokně úloh Zdroj dat. Jestliže chcete, aby se tento dotaz spustil automaticky při každém otevření formuláře uživatelem, zaškrtněte políčko Automaticky načíst data při otevření formuláře.

Krok 2: Konfigurace šablony formuláře na používání sekundárního datového připojení

Chcete-li, aby formuláře založené na této šabloně formuláře použily po otevření uživatelem toto datové připojení, můžete do šablony formuláře přidat pravidlo, které zajistí použití tohoto datového připojení za určité podmínky, nebo můžete do šablony formuláře přidat tlačítko, na které mohou uživatelé kliknout a použít tak toto datové připojení.

Přidání pravidla

Přidáním pravidla do šablony formuláře můžete prostřednictvím datového připojení pro dotazy získat data vždy, když je splněna podmínka daného pravidla. V následujícím postupu se předpokládá, že jste vytvořili datové připojení pro dotazy určené pro šablonu formuláře a že jste v této šabloně nakonfigurovali ovládací prvek pro zobrazení dat získaných prostřednictvím daného datového připojení.

  1. Pokud šablona formuláře obsahuje více zobrazení, klikněte v nabídce Zobrazit na název zobrazení a tak přejděte na zobrazení obsahující ovládací prvek, ve kterém chcete zobrazit data ze sekundárního zdroje dat.

  2. Poklepejte na ovládací prvek, pomocí něhož chcete zobrazit výsledky dotazu.

  3. Klepněte na kartu Data.

  4. V části Ověření a pravidla klepněte na tlačítko Pravidla.

  5. V dialogovém okně Pravidla klepněte na tlačítko Přidat.

  6. Do pole Název zadejte název pravidla.

  7. Pokud chcete určit podmínku, za jaké bude pravidlo spuštěno, klepněte na tlačítko Nastavit podmínku a zadejte podmínku. Pravidlo bude spuštěno, když se podmínka splní. Pokud podmínku nenastavíte, bude pravidlo spuštěno pokaždé, když uživatel změní hodnotu v ovládacím prvku a následně odsune kurzor z daného ovládacího prvku.

  8. Klepněte na tlačítko Přidat akci.

  9. V rozevíracím seznamu Akce klepněte na položku Zadat dotaz pomocí datového připojení.

  10. V rozevíracím seznamu Datové připojení klepněte na datové připojení pro dotazy, které chcete použít, a postupným klepnutím na tlačítka OK zavřete všechna otevřená dialogová okna.

  11. Změny můžete otestovat kliknutím na Náhled na panelu nástrojů Standardní nebo stisknutím kláves CTRL+SHIFT+B.

Přidání tlačítka

Do šablony formuláře můžete přidat tlačítko umožňující uživatelům toto datové připojení pro dotazy používat. V následujícím postupu se předpokládá, že jste vytvořili datové připojení pro dotazy určené pro šablonu formuláře.

  1. Pokud šablona formuláře obsahuje více zobrazení, klikněte v nabídce Zobrazit na název zobrazení a tak přejděte na zobrazení obsahující ovládací prvek, ve kterém chcete zobrazit data ze sekundárního zdroje dat.

  2. Pokud není vidět podokno úloh Ovládací prvky, klikněte na Další ovládací prvky v nabídce Vložit nebo stiskněte klávesy ALT+I, C.

  3. Přetáhněte tlačítko do šablony formuláře.

  4. Poklepejte na tlačítko, které jste právě přidali do šablony formuláře.

  5. Klepněte na kartu Obecné.

  6. V rozevíracím seznamu Akce klepněte na položku Aktualizovat.

  7. Do pole Popisek zadejte název, který se má zobrazit na tlačítku v šabloně formuláře.

  8. Klepněte na tlačítko Nastavení.

  9. V dialogovém okně Aktualizovat klepněte na možnost Jeden sekundární zdroj dat.

  10. V seznamu Zvolte sekundární zdroj dat klepněte na sekundární zdroj dat přidružený k datovému připojení pro dotazy a potom postupným klepnutím na tlačítka OK zavřete všechna otevřená dialogová okna.

  11. Změny můžete otestovat kliknutím na Náhled na panelu nástrojů Standardní nebo stisknutím kláves CTRL+SHIFT+B.

Začátek stránky

Přidání datového připojení pro odesílání

Chcete-li uživatelům umožnit odesílat formuláře založené na šabloně formuláře do knihovny dokumentů, je třeba postupovat podle následujících kroků:

  1. Přidejte sekundární datové připojení, prostřednictvím něhož budou data odesílána do šablony formuláře.

  2. Nakonfigurujte šablonu formuláře tak, aby uživatelům umožňovala odesílat data formuláře do knihovny dokumentů.

Krok 1: Přidání sekundárního datového připojení

  1. V nabídce Nástroje klikněte na příkaz Datová připojení.

  2. V dialogovém okně Datová připojení klikněte na tlačítko Přidat.

  3. V Průvodci datovým připojením klepněte na přepínač Vytvořit nové připojení k, na přepínač Odesílat data a potom na tlačítko Další.

  4. V části Jak chcete svá data odeslat? klepněte na přepínač Do knihovny dokumentů na webu služby SharePoint a potom klepněte na tlačítko Další.

  5. Do pole Knihovna dokumentů v Průvodci datovým připojením zadejte adresu URL knihovny dokumentů služby SharePoint.

  6. Do pole Název souboru zadejte název, který bude sloužit k identifikaci formuláře v knihovně dokumentů.

    Tip : Můžete použít vzorec a zajistit tak jedinečnost názvu každého formuláře.

    Postup

    1. Klikněte na tlačítko Vložit vzorec Obrázek tlačítka .

    2. V dialogovém okně Vložit vzorec proveďte některou z následujících akcí:

      • Chcete-li ve vzorci použít pole, klepněte na položku Vložit pole nebo skupinu, vyberte pole, které chcete použít v dialogovém okně Vyberte pole nebo skupinu, a klepněte na tlačítko OK.

      • Chcete-li ve vzorci použít funkci, klepněte na položku Vložit funkci, vyberte funkci, kterou chcete použít v dialogovém okně Vložit funkci, a klepněte na tlačítko OK.

        Tip : Pokud funkce vyžaduje zadání parametrů, vyberte funkci v dialogovém okně Vložit funkci, klikněte na tlačítko OK a poté v poli Vzorec v dialogovém okně Vložit vzorec dvakrát klikněte na funkci, kterou jste přidali, a klikněte na pole nebo skupinu. Odkazy na další informace o funkcích najdete v části Viz také.

      • Chcete-li do vzorce vložit hodnotu nebo matematický operátor, zadejte hodnotu nebo symbol matematické operace do pole Vzorec.

    Operace

    Symbol

    Sčítání

    +

    Odečítání

    -

    Násobení

    *

    Dělení

    /

    • Poznámka : Pokud vzorec používá operátor dělení (/), ujistěte se, že před i za operátorem je mezera. Pokud nebude operátor dělení z obou stran oddělen mezerou, bude ho aplikace InfoPath považovat za oddělovač v umístění cesty XPath, ne za operátor dělení.

    • Chcete-li zkontrolovat syntaxi vzorce, v dialogovém okně Vložit vzorec klikněte na tlačítko Ověřit vzorec.

      Odkazy na články s dalšími informacemi o vzorcích naleznete v části Viz také.

  7. Chcete-li přepsat existující formuláře v knihovně dokumentů se stejným názvem, zaškrtněte políčko Povolit přepsání, pokud soubor existuje.

  8. Klepněte na tlačítko Další.

  9. Na další stránce průvodce zadejte do pole Zadejte název tohoto datového připojení popisný název tohoto datového připojení pro odesílání.

Po přidání sekundárního datového připojení pro odesílání je třeba nakonfigurovat šablonu formuláře tak, aby uživatelům umožňovala odesílat data formuláře prostřednictvím tohoto datového připojení pro odesílání.

Krok 2: Povolení odesílání v šabloně formuláře

Pokud šablonu formuláře nakonfigurujete tak, aby uživatelům umožňovala odesílat data formuláře, přidá aplikace InfoPath na panel nástrojů Standardní formuláře tlačítko Odeslat a do nabídky Soubor formuláře příkaz Odeslat. Možnosti odesílání je možné u šablony formuláře také následujícími způsoby upravit:

  • lze změnit text zobrazený na tlačítku Odeslat,

  • lze změnit klávesovou zkratku pro tlačítko Odeslat,

  • lze vytvořit vlastní zprávy, které se uživatelům zobrazí při odeslání formulářů,

  • Výběr z možností, zda po odeslání formulář zavřít, nechat jej otevřený nebo zda otevřít nový nevyplněný formulář.

  • V nabídce Nástroje klikněte na Možnosti odeslání.

  • V dialogovém okně Možnosti odeslání zaškrtněte políčko Povolit uživatelům odeslat tento formulář, klikněte na možnost Odeslat data formuláře do jednoho umístění a v seznamu potom klikněte na Knihovna dokumentů SharePoint.

  • V seznamu Zvolte datové připojení pro odeslání klikněte na název datového připojení pro odesílání dat do knihovny služby SharePoint.

    1. Chcete-li změnit název tlačítka Odeslat, které se zobrazuje na panelu nástrojů Standardní a příkazu Odeslat, který se zobrazuje v nabídce Soubor, když uživatelé vyplní formulář, zadejte nový název do pole Titulek v dialogovém okně Možnosti odeslání.

      Tip : Pokud chcete k tomuto tlačítku a příkazu přiřadit klávesovou zkratku, zadejte znak ampersandu (&) před znak, který chcete použít jako klávesovou zkratku. Chcete-li k tlačítku a příkazu Odeslat přiřadit například klávesovou zkratku ALT+D, zadejte O&deslat.

  • Pokud uživatelům při vyplňování formuláře nechcete povolit použití příkazu Odeslat ani tlačítka Odeslat na panelu nástrojů Standardní, zrušte zaškrtnutí políčka Zobrazit položku nabídky Odeslat a tlačítko Odeslat na panelu nástrojů.

    1. Ve výchozím nastavení zůstane formulář po odeslání otevřený a aplikace InfoPath zobrazí zprávu s informacemi o tom, zda byl formulář úspěšně odeslán. Jestliže chcete toto výchozí chování změnit, klepněte na tlačítko Upřesnit a proveďte jeden z následujících kroků:

      • Chcete-li po odeslání vyplněného formuláře uživatelem formulář zavřít nebo vytvořit nový prázdný formulář, klepněte na požadovanou možnost v rozevíracím seznamu Po odeslání.

      • Chcete-li vytvořit vlastní zprávu s informacemi o tom, zda byl formulář úspěšně odeslán, zaškrtněte políčko Použít vlastní zprávy a potom zadejte požadované zprávy do polí Při úspěchu a Při neúspěchu.

        Tip : Pomocí zprávy v poli Při neúspěchu uživatelům sdělte, co je třeba provést, pokud nelze formulář odeslat. Můžete uživatelům například navrhnout, aby uložili formulář a požádali o další pokyny jinou osobu.

      • Pokud nechcete, aby se po odeslání formuláře uživateli zobrazila zpráva, zrušte zaškrtnutí políčka Zobrazit zprávy o úspěšném nebo neúspěšném provedení.

Začátek stránky

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×