Přidání datového připojení k databázi Microsoft Accessu

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Pokud vaši uživatelé potřebují dat z databáze Microsoft Office Access 2007 (ACCDB) nebo z databáze aplikace Access uložené ve formátu starší verze (MDB) vyplňovat formuláře založené na šabloně formuláře aplikace Microsoft Office InfoPath, můžete přidat sekundárního datového připojení k šabloně formuláře, dotazy databáze aplikace Access.

Můžete přidat sekundárního datového připojení, ale tato datová připojení jenom dotazu databáze aplikace Access. Nemůžete přidat sekundárního datového připojení pro odesílání dat formuláře do databáze aplikace Access.

Pokud chcete uživatelům odesílání dat formuláře do databáze aplikace Access, můžete navrhnout šablonu formuláře, který je založený na databáze aplikace Access a povolení datového připojení pro odesílání hlavní datové připojení. Můžete taky můžete přidat sekundárního datového připojení k webové službě, se kterými spolupracuje databáze aplikace Access.

Odkazy na další informace o navrhování šablon formulářů, které jsou založeny na databáze aplikace Access a přidání sekundárního datového připojení webové služby v části Viz také.

V tomto článku

Základní informace

Důležité informace o kompatibilitě

Než začnete

Krok 1: Přidání sekundárního datového připojení

Krok 2: Nakonfigurujte šablony formuláře použití datového připojení

Přehled

Sekundární Datové připojení je datové připojení, které přidáte do šablony formuláře. Sekundárního datového připojení se liší od hlavního datové připojení, které vytvoříte, když návrh nové šablony formuláře, který je založený na databázi nebo webové služby. Hlavní datové připojení šablony formuláře můžete zobrazit data z externího zdroje dat a můžete taky odeslání dat formuláře do externího zdroje dat. Šablony formuláře však může mít jenom jeden datového připojení.

Můžete přidat tolik sekundárního datového připojení do šablony formuláře jak chcete. Předpokládejme například, že Accesovou databázi obsahující tabulku, která obsahuje údaje o zaměstnancích a druhou tabulku, která jsou uložená data o zákaznících. Můžete přidat sekundárního datového připojení, která načte data v tabulce Zaměstnanci a také můžete přidat další sekundárního datového připojení, který načítá data z tabulky Zákazník ve stejné databázi aplikace Access.

I když sekundárního datového připojení můžete přidat do šablony formuláře, který můžete odeslání dat formuláře ke zdroji externích dat, jako jsou webové služby nebo knihovna služby Windows SharePoint Services, můžete použít jenom sekundárního datového připojení k načtení dat z databáze aplikace Access. Nemůžete přidat sekundárního datového připojení pro odesílání dat formuláře do databáze aplikace Access.

Když přidáte dotazu datové připojení k databázi, aplikace InfoPath vytvoří sekundární Zdroj dat obsahující datová pole a skupiny, které odpovídají způsob uložení dat v databázi. Vzhledem k tomu struktura dat v sekundární zdroj dat se musí shodovat způsobu uložení dat v databázových tabulkách, nelze měnit pole nebo skupiny v sekundární zdroj dat.

Můžete nakonfigurovat každého dotazu datového připojení pro uložení jeho výsledky, aby uživatelé měli přístup k datům, když formuláře není připojený k síti. Podle povahy data můžete zobrazit výsledky dotazu pouze v případě, že uživatelé připojení k síti.

Poznámka zabezpečení : Jestliže používáte sekundární datové připojení k načtení citlivých dat z externího zdroje dat nebo ze seznamu, možná budete chtít tuto funkci zakázat z důvodu ochrany dat před zneužitím v případě, že by došlo ke ztrátě nebo odcizení počítače. Pokud funkci zakážete, budou data dostupná pouze v době připojení uživatele k síti.

Pokud přidáte datové připojení dotazu do šablony formuláře, bude u formulářů založených na této šabloně datové připojení standardně použito při otevření formuláře uživatelem. Šablonu formuláře lze nakonfigurovat také tak, aby používala datové připojení dotazu některým z následujících způsobů:

  • Přidat pravidlo    Můžete nakonfigurovat pravidlo, aby se při splnění podmínky obsažené v pravidle použilo datové připojení pro dotazy.

  • Přidat tlačítko    Do šablony formuláře můžete přidat tlačítko, na které mohou uživatelé kliknout a získat tak pomocí datového připojení pro dotazy požadovaná data.

  • Použít vlastní kód    Pokud nemůžete přidat pravidlo ani tlačítko, můžete k získání dat pomocí datového připojení pro dotazy použít vlastní kód. Tento kód musí vytvořit vývojář.

Začátek stránky

Aspekty kompatibility:

Připojení dat nemůžete přidat do databáze aplikace Access pro Šablona formuláře kompatibilní s prohlížečem.

Začátek stránky

Než začnete

Než přidáte sekundárního datového připojení k databázi aplikace Access do šablony formuláře, je potřeba tyto údaje:

  • Název a umístění databáze.

    Poznámka : Pokud databáze aplikace Access uložený ve umístění v síti, ujistěte se, že je databáze mají uživatelé přístup.

  • Název tabulky nebo dotazu, které slouží k zadání dat do formuláře založené na této šabloně. Použijete tento tabulky nebo dotazu jako primární tabulky nebo dotazu při konfiguraci dotazu datové připojení.

  • Názvy jiných tabulek nebo dotazů, které poskytují další data do primární tabulky nebo dotazu. Ve většině případů jsou už povolili relací mezi tabulkami v databázi. Pokud budete muset ručně vytvořit relace mezi primární tabulka nebo dotaz a další tabulku nebo dotaz, budete potřebovat související pole názvy tabulek nebo dotazů.

Začátek stránky

Krok 1: Přidání sekundárního datového připojení

  1. V nabídce Nástroje klikněte na příkaz Datová připojení.

  2. V dialogovém okně Datová připojení klikněte na tlačítko Přidat.

  3. V Průvodci datovým připojením klikněte na možnost Vytvořit nové připojení k, pokračujte kliknutím na příkaz Přijímat data a na tlačítko Další.

  4. Na první stránce průvodce klepněte na přepínač Databáze (pouze Microsoft SQL Server nebo Microsoft Office Access) a pak klepněte na tlačítko Další.

  5. Na další stránce průvodce klepněte na tlačítko Vybrat databázi.

  6. V dialogovém okně Vybrat zdroj dat přejděte k umístění vaší databáze.

    Poznámka : Pokud je databáze uložená v umístění v síti, přejděte na cestu konvence UNC umístění. Není přejděte do umístění v síti prostřednictvím síťovou jednotku. Pokud používáte síťovou jednotku, uživatelé, kteří vytvářejí formuláře založené na této šabloně vyhledá tuto databázi síťovou jednotku. Pokud uživatel nemá síťovou jednotku, formuláři nenajde databáze.

  7. Klikněte na název databáze a pak klikněte na Otevřít.

  8. V dialogovém okně Vybrat tabulku klikněte na primární tabulka nebo dotaz, který chcete použít a klikněte na OK.

  9. Na další stránce průvodce zaškrtněte políčko Zobrazit sloupce tabulky.

    Ve výchozím nastavení všech polí v tabulce nebo dotazu se přidají do hlavního zdroje dat šablony formuláře.

  10. Zrušte zaškrtnutí políček u polí, která nechcete zahrnout sekundární zdroj dat.

    Přidání dalších tabulek nebo dotazů do datového připojení.

    Postup

    1. Klepněte na tlačítko Přidat tabulku.

    2. V dialogovém okně Přidat tabulku nebo dotaz klepněte na název podřízené tabulky a potom na tlačítko Další. V aplikaci InfoPath dojde k pokusu nastavit relace porovnáním názvů polí v obou tabulkách. Pokud nechcete použít navrženou relaci, vyberte ji a klepněte na tlačítko Odebrat relaci. Chcete-li relaci přidat, klepněte na tlačítko Přidat relaci. V dialogovém okně Přidat relaci klepněte na název každého souvisejícího pole v příslušném sloupci a potom klepněte na tlačítko OK.

    3. Klepněte na tlačítko Dokončit.

    4. Chcete-li přidat další podřízené tabulky, opakujte uvedené kroky.

  11. Klepněte na tlačítko Další.

  12. Chcete-li zajistit, aby byly výsledky datového připojení pro dotazy k dispozici v případě, že není formulář připojen k síti, zaškrtněte políčko Uložit kopii dat do šablony formuláře.

    Poznámka zabezpečení : Zaškrtnutím tohoto políčka jsou uložená data na počítači uživatele formuláře při použití tohoto datového připojení. Pokud formuláři načítá citlivá data z tohoto datového připojení, můžete k zakázání této funkce se můžete pomoci chrá data v případě ztráty či krádeže počítače.

  13. Klepněte na tlačítko Další.

  14. Na další stránce průvodce zadejte popisný název tohoto sekundárního datového připojení a pak ověřte, že jsou informace v části Shrnutí správné.

  15. Pokud chcete nakonfigurovat formuláře, který se automaticky obnoví data při otevření formuláře, zaškrtněte políčko automaticky obnoví data při otevření formuláře.

Začátek stránky

Krok 2: Konfigurace šablony formuláře na používání daného datového připojení

Pokud budete potřebovat formuláře založené na této šabloně formuláře a použít tento datové připojení po otevření formuláře, Pravidlo můžete přidat do šablony formuláře, který používá datové připojení pod určitou podmínkou nebo přidání tlačítka na šablonu formuláře, pomocí kterého uživatelé můžete použít toto datové připojení.

Přidání pravidla

Přidání pravidla do šablony formuláře, který slouží k načtení dat z datové připojení dotazu kdykoli splnění podmínky pravidla. Textové pole můžete například přidat do šablony formuláře, který uživatel vyplňovat přejít specifická data z externího zdroje dat. Pak můžete přidat pravidlo, které používá datové připojení pokaždé, když uživatel zadá data do textového pole.

Následující postup předpokládá, že jste vytvořili datové připojení dotazu pro šablonu formuláře a že jste nakonfigurovali ovládacího prvku (jiné než tlačítko) v šabloně formuláře pro zobrazení dat z daného datového připojení.

  1. Pokud šablona formuláře obsahuje více zobrazení, klikněte v nabídce Zobrazit na název zobrazení a tak přejděte na zobrazení obsahující ovládací prvek, ve kterém chcete zobrazit data ze sekundárního zdroje dat.

  2. Poklepejte na ovládací prvek, ke kterému chcete přidat pravidlo.

  3. Klepněte na kartu Data.

  4. V části Ověření a pravidla klepněte na tlačítko Pravidla.

  5. V dialogovém okně Pravidla klepněte na tlačítko Přidat.

  6. Do pole Název zadejte název pravidla.

  7. Pokud chcete určit podmínku, za jaké bude pravidlo spuštěno, klepněte na tlačítko Nastavit podmínku a zadejte podmínku. Pravidlo bude spuštěno, když se podmínka splní. Pokud podmínku nenastavíte, bude pravidlo spuštěno pokaždé, když uživatel změní hodnotu v ovládacím prvku a následně odsune kurzor z daného ovládacího prvku.

  8. Klepněte na tlačítko Přidat akci.

  9. V rozevíracím seznamu Akce klepněte na položku Zadat dotaz pomocí datového připojení.

  10. V rozevíracím seznamu Datové připojení klepněte na datové připojení pro dotazy, které chcete použít, a postupným klepnutím na tlačítka OK zavřete všechna otevřená dialogová okna.

  11. Změny můžete otestovat kliknutím na Náhled na panelu nástrojů Standardní nebo stisknutím kláves CTRL+SHIFT+B.

Přidání tlačítka

Do šablony formuláře můžete přidat tlačítko, na které mohou uživatelé klepnout a získat tak data prostřednictvím datového připojení pro dotazy.

  1. Pokud šablona formuláře obsahuje více zobrazení, klikněte v nabídce Zobrazit na název zobrazení a tak přejděte na zobrazení obsahující ovládací prvek, ve kterém chcete zobrazit data ze sekundárního zdroje dat.

  2. Pokud není vidět podokno úloh Ovládací prvky, klikněte na Další ovládací prvky v nabídce Vložit nebo stiskněte klávesy ALT+I, C.

  3. Přetáhněte tlačítko do šablony formuláře.

  4. Poklepejte na tlačítko, které jste právě přidali do šablony formuláře.

  5. Klepněte na kartu Obecné.

  6. V rozevíracím seznamu Akce klepněte na položku Aktualizovat.

  7. Do pole Popisek zadejte název, který se má zobrazit na tlačítku v šabloně formuláře.

  8. Klepněte na tlačítko Nastavení.

  9. V dialogovém okně Aktualizovat proveďte jednu z následujících akcí:

    • Pro příjem nejnovější data ze všech zdrojů externích dat s sekundárního datového připojení na této šabloně, klikněte na Všechny sekundární zdroje dat.

    • Pro nastavení na tlačítko Zobrazit aktuální data z jednoho zdroje externích dat s sekundárního datového připojení do šablony formuláře, klikněte na jedno sekundárního datového připojení a klikněte sekundární zdroj dat v seznamu vyberte sekundární zdroj dat.

  10. Postupným klepnutím na tlačítka OK zavřete všechna otevřená dialogová okna.

  11. Změny můžete otestovat kliknutím na Náhled na panelu nástrojů Standardní nebo stisknutím kláves CTRL+SHIFT+B.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×