Převod databáze do formátu souboru ACCDB

Ve výchozím nastavení vytváří Access 2016, Access 2013, Access 2010 a Access 2007 databáze ve formátu souborů .accdb. Tento formát podporuje funkce, jako jsou pole s několika hodnotami, datová makra a publikování do služby Access Services.

Databáze vytvořené v aplikaci Microsoft Office Access 2003, Access 2002, Access 2000 nebo Access 97 lze do formátu souboru ACCDB převést. Mějte však na paměti, že databázi ve formátu souboru ACCDB nelze otevřít ani propojit ve verzích aplikace Access starších než Access 2007.

Kromě toho formát ACCDB nepodporuje replikaci nebo zabezpečení na úrovni uživatele. Pokud potřebujete databázi sdílet s uživateli, kteří používají aplikaci Access 2003 nebo starší, nebo potřebujete používat replikaci nebo zabezpečení na úrovni uživatele, je nutné používat formát souboru MDB.

Poznámka : I když sdílí stejný formát souboru, nejde některé funkce v Accessu 2016, Accessu 2013 a Accessu 2010 použít v Accessu 2007. Další informace najdete v části Použití Accessu 2007 k otevření databáze, která byla vytvořená nebo změněná v Accessu 2010, Accessu 2013 nebo Accessu 2016.

V tomto článku

Převod databáze Accessu 2000 nebo Accessu 2002–2003 do formátu .accdb

Převod databáze Accessu 97 do formátu .accdb

Použití Accessu 2007 k otevření databáze, která byla vytvořená nebo změněná v Accessu 2010, Accessu 2013 nebo Accessu 2016

Převod databáze aplikace Access 2000 nebo aplikace Access 2002–2003 do formátu ACCDB

Pokud chcete převést databázi Accessu 2000 nebo Accessu 2002–2003 (.mdb) do formátu souboru .accdb, musíte ji nejdřív otevřít v Accessu 2007, Accessu 2010, Accessu 2013 nebo Accessu 2016 a pak ji uložit ve formátu souboru .accdb.

  1. Klikněte na položku Soubor a poté na příkaz Otevřít.

  2. Klikněte na databázi aplikace Access 2000 nebo Access 2002–2003 (MDB), kterou chcete převést.

    Poznámka : Zobrazí-li se dialogové okno Zlepšení databáze, používá databáze formát souboru starší než Access 2000. Pokračujte podle části Převod databáze aplikace Access 97 do formátu ACCDB.

  3. Klikněte na kartu Soubor, klikněte na možnost Uložit jako a poté klikněte na možnost Uložit databázi jako.

  4. Jako typ souboru zvolte Access a poté klikněte na možnost Uložit jako.

    Jsou-li některé databázové objekty při kliknutí na možnost Uložit jako otevřené, zobrazí se v aplikaci Access výzva k jejich zavření před vytvořením kopie. Kliknete-li na tlačítko Ano, aplikace Access objekty zavře, a kliknete-li na tlačítko Ne, celý proces se zruší. Aplikace Access zobrazí v případě potřeby výzvu k uložení změn.

  5. V dialogovém okně Uložit jako zadejte název souboru do pole Název souboru a klikněte na tlačítko Uložit.

    Aplikace Access vytvoří kopii databáze a potom ji otevře. Původní databáze se automaticky zavře.

Začátek stránky

Převod databáze aplikace Access 97 do formátu ACCDB

Počínaje Accessem 2013 už není možné převádět databáze aplikace Access 97 (.mdb) přímo do formátu souborů ACCDB. Databázi Accessu 97 však můžete otevřít v předchozí verzi Accessu a uložit ji ve formátu, který Access 2013 umožňuje otevřít. Následující příklad popisuje, jak pomocí Accessu 2003 otevřít databázi Accessu 97 a převést ji na formát, který se dá otevřít v Accessu 2013:

  1. Otevřete databázi Accessu 97 v Accessu 2003.

  2. Klikněte na Nástroje > Správa databáze > Převést databázi > na Formát souborů Accessu 2002–2003.

  3. Zadejte název databáze a klikněte na Uložit.

  4. Zavřete Access 2003 a otevřete Access 2013.

  5. Otevřete databázi a klikněte na Soubor > Uložit jako > Databáze aplikace Access (.accdb) > Uložit jako > Uložit.

K převodu databáze Accessu 97 do formátu ACCDB můžete použít taky Access 2007 nebo Access 2010. Pokud otevřete databázi Accessu 97 v některé z těchto dvou aplikací, zobrazí se průvodce Zlepšení databáze, který vám pomůže převést databázi do formátu ACCDB.

Začátek stránky

Použití Accessu 2007 k otevření databáze, která byla vytvořená nebo změněná v Accessu 2010, Accessu 2013 nebo Accessu 2016

Protože Access 2016, Access 2013, Access 2010 a Access 2007 používají stejný formát souboru, můžete z Accessu 2007 otevřít databázi, která byla vytvořená v Accessu 2010, Access 2013 nebo v Accessu 2016, i když předtím nepoužijete příkaz Uložit jako. Access 2016, Access 2013 a Access 2010 ale obsahují určité nové funkce, které ke spuštění potřebují Access 2016, Access 2013 a Access 2010. V závislosti na příslušné funkci se při pokusu o použití databáze v Accessu 2007 může stát jedna z těchto věcí:

  • Objekt, který používá tuto funkci, nelze změnit.

  • Objekt, který používá tuto funkci, nelze otevřít.

  • Databázi nelze v aplikaci Access 2007 vůbec otevřít.

Začátek stránky

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×