Převod čísel do slov

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Excel 2013 a Excel 2016 nemají výchozí funkci, která slouží k zobrazení čísel jako anglických slov v buňce tabulky, ale můžete přidat tuto funkci zadáním nebo vložením kód funkce SpellNumber do listu modulu. Tato funkce umožňuje převést částky Kč a cent slov.

Pokud chcete k převodu číselných hodnot ve formátu textu bez jejich zobrazením jako slova, použijte funkci hodnota.na.text .

V tomto článku

Vytvoření funkci SpellNumber k převodu čísla na slova

  1. Použijte klávesovou zkratku Alt + F11 slouží k otevření editoru jazyka Visual Basic.

    Poznámka : Můžete taky zpřístupníte editoru jazyka Visual Basic zobrazením kartu Vývojář na pásu karet.

  2. Klikněte na kartu Vložení a klepněte na příkaz Module.

    V nabídce Vložit klikněte na modul.
  3. Zkopírujte následující řádky kódu.

    Poznámka : Jmenoval převodem maker, tento kód zautomatizovat o převedení čísla na text v celé tabulce.

    Možnost explicitní

    "Hlavní (funkce)

    Funkce SpellNumber (ByVal MyNumber)

    Dim dolary částky, Temp

    Dim desetinné místo počet

    ReDim Place(9) jako řetězec

    Place(2) = "Tisíc"

    Place(3) = "milionů"

    Place(4) = "Bilion"

    Place(5) = "bilion"

    "Řetězec znázornění množství.

    MyNumber = Trim(Str(MyNumber))

    "Pozici od desetinné čárky 0, pokud není k dispozici.

    Desetinné místo = InStr (MyNumber, ".")

    "Převést částky a nastavte MyNumber na částku v korunách.

    Pokud desetinné místo > = 0 Then

    Částky = GetTens (vlevo (Mid (MyNumber, desetinné místo + 1) & _ "00"; 2))

    MyNumber = Trim (vlevo (MyNumber, desetinné místo - 1))

    Ukončení

    Count = 1

    Při MyNumber <> ""

    Temp = GetHundreds (vpravo (MyNumber, 3))

    Pokud Temp <> "" potom dolary = Temp a Place(Count) & dolary

    Pokud Len(MyNumber) > 3 potom

    MyNumber = zleva (MyNumber, Len(MyNumber) - 3)

    Else

    MyNumber = ""

    Ukončení

    Count = počet + 1

    Opakovat

    Vyberte případu dolary

    Velikost písmen ""

    Dolary = "Bez Kč"

    Velikost písmen "Jeden"

    Dolary = "Jeden Kč"

    Případ ještě

    Dolary = dolary & "Kč"

    Vyberte konec

    Vyberte případu částky

    Velikost písmen ""

    Částky = "a ne částky"

    Velikost písmen "Jeden"

    Částky = "a jeden %"

    Případ ještě

    Částky = "a" & částky & "Částky"

    Vyberte konec

    SpellNumber = dolary & částky

    Ukončení (funkce)

    "Převede číslo z 100 999 textu

    Funkce GetHundreds (ByVal MyNumber)

    Dim výsledek jako řetězec

    Pokud Val(MyNumber) = 0 pak konec (funkce)

    MyNumber = zprava ("000" & MyNumber, 3)

    "Převést stovky umístit.

    Když Mid (MyNumber, 1, 1) potom <> "0"

    Výsledek = GetDigit (Mid (MyNumber, 1, 1)) & "set"

    Ukončení

    "Převedení místních desítky a souborů.

    Když Mid (MyNumber, 2, 1) potom <> "0"

    Výsledek = výsledek & GetTens (Mid (MyNumber, 2))

    Else

    Výsledek = výsledek & GetDigit (Mid (MyNumber, 3))

    Ukončení

    GetHundreds = výsledek

    Ukončení (funkce)

    "Převede číslo z 10 až 99 text.

    GetTens(TensText) (funkce)

    Dim výsledek jako řetězec

    Výsledek = "" "dočasné funkce hodnotu Null.

    Pokud Val (vlevo (TensText, 1)) = 1, pak "Pokud hodnotu mezi 10 19...

    Vyberte případu Val(TensText)

    Případ 10: Výsledek: = "Deset"

    Případ 11: Výsledek: = "Jedenáct"

    Případ 12: Výsledek: = "Dvanáct"

    Případ 13: Výsledek: = "Třináct"

    Případ 14: Výsledek: = "Čtrnáct"

    Případ 15: Výsledek: = "Patnáct"

    Případ 16: Výsledek: = "Šestnáct"

    Případ 17: Výsledek: = "Sedmnáct"

    18 případ: Výsledek: = "18 let"

    Případ 19: Výsledek: = "Devatenáct"

    Případ ještě

    Vyberte konec

    Dalšího "Pokud hodnotu mezi 20 99...

    Vyberte případu Val (vlevo (TensText, 1))

    Případ 2: Výsledek: = "Dvacet"

    Případ 3: Výsledek: = "Třicet"

    Případ 4: Výsledek: = "Čtyřicet"

    Případ 5: Výsledek: = "Padesát"

    Případ 6: Výsledek: = "Šedesát"

    Případ 7: Výsledek: = "70"

    Případ 8: Výsledek: = "Osmdesát"

    Případ 9: Výsledek: = "90"

    Případ ještě

    Vyberte konec

    Výsledek = výsledek & GetDigit _

    (Vpravo (TensText, 1)) "Načíst tak místo.

    Ukončení

    GetTens = výsledek

    Ukončení (funkce)

    "Převede číslo od 1 do 9 text.

    GetDigit(Digit) (funkce)

    Vyberte případu Val(Digit)

    Případ 1: GetDigit = "Jednu"

    Případ 2: GetDigit = "2"

    Případ 3: GetDigit = "3"

    Případ 4: GetDigit = "Čtyři"

    Případ 5: GetDigit = "5"

    Případ 6: GetDigit = "Šest"

    Případ 7: GetDigit = "7"

    Případ 8: GetDigit = "Osm"

    Případ 9: GetDigit = "Devíti"

    Případ ještě: GetDigit = ""

    Vyberte konec

    Ukončení (funkce)

  4. Vložit řádky kódu do Module1 (kód) pole.

    Kód vložený do Module1 pole (kód).
  5. Klikněte na kartu soubor a klikněte na Zavřít a návrat do aplikace Microsoft Excel. Funkce SpellNumber je nyní připravena k použití.

    Poznámka : Tato funkce funguje jenom pro aktuální soubor Excel tlačítky otevřít. Tuto funkci nelze použít v jiném sešitu Excel, musíte opakujte kroky zkopírujte a vložte kód v tomto souboru.

Začátek stránky

Použít funkci SpellNumber v jednotlivých buňkách

  1. Zadejte vzorec = SpellNumber (hodnota) do buňky, ve které chcete zobrazit ručně psaných číslo nahrazení hodnota číslo svého výběru.

  2. Na klávesnici stiskněte klávesu Enter.

    Třeba když zadáte =SpellNumber(22.50), buňku by si přečíst Dvacet dva dolary a 50 částky.

    Tip : K převodu čísla na text do zvláštní buňky, nahraďte odkaz na buňku ve vzorci SpellNumber číselnou hodnotu. Zadejte například =SpellNumber(A1) k zobrazení ručně psaných hodnoty buňky A1.

Začátek stránky

Uložte sešit SpellNumber (funkce)

Excel nelze uložit sešitu s funkcemi makra ve formátu Standardní sešitu bez maker. Pokud kliknete na soubor > Uložit. Otevře se dialogové okno projektu jazyka Visual Basic. Klikněte na Ne.

V dialogovém okně VB Projekt klikněte na Ne.

Soubor můžete uložit jako Šablonu jako zachovat soubor v tomto formátu.

  1. Klikněte na Soubor > Uložit jako.

  2. Klikněte na rozevírací nabídky Uložit jako typ a vyberte Excel Macro-Enabled Template.

    Vyberte šablona aplikace Excel s podporou maker.
  3. Klikněte na Uložit.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Viz taky

HODNOTA.NA.TEXT

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×