Převedení dokumentu aplikace Word na šablonu formuláře aplikace InfoPath

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Ačkoli je pravda, že v aplikaci Microsoft Office Word lze vytvořit dokument, který se chová a vypadá jako formulář, aplikace Word je především určena ke zpracování textu a nikoli k navrhování formulářů. Naproti tomu aplikace Microsoft Office InfoPath byla vytvořena přímo pro navrhování a vyplňování elektronických formulářů. Chcete-li převést existující dokumenty aplikace Word na šablony formulářů aplikace InfoPath, použijte Průvodce importem aplikace InfoPath. Poté můžete začít využívat nástroje aplikace InfoPath vytvořené zvlášť pro návrh, publikování a vyplňování formulářů. Příklad: V šabloně formuláře zprávy o tržbách můžete použít Podmíněné formátování a nastavit, aby se barva pozadí změnila na červenou pokaždé, když jsou hodnoty nižší než předpokládané tržby. Nebo můžete použít Pravidlo a povolit, aby formuláře založené na této šabloně byly odesílány jako přílohy e-mailových zpráv pokaždé, když uživatel klepne na tlačítko Odeslat. Kromě toho můžete šablonu formuláře zpřístupnit širšímu okruhu uživatelů použitím Šablona formuláře s podporou prohlížeče.

Po převedení dokumentu aplikace Word na šablonu formuláře aplikace InfoPath bude mít výsledná šablona formuláře stejné rozložení jako původní dokument aplikace Word. Kromě toho budou položky v dokumentu aplikace Word, které odpovídají určitým požadavkům, automaticky převedeny na příslušné ovládací prvky, do kterých mohou uživatelé zadávat data. Příklad: Pokud dokument aplikace Word obsahuje závorky ohraničující několik mezer, aplikace InfoPath bude předpokládat, že se jedná o pole pro zadání textu, a v šabloně formuláře převede tento řetězec na ovládací prvek textového pole. Pole formuláře aplikace Word budou v aplikaci InfoPath převedena na odpovídající ovládací prvky.

Chcete-li změnit možnosti pro převod dokumentu aplikace Word na šablonu formuláře aplikace InfoPath, můžete použít nastavení v dialogovém okně Možnosti importu.

Tento článek se zabývá základními pojmy a postupy převádění dokumentu aplikace Word na šablonu formuláře InfoPath včetně funkcí a nastavení, které proces převedení nepodporuje.

V tomto článku:

Informace o převedení dokumentu aplikace Word na šablonu formuláře aplikace InfoPath

Funkce a nastavení aplikace Word, které proces převedení plně nepodporuje

Převod dokumentu aplikace Word na šablonu formuláře aplikace InfoPath

Změna tabulky rozložení na tabulku s opakováním

Změna zaškrtávacích políček na skupinu přepínačů

Kontrola potíží s převedením v podokně úloh Kontrola návrhu

Informace o převedení dokumentu aplikace Word na šablonu formuláře aplikace InfoPath

Při převádění dokumentu aplikace Word na šablonu formuláře aplikace InfoPath se původní dokument používá jako plán, podle kterého se vytváří nová šablona. Základní struktura dokumentu je v šabloně formuláře dodržena tak přesně, jak to jen jde. V dokumentu aplikace Word je pole formuláře místo, kde je uložen konkrétní typ dat, například jméno nebo adresa. Pokud se rozhodnete, že při převádění dokumentu chcete zachovat také pole formuláře aplikace Word, budou do šablony formuláře aplikace InfoPath na příslušná místa odpovídající umístěním polí v dokumentu aplikace Word přidány ovládací prvky textového pole, zaškrtávacího políčka a rozevíracího seznamu. Aplikace InfoPath dále rozpozná části dokumentu aplikace Word, které by se daly použít jako tabulky s opakováním a pole s formátovaným textem, a převede je na příslušné ovládací prvky. Příklad: Pokud dokument zprávy o nákladech obsahuje prázdný podtržený prostor, kam mohou uživatelé přidat poznámku o konkrétních výdajích, aplikace InfoPath převede tento prostor na pole s formátovaným textem. Do tohoto pole mohou uživatelé napsat i několik řádků textu a text mohou podle potřeby zformátovat.

Chcete-li lépe porozumět tomu vztah mezi dokumentu aplikace Word, které převádíte pomocí Průvodce importem aplikace InfoPath a šabloně formuláře aplikace InfoPath, představte si, že pro několik posledních let organizaci použil dokumentu aplikace Word s názvem ZprávaVýdaje.doc shromažďovat data sestavy výdajů zaměstnanců. Oddělení IT chce tento dokument tak, aby dat formuláře lze odeslat jako jazyk XML (Extensible Markup) systému závazky převést na šablonu formuláře aplikace InfoPath.

Pokud k převedení souboru ZprávaVýdaje.doc na šablonu formuláře použijete Průvodce importem, vytvoří aplikace InfoPath šablonu formuláře s názvem ZprávaVýdaje.xsn. V následujícím příkladu byla tabulka Podrobnosti výdajů z dokumentu aplikace Word ve výsledné šabloně formuláře aplikace InfoPath převedena na tabulku s opakováním. Tabulka s opakováním umožňuje uživatelům vkládat nebo odstraňovat výdaje podle potřeby klepnutím na příkazy v místní nabídce.

Tabulka aplikace Word, která byla převedena na tabulku s opakováním aplikace InfoPath

Při převodu dokumentu aplikace Word na šablonu formuláře aplikace InfoPath jsou rozložení a ostatní prvky zachovány. Ve výchozím nastavení odpovídá počet prázdných řádků v tabulce s opakováním aplikace InfoPath počtu prázdných řádků v tabulce aplikace Word. V šabloně formuláře je však možné uspořit místo tím, že výchozí nastavení upravíte tak, aby se zobrazil vždy pouze jeden nebo dva řádky.

Nová šablona formuláře obsahuje prvky, které jsou podobné prvkům dokumentu aplikace Word, například tabulku pro sběr informací o výdajích. V závislosti na zvolených nastaveních průvodce importem se však mohou některé funkce ve výsledné šabloně lišit:

  • Pokud k importu dokumentu aplikace Word použijete Průvodce importem a zachováte pouze rozložení.    Výsledná šablona formuláře obsahuje tabulku s opakováním pro zadávání položek do zprávy o výdajích. Chybí v ní však veškerá pole formuláře, která byla v původním dokumentu, jako jsou textové pole Jméno, rozevírací seznam Oddělení nebo zaškrtávací políčka Divize.

  • Pokud k importu dokumentu aplikace Word použijete Průvodce importem a zachováte rozložení a převedete pole formuláře aplikace Word na ovládací prvky (výchozí nastavení).    Výsledná šablona formuláře obsahuje tabulku s opakováním pro zadávání položek do zprávy o výdajích. Veškerá pole formuláře, která byla v původním dokumentu, jako jsou textové pole Jméno, rozevírací seznam Oddělení nebo zaškrtávací políčka Divize, budou převedena na odpovídající ovládací prvky aplikace InfoPath.

  • Pokud k importu dokumentu aplikace Word použijete Průvodce importem a zachováte rozložení a převedete pole formuláře na ovládací prvky (vlastní nastavení).    Můžete vybrat pole, která budou při importu zprávy o výdajích převedena. Příklad: Můžete zakázat převod prázdných buněk tabulky dokumentu na textová pole ve výsledné šabloně formuláře.

Začátek stránky

Funkce a nastavení aplikace Word, které proces převedení plně nepodporuje

Některá nastavení a formáty použité v dokumentech aplikace Word nejsou v šablonách formuláře aplikace InfoPath podporovány. Při převedení dokumentu aplikace Word obsahujícího nepodporovaná nastavení nebudou tyto funkce a nastavení ve výsledné šabloně formuláře obsaženy. Příklad: Pokud dokument aplikace Word obsahuje značky revize, budou tyto značky ve výsledné šabloně formuláře chybět, protože aplikace InfoPath tuto funkci nepodporuje.

K odhalení veškerých potíží při převedení můžete použít podokno úloh Kontrola návrhu v Režim návrhu. Poté můžete začít s odstraňováním těchto problémů.

V následujícím seznamu jsou uvedeny některé funkce a nastavení, které nebudou při převodu dokumentu aplikace Word na šablonu formuláře aplikace InfoPath zachovány. V některých případech je zachován původní text a formátování nikoli. Příklad: Pokud používáte sloupce ve stylu bulletinu, aplikace InfoPath bude importovat pouze text z těchto sloupců a nikoli sloupce samotné.

  • Záložky

  • Animovaný text

  • Motivy

  • Vodoznaky

  • Čísla řádků

  • Ohraničení stránky

  • Poznámky pod čarou a vysvětlivky

  • Rozložení sloupců ve stylu bulletinu

  • Soubory jako příloha

  • Propojené nebo vložené objekty, například sešity aplikace Microsoft Office Excel nebo výkresy aplikace Microsoft Office Visio

  • Objekty kreslení (včetně automatických tvarů, křivek, čar a objektů WordArt)

  • Mezery mezi znaky (včetně velikosti znaku, rozšířené nebo zúžené mezery, zvýšené nebo snížené umístění textu a prokládání znaků)

  • Ovládací prvky ActiveX

  • Komentáře a sledované změny (včetně vloženého textu, odstraněného textu nebo změn formátování)

  • Některé funkce, které jsou specifické pro Microsoft Office Word 2007 (včetně stavebních bloků a ovládací prvky obsahu)

  • Některá nastavení tisku (včetně smíšeného formátování znaků v záhlaví nebo zápatí, různého záhlaví nebo zápatí na sudých a lichých stránkách, různého záhlaví nebo zápatí na první stránce, nastavení okrajů, záporných hodnot pro horní a dolní okraj, různé orientace stránek a nastavení pro jednotlivé oddíly)

Poznámka : Bez hesla nelze upravovat některé dokumenty aplikace Word. Pokud jde o případ s dokumentem, nebudete moci úspěšně importujte ho na InfoPath. Tento problém, zkuste před importem odebrání ochrany heslem z dokumentu. Kromě toho některé dokumenty omezit oprávnění uživatelů k určité typy úprav akce, třeba k zadání dat v poli formuláře. Pokud jde o případ s dokumentem, nemusí být úspěšně importovat do aplikace InfoPath. Tento problém, zkuste odebrat omezení úprav dokumentu před importem.

V následujícím seznamu jsou uvedeny funkce a nastavení s částečnou podporou při převodu dokumentu aplikace Word na šablonu formuláře aplikace InfoPath:

Svislý text.    Aplikace InfoPath zachová formátování svislého textu z dokumentu aplikace Word, pokud je svislý text obsažen v buňce tabulky. Pokud se svislý text nachází mimo tabulku v jiné části dokumentu aplikace Word, není jeho formátování při převodu aplikací InfoPath zachováno.

Textová pole.    V dokumentech aplikace Word jsou textová pole kontejnery na text, které mohou být umístěny na stránku a u kterých lze měnit velikost. Pokud dokument aplikace Word obsahuje textové pole, bude textové pole do výsledné šablony formuláře převedeno jako buňka tabulky. Veškerý text z textového pole bude ve výsledné šabloně formuláře zobrazen v příslušné buňce tabulky.

Podtržený text.    Šablony formulářů aplikace InfoPath podtržený text podporují. Avšak veškerá dekorativní nebo dvojitá podtržení budou v šabloně formuláře převedena na jednoduchá podtržení.

Hypertextové odkazy odkazující na nepodporované protokoly.     Veškeré hypertextové odkazy budou převedeny, ale pokud některý hypertextový odkaz používá jiný protokol než HTTP, HTTPS, FILE, FTP nebo MAILTO, nebude ve výsledné šabloně formuláře funkční.

Styly znaků a textové efekty.    Formáty textu horní index, dolní index a text s jednoduchým přeškrtnutím jsou při procesu převedení zachovány. Jiné styly formátování a textové efekty včetně textu s efektem obrysů, skrytého textu a stínovaného písma při procesu převedení zachovány nejsou. Text s efektem reliéfu a text s efektem rytiny jsou ve výsledné šabloně formuláře převedeny na šedý text.

Nastavení oddílu.    V aplikaci Word se oddíly používají k odlišení rozložení textu dokumentu na jedné nebo více stránkách. Aplikace InfoPath tyto typy oddílů nepodporuje, oddíly proto při převedení nejsou zachovány. V celé výsledné šabloně formuláře aplikace InfoPath budou použita nastavení prvního oddílu dokumentu aplikace Word.

Formátování záhlaví a zápatí.    Text záhlaví a zápatí dokumentu aplikace Word bude ve výsledné šabloně formuláře aplikace InfoPath převeden na text záhlaví a zápatí. Je možné, že při procesu převedení nebude zpracováno některé formátování znaků. Přiklad: Pokud v záhlaví dokumentu aplikace Word používáte kurzívu i tučné písmo, aplikace InfoPath pro celou šablonu formuláře použije první formátování písma, na které narazí, jakékoliv další formáty písma nebudou zpracovány. Nastavení použitá pro první záhlaví a zápatí v dokumentu aplikace Word budou podle stejného principu použita na všechna záhlaví a zápatí v šabloně formuláře aplikace InfoPath.

Převedení typů písma.    Aplikace InfoPath importuje při vytváření nové šablony formuláře typ písma z původního dokumentu aplikace Word. Pokud však v počítači, kde import provádíte, nejsou potřebné typy písma k dispozici, budou pro potřeby šablony formuláře automaticky zvoleny zástupné typy písma.

Záporné okraje stránky.    Záporné horní a dolní okraje stránky budou importovány s hodnotou 0.

Nastavení záporných hodnot okrajů a odsazení obsahu.    Záporné hodnoty okrajů a odsazení obsahu budou importovány jako hodnota 0.

Začátek stránky

Převedení dokumentu aplikace Word na šablonu formuláře aplikace InfoPath

  1. Je-li dokument aplikace Word, který chcete importovat, otevřený, zavřete jej.

  2. V návrhovém režimu klepněte v nabídce Soubor na příkaz Importovat formulář.

  3. V Průvodci importem klepněte na položku Import dokumentů aplikace Word do aplikace InfoPath a klepněte na tlačítko Další.

  4. Klepněte na tlačítko Procházet.

  5. Vyhledejte dokument aplikace Word, klepněte na něj a poté na tlačítko Otevřít.

    Poznámka : Pokud chcete importovat dokument aplikace Word s omezeným oprávněním, je k němu nejprve třeba získat přístup na úrovni Úplné řízení. Pokud máte k dokumentu pouze oprávnění Číst nebo Měnit, zobrazí se při pokusu o import chybová zpráva.

  6. Chcete-li změnit výchozí nastavení importu, klepněte na tlačítko Možnosti a zaškrtněte požadované možnosti.

  7. Klepněte na tlačítko Dokončit.

Začátek stránky

Změna tabulky rozložení na tabulku s opakováním

Pokud dokument aplikace Word obsahuje tabulku, aplikace InfoPath ji ve výsledné šabloně formuláře může převést na Tabulka rozložení nebo na tabulku s opakováním. Zvolený typ tabulky závisí na tom, jaká rozhodnutí o návrhu učiníte v původním dokumentu aplikace Word. Pro rychlou změnu převedené tabulky rozložení na tabulku s opakováním postupujte podle následujícího návodu.

Použití tabulky s opakováním nabízet vaši uživatelé navíc stupeň pružnost při vyplňování formulářů. Při použití tabulky s opakováním šablony formuláře nemá zobrazíte spoustu prázdné řádky uživatele při prvním otevření. Místo toho uživatelé obvykle zobrazuje jenom jeden řádek a přidat další jenom, když a pokud je potřebují. Uloží místo ve formuláři a umožňuje uživatelům navíc stupeň pro individuální nastavení.

  1. V šabloně formuláře klikněte pravým tlačítkem na libovolné místo uvnitř tabulky rozložení, který chcete převést.

  2. V místní nabídce přejděte na příkaz Změnit na a klepněte na příkaz Tabulka s opakováním.

  3. V dialogovém okně Změnit na tabulku s opakováním proveďte jednu nebo více následujících akcí:

    • Chcete-li určit, kolik má tabulka s opakováním obsahovat řádků záhlaví, zadejte hodnotu do pole Počet řádků, které mají být ponechány jako záhlaví tabulky. Řádek záhlaví slouží obvykle pro záhlaví sloupců.

    • Chcete-li určit, kolik má tabulka s opakováním obsahovat řádků zápatí, zadejte hodnotu do pole Počet řádků, které mají být uchovány jako zápatí tabulky. Mnohé tabulky řádky zápatí vůbec neobsahují.

    • Chcete-li určit, kolik má být použito datových řádků, zadejte hodnotu do pole Počet řádků s opakováním, které mají být zahrnuty při vyplňování formuláře. Datový řádek je řádek, který se může ve formuláři „opakovat“ tolikrát, kolikrát je třeba.

  4. Klepněte v nabídce Vložit na příkaz Další ovládací prvky nebo stiskněte klávesovou zkratku ALT+I a pak klávesu D.

  5. Vložte do buněk tabulky požadované ovládací prvky.

Začátek stránky

Změna zaškrtávacích políček na skupinu přepínačů

Pokud jste v dokumentu aplikace Word použili více zaškrtávacích políček, aplikace InfoPath je ve výsledné šabloně formuláře převede na zaškrtávací políčka. Pokud byste pro šablonu formuláře raději použili skupinu tlačítek možností, postupujte podle následujícího návodu.

Můžete skupinu přepínačů na šablonu formuláře aplikace Microsoft Office InfoPath, pokud chcete uživatelům povolit provádění jediným výběru ze sady omezené možnosti.

  1. V šabloně formuláře klepněte na jedno ze zaškrtávacích políček, která chcete převést, podržte stisknutou klávesu CTRL a klepněte na další požadovaná zaškrtávací políčka.

  2. V nabídce Úpravy přejděte na příkaz Změnit na a poté klepněte na příkaz Přepínač.

    V šabloně formuláře se místo zaškrtávacích políček objeví skupina přepínačů. Všechny přepínače jsou vázány na stejné pole zdroje dat. Jestliže uživatel klepne na jeden z přepínačů, uloží se do pole hodnota přidružená k tomuto přepínači.

Začátek stránky

Kontrola potíží s převedením v podokně úloh Kontrola návrhu

Je možné, že některé prvky původního dokumentu aplikace Word nejsou ve výsledné šabloně formuláře aplikace InfoPath zobrazeny podle očekávání uživatele, nebo že jsou během procesu převedení odstraněny. Příklad: Aplikace InfoPath nepodporuje funkci aplikace Word Objekt WordArt a objekty WordArt nahrazuje ve výsledné šabloně formuláře zástupnými obrázky.

Pokud aplikace InfoPath narazí během procesu převedení na potíže, zobrazí se po ukončení Průvodce importem automaticky podokno úloh Kontrola návrhu. V tomto podokně se zobrazí seznam potíží, k nimž došlo. Poté lze zahájit kroky k jejich odstranění.

  1. Pokud se podokno úloh Kontrola návrhu nezobrazilo, klepněte v nabídce Nástroje na položku Kontrola návrhu.

    Pokud nastaly se šablonou formuláře potíže, zobrazí se v podokně úloh příslušné zprávy.

  2. V podokně úloh Kontrola návrhu klepněte na text zprávy, kterou se chcete zabývat.

    Zobrazí se dialogové okno s podrobnostmi o potížích.

    Poznámka : Pokud dokument aplikace Word obsahuje objekt nepodporovaný aplikací InfoPath, například objekt kreslení aplikace Word, aplikace InfoPath jej ve výsledné šabloně formuláře nahradí zástupným obrázkem, který označuje místo, kde byl tento objekt v původním dokumentu aplikace Word umístěn. Chcete-li získat další informace o objektu, klepněte na zástupný obrázek v šabloně formuláře pravým tlačítkem myši a v místní nabídce vyberte příkaz Další podrobnosti.

  3. Pokud je to nutné, odstraňte potíže šablony formuláře. Přiklad: Odstraňte zástupné obrázky, které nechcete v hotové šabloně formuláře použít.

Poznámka : Můžete zaznamenat, aby obsahoval podokno úloh Kontrola návrhu tlačítko Aktualizovat. Klikněte na tlačítko Aktualizovat neaktualizují zprávy, která se zobrazí importu Wordového dokumentu do aplikace InfoPath. Pokud chcete odebrat import zpráv z podokna úloh Kontrola návrhu, musíte otevřete dialogové okno Souborů prostředků (nabídkaNástroje ) a pak odstraňte soubor s názvem ImportErrors.xml. Tento soubor je vytvořen automaticky při importu Wordového dokumentu do aplikace InfoPath. Když odeberete ImportErrors.xml soubor, klepněte na tlačítko Aktualizovat v podokně úloh Kontrola návrhu chcete trvale odstranit import zpráv. Soubor ImportErrors.xml není potřeba pro šablonu formuláře budou fungovat správně. Ve skutečnosti z bezpečnostních důvodů, je vhodné před publikování šablony formuláře odstraňte tento soubor.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×