Přesunutí publikované šablony formuláře do nové knihovny služby SharePoint

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

V tomto článku

Základní informace

Než začnete

Získání funkční kopie šablony formuláře

Krok 1: Publikování šablony formuláře do nové knihovny dokumentů

Krok 2: Zkopírování a znovu připojit existující formuláře

Základní informace

Po publikování šablony formuláře do knihovny dokumentů pro uživatele můžete potřebovat přesunout tuto šablonu do jiné knihovny dokumentů. Příklad: Musíte přemístit šablonu formuláře na server s větší kapacitou, aby mohlo formuláře vyplňovat více uživatelů najednou. Někteří uživatelé již vyplnili formuláře založené na dané šabloně v její původní knihovně dokumentů. Po přemístění šablony formuláře do nové knihovny dokumentů je vhodné přemístit i existující formuláře. Před archivací nebo odstraněním staré knihovny dokumentů je rovněž vhodné se ujistit, že všechny formuláře v novém umístění fungují.

Tip : Před přesunutím publikovaných šablon formulářů do nové knihovny dokumentů vypracujte plán, ve kterém bude zahrnuto informování uživatelů o přesunutí jejich formulářů do nové knihovny dokumentů. Je třeba zařídit, aby uživatelé začali pro ukládání nových a úpravu starých formulářů používat novou knihovnu dokumentů. Plán by měl rovněž zahrnovat proces archivace nebo odstranění původní knihovny dokumentů.

Chcete-li přesunout šablonu formuláře a existující formuláře do nové knihovny dokumentů, je nejprve třeba do nové knihovny dokumentů publikovat funkční kopii šablony formuláře. Funkční kopie je verze uložená na vašem počítači nebo v programu pro správu verzí jako například program Microsoft Visual SourceSafe.

Tip : Pokud nemáte funkční kopii šablony formuláře, můžete si uložit kopii z původní knihovny dokumentů na svůj počítač a použít ji jako funkční kopii.

Po publikování funkční kopie do nové knihovny dokumentů je třeba zkopírovat všechny formuláře ze staré knihovny dokumentů do nové a poté je v nové knihovně dokumentů opětovně propojit s nově publikovanou šablonou formuláře.

Pokud potřebujete v důsledku přesunutí šablony formuláře provést jakékoli změny, proveďte je před jejím publikováním. Příklad: Umístění vnějších zdrojů dat používaných formuláři založenými na dané šabloně formuláře se důsledkem přesunutí šablony formuláře změnilo. V takovém případě je třeba změnit datové připojení v šabloně formuláře na nové umístění vnějších zdrojů dat před publikováním šablony formuláře. Další informace o změně datových připojení naleznete v části Viz také.

Poznámka : Publikování šablony formuláře není stejný jako uložení šablony formuláře. Po publikování šablony formuláře Publishing Wizard přidá umístění pro publikování a pokynů k šabloně formuláře pro zpracování, aby uživatelé mohli otevřít formuláře založené na této šabloně. Při uložení šablony formuláře chcete uložit kopii šablony formuláře, stejně jako při ukládání souboru s vaším počítačem. Vždy používejte Publishing Wizard mají být k dispozici pro uživatele vyplňovat uživatelé šablony formuláře.

Začátek stránky

Než začnete

Před přesunutím šablony formuláře a všech existujících formulářů založených na této šabloně do nové knihovny dokumentů je třeba provést následující akce:

  • Funkční kopie šablony formuláře.     Toto je kopie šablony formuláře, kterou je třeba upravit a poté znovu publikovat do nové knihovny dokumentů. Funkční kopie může být uložena ve vašem počítači nebo v programu pro správu verzí, jako je například program Visual SourceSafe.

  • Umístění všech nových vnějších zdrojů dat.    Pokud formuláře založené na šabloně formuláře používají vnější zdroje dat, které se změnily, je třeba zadat jejich nová umístění. Ověřte u správce sítě, že máte společně s uživateli dostatečná oprávnění k používání vnějších zdrojů dat. Pokud šablona formuláře používá nastavení ze souboru datových připojení k připojení na vnější zdroj dat, ověřte, zda je soubor datových připojení aktualizován na nové umístění vnějších zdrojů dat.

  • Příslušná práva na serveruWindows SharePoint Services 3.0.     Pro publikování šablony formuláře a pro kopírování existujících formulářů ze staré knihovny dokumentů do nové je třeba mít příslušná práva na serveru. Ověřte u správce sítě, že tato práva máte.

Začátek stránky

Získání funkční kopie šablony formuláře

Chcete-li upravit šablonu formuláře publikovanou do knihovny dokumentů nebo do sdílené síťové složky a nemáte její funkční kopii, můžete si uložit funkční kopii šablony formuláře z umístění publikace do svého počítače.

Tip : Je vhodné zvážit používání programu pro správu verzí, jako je například program Microsoft Visual SourceSafe, který by kontroloval dostupnost funkčních kopií šablon formulářů.

Uložte kopii šablony formuláře z knihovny dokumentů do vašeho počítače.

  1. Ve webovém prohlížeči otevřete knihovnu dokumentů, ve které byla šablona formuláře publikována.

  2. V nabídce Nastavení klepněte na příkaz Nastavení a potom klepněte na tlačítko Nastavení knihovny formulářů.

  3. Ve skupinovém rámečku Obecné nastavení klepněte na možnost Upřesňující nastavení.

  4. V části Šablona dokumentu klepněte na možnost Upravit šablonu.

    Šablona formuláře se otevře v aplikaci Microsoft Office InfoPath.

  5. V dialogovém okně Microsoft Office InfoPath klepněte na možnost Ano.

  6. V nabídce Soubor klikněte na příkaz Uložit jako.

  7. V dialogovém okně Microsoft Office InfoPath klepněte na tlačítko OK.

  8. V dialogovém okně Uložit jako vyhledejte složku, do které chcete uložit kopii šablony formuláře, a pak klepněte na tlačítko Uložit.

Uložte kopii šablony formuláře ze sdílené síťové složky do svého počítače

  1. V nabídce Soubor klepněte na příkaz Navrhnout šablonu formuláře.

  2. V oddílu Otevření šablony formuláře klepněte na položku V tomto počítači.

  3. Přejděte do sdílené síťové složky publikované šablony formuláře, klepněte na šablonu formuláře a potom klepněte na tlačítko Otevřít.

  4. V nabídce Soubor klikněte na příkaz Uložit jako.

  5. V dialogovém okně Microsoft Office InfoPath klepněte na tlačítko OK.

  6. V dialogovém okně Uložit jako vyberte umístění (jiné než původní umístění publikování), kam chcete uložit pracovní kopii šablony formuláře, a klepněte na tlačítko Uložit.

Začátek stránky

Krok 1: Publikujte šablonu formuláře do nové knihovny dokumentů.

  1. Otevřete funkční kopii šablony formuláře v návrhovém režimu.

  2. V nabídce Soubor klikněte na příkaz Publikovat.

  3. V průvodci publikováním klepněte na možnost Na server SharePoint s nebo bez služby InfoPath Forms Services a klepněte na tlačítko Další.

  4. Do pole Zadejte umístění služby SharePoint nebo InfoPath Forms Services zadejte umístění webu služby SharePoint, který obsahuje novou knihovnu dokumentů, do které chcete přesunout šablonu formuláře, a klepněte na tlačítkoDalší.

  5. Na další stránce průvodce klepněte na možnost Knihovna dokumentů a poté na tlačítko Další.

  6. Klepněte na položku Vytvořit novou knihovnu formulářů a poté na tlačítko Další.

  7. Na další stránce průvodce zadejte název a popis nové knihovny dokumentů a klepněte na tlačítko Další.

  8. V šabloně formuláře vyberte pole, která chcete zobrazit jako sloupce ve výchozím zobrazení knihovny dokumentů.

    Postup

    1. Klepněte na tlačítko Přidat.

    2. Vyberte pole, které chcete v knihovně dokumentů přidat jako sloupec, a potom proveďte jednu z následujících akcí:

      • Zadejte název sloupce do pole Název sloupce.

      • Vyberte sloupec webu v seznamu Skupina sloupců webu, vyberte název v seznamu Název sloupce a potom klepněte na tlačítko OK.

        Poznámka : Jestliže jste k zobrazení dat v knihovně dokumentů zvolili opakující se pole, můžete klepnutím na hodnotu v seznamu Funkce definovat, jakým způsobem chcete pole v knihovně dokumentů zobrazit. Je možné zvolit zobrazení první hodnoty v poli, poslední hodnoty v poli nebo počtu všech výskytů pole či zda mají být všechny hodnoty sloučeny.

    3. Klepněte na tlačítko OK.

    Další informace o zobrazování dat ve sloupcích v knihovně dokumentů naleznete v části Viz také.

  9. Klepněte na tlačítko Další.

  10. Na další straně průvodce ověřte, zda jsou uvedené informace správné a klepněte na tlačítko Publikovat.

  11. Chcete-li otevřít knihovnu dokumentů a vyzkoušet proces vyplnění formuláře založeného na této šabloně, zaškrtněte políčko Otevřít tuto knihovnu dokumentů a pak klepněte na tlačítko Zavřít.

    Knihovna dokumentů se otevře v okně prohlížeče. Klepnutím na tlačítko Nový na liště nástrojů se v aplikaci InfoPath otevře formulář založený na této šabloně formuláře.

Po zveřejnění šablony formuláře do nové knihovny dokumentů můžete zkopírovat existující formuláře založené na staré verzi šablony formuláře ze staré knihovny do nové. Po zkopírování existujících formulářů je můžete znovu propojit s novou verzí šablony formuláře. Pokud je nepropojíte, uživatelé mohou mít potíže s jejich otevřením.

Začátek stránky

Krok 2: Zkopírujte a znovu propojte existující formuláře

Tento postup předpokládá, že obě knihovny dokumentů jsou umístěny na serveru, který podporuje službu Windows SharePoint Services 3.0.

  1. Otevřete starou knihovnu dokumentů ve webovém prohlížeči.

  2. V nabídce Zobrazit klepněte na příkaz Zobrazení Průzkumníka.

  3. Stiskněte a podržte klávesu CTRL a vyberte všechny formuláře, které si přejete přesunout, a poté na jeden z nich klepněte pravým tlačítkem myši.

  4. V dialogovém okně Internet Explorer klepněte na tlačítko Ano a poté v místní nabídce klepněte na tlačítko Kopírovat.

  5. Otevřete novou knihovnu dokumentů.

  6. V podnabídce Vyberte zobrazení klepněte na možnost Zobrazení Průzkumníka.

  7. Pravým tlačítkem myši klepněte na prázdné místo v okně složek.

  8. V dialogovém okně Internet Explorer klepněte na tlačítko Ano a poté v místní nabídce klepněte na tlačítko Vložit.

  9. V nabídce Zobrazit klepněte na příkaz Znovu připojit dokumenty.

  10. Ve sloupci Znovu spojit zaškrtněte políčko u každého formuláře, který si přejete propojit s novou šablonou formuláře.

  11. Na liště nástrojů seznamu klepněte na příkaz Znovu připojit vybrané dokumenty.

Po opětovném propojení existujících formulářů s novou šablonou formuláře budou uživatelé moci měnit existující formuláře nebo vyplňovat nové formuláře založené na nově publikované šabloně formuláře.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Sdílení Facebook Facebook Twitter Twitter E-mail E-mail

Byly tyto informace užitečné?

Výborně! Je ještě něco dalšího, co byste nám chtěli dát vědět?

Jak bychom ho mohli vylepšit?

Děkujeme vám za zpětnou vazbu.

×