Přehled sdílení dat aplikace Excel a spolupráce

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Sdílení dat aplikace

Existuje mnoho způsobů sdílení, analyzování a předávání obchodních informací a údajů v aplikaci Microsoft Excel. Zvolený způsob sdílení dat závisí na mnoha faktorech, včetně toho, jakým způsobem chcete, aby ostatní uživatelé s daty pracovali. Chcete například zabránit úpravám citlivých či důležitých informací, nebo chcete uživatelům umožnit data měnit a editovat? Možná potřebujete sdílet data s uživateli, kteří nevlastní aplikaci Excel nebo mají ve svých počítačích jiné verze této aplikace. Nebo jen potřebujete sdílet jednu verzi sešitu, kterou lze snadno posílat e-mailem a tisknout.

Tento článek souží jako přehled, který popisuje, jak sílet data v aplikaci Excel, co je potřeba pro zobrazení a práci s daty a jaká omezení platí pro sdílení dat. Uvedeny jsou také odkazy na detailnější články.

V tomto článku

Sdílení dat a zachovat jednu verzi sešitu pomocí služby SharePoint

Spolupráce na sešitech uložená na serveru správy dokumentů

Distribuce dat prostřednictvím e-mailu, faxu nebo tisku

Výměna sešitů s uživateli, kteří používají starší verze aplikace Excel

Distribuce sešitů uživatelům, kteří nemají aplikaci Excel

Povolení více uživatelů najednou upravit sešit

Distribuce kopie sešitu a potom slučování nebo sloučení dat z každé kopie

Použití služby SharePoint Services pro sdílení dat a zachování jedné verze sešitu

Pokud máte přístup k instalaci služby SharePoint Services, ve které lze spustit Výpočetní službu aplikace Excel (takový server se označuje také jako server s aktivovanými službami Excel Services), můžete sešit uložit na tento server, aby k němu celému nebo k jeho částem měli přístup jiní uživatelé prostřednictvím webového prohlížeče.

Kromě prohlížení a interakce se sešity v tabulce mohou uživatelé ve webovém prohlížeči rovněž provádět výpočty, vytvářet snímky, aktualizovat data a extrahovat hodnoty ze sešitů. Sešity lze také použít v sestavách řídicího panelu. (Řídicí panel funguje podobně jako přístrojová deska v autě – zobrazuje kritická data v souhrnné formě, takže uživatel může na první pohled získat potřebné informace.) Kromě toho není pro zobrazení dat sešitu v prohlížeči nutné, aby uživatelé měli aplikaci Excel nainstalovánu ve svých místních počítačích.

Následující ilustrace znázorňuje použití dat publikovaného sešitu v sestavě řídicího panelu.

Data aplikace Excel v sestavě řídicího panelu

Pokud sešit publikujete, uloží se sice na server celý, ale je možné určit, že se ve webovém prohlížeči budou zobrazovat jen některé jeho části (například jednotlivé listy, pojmenované oblasti nebo grafy). Lze také nastavit parametry umožňující interakci, a to určením jednotlivých buněk, které lze na listu zobrazitelném v prohlížeči upravovat. Můžete například určit buňky, kam mohou uživatelé zadávat hodnoty, které budou použity ve vzorcích v jiných buňkách, a uživatelé pak uvidí vypočítané výsledky.

Publikování sešitu na web služby SharePoint je vhodné jako formu sdílení dat využít za těchto okolností:

  • Ve vaší organizaci máte aktivovány služby Excel Services, tzn. na serveru SharePoint lze využívat Výpočetní službu aplikace Excel. Výpočetní služba aplikace Excel představuje stejný „výpočetní stroj“, jaký klientská aplikace Excel využívá pro výpočet dat, vytváření a zobrazování grafů a provádění mnoha dalších akcí.

  • Chcete spravovat pouze jednu kopii sešitu nebo listu v centrálním, bezpečném umístění.

  • Uživatelé potřebují analyzovat, přesouvat a interaktivně pracovat s daty a vytvářet z nich grafy prostřednictvím prohlížeče. Uživatelé nemusí mít na počítači nainstalovanou aplikaci Excel.

  • Chcete zabezpečit a ochránit modely sešitů a data, která modely naplňují. Uživatelům můžete udělit oprávnění pouze k prohlížení, takže mohou sešity v prohlížeči zobrazit, ale nemohou k nim přistupovat přímo pomocí aplikace Excel nebo jiného (klientského) programu. Kromě toho můžete určit, které části sešitu mohou uživatelé v prohlížeči zobrazit.

  • Chcete používat sešit ve zprávě s graficky zvýrazněnými nejdůležitějšími informacemi na webové stránce, kde je možné rychle zobrazit a analyzovat důležité projektové informace.

  • Chcete pomocí funkcí tvorby zpráv upozorňovat uživatele na aktualizované zprávy.

Další informace najdete v tématu publikování sešitu na web služby SharePoint.

Začátek stránky

Spolupráce na sešitech uložených na serveru správy dokumentů

Pokud chcete jeden nebo více sešitů zpřístupnit pro spolupráci v centrálním umístění, můžete je uložit na server správy dokumentů. Server správy dokumentů umožňuje pomocí funkcí správy dokumentů, například automatizovaných pracovních postupů a sdílených knihoven dokumentů, dokumenty rezervovat a vracet se změnami. Pokud navíc můžete využívat službu SharePoint Services, můžete uložením dokumentu do sdíleného pracovního prostoru ještě více usnadnit spolupráci ostatních uživatelů na dokumentu a synchronizovat místní kopii sešitu se změnami na serveru.

Uložení sešitu na server správy dokumentů

Sešity lze uložit na server správy dokumentů, například do služby SharePoint Services, a poskytnout tak uživatelům centrální umístění pro spolupráci na dokumentech a možnost využívat mnoho funkcí správy dokumentů nabízených systémy těchto serverů.

Používejte ke spolupráci server správy dokumentů, pokud:

  • Máte přístup k serveru správy dokumentů.

  • Uživatelé mají ve svých počítačích nainstalovanou aplikaci Excel, a mohou tak otevírat a používat sešity ze serveru správy dokumentů.

  • Chcete využívat funkce serveru správy dokumentů, například:

    • Automatizovaný sled prací, aby uživatelé vždy věděli, na které pracovní fázi se podílí (revize, zpětná vazba, schvalování atd.), a mohli tak podle potřeby poskytovat informace a expertízy.

    • Knihovny dokumentů, kde lze ukládat a uspořádávat sešity.

    • Rezervace sešitu, vracení sešitu se změnami nebo práce s několika verzemi sešitu.

    • Funkce správy a tvorby zpráv.

    • Funkce spolupráce, například web pracovního prostoru dokumentů.

Chcete-li publikovat sešit do knihovny dokumentů na webu služby SharePoint, ověřte, zda je web k dispozici, a proveďte následující akce:

  1. Klikněte na kartu Soubor, na položku Uložit a odeslat a na možnost Uložit na web služby SharePoint.

  2. V dialogovém okně Uložit jako zvolte umístění serveru a název sešitu a potom klikněte na tlačítko Uložit.
    Před kliknutím na tlačítko Uložit můžete kliknout na tlačítko Možnosti publikování a zvolit jednotlivé listy nebo položky v sešitu (například pojmenované oblasti, grafy a kontingenční tabulky), které chcete publikovat, případně vytvořit parametry.

Bez ohledu na to, zda zvolíte jednotlivé listy či položky k publikování nebo vytvoříte parametry, bude do knihovny dokumentů vždy uložen celý sešit. Zvolené možnosti publikování však mohou ovlivnit, jaký obsah bude nebo nebude viditelný pro uživatele v zobrazení prohlížeče.

Začátek stránky

Distribuce dat prostřednictvím e-mailu, faxu nebo tiskem

Nejběžnějšími způsoby sdílení dat aplikace Excel jsou pravděpodobně posílání sešitů e-mailem, faxování sešitů a distribuce tištěných kopií sešitů. Distribuujte sešity prostřednictvím e-mailu, faxu nebo tiskem, pokud:

  • Vlastníte e-mailovou aplikaci, například Microsoft Outlook.

  • Vlastníte faxový přístroj nebo faxový software a máte připojení k internetu.

  • Vlastníte tiskárnu a chcete používat nebo distribuovat tištěné kopie svých dat pro referenční účely.

Posílání sešitů e-mailem

Sešit lze odeslat z aplikace Excel nebo z e-mailové aplikace. Chcete-li sešit poslat z aplikace Excel, otevřete požadovaný sešit, klikněte na kartu Soubor, na položku Uložit a odeslat a na možnost Odeslat e-mailem.

Faxování sešitů

Sešit můžete z aplikace Excel odeslat faxem, pokud jste přihlášeni u poskytovatele faxových služeb nebo vlastníte faxový software a připojení k Internetu nebo faxmodem. Sešit můžete také vytisknout a poslat jej pomocí faxového přístroje.

Chcete-li poslat sešit faxem z aplikace Excel, ujistěte se, že máte funkční připojení k Internetu a jste přihlášeni u poskytovatele faxových služeb. Otevřete sešit obsahující informace, které chcete odfaxovat, klikněte na kartu Soubor, na položku Uložit a odeslat a na možnost Odeslat jako internetový fax.

Tisk sešitů

Sešit lze z aplikace Excel snadno vytisknout. Před tiskem sešitu, který obsahuje velké množství dat a grafů, jej můžete snadno upravit v zobrazení Rozložení stránky, a dosáhnout tak profesionálního vzhledu. V tomto zobrazení můžete měnit rozložení a formát dat stejně jako v normálním zobrazení. Máte však také možnost měnit šířku a výšku dat pomocí pravítek, měnit orientaci stránky, přidávat nebo měnit záhlaví a zápatí stránky, nastavovat okraje pro tisk a skrývat či zobrazovat záhlaví řádků a sloupců.

Další informace o tisku z Excelu najdete v tématu Tisk listu nebo sešitu.

Začátek stránky

Výměna sešitů s uživateli používajícími starší verze aplikace Excel

Pokud si chcete vyměňovat sešity s jinými uživateli, kteří používají starší verze aplikace Excel, můžete místo formátu XML nebo binárního formátu aplikace Excel (XLSX nebo XLSB) uložit sešit ve formátu Excel 97-2003 (XLS) a pracovat na dokumentu v režimu kompatibility. Režim kompatibility se automaticky zapne při otevření sešitu ve formátu Excel 97-2003. Jestliže pracujete ve formátu souboru starší verze, zobrazí se v záhlaví aplikace vizuální upozornění Režim kompatibility.

Režim kompatibility vynucuje kompatibilitu mezi aplikací Excel 2010 a sešity aplikací Excel 2003, Excel 2002, Excel 2000 a Excel 2007, a to potlačením funkcí aplikace Excel 2010, které by potenciálně mohly přidat obsah nekompatibilní se staršími verzemi systému Office.

Když uložíte sešit, který je otevřen v režimu kompatibility, Excel automaticky spustí kontrolu kompatibility k identifikaci jakékoli problémy s kompatibilitou. Pokud nepoužíváte režimu kompatibility, můžete také kontrolu kompatibility pomoci při uložení sešitu ve formátu souboru XLSX nebo XLSB do formátu souboru dřívější verze aplikace Excel – například při převodu .xlsx (formát XML aplikace Excel) XLS (sešit Excelu 97 – 2003). Nástroj Kontrola kompatibility upozorňuje obsah v sešitu, který nemusí být kompatibilní s dřívějšími verzemi a proto může to mít vliv na tak, že převod formátu souboru.

Použijte režim kompatibility, pokud:

  • Chcete distribuovat kopie sešitu ostatním uživatelům, kteří pracují ve starších verzích aplikace Excel.

  • Očekáváte, že ostatní uživatelé budou chtít zaslaná data měnit nebo s nimi pracovat.

  • Chcete, aby příjemci sešitu mohli při práci s daty používat známé funkce aplikace Excel.

Další informace o tom, jak pracovat v režimu kompatibility najdete v článku Použití aplikace Excel s dřívějšími verzemi Excelu.

Začátek stránky

Distribuce sešitů uživatelům, kteří nevlastní aplikaci Excel

Použití služeb Excel Services je výborný způsob, jak uživatelům bez aplikace Excel umožnit prohlížení dat aplikace Excel a práci s nimi. Nemáte-li však přístup ke službám Excel Services, můžete nainstalovat doplněk pro uložení sešitu do formátu PDF nebo XPS, případně můžete sešit uložit do jiných formátů souborů a poté jej odeslat příjemcům e-mailem nebo faxem nebo jej uložit do síťové složky nebo na webový server, k nimž mají uživatelé přístup.

Distribuce pevných verzí dat pro prohlížení a tisk pomocí formátu PDF nebo XPS

Pro tisk, vystavení nebo distribuci dat e-mailem je možné data aplikace Excel uložit do formátu PDF (Portable Document Format) nebo XPS (XML Paper Specification). Uložením sešitu do souboru PDF nebo XPS zachytíte informace ve formě, která si zachová všechny formátovací charakteristiky a lze ji snadno šířit, přitom však nevyžaduje, aby ostatní uživatelé měli pro prohlížení nebo tisk těchto informací nainstalovanou aplikace Excel.

Uložte sešit ve formátu PDF nebo XPS, pokud:

  • Chcete distribuovat pevné verze souborů prostřednictvím e-mailu nebo síťového či webového serveru.

  • Je možné, že příjemci souboru nemají nainstalovanou aplikaci Excel.

  • Chcete umožnit uživatelům snadný tisk informací.

  • Nechcete, aby někdo měnil zdrojová data.

  • Neočekáváte častou aktualizaci dat.

Další informace o převedení sešitu ve formátu PDF nebo XPS najdete v článku uložení ve formátu PDF nebo XPS.

Distribuce sešitů v jiných formátech souborů

Sešity aplikace Excel lze uložit v různých formátech souborů, aby je mohli v jiných aplikacích nebo datových systémech otevřít i ti uživatelé, kteří nevlastní aplikaci Excel.

Ukládání souborů aplikace Excel jako XML soubory, soubory ve formátu RTF, webových stránek (souborů ve formátu HTML) a ostatní. Seznam formátů, které můžete uložit do najdete v tématu formáty souborů podporované v aplikaci Excel.

Důležité    Při uložení do jiných souborových formátů se zachovají ne všechny funkce Excelu. Formátování často se nezachová a někdy nezachovají vzorce, v závislosti na formátu. Kromě toho při ukládání do některé formáty se uloží jenom aktivní list. Proto pokud máte několik listů v sešitu a chcete-li uložit všechny listy v určitém formátu, budete muset jednotlivé list uložit samostatně

Uložte sešit do jiných formátů souborů, pokud:

  • Chcete sdílet data, ale ne nutně i s formátováním nebo funkcemi charakteristickými pro aplikaci Excel.

  • Máte systém na bázi technologie XML a chcete přenášet data pomocí standardu XML.

  • Potřebujete na jiných systémech používat jednoduché textové soubory.

  • Potřebujete vystavit informace na webu a chcete data aplikace Excel uložit jako webovou stránku a začlenit ji do svého webu.

Chcete-li soubor uložit do jiného formátu, klikněte na kartu Soubor a potom na položku Uložit jako. Klikněte na šipku vedle seznamu Uložit jako typ a potom v seznamu klikněte na požadovaný typ souboru.

Další informace o ukládání do jiných formátů souborů najdete v článku uložení sešitu v jiném formátu souboru.

Začátek stránky

Umožnění několika uživatelům současně upravovat sešit

Pokud chcete umožnit více uživatelům simultánně přidávat data do určitého sešitu nebo data upravovat, můžete nastavit a uložit sešit jako „sdílený“ a potom jej zpřístupnit v síťové složce (nikoli na webovém serveru).

Část dialogového okna Sdílení sešitu

Funkci sdílení sešitu používejte, pokud:

  • Chcete, aby více uživatelů mohlo simultánně upravovat data v jednom sešitu a nevadí vám, že původní data v sešitu budou upravována, doplňována, mazána a jinak měněna.

  • Máte k dispozici síťovou složku, kam je možné sešit uložit a kam mají uživatelé přístup.

    Poznámka : Sdílený sešit, který je uložen na webu služby SharePoint Services, nemůže v jeden okamžik upravovat více než jeden uživatel. Chcete-li sešit uložit na web služby SharePoint Services, měli byste tak učinit až po dokončení spolupráce na sdíleném sešitu.

  • Chcete uchovávat informace o změnách provedených v sešitu.

  • Neočekáváte, že by se v budoucnu měnily následující funkce, které po sdílení sešitu nelze měnit: sloučené buňky, podmíněné formáty, ověření dat, grafy, obrázky, objekty (včetně nakreslených objektů), hypertextové odkazy, scénáře, osnovy, souhrny, datové tabulky, kontingenční tabulky, zámky sešitu nebo listu a makra.

Důležité : Uložením sdíleného sešitu aplikace Excel do formátu souboru starší verze se zruší sdílení sešitu a bude ztracena historie revizí, která dokumentuje konflikty a řešení. Potřebujete-li sešit uložit do formátu starší verze, je vhodné nejdříve uložit kopii historie revizí.

Jako vlastník sešitu můžete sešit připravit na sdílení vložením a naformátováním dat, která se v něm mají vyskytovat. Po dokončení klikněte na příkaz Sdílet sešit ve skupině Změny na kartě Revize, vyberte požadované možnosti a potom sešit uložte do sdílené složky (ne na webový server), která je dostupná pro zamýšlené uživatele. Případně můžete kliknutím na příkaz Zamknout a sdílet sešit ve skupině Změny na kartě Revize zabránit ostatním uživatelům ve vypnutí funkce sledování změn v sešitu.

Vzhled pásu karet aplikace Excel

Při každém uložení sdíleného sešitu jste informováni o změnách, které jiní uživatelé uložili poté, co jste sešit naposledy uložili. Chcete-li sledovat průběh práce ve sdíleném sešitu a ponechat jej otevřený, můžete v aplikaci Microsoft Excel nastavit automatickou aktualizaci změn v určitých časových intervalech, aniž by bylo nutné sešit uložit.

Při uložení změn do sdíleného sešitu může jiný uživatel, který aktuálně provádí úpravy v sešitu, uložit změny do stejných buněk. V takovém případě dojde ke konfliktu změn a zobrazí se dialogové okno pro řešení konfliktů. V tomto okně lze rozhodnout, které změny budou zachovány.

Další informace o nastavení a používání sdílených sešitů najdete v tématu použití sdíleného sešitu ke spolupráci.

Začátek stránky

Distribuce kopií sešitu a následné slučování (neboli konsolidace) dat z jednotlivých kopií

Distribuce sešitů a slučování změn z každého z nich

Chcete-li distribuovat kopie sešitu a poté sloučit změny z několika kopií, je třeba sešit nastavit jako sdílený.

Další informace naleznete v části Umožnění několika uživatelům najednou upravit sešit.

Rozdíl je v tom, že namísto uložení sešitu v jednom umístění, kde jej může několik uživatelů upravovat, můžete kopie sešitu rozeslat a umožnit uživatelům provést změny a poslat sešity zpět. Sešity pak uložíte na jednom místě a kliknete na příkaz Porovnat a sloučit sešity. Změny můžete zkontrolovat a přijmout ty změny, které chcete zachovat, a použít v hlavním sešitu. Chcete-li přidat příkaz Porovnat a sloučit sešity na panel nástrojů Rychlý přístup, postupujte takto:

  1. Klikněte na kartu Soubor, na položku Možnosti a poté na kategorii Panel nástrojů Rychlý přístup.

  2. V seznamu Zvolit příkazy z klikněte na položku Všechny příkazy.

  3. Vyberte položku Porovnat a sloučit sešity, klikněte na tlačítko Přidat a potom klikněte na tlačítko OK.

Funkci porovnání a sloučení použijte, pokud:

  • Chcete sbírat vstupy od několika klíčových uživatelů, ale zároveň chcete mít větší kontrolu nad prováděnými a schvalovanými změnami v původní verzi.

  • Namísto uložení sešitu v jednom centrálním umístění s možným přístupem několika uživatelů chcete distribuovat kopie sešitu (například pomocí e-mailu).

  • Chcete vést záznamy o schválených změnách.

  • Můžete přijmout omezení sdílených sešitů (viz oddíl Umožnění několika uživatelům současné úpravy sešitu).

Distribuce sešitů a slučování dat z několika sešitů

Pokud nastavíte podobné nebo stejné rozložení listů a kopie těchto sešitů pošlete uživatelům ke zpracování, můžete výsledky od všech těchto uživatelů shrnout na hlavním listu. Pokud máte například list s údaji o výdajích pro jednotlivé místní pobočky, můžete tyto údaje shrnout do jednoho společného listu o výdajích celé společnosti.

Příklad sloučení dat

Sloučení dat použijte, pokud:

  • Chcete shromažďovat vstup od několika klíčových uživatelů a shrnout je na jednom hlavním listu.

  • Namísto uložení sešitu v jednom centrálním umístění s možným přístupem několika uživatelů chcete distribuovat kopie sešitu (například pomocí e-mailu).

  • Již máte nebo jste ochotni vytvářet podobné nebo stejné listy, ze kterých bude slučování probíhat.

Chcete-li sloučit data, klepněte na kartě Data ve skupině Datové nástroje na položku Sloučit a potom zadejte nebo vyberte odkazy na data, která chcete sloučit.

Vzhled pásu karet aplikace Excel

Při sloučení dat se nabízí několik možností. Data lze sloučit podle následující možností:

Pozice     Tuto možnost zvolte, pokud jsou data na všech listech uspořádána ve stejném pořadí a jsou stejně umístěna.

Kategorie     Tuto možnost zvolte, pokud jsou data v každém listu uspořádána různě, ale všechny listy používají stejné popisky řádků a sloupců, pomocí kterých lze k sobě přiřadit odpovídající si data.

Prostorové vzorce     Tuto možnost zvolte, pokud sešity nejsou stejného typu. Je možné vytvořit vzorce, které odkazují na buňky v každé slučované oblasti dat. Vzorce odkazující na buňky na více listech se nazývají prostorové vzorce.

Další informace najdete v tématu konsolidovat data z více listů v jednom listu.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Sdílení Facebook Facebook Twitter Twitter E-mail E-mail

Byly tyto informace užitečné?

Výborně! Je ještě něco dalšího, co byste nám chtěli dát vědět?

Jak bychom ho mohli vylepšit?

Děkujeme vám za zpětnou vazbu.

×