Příprava zdroje dat v Excelu pro hromadnou korespondenci ve Wordu

Základním krokem v procesu hromadné korespondence ve Wordu je vytvoření a příprava zdroje dat. Můžete použít existující excelový zdroj dat nebo můžete vytvořit nový, a to naimportováním souboru s hodnotami oddělenými tabulátory (TXT) nebo čárkami (CSV). Po vytvoření a přípravě dat můžete vytvořit hromadnou korespondenci pomocí technologie DDE (Dynamic Data Exchange) s Podrobným průvodcem hromadnou korespondencí nebo pomocí metody ručního vytvoření hromadné korespondence.

Pokud pro hromadnou korespondenci nepoužijete existující excelový zdroj dat, můžete použít seznam kontaktů nebo adresář ve formátu souboru TXT nebo CSV. Průvodce importem textu vás provede procesem vložení dat uložených v souboru TXT nebo CSV do Excelu.

  1. Otevřete Excel.

  2. Na kartě Data zvolte Načíst externí data > Z textu.

    Na kartě Data je zvýrazněná možnost Z textu.

  3. Vyberte požadovaný soubor .txt nebo .csv a pak zvolte Importovat.

  4. V Průvodci importem textu zvolte v podokně Zdrojový datový typ možnost Oddělovač.

    Excel, Načíst externí data, Z textu, Průvodce importem textu, Krok 1 ze 3

  5. Pokud importovaný soubor obsahuje záhlaví, zaškrtněte políčko Data obsahují záhlaví nad podoknem Náhled. Potom zvolte Další.

  6. V podokně Oddělovače zaškrtněte políčko u oddělovače, který je použitý u vašich dat (například Tabulátor nebo Středník), a pak zvolte Další.

    V Průvodci importem textu jsou zvýrazněné možnosti pro Oddělovače.

    Tip: Podokno Náhled dat ukazuje, jak budou výsledky vypadat v tabulkovém formátu.

  7. V podokně Náhled dat zvolte sloupec, který obsahuje poštovní směrovací čísla (PSČ) a v podokně Formát dat ve sloupcích zvolte Text.

    V Průvodci importem textu je pro Formát dat ve sloupcích zvýrazněná možnost Text.

    Poznámky: 

    • Dostupné formáty jsou Obecný, Text a Datum. Název formátu se pokaždé, když na sloupec použijete formát dat, objeví v záhlaví tabulky tohoto sloupce.

    • Sloupec, který obsahuje číselná data, například hodnotu procent nebo měny, je možné formátovat až po naimportování souboru. Další informace najdete v pododdílu Formátování číselných dat v Excelu dále v tomto článku.

  8. Krok 7 opakujte podle potřeby. Vyberte sloupec, který chcete změnit, a formát dat, který chcete použít.

  9. Zvolte Dokončit.

  10. V dialogovém okně Importovat data přijměte výchozí nastavení Existující list a adresu buňky a pak zvolte OK.

    V dialogovém okně Import dat zvolte, jestli chcete data umístit do existujícího listu (výchozí nastavení), nebo do nového listu.

    Upozornění: Adresa buňky v dialogovém okně Importovat data odpovídá aktuálně vybrané buňce. Data se naimportují do oblasti začínající uvedenou adresou buňky.

  11. Až budete hotovi, uložte zdroj dat pod novým názvem souboru.

Formátování číselných dat v Excelu

Zformátujte veškerá číselná data, jako jsou hodnoty procent nebo měny, ve všech nových nebo existujících excelových zdrojích dat, které chcete použít v hromadné korespondenci ve Wordu. Aby se při hromadné korespondenci zachovala číselná data, která jste zformátovali jako procenta nebo měnu, postupujte podle pokynů v části Krok 2: Použití technologie DDE (Dynamic Data Exchange) pro hromadnou korespondenci.

V excelovém zdroji dat, který chcete použít jako seznam adresátů ve wordové hromadné korespondenci, zajistěte správné formátování sloupců číselných dat. Například sloupec obsahující čísla naformátujte tak, aby to odpovídalo určité kategorii, třeba Měna.

  1. Otevřete excelový zdroj dat.

  2. Zvolte sloupec, který chcete zformátovat.

  3. Na kartě Domů ve skupině Číslo zvolte šipku dolů u pole Formát čísla – Obecný a pak vyberte jednu z možností v seznamu.

    V Excelu na kartě Domů ve skupině Číslo zvolte šipku dolů u pole Obecný a zvolte požadovaný číselný formát.

  4. Podle potřeby opakujte kroky 2 a 3.

  5. Až to budete mít, zvolte Uložit.

Pokud máte excelový zdroj dat, který obsahuje formátovaná čísla, například hodnoty procent nebo měny, nemusí se při hromadné korespondenci některá číselná data zachovat v požadovaném formátu. Požadovaných výsledků hromadné korespondence a zachování formátu číselných dat v Excelu dosáhnete použitím technologie DDE.

Formát dat v Excelu v porovnání s polem Sloučit ve Wordu při použití a nepoužití DDE

Poznámka: Pokud se rozhodnete DDE nepoužít, postupujte podle pokynů v článku Použití hromadné korespondence k posílání hromadných e-mailových zpráv.

  1. Otevřete Word, zvolte Soubor > Možnosti > Upřesnit.

  2. V oddílu Obecné zaškrtněte políčko Při otevírání potvrdit převod formátu souboru.

    Možnost Při otevírání potvrdit převod formátu souboru

  3. Zvolte OK.

  4. Na kartě Korespondence zvolte Spustit hromadnou korespondenci > Podrobný průvodce hromadnou korespondencí.

    Ve Wordu na kartě Korespondence zvolte Spustit hromadnou korespondenci a potom vyberte Podrobného průvodce hromadnou korespondencí.

  5. V podokně Hromadná korespondence v části Vybrat příjemce zvolte Použít existující seznam.

    Podokno úloh Hromadná korespondence ve Wordu, které se otevře při výběru Podrobného průvodce hromadnou korespondenci ve skupině Hromadná korespondence

  6. V části Použít existující seznam zvolte Procházet a potom otevřete formátovanou tabulku.

  7. V dialogovém okně Potvrdit zdroj dat zaškrtněte políčko Zobrazit vše, zvolte Sešity MS Excel pomocí rozhraní DDE (*.xls) > OK.

    Dialogové okno Potvrdit zdroj dat

  8. V dialogovém okně Microsoft Excel zvolte Celý list > OK.

    Dialogové okno Microsoft Excelu ve Wordu

  9. V dialogovém okně Příjemci hromadné korespondence, které se otevře, zvolte OK.

    Dialogové okno Příjemci hromadné korespondence, které zobrazuje obsah excelové tabulky použité jako zdroj dat pro seznam adresátů

  10. Pokračujte v psaní dopisu, e-mailové zprávy, štítku nebo obálky pro hromadnou korespondenci.

Tip: Pokud nechcete, aby vám Word při každém otevření datového souboru zobrazoval výzvu, proveďte následující postup. Po připojení k seznamu adresátů přejděte na Soubor > Možnosti > Upřesnit. V oddílu Obecné zrušte zaškrtnutí políčka Při otevírání potvrdit převod formátu souboru.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×