Příprava, publikování a údržba webu v aplikaci Publisher

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Poznámka : Webové publikace jsou pouze k dispozici v aplikaci Publisher 2007 a dřívějších. Informace o aktualizaci stávající Web publikace v aplikaci Publisher 2010 najdete v tématu funkce webu.

Po plánování a vytvořit webovou publikaci v Microsoft Office Publisher 2007, můžete ho publikovat na web, síťovém serveru nebo do sdílené složky ve vašem počítači. Bez ohledu na cíl, Publisher filtrované souborů ve formátu HTML z vytvoří webovou publikaci. Můžete otevřít a přečtěte si tyto soubory ve formátu HTML do libovolného webového prohlížeče, jako je Windows Internet Explorer.

Publikování webu

V tomto článku

Tento článek popisuje postupy pro vytváření a publikování webové publikace jako soubory ve formátu HTML a aktualizace webu úpravou webovou publikaci a jeho publikování.

Příprava vašeho webu

Publikovat svůj web

Zachování vašeho webu

Příprava vašeho webu

Váš web je rozšíření se, máte ve firmě, a business branding. Před vytvořením webem plán ho. Pokud potřebujete pomoc s tím najdete v článku plánování webu.

Co je vhodného nástroje?

Při plánování webu a informace, které bude obsahovat, zvažte, které vývojového nástroje je vyhovuje vašim potřebám. Office Publisher 2007 je skvělým nástrojem pro vytváření používat, když chcete rychle vytvářet, publikovat a spravovat jednoduché, statické weby, které odpovídají firmy značku a revize pouze textu a grafiky, které vyžadují. Office Publisher 2007 není nástroj vhodné v následujících případech:

  • Pokud váš web potřebuje interaktivity nebo databázových aplikací obsah tak, aby návštěvníci můžete odpovědět v webu protokolu (blog) nebo koupit položek v nákupní košík

  • Pokud váš web vyžaduje ověření dat, například konkrétní ověření kreditní karty čísel

  • Pokud budete chtít později změnit nezpracovanými kód HTML v editoru HTML po vytvoření webu v Office Publisher 2007, který kombinuje kód HTML, XML a VML k vytvoření webů

Vytvoření webu

Vytvoření nové webové publikace v Office Publisher 2007. Pokud chcete pracovat na stávající web ke kterým máte žádné webovou publikaci, můžete zkopírovat a vložit obsah z webových stránek publikovaných do nové publikace Web znovu vytvoří webu jako webovou publikaci, nebo můžete použít nástroj pro úpravy HTML.

  1. V nabídce Soubor klepněte na příkaz Nový.

  2. V seznamu Typů publikací klikněte na weby.

  3. Proveďte některou z následujících akcí:

    • Vytvořit vlastní web založený na požadavky na web, ujistěte se, že Použít Průvodce snadno Web, v podokně úloh Možnosti zaškrtnuté a klikněte na požadovaný návrh.

    • Vytvoření webu úplně od začátku, v části webové stránky, klikněte na Prázdný velikosti a klikněte na požadovanou velikost.

  4. Klikněte na tlačítko Vytvořit.

  5. Pokud se rozhodnete použít Průvodce rychlým vytvářením webů, vyberte požadované možnosti v dialogovém okně Nástroj pro rychlé vytváření webů a klepněte na tlačítko OK.

  6. Přidejte do publikace obsah a proveďte požadované změny.

    Tip : Vyhněte se umístění objektů na stránky předlohy v publikaci Web. Objekty, které jsou umístěná na stránky předlohy Office Publisher 2007 se nezobrazují správně při zobrazení v některé webové prohlížeče.

Kontrola webové publikace

Před publikováním webu zkontrolujte, že bude web fungovat podle očekávání a že jste vyřešili všechny možné problémy, které můžou nastat.

Možné problémy zjistíte pomocí nástroje Kontrola návrhu a náhledem webu.

Hledání a odstranění problémů pomocí nástroje Kontrola návrhu

Kontrola návrhu je výkonný nástroj pro hledání potenciálních problémů. Hledá především základní problémy formátování. Hledá však také speciálně problémy, které mohou negativně ovlivnit webové publikace. Chcete-li zkontrolovat návrh tímto nástrojem, postupujte takto:

  1. V nabídce Nástroje klepněte na příkaz Kontrola návrhu.

  2. V podokně úloh Kontrola návrhu zaškrtněte políčka Spustit obecné kontroly návrhu a Spustit kontroly pro weby.

    Poznámka : Ujistěte se, že není zaškrtnuto políčko Spustit kontroly pro komerční tisk.

  3. V části Vyberte položku, kterou chcete opravit v podokně úloh Kontrola návrhu klepněte na šipku zobrazenou vedle položky, kterou chcete opravit, a potom proveďte jednu z následujících akcí:

    • Klikněte na Automatické opravy automaticky tento problém s položkou.

      Automatická oprava bude záviset na problému. Ve většině případů nebude k dispozici žádná automatická oprava.

    • Klepnutím na příkaz Přejít na tuto položku přejděte na stránku, kde je vybraná problémová položka umístěna.

      Provedením potřebných změn potom můžete daný problém odstranit.

    • Klepnutím na příkaz Vysvětlit otevřete téma nápovědy, ve kterém je daný problém podrobněji vysvětlen a je navrženo jeho řešení.

    • Kontrolu vypnete klepnutím na příkaz Tuto kontrolu již nespouštět.

      Klepnutí na tuto možnost bude mít vliv na všechny výskyty daného problému.

Náhled vašeho webu

  • V nabídce Soubor klepněte na příkaz Náhled webové stránky.

Ve výchozím prohlížeči se náhled vašeho webu. Zkontrolujte v náhledu takto:

  • Web se zobrazí a všechny stránky jsou přístupné.

  • Všechny hypertextové odkazy fungují podle očekávání.

  • Navigační ovládací prvky pracují podle očekávání.

  • Žádné prvky nechybí.

  • Zvuky v pozadí se přehrávají podle očekávání.

Vyhledání webové hostitelské služby

Musíte před publikováním webu na webu, budete muset přihlásit k odběru webové hostitelské služby, který poskytuje společnost poskytovatele internetových služeb (ISP). Tato služba poskytuje přístup k Internetu, úložiště na webový server a Locator URL (Uniform Resource) tak, aby uživatelé mají přístup k webu. Před publikováním svůj web, kontaktujte poskytovatele internetových služeb nebo správce systému získat potřebné informace a adresu URL webu nebo adresu FTP webu, kde můžete ukládat soubory.

Několik poskytovatelů jsou nejspíš dostupné ve vaší oblasti. Ujistěte se, že poskytovatel internetových služeb, že se přihlásíte k odběru nabízí druh podpory, které chcete. Pokud máte malou prostředí při publikování na webu, je vhodné poskytovatele, který vám pomůže nějaké možné problémy.

Začátek stránky

Publikování webu

Po zkontrolovat a zobrazit náhled publikace Web a přihlášení k odběru služby pro hostování webů, jste připraveni publikovat svůj web.

Publikováním na web Webový server, síťovém serveru, serveru File Transfer Protocol (FTP) nebo do složky ve vašem počítači.

Publikování webu v umístění ve vlastním počítači může sloužit k různým účelům:

  • Publikované soubory můžete použít k testování webem před zpřístupníte soubory na webu.

  • Nástroj FTP umožňuje publikovat soubory na webu tím, že je odešlete z umístění v počítači.

  • Je zachována místní kopie souborů HTML i webová publikace.

Poskytovatel služeb Internetu vám může poskytnout informace, které vám pomohou zvolit nejvhodnější metodu publikování.

Jestli publikováním na web nebo do počítače, Office Publisher 2007 sestaví souvisejících souborů, které předtím vytvořil v jedné složky. Soubory, které Office Publisher 2007 vytvoří zahrnout na jiné stránky HTML, které tvoří webu, která je ve formátu GIF a JPEG symboly používat na stránkách a všech souborů vložených zvuků.

Můžete nastavit Office Publisher 2007 uspořádání tyto soubory ve složce místo, kam jste publikovali svůj web jedním ze dvou způsobů. Ve výchozím nastavení vytvoří Office Publisher 2007 jednu domovskou stránku a podsložku, která obsahuje podpůrné soubory, které jsou potřebné pro váš web. Nebo můžete uspořádat na domovskou stránku s podpůrné soubory pro váš web v jedné složce.

Jak se dá nastavit místo, kam Office Publisher 2007 uspořádává na webu publikování soubory?

V nabídce Nástroje klikněte na tlačítko Možnosti, klikněte na kartu Web a pak udělejte jednu z těchto věcí:

  • K oddělení na domovskou stránku z podpůrné soubory, zaškrtněte políčko Uspořádat podpůrné soubory ve složce.

  • Zařadit do skupiny na domovskou stránku a všechny podpůrné soubory do stejné složky, zrušte zaškrtnutí políčka Uspořádat podpůrné soubory ve složce.

Při publikování publikace na webu vytvoří Office Publisher 2007 filtrované souborů ve formátu HTML, které šířit na webu rychleji než nefiltrovaným souborů ve formátu HTML. Protože filtrované HTML soubory, které Office Publisher 2007 vytvoří obsahovat žádné značky specifické pro aplikaci Microsoft Office, nemůžete v Office Publisher 2007 otevřít soubory ve formátu HTML a upravovat. Musí změňte na váš web v publikaci Web a potom ji znovu publikovat webu na webu.

Publikování na webu do umístění na Internetu nebo k síti

Před provedením tohoto postupu, kontaktujte poskytovatele internetových služeb nebo správce systému získat informace, které je potřeba publikovat a adresu URL webu, kde můžete ukládat soubory.

  1. V nabídce Soubor klikněte na příkaz Publikovat na webu.

  2. V dialogovém okně Publikovat na webu do pole název souboru zadejte adresu URL webu nebo síti serveru, na místo, kam chcete uložit svůj web. Zadejte například http://www.northwindtraders.com.

  3. Klikněte na Uložit.

  4. Zobrazí-li se výzva k zadání uživatelského jména a hesla, zadejte je a potom klepněte na tlačítko OK.

    V dialogovém okně Publikovat na webu se zobrazí v adresáři, který je spojený s svoji adresu URL.

  5. Poklikejte na složku, kam chcete uložit svůj web.

  6. V rozevíracím poli Název souboru vyberte jako výchozí název domovské stránky index a klikněte na Uložit.

    Index.htm je výchozí hodnota. Výběr index jako název domovské stránky usnadňuje přístup a zabrání uživatelům v zobrazení Seznam souborů, které tvoří váš web.

  7. Po výzvě klikněte na tlačítko OK.

Publikovat na webu pomocí FTP

Před provedením tohoto postupu, obraťte se na váš poskytovatel internetových služeb nebo správce systému získat informace, které potřebujete k publikování na kolekci webů pro FTP. Musíte taky vytvořit serveru FTP v Umístění FTP.

Než přidáte server FTP do seznamu ve složce Adresy FTP, musíte mít přístup k Internetu nebo k intranetu.

  1. V nabídce Soubor klikněte na příkaz Publikovat na webu.

  2. V dialogovém okně Publikovat na webu klepněte na tlačítko Nástroje a potom klepněte na příkaz Připojit síťovou jednotku.

  3. V dialogovém okně Připojit síťovou jednotku proveďte následující kroky:

    • V seznamu Jednotka klepněte na písmeno jednotky. Můžete zvolit libovolné dostupné písmeno.

    • Připojení pokaždé, když se přihlásíte se svým počítačem, zaškrtněte políčko znovu připojit při přihlášení.

    • Klepněte na odkaz Připojit k webovému serveru, na který lze ukládat dokumenty a obrázky.

  4. V Průvodci přidáním umístění v síti klepněte na tlačítko Další, klepněte na položku Vybrat vlastní umístění v síti a potom na tlačítko Další.

  5. Do pole Adresa Internetu nebo k síti zadejte adresu FTP (třeba typ ftp://ftp.microsoft.com) a klikněte na tlačítko Další.

    Poznámka : Pokud se k síťové jednotce nebo složce nelze připojit, je daný počítač pravděpodobně vypnutý nebo nemáte správná oprávnění. Nelze-li se připojit, obraťte se na správce sítě nebo poskytovatele služeb Internetu.

  6. Pokud se nechcete k serveru přihlásit anonymně, zrušte zaškrtnutí políčka Přihlásit se anonymně, zadejte do pole Uživatelské jméno uživatelské jméno a klepněte na tlačítko Další.

  7. Zadejte název umístění v síti a klepněte na tlačítko Další.

  8. Klikněte na Dokončit.

  9. V nabídce Soubor klikněte na příkaz Publikovat na webu.

  10. V seznamu Uložit do klikněte na Umístění FTP.

  11. V seznamu webů FTP poklikejte na web, který chcete a potom poklikejte na složku, ve které chcete publikovat svůj web.

    Poznámka : Pokud váš poskytovatel služeb Internetu vyžaduje, abyste k nahrání webu používat speciálním programu zaměřeném na nebo pokud publikujete webu k podnikové síti, budete muset verzi webu uložit ve formátu souboru konkrétní HTML a použít jiný postup publikovat svůj web. Požádejte poskytovatele internetových služeb nebo správce systému informace o tom, jak uložit a publikovat svůj web.

Publikování na webu do složky ve vašem počítači

  1. V nabídce Soubor klikněte na příkaz Publikovat na webu.

  2. Na panelu Adresa klikněte na jednotku nebo složku, ve které chcete publikovat svůj web, třeba složku dokumenty.

    Pokud chcete přidat váš web do nové složky, klikněte na Nová složka na panelu nástrojů pro vytvoření nové složky, zadejte název nové složky a stiskněte klávesu ENTER.

  3. V rozevíracím poli Název souboru vyberte jako výchozí název domovské stránky index a klikněte na Uložit.

    Index.htm je výchozí hodnota. Výběr index jako název domovské stránky usnadňuje přístup a zabrání uživatelům v zobrazení Seznam souborů, které tvoří váš web.

Zachování vašeho webu

Po publikování webu můžete aktualizovat podle potřeby tak, aby odrážely nové informace. Filtrované souborů ve formátu HTML nelze však otevřít v aplikaci Publisher. Musíte otevřete původní webovou publikaci, proveďte požadované změny a pak publikovat webu na webu.

Poznámka : Zkusíte neměli aktualizace souborů ve formátu HTML filtrované pomocí textovém editoru, jako je Notepad nebo Microsoft WordPad. Přestože je možné k tomuto, vytvořené prvky HTML jsou velmi složité a nejspíš najdete ji obtížné od ruky upravit. Nejlepších výsledků dosáhnete vždy aktualizovat svůj web aplikace Publisher pomocí webovou publikaci a znovu publikovat na webu.

Publikování změn

V Office Publisher 2007, můžete publikovat aktualizace dříve publikované webové stránky rychle pomocí přírůstková publikování na webu, který publikuje jenom stránky, které jste změnili. Pokud budete chtít často aktualizovat svůj web, nebo pokud váš web je velkých a složité, přírůstková publikovat na webu můžete urychlit úkol aktualizace váš web.

Pokud uděláte změny na váš web přímo na Webový server mimo Office Publisher 2007, ale zapnutí přírůstková publikování na webu může bránit publikování následné aktualizace k vašemu webu pomocí příkazu Publikovat na webu. Pokud chcete spravovat web soubory přímo na webovém serveru (například prostřednictvím programu samostatné FTP ), měli byste vypnout přírůstková publikování na webu.

Poznámka : Přírůstková publikování na web je zapnutá ve výchozím nastavení v aplikaci Publisher.

Vypnutí dílčích publikování na webu nebo vypnutí

  1. V nabídce Nástroje klikněte na Možnosti a potom klikněte na kartu Web.

  2. Ve skupinovém rámečku, uložení proveďte jednu z následujících akcí:

    • Pokud chcete vypnout přírůstková publikování na webu, zrušte zaškrtnutí políčka Povolit přírůstková publikování na webu.

    • Pokud chcete vypnout přírůstková publikování na webu, zaškrtněte políčko Povolit přírůstková publikování na webu.

Publikování změn na váš web

Publikování aktualizací na web se mírně liší od publikování na web poprvé. Po publikování na webu do umístění na webu nebo v síti zástupce na webový server nebo síťovém serveru se zobrazí místa v síti.

  1. V nabídce Soubor klikněte na příkaz Publikovat na webu.

  2. V dialogovém okně Publikovat na webu v navigačním podokně klikněte na Tento počítač.

  3. V seznamu souborů poklikejte na zástupce složky na webový server nebo síťovém serveru, kam jste publikovali svůj web.

  4. Poklepejte na složku, do níž chcete soubor uložit.

  5. Do pole Název souboru zadejte název aktualizovaného souboru a potom klepněte na tlačítko Uložit.

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×