Oprava poškozeného sešitu

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Pokud Microsoft Excel při otevírání sešitu zjistí, že je poškozený, automaticky spustí režim obnovení souboru a zkusí sešit opravit. Když se režim obnovení souboru nespustí, zkuste pomocí tohoto postupu obnovit sešit ručně:

  1. Klikněte na Soubor > Otevřít.

  2. Klikněte na umístění a složku obsahující poškozený sešit.

  3. V dialogovém okně Otevřít vyberte poškozený sešit.

  4. Klikněte na šipku u tlačítka Otevřít a potom klikněte na příkaz Otevřít a opravit.

    Příkaz Otevřít a opravit

  5. Když chcete obnovit co nejvíc dat sešitu, vyberte Opravit.

    Pokud se při použití Opravit nepovede data obnovit, vyberte Extrahovat data, a extrahujte tak ze sešitu hodnoty a vzorce.

Pokud automatická ani ruční oprava nefunguje, možná se vám podaří zachránit svoje data pomocí některých metod obnovení. Abyste o svou práci nepřišli, můžete taky podniknout určitá preventivní opatření, jako je automatické ukládání záložní kopie sešitu nebo občasné vytváření obnovovacího souboru.

Obnovení dat z poškozeného sešitu

Automatické ukládání záložní kopie sešitu

Automatické vytváření obnovovacího souboru v nastavených intervalech

Obnovení dat z poškozeného sešitu

Vyberte si jednu z následujících metod, která vám pomůže obnovit data. Pokud se vám to pomocí ní nepodaří, zkuste jinou. Případně taky můžete zkusit sešit obnovit pomocí softwarového řešení jiných výrobců.

Důležité : Pokud otevření sešitu brání chyby na disku nebo v síti, přesuňte sešit na jiný pevný disk nebo místní disk a pak zkuste některou z těchto možností obnovení.

Obnovení dat, když je sešit otevřený v Excelu

  • Návrat k poslední uložené verzi sešitu    Pokud se sešit poškodí, když na něm pracujete, ale ještě jste neuložili svoje změny, můžete se vrátit k poslední uložené verzi sešitu:

    1. Klikněte na Soubor > Otevřít.

    2. Poklikejte na název sešitu, který máte otevřený v aplikaci Excel.

    3. Kliknutím na tlačítko Ano znovu otevřete sešit.

      Sešit se otevře a nebudou v něm žádné změny, které jste udělali a které mohly být příčinou poškození sešitu.

Obnovení dat, když sešit nejde otevřít v Excelu

  • Nastavení možností výpočtu v aplikaci Excel na ruční    Zkuste změnit natavení tak, aby se výpočet neprováděl automaticky, ale ručně. Sešit se tak nebude přepočítávat a možná půjde otevřít.

    1. Klikněte na Soubor > Nový.

    2. V části Nový klikněte na Prázdný sešit.

    3. Klikněte na Soubor > Možnosti.

    4. V kategorii Vzorce v části Možnosti výpočtů vyberte Ručně a potom klikněte na OK.

    5. Klikněte na Soubor > Otevřít.

    6. Najděte poškozený sešit a poklikáním ho otevřete.

  • Použití externích odkazů pro propojení s poškozeným sešitem    Když chcete ze sešitu získat jenom data a ne vzorce nebo počítané hodnoty, zkuste k propojení s poškozeným sešitem použít externí odkazy.

    1. Klikněte na Soubor > Otevřít.

    2. Přejděte do složky, která obsahuje poškozený sešit.

    3. Pravým tlačítkem klikněte na název souboru poškozeného sešitu, klikněte na Kopírovat a potom klikněte na Zrušit.

    4. Klikněte na Soubor > Nový.

    5. V části Nový klikněte na Prázdný sešit.

    6. V novém sešitu zadejte do buňky A1 vzorec =Název souboru!A1, kde Název souboru je název poškozeného sešitu, který jste zkopírovali v kroku 3 tohoto postupu. Potom stiskněte Enter.

      Poznámka : Musí se zadat jenom název sešitu (bez přípony).

    7. Jestliže se zobrazí dialogové okno Aktualizovat hodnoty, vyberte poškozený list a klikněte na tlačítko OK.

    8. Jestliže se zobrazí dialogové okno Vybrat list, vyberte příslušný list a klikněte na tlačítko OK.

    9. Vyberte buňku A1.

    10. Klikněte na Domů > Kopírovat, nebo stiskněte Ctrl+C.

    11. Vyberte oblast, která bude začínat v buňce A1 a bude přibližně stejně velká, jako je oblast buněk obsahující data v poškozeném sešitu.

    12. Klikněte na Domů > Vložit, nebo stiskněte Ctrl+V.

    13. Nechte oblast buněk pořád vybranou a klikněte znova na Domů > Kopírovat, nebo stiskněte Ctrl+C.

    14. Klikněte na Domů > šipka pod Vložit a potom v části Vložit hodnoty klikněte na Hodnoty.

      Vložením hodnot se odstraní odkazy na poškozený sešit a ponechají se pouze data.

  • Extrahování dat z poškozeného sešitu pomocí makra    Pokud je s poškozeným sešitem propojený graf, zkuste pomocí makra extrahovat zdrojová data grafu.

    1. Zkopírujte tento kód makra a vložte ho do listu modulu:

      Sub GetChartValues()

      Dim NumberOfRows As Integer

      Dim X As Object

      Counter = 2

      ' Calculate the number of rows of data.

      NumberOfRows = UBound(ActiveChart.SeriesCollection(1).Values)

      Worksheets("ChartData").Cells(1, 1) = "X Values"

      ' Write x-axis values to worksheet.

      With Worksheets("ChartData")

      .Range(.Cells(2, 1), _

      .Cells(NumberOfRows + 1, 1)) = _

      Application.Transpose(ActiveChart.SeriesCollection(1).XValues)

      End With

      ' Opakovaně prochází všechny řady v grafu a jejich hodnoty zapisuje na

      ' list.

      For Each X In ActiveChart.SeriesCollection

      Worksheets("ChartData").Cells(1, Counter) = X.Name

      With Worksheets("ChartData")

      .Range(.Cells(2, Counter), _

      .Cells(NumberOfRows + 1, Counter)) = _

      Application.Transpose(X.Values)

      End With

      Counter = Counter + 1

      Next

      End Sub

    2. Vložte list do sešitu nebo ho ze sešitu odstraňte, klikněte na ouško listu pravým tlačítkem a pak list přejmenujte na ChartData.

    3. Vyberte graf, z kterého chcete extrahovat příslušné datové hodnoty.

      Poznámka : Graf může být vožený v listu nebo na zvláštním listu s grafem.

    4. Spusťte makro GetChartValues.

    5. Data z grafu se vloží na list ChartData.

Začátek stránky

Automatické ukládání záložní kopie sešitu

Díky záložní kopii sešitu budete mít ke svým datům vždycky přístup, i kdyby se vám sešit nechtěně vymazal nebo se poškodil.

  1. Klikněte na Soubor > Uložit jako.

  2. Klikněte na Počítač a potom na tlačítko Procházet.

    Tlačítko Procházet

  3. V dialogu Uložit jako klikněte na šipku vedle Nástroje a potom klikněte na Obecné možnosti.

    Obecné možnosti v nabídce Nástroje

  4. V dialogu Obecné možnosti zaškrtněte políčko Vždy vytvořit záložní kopii.

    Možnost Vždy vytvořit záložní kopii v dialogovém okně Obecné možnosti

Začátek stránky

Automatické vytváření obnovovacího souboru v nastavených intervalech

Obnovovací soubor sešitu vám taky pomůže zajistit přístup k vašim datům v případě nechtěného odstranění sešitu nebo jeho poškození.

  1. Klikněte na Soubor > Možnosti.

  2. V kategorii Uložit zaškrtněte v části Uložit sešity políčko Ukládat informace pro automatické obnovení po a zadejte počet minut. (Výchozí hodnota je 10.)

    Možnost pro automatické obnovení na kartě Uložit v dialogu Možnosti aplikace Excel

  3. V poli Umístění souboru automatického obnovení zadejte umístění, kam chcete ukládat obnovovací soubor.

  4. Zkontrolujte, jestli je zaškrtnutí políčka Zakázat automatické obnovení pouze pro tento sešit zrušené.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Sdílení Facebook Facebook Twitter Twitter E-mail E-mail

Byly tyto informace užitečné?

Výborně! Je ještě něco dalšího, co byste nám chtěli dát vědět?

Jak bychom ho mohli vylepšit?

Děkujeme vám za zpětnou vazbu.

×