Oprava přerušení propojení s daty

Důležité informace:  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Pokud sešit obsahuje propojení s daty v sešitu nebo jiný soubor, který byl přesunut do jiného umístění, můžete opravit odkaz aktualizací cestu této Zdrojový soubor. Pokud nemůžete najít nebo nemají přístup k dokumentu, který jste původně vytvořili propojení, můžete zabránit Excel pokusu o aktualizaci propojení vypnutí automatických aktualizací nebo odebráním odkaz.

Udělejte některou z těchto věcí:

Důležité informace: Propojený objekt nejsou stejné jako hypertextové odkazy. Následující postup nebude opravit přerušené hypertextové odkazy. Další informace o hypertextových odkazech najdete v tématu Vytvoření nebo úprava hypertextového odkazu.

Oprava nefunkčního odkazu

Upozornění: Tuto akci nejde vrátit zpět. Můžete chtít před zahájením tohoto postupu uložit záložní kopii sešitu.

  1. Otevřete sešit obsahující nefunkční odkaz.

  2. Na kartě Data klikněte na Upravit odkazy.

    Příkaz Upravit odkazy není k dispozici, pokud váš sešit neobsahuje odkazy.

  3. V dialogovém okně zdrojového souboru vyberte nefunkční odkaz, který chcete odstranit.

    Poznámka: Vyřešíte více vazeb mezi podržte COMMAND (PŘÍKAZ) a pak klikněte na každý odkaz.

  4. Klikněte na tlačítko Změnit zdroj.

  5. Přejděte do umístění souboru, který obsahuje propojená data.

  6. Vyberte nový zdrojový soubor a potom klikněte na tlačítko Změnit zdroj.

  7. Klikněte na Zavřít.

Odstranění nefunkčního odkazu

Při přerušení propojení všechny vzorce, které odkazují na zdrojový soubor se převedou na své aktuální hodnoty. Například pokud vzorec = SUMA([Budget.xls]Annual! C10: C25) výsledky v 45, vzorec bude převedena na 45 po přerušení propojení.

  1. Otevřete sešit obsahující nefunkční odkaz.

  2. Na kartě Data klikněte na Upravit odkazy.

    Příkaz Upravit odkazy není k dispozici, pokud váš sešit neobsahuje odkazy.

  3. V dialogovém okně zdrojového souboru vyberte nefunkční odkaz, který chcete odstranit.

    Poznámka: Chcete-li odebrat více propojení, podržte klávesu COMMAND (PŘÍKAZ) klikněte na jednotlivé odkazy.

  4. Klikněte na tlačítko Zrušit propojení.

  5. Klikněte na Zavřít.

Důležité informace: Propojený objekt nejsou stejné jako hypertextové odkazy. Následující postup nebude opravit přerušené hypertextové odkazy. Další informace o hypertextových odkazech najdete v tématu Vytvoření, úprava nebo odebrání hypertextového odkazu

Oprava nefunkčního odkazu

Upozornění: Tuto akci nejde vrátit zpět. Můžete chtít před zahájením tohoto postupu uložit záložní kopii sešitu.

  1. Otevřete sešit obsahující nefunkční odkaz.

  2. V nabídce Úpravy klikněte na Propojení.

    Příkaz propojení je k dispozici, pokud váš sešit neobsahuje odkazy.

  3. V dialogovém okně zdrojového souboru klikněte na nefunkční odkaz, který chcete odstranit.

    Poznámka: Vyřešíte více vazeb mezi podržte COMMAND (PŘÍKAZ) a pak klikněte na každý odkaz.

  4. Klikněte na tlačítko Změnit zdroj.

  5. Udělejte něco z tohoto:

    Co chcete udělat

    Akce

    Oprava nefunkčního odkazu na list v jiném sešitu

    V dialogovém okně Otevřít vyhledejte sešit a potom klikněte na změnit.

    Oprava nefunkční odkaz na sešitu nebo jiném dokumentu sady Office

    Zadejte nový název nebo umístění pro dokument v textovém poli změnit odkazy na a potom klikněte na OK.

Vypnutí automatických aktualizací v propojená data

  1. Otevřete sešit obsahující nefunkční odkaz.

  2. V nabídce Úpravy klikněte na Propojení.

    Příkaz propojení je k dispozici, pokud váš sešit neobsahuje odkazy.

  3. V dialogovém okně zdrojového souboru klikněte na nefunkční odkaz, který chcete odstranit.

    Poznámka: Vyřešíte více vazeb mezi podržte COMMAND (PŘÍKAZ) a pak klikněte na každý odkaz.

  4. Klikněte na Manual (Ruční).

Odstranění nefunkčního odkazu

Při přerušení propojení všechny vzorce, které odkazují na zdrojový soubor se převedou na své aktuální hodnoty. Například pokud vzorec = SUMA([Budget.xls]Annual! C10: C25) výsledky v 45, vzorec bude převedena na 45 po přerušení propojení.

  1. Otevřete sešit obsahující nefunkční odkaz.

  2. V nabídce Úpravy klikněte na Propojení.

    Příkaz propojení je k dispozici, pokud váš sešit neobsahuje odkazy.

  3. V dialogovém okně zdrojového souboru klikněte na nefunkční odkaz, který chcete odebrat.

    Poznámka: Chcete-li odebrat více propojení, podržte stisknutou COMMAND (PŘÍKAZ) a klikněte na jednotlivé odkazy.

  4. Klikněte na tlačítko Zrušit propojení.

Viz taky

Import dat ze souboru CSV, HTML nebo z textového souboru

Poznámka: Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×