Oprava chyby #HODNOTA! u funkce SOUČIN.SKALÁRNÍ

Toto téma popisuje nejběžnější scénáře chyby #HODNOTA! při práci s funkcí SOUČIN.SKALÁRNÍ.

Problém: Argumenty matice nemají stejnou dimenzi

Všechny argumenty matice musí mít stejnou dimenzi. V opačném případě bude výsledkem chyba #HODNOTA!. Pokud třeba matice 1 označuje oblast 3 řádků a 2 sloupců, potom musí také matice 2 odpovídat podobné oblasti.

Vzorec SOUČIN.SKALÁRNÍ, který způsobuje chybu, je =SUMPRODUCT(D2:D13;E2:E10) – E10 je nutné změnit na E13, aby to vyhovovalo první oblasti.
  • =SOUČIN.SKALÁRNÍ(D2:D13;E2:E10)

Protože odkazované oblasti nemají stejný počet řádků (13 v první oblasti), ale jenom 10 ve druhé), dojde k chybě.

Řešení: Změňte vzorec takto:

  • =SOUČIN.SKALÁRNÍ(D2:D13;E2:E13)

Obě oblasti pak budou mít stejná čísla počátečního a koncového řádku. Vzorec pak zkuste použít znovu v této nové podobě.

Vyřešení chyby SOUČIN.SKALÁRNÍ vyřešením chyby #HODNOTA! v datech

Problém: Minimálně jedna buňka v oblasti obsahuje text

V případě, že některé z buněk v odkazované oblasti obsahují text nebo jsou naformátované jako datový typ Text, bude výsledkem vzorce chyba #HODNOTA!. Text může být výsledkem výpočtu z jiného vzorce nebo je možné, že buňka není jednoduše správně naformátovaná.

Vzorec v buňce E15 zobrazuje chybu #HODNOTA!, protože chyba #HODNOTA! je ve sloupci E.

Řešení: Vyhledejte veškeré buňky, které obsahují text nebo jsou naformátované jako text, a nastavte u nich správný datový typ.

Máte konkrétní otázku k funkci?

Zadejte dotaz do komunitního fóra Excelu

Pomozte nám vylepšit Excel

Máte nějaké návrhy na zlepšení dalších verzí Excelu? Pokud ano, podívejte se prosím na témata na webu Excel User Voice.

Viz taky

Oprava chyby #HODNOTA!

Funkce SOUČIN.SKALÁRNÍ

Přehled vzorců v Excelu

Jak se vyhnout nefunkčním vzorcům

Oprava chyb ve vzorcích pomocí kontroly chyb

Všechny funkce Excelu (podle abecedy)

Všechny funkce Excelu (podle kategorie)

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×