Oprava chyby #HODNOTA! u funkce CONCATENATE

Důležité : V aplikacích Excel 2016, Excel Mobile a Excel Online byla funkce CONCATENATE nahrazena funkcí CONCAT. I když je funkce CONCATENATE kvůli zpětné kompatibilitě pořád k dispozici, měli byste zvážit možnost používání funkce CONCAT, protože je výkonnější.

Jedním z nejobvyklejších případů, kdy dojde k chybě #HODNOTA! u funkce CONCATENATE je, když se pokusíte vytvořit řetězec, který obsahuje odkaz na buňku s chybou, například #HODNOTA!.

V následujícím příkladu chceme zřetězit hodnoty buněk D2, E2 a F2, přičemž v buňce E2 je chyba #HODNOTA!.

Chyba #HODNOTA! u funkce CONCATENATE

Chyba v buňce E2 způsobí, že funkce zobrazí chybu #HODNOTA!. Aby mohla funkce úspěšně fungovat, musíte chybu nahradit jinou hodnotou, než je chyba. Můžete vytvořit vzorec, který zjišťuje chyby v odkazu na buňku, a pokud se zjistí chyba, zobrazí se textový řetězec, kde se místo chyby zobrazí 0 (nebo můžete nahradit 0 vlastním textem, ale bude nutné tento text uzavřít do uvozovek – "váš text").

Takovýto vzorec bude fungovat:

=KDYŽ(JE.CHYBA(E2),CONCATENATE(D2;" ";0;" ";F2))

Funkce KDYŽ a JE.CHYBHODN použité jako alternativní řešení k řetězení řetězce s chybou #HODNOTA!

Jak to funguje? Funkce KDYŽ používá funkci IFERROR ke zjištění, jestli je chyba v buňce E2, a pokud tam je, zkombinuje funkce CONCATENATE hodnoty v buňce D2, E2 a F2 (funkce nahradí chybu číslem 0) a zobrazí výsledný textový řetězec. Poznámka: K vizuálnímu oddělení hodnot se ve vzorci používají mezery (" ").

Oprava chyby #HODNOTA! pomocí funkce CONCATENATE v Excelu 2003 a starších verzích

Pokud se zobrazuje chyba #HODNOTA! v aplikaci Office Excel 2003 nebo starších verzích, bude nutné v aplikaci Excel zrušit zaškrtnutí možnosti převodu výpočtu vzorců (TFE). Při řešení tohoto problému postupujte podle pokynů v tématu Chyba #HODNOTA! při řetězení buněk.

Máte konkrétní otázku k funkci?

Zadejte dotaz do komunitního fóra Excelu

Pomozte nám vylepšit Excel

Máte nějaké návrhy na zlepšení dalších verzí Excelu? Pokud ano, podívejte se prosím na témata na webu Excel User Voice.

Viz taky

Oprava chyby #HODNOTA!

Funkce CONCATENATE

Funkce CONCAT

Přehled vzorců v Excelu

Jak se vyhnout nefunkčním vzorcům

Oprava chyb ve vzorcích pomocí kontroly chyb

Všechny funkce Excelu (podle abecedy)

Všechny funkce Excelu (podle kategorie)

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×