Oprava chyby #DĚLENÍ_NULOU!

Microsoft Excel zobrazí chybu #DĚLENÍ_NULOU! v případě, že se nějaké číslo dělí nulou (0). Stává se to při zadání jednoduchého vzorce, třeba =5/0, nebo pokud vzorec odkazuje na buňku, která obsahuje nulu nebo je prázdná, jak je vidět na tomto obrázku.

Příklad vzorců, které způsobují chyby #DĚLENÍ_NULOU!.

Chybu opravíte tak, že uděláte některý z těchto kroků:

  • Zkontrolujte si, jestli dělitel ve funkci nebo vzorci není nula nebo prázdná buňka.

  • Změňte odkaz na buňku ve vzorci na jinou buňku, která neobsahuje nulu (0) nebo prázdnou hodnotu.

  • Zadejte do buňky, na kterou se ve vzorci odkazuje jako na dělitel, hodnotu #NENÍ_K_DISPOZICI. Tím se výsledek vzorce změní na #NENÍ_K_DISPOZICI, z čehož bude zřejmé, že hodnota dělitele není dostupná.

Často se stává, že chybě #DĚLENÍ_NULOU! není možné zabránit, protože vzorce čekají na vstup od vás nebo od někoho jiného. V takovém případě vůbec nepotřebujete, aby se vám chybová zpráva zobrazovala. Máte k dispozici několik možností, jak chybu zpracovat a potlačit, zatímco čekáte na vstup.

Vyhodnocení jmenovatele jako 0 nebo bez hodnoty

Nejjednodušší způsob, jak potlačit chybu #DĚLENÍ_NULOU!, je použít funkci KDYŽ k vyhodnocení existence jmenovatele. Když je jmenovatel 0 nebo bez hodnoty, pak zobraz jako výsledek vzorce místo chybové hodnoty #DĚLENÍ_NULOU! číslo 0 nebo žádnou hodnotu, jinak vzorec spočítej.

Pokud například chybu vrací vzorec =A2/A3, můžete zadat =KDYŽ(A3,A2/A3,0), aby se vrátila 0, nebo =KDYŽ(A3,A2/A3,""), aby se vrátil prázdný řetězec. Můžete také nechat zobrazit vlastní zprávu, jako například: =IF(A3,A2/A3,"Nutný vstup"). S funkcí QUOTIENT z prvního příkladu byste použili =IF(A3,QUOTIENT(A2,A3),0). Tím sdělíte Excelu následující: KDYŽ(A3 existuje, vrať výsledek vzorce, jinak ho ignoruj).

Příklady řešení chyb #DĚLENÍ_NULOU!.

Použití funkce IFERROR k potlačení chyby #DĚLENÍ_NULOU!

Tuto chybu můžete potlačit také tak, že operaci dělení vnoříte do funkce IFERROR. Pokud opět použijeme příklad A2/A3, můžete použít =IFERROR(A2/A3,0). Tak sdělíte Excelu, že pokud vzorec vyhodnotí jako chybu, má vrátit 0, jinak má vrátit výsledek vzorce.

U verzí Excelu starších než Excel 2007 můžete použít metodu KDYŽ(JE.CHYBHODN()): =KDYŽ(JE.CHYBHODN(A2/A3),0,A2/A3) (Viz článek o funkcích typu JE).

Poznámka: Jak funkce IFERROR, tak funkce KDYŽ(JE.CHYBHODN()) se aplikují na všechny chyby – jinak řečeno, potlačí všechny chyby, nejen #DĚLENÍ_NULOU!. Než přistoupíte ke zpracování chyby, musíte si být jistí, že vzorec funguje tak, jak má, jinak může dojít k tomu, že vzorec nebude fungovat podle očekávání a vy o tom nebudete vědět.

Tip : Pokud je v Excelu zapnutá kontrola chyb, můžete kliknout na vzhled tlačítka vedle buňky, ve které je chyba zobrazená. Klikněte na Zobrazit kroky výpočtu, pokud je tato možnost dostupná, a vyberte si řešení, které bude fungovat u vašich dat.

Máte konkrétní otázku k funkci?

Zadejte dotaz do komunitního fóra Excelu.

Pomozte nám vylepšit Excel

Máte nějaké návrhy na zlepšení dalších verzí Excelu? Pokud ano, podívejte se prosím na témata na webu Excel User Voice.

Viz taky

Funkce KDYŽ

IFERROR (funkce)

JE.x (funkce)

Přehled vzorců v Excelu

Jak se vyhnout nefunkčním vzorcům

Zjišťování chyb ve vzorcích

Funkce aplikace Excel (podle abecedy)

Funkce aplikace Excel (podle kategorie)

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×