Odeslání dat formuláře do webové služby

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Pokud chcete, aby uživatelé odesílali data formulářů do webové služby, můžete na šablonu formuláře přidat datové připojení pro odesílání jako vedlejší datové připojení. V závislosti na typu dat přijímaných webovou službou můžete nastavit datové připojení pro odesílání tak, aby odesílalo data v konkrétním poli, data ve všech polích konkrétní skupiny nebo veškerá data ve formuláři.

Po přidání datového připojení pro odesílání můžete nastavit šablonu formuláře tak, aby uživatelům povolila odesílání dat do webové služby. Po dokončení tohoto kroku přidá aplikace Microsoft Office InfoPath na panel nástrojů Standardní tlačítko Odeslat a do nabídky Soubor přidá příkaz Odeslat. Možnosti odesílání je možné přizpůsobit následujícími způsoby:

  • Změna textu, který se zobrazuje na tlačítku Odeslat na panelu nástrojů Standardní a v příkazu Odeslat v nabídce Soubor.

  • Změna klávesové zkratky pro tlačítko Odeslat na panelu nástrojů Standardní a příkaz Odeslat v nabídce Soubor.

  • Vytvoření vlastních zpráv, které se uživateli zobrazí po odeslání formuláře.

  • Výběr z možností, zda po odeslání formulář zavřít, nechat jej otevřený nebo zda otevřít nový nevyplněný formulář.

Přidání datového připojení pro odesílání

  1. V nabídce Nástroje klikněte na Možnosti odeslání.

  2. V dialogovém okně Možnosti odeslání zaškrtněte políčko Povolit uživatelům odeslat tento formulář.

  3. Klepněte na položku Odeslat data formuláře do jednoho umístění a poté klepněte v seznamu na možnost Webová služba.

  4. Klepněte na tlačítko Přidat.

  5. V Průvodci datovým připojením zadejte umístění webové služby, kam budou uživatelé odesílat data, a klepněte na tlačítko Další.

    Tip : Chcete-li webovou službu vyhledat na serveru UDDI (Universal Description, Discovery, and Integration), klepněte na tlačítko Hledat pomocí služby UDDI, zadejte vyhledávaný server UDDI, určete, zda chcete hledat podle zprostředkovatele nebo podle poskytovaných služeb, zadejte klíčové slovo vyhledávání a klepněte na tlačítko Hledat. V seznamu Výsledky hledání se zobrazí webové služby, které odpovídají vyhledávanému klíčovému slovu.

  6. Na další stránce průvodce v seznamu Vyberte operaci vyberte operaci webové služby, kterou chcete použít pro přijímání dat formuláře, a klepněte na tlačítko Další.

  7. Na další stránce průvodce vyberte pro každý parametr webové služby data formuláře, která budou odeslána. Proveďte jednu z následujících akci:

    Odeslání dat v poli nebo skupině

    1. V seznamu Parametry vyberte parametr webové služby, který bude přijímat data z formuláře.

    2. V oddílu Možnosti parametru klepněte na položku Pole nebo skupina.

    3. Klikněte na Upravit Vzhled tlačítka .

    4. V dialogovém okně Vybrat pole nebo skupinu klepněte na pole nebo skupinu, jejichž obsah chcete odeslat, a klepněte na tlačítko OK.

    5. V poli Zahrnout klepněte na položku Pouze text a podřízené prvky, pokud chcete odeslat pouze data v tomto poli a podřízené prvky pole nebo skupiny, nebo klepněte na položku Dílčí stromová struktura XML, včetně vybraného prvku, pokud chcete odeslat název pole, data v poli a podřízené prvky ve vybrané skupině nebo poli.

    Odeslání veškerých dat ve formuláři

    1. V seznamu Parametry vyberte parametr webové služby, který bude přijímat data z formuláře.

    2. Ve skupinovém rámečku Možnosti parametrů klepněte na možnost Celý formulář (dokument XML, včetně pokynů pro zpracování).

    Odeslání dat jako řetězce

    1. V seznamu Parametry vyberte parametr webové služby, který bude přijímat data z formuláře.

    2. Ve skupinovém rámečku Možnosti parametrů klepněte na možnost Celý formulář (dokument XML, včetně pokynů pro zpracování).

    3. Zaškrtněte políčko Odeslat data jako řetězec.

      Poznámka : Tato možnost se běžně používá pro odesílání dat s elektronickým podpisem. Ve většině případů toto políčko nemusí být zaškrtnuto.

    Technické podrobnosti o objektech Microsoft ADO.NET DataSet

    Pokud webová služba vyžaduje objekt ADO.NET DataSet, vyberte při nastavení tohoto datového připojení uzel DataSet. Pokud pro datové připojení k webové službě vyžadující objekt ADO DataSet použijete jakýkoliv jiný typ uzlu, akce odeslání neproběhne.

  8. Klepněte na tlačítko Další.

  9. Na další stránce průvodce zadejte do pole Zadejte název tohoto datového připojení popisný název tohoto datového připojení pro odesílání.

    1. Chcete-li změnit název tlačítka Odeslat, které se zobrazuje na panelu nástrojů Standardní a příkazu Odeslat, který se zobrazuje v nabídce Soubor, když uživatelé vyplní formulář, zadejte nový název do pole Titulek v dialogovém okně Možnosti odeslání.

      Tip : Pokud chcete k tomuto tlačítku a příkazu přiřadit klávesovou zkratku, zadejte znak ampersandu (&) před znak, který chcete použít jako klávesovou zkratku. Chcete-li k tlačítku a příkazu Odeslat přiřadit například klávesovou zkratku ALT+D, zadejte O&deslat.

  10. Ověřte správnost informací v oddílu Shrnutí a klepněte na tlačítko Dokončit.

  11. Chcete-li uživatelům povolit použití příkazu Odeslat nebo tlačítka Odeslat na panelu nástrojů Standardní při vyplňování formuláře, zaškrtněte políčko Zobrazit položku nabídky Odeslat a tlačítko Odeslat na panelu nástrojů.

    1. Ve výchozím nastavení zůstane formulář po odeslání otevřený a aplikace InfoPath zobrazí zprávu s informacemi o tom, zda byl formulář úspěšně odeslán. Jestliže chcete toto výchozí chování změnit, klepněte na tlačítko Upřesnit a proveďte jeden z následujících kroků:

      1. Chcete-li po odeslání vyplněného formuláře uživatelem formulář zavřít nebo vytvořit nový prázdný formulář, klepněte na požadovanou možnost v rozevíracím seznamu Po odeslání.

      2. Chcete-li vytvořit vlastní zprávu s informacemi o tom, zda byl formulář úspěšně odeslán, zaškrtněte políčko Použít vlastní zprávy a potom zadejte požadované zprávy do polí Při úspěchu a Při neúspěchu.

        Tip : Pomocí zprávy v poli Při neúspěchu uživatelům sdělte, co je třeba provést, pokud nelze formulář odeslat. Můžete uživatelům například navrhnout, aby uložili formulář a požádali o další pokyny jinou osobu.

      3. Pokud nechcete, aby se po odeslání formuláře uživateli zobrazila zpráva, zrušte zaškrtnutí políčka Zobrazit zprávy o úspěšném nebo neúspěšném provedení.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×