Odeslání dat formuláře do několika umístění

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Šablonu formuláře lze navrhnout tak, aby uživatelé po stisknutí tlačítka Odeslat odeslali data ve formuláři do několika umístění.

V tomto článku:

Základní informace

Krok 1: Přidání datových připojení pro odesílání

Krok 2: Nakonfigurujte povolit odesílání v šabloně formuláře

Přehled

Chcete-li uživatelům povolit odesílání dat z formulářů do několika umístění, je třeba do šablony formuláře přidat vedlejší datová připojení, která budou odesílat data do všech vedlejších umístění. Po přidání všech datových připojení pro odesílání je třeba nastavit šablonu formuláře tak, aby bylo uživatelům povoleno odesílat data do více umístění pomocí Pravidlo. Aplikace Microsoft Office InfoPath pak při vyplňování formuláře přidá na panel nástrojů Standardní tlačítko Odeslat a do nabídky Soubor přidá příkaz Odeslat. Aplikace InfoPath odešle data do vedlejších umístění v pořadí, v jakém jsou tato umístění v pravidle uvedena. Pravidlo však nelze nastavit tak, aby byla data odeslána do všech umístění najednou.

Při nastavení šablony formuláře a povolení odesílání dat uživatelem můžete rovněž přizpůsobit následující možnosti odesílání dat:

  • Změna textu, který se zobrazuje na tlačítku Odeslat na panelu nástrojů Standardní a v příkazu Odeslat v nabídce Soubor.

  • Změna klávesové zkratky pro tlačítko Odeslat na panelu nástrojů Standardní a příkaz Odeslat v nabídce Soubor.

  • Vytvoření vlastních zpráv, které se uživateli zobrazí po odeslání formuláře.

  • Můžete určit, jestli má formulář po odeslání zůstat otevřený, nebo se má zavřít, nebo se má otevřít nový prázdný formulář.

Začátek stránky

Krok 1: Přidání datového připojení pro odesílání

Chcete-li nastavit šablonu formuláře tak, aby uživatelům povolila odesílání vyplněných formulářů do několika umístění, je třeba do šablony formuláře přidat potřebná datová připojení pro odesílání. Je možné přidat datová připojení do následujících umístění:

  • webová služba

  • knihovna dokumentů na serveru podporující službu Microsoft Windows SharePoint Services

  • e-mailová zpráva

    Poznámka : Pokud chce uživatel odesílat data z formuláře pomocí e-mailu, je nutné, aby měl v počítači nainstalovánu aplikaci Microsoft Office Outlook.

Následující postup popisuje, jak lze přidat datová připojení pro odesílání pro tato umístění.

Přidání datového připojení, které odesílá data do webové služby

  1. V nabídce Nástroje klikněte na příkaz Datová připojení.

  2. V dialogovém okně Datová připojení klikněte na tlačítko Přidat.

  3. V Průvodci datovým připojením klepněte na přepínač Vytvořit nové připojení k, na přepínač Odesílat data a potom na tlačítko Další.

  4. Na další stránce průvodce klepněte na přepínač Pro webovou službu a klepněte na tlačítko Další.

  5. Na další stránce zadejte umístění webové služby, kam budou uživatelé odesílat formuláře, a klepněte na tlačítko Další.

    Chcete-li webovou službu vyhledat na serveru UDDI (Universal Description, Discovery, and Integration), klepněte na tlačítko Hledat pomocí služby UDDI, zadejte vyhledávaný server UDDI, určete, zda chcete hledat podle zprostředkovatele nebo podle poskytovaných služeb, zadejte klíčové slovo vyhledávání a klepněte na tlačítko Hledat. V seznamu Výsledky hledání se zobrazí webové služby, které odpovídají vyhledávanému klíčovému slovu.

  6. Na další stránce průvodce v seznamu Vyberte operaci vyberte operaci webové služby, kterou chcete použít pro přijímání dat formuláře, a klepněte na tlačítko Další.

  7. Na další stránce průvodce proveďte některou z následujících akcí:

    Odeslání dat do pole nebo skupiny

    1. V seznamu Parametry vyberte parametr webové služby, který bude přijímat data z formuláře.

    2. V oddílu Možnosti parametru klepněte na položku Pole nebo skupina.

    3. Klikněte na Upravit Vzhled tlačítka .

    4. V dialogovém okně Vybrat pole nebo skupinu klepněte na pole nebo skupinu, jejíž obsah chcete odeslat, a pak klepněte na tlačítko OK.

    5. V poli Zahrnout klepněte na možnost Pouze text a podřízené prvky, pokud chcete odeslat pouze obsah a veškeré podřízené prvky pole nebo skupiny, nebo klepněte na možnost Dílčí stromová struktura XML, včetně vybraného prvku, jestliže chcete odeslat obsah i vybrané pole či skupinu.

    Odeslání všech dat ve formuláři

    1. Klepněte na položku Celý formulář (dokument XML, včetně pokynů pro zpracování).

    Odeslání dat jako řetězec

    1. Zaškrtněte políčko Odeslat data jako řetězec.

      Tato možnost se běžně používá pro odesílání dat s elektronickým podpisem. Ve většině případů toto políčko nemusí být zaškrtnuto.

  8. Klepněte na tlačítko Další.

  9. Na další stránce průvodce zadejte do pole Zadejte název tohoto datového připojení popisný název tohoto datového připojení pro odesílání.

  10. Ověřte správnost informací v oddílu Shrnutí a klikněte na tlačítko Dokončit.

Přidání datového připojení, které odesílá data do knihovny dokumentů

  1. V nabídce Nástroje klikněte na příkaz Datová připojení.

  2. V dialogovém okně Datová připojení klikněte na tlačítko Přidat.

  3. V Průvodci datovým připojením klepněte na přepínač Vytvořit nové připojení k, na přepínač Odesílat data a potom na tlačítko Další.

  4. Na další stránce průvodce klepněte na přepínač Do knihovny dokumentů na webu služby SharePoint a pak klepněte na tlačítko Další.

  5. Na další stránce průvodce zadejte do pole Knihovna dokumentů umístění knihovny dokumentů služby SharePoint.

  6. Do pole Název souboru zadejte název, který se bude používat jako identifikace formuláře v knihovně dokumentů. Můžete použít vzorec a zajistit tak jedinečnost každého názvu formuláře.

    Postup

    1. Klikněte na tlačítko Vložit vzorec Obrázek tlačítka .

    2. V dialogovém okně Vložit vzorec proveďte některou z následujících akcí:

      • Chcete-li ve vzorci použít pole, klepněte na položku Vložit pole nebo skupinu, vyberte pole, které chcete použít v dialogovém okně Vyberte pole nebo skupinu, a klepněte na tlačítko OK.

      • Chcete-li ve vzorci použít funkci, klepněte na položku Vložit funkci, vyberte funkci, kterou chcete použít v dialogovém okně Vložit funkci, a klepněte na tlačítko OK.

        Pokud funkce vyžaduje parametry, vyberte funkci v dialogovém okně Vložit funkci, klepněte na tlačítko OK a poté v dialogovém okně Vložit vzorec v poli Vzorec poklepejte na funkci, kterou jste přidali, a klepněte na pole nebo skupinu. Odkazy na další informace o funkcích naleznete v oddílu Viz také.

      • Chcete-li do vzorce vložit hodnotu nebo matematický operátor, zadejte hodnotu nebo symbol matematické operace do pole Vzorec.

    Operace

    Symbol

    Sčítání

    +

    Odečítání

    -

    Násobení

    *

    Dělení

    /

    • Poznámka : Pokud vzorec používá operátor dělení (/), ujistěte se, že před i za operátorem je mezera. Pokud nebude operátor dělení z obou stran oddělen mezerou, bude jej aplikace InfoPath považovat za oddělovač v umístění cesty XPath a nikoli za operátor dělení.

    • Chcete-li zkontrolovat syntaxi vzorce, v dialogovém okně Vložit vzorec klikněte na tlačítko Ověřit vzorec.

      Odkazy na články s dalšími informacemi o vzorcích naleznete v části Viz také.

  7. Chcete-li přepsat existující formuláře se stejným názvem v knihovně dokumentů, zaškrtněte políčko Povolit přepsání, pokud soubor existuje.

  8. Klepněte na tlačítko Další.

  9. Na další stránce průvodce zadejte do pole Zadejte název tohoto datového připojení popisný název tohoto datového připojení pro odesílání.

  10. Ověřte správnost informací v oddílu Shrnutí a klikněte na tlačítko Dokončit.

Přidání datového připojení, které odesílá data v e-mailové zprávě

  1. V nabídce Nástroje klikněte na příkaz Datová připojení.

  2. V dialogovém okně Datová připojení klikněte na tlačítko Přidat.

  3. V Průvodci datovým připojením klepněte na přepínač Vytvořit nové připojení k, na přepínač Odesílat data a potom na tlačítko Další.

  4. Na další stránce průvodce klepněte na přepínač Jako e-mailová zpráva a klepněte na tlačítko Další.

  5. Na další stránce průvodce zadejte e-mailové adresy příjemců zprávy, předmět zprávy a veškerý úvodní text, který se má zobrazit v odpovídajících polích, a pak klepněte na tlačítko Další. Ve všech polích kromě pole Úvod lze také použít vzorec.

    Postup

    1. Klikněte na tlačítko Vložit vzorec Obrázek tlačítka .

    2. V dialogovém okně Vložit vzorec proveďte některou z následujících akcí:

      • Chcete-li ve vzorci použít pole, klepněte na položku Vložit pole nebo skupinu, vyberte pole, které chcete použít v dialogovém okně Vyberte pole nebo skupinu, a klepněte na tlačítko OK.

      • Chcete-li ve vzorci použít funkci, klepněte na položku Vložit funkci, vyberte funkci, kterou chcete použít v dialogovém okně Vložit funkci, a klepněte na tlačítko OK.

        Pokud funkce vyžaduje parametry, vyberte funkci v dialogovém okně Vložit funkci, klepněte na tlačítko OK a poté v dialogovém okně Vložit vzorec v poli Vzorec poklepejte na funkci, kterou jste přidali, a klepněte na pole nebo skupinu. Odkazy na další informace o funkcích naleznete v oddílu Viz také.

      • Chcete-li do vzorce vložit hodnotu nebo matematický operátor, zadejte hodnotu nebo symbol matematické operace do pole Vzorec.

    Operace

    Symbol

    Sčítání

    +

    Odečítání

    -

    Násobení

    *

    Dělení

    /

    • Poznámka : Pokud vzorec používá operátor dělení (/), ujistěte se, že před i za operátorem je mezera. Pokud nebude operátor dělení z obou stran oddělen mezerou, bude jej aplikace InfoPath považovat za oddělovač v umístění cesty XPath a nikoli za operátor dělení.

    • Chcete-li zkontrolovat syntaxi vzorce, v dialogovém okně Vložit vzorec klikněte na tlačítko Ověřit vzorec.

      Odkazy na články s dalšími informacemi o vzorcích naleznete v části Viz také.

  6. Na další stránce průvodce proveďte některou z následujících akcí:

    1. Chcete-li formulář zobrazit v textu e-mailové zprávy, klepněte na položku Odeslat pouze aktivní zobrazení formuláře bez příloh.

    2. Odeslání dat formuláře jako přílohu na e-mailové zprávy, klikněte na odesílání dat formuláře jako přílohu, zaškrtněte políčko Připojit šabloně formuláře zajistit, aby uživatelé mohli otevřít formulář a potom zadejte název formuláře do pole Název přílohy. Můžete taky určit pole nebo použijte vzorec a ujistěte se, že každý název formuláře je jedinečný. Tato možnost je k dispozici pouze v případě šablona formuláře nakonfigurovaný tak, aby automaticky určují úroveň zabezpečení nebo nakonfigurovaný tak, aby s omezeným přístupem nebo plnými úroveň zabezpečení.

      Postup

      1. Klikněte na tlačítko Vložit vzorec Obrázek tlačítka .

      2. V dialogovém okně Vložit vzorec proveďte některou z následujících akcí:

        • Chcete-li ve vzorci použít pole, klepněte na položku Vložit pole nebo skupinu, vyberte pole, které chcete použít v dialogovém okně Vyberte pole nebo skupinu, a klepněte na tlačítko OK.

        • Chcete-li ve vzorci použít funkci, klepněte na položku Vložit funkci, vyberte funkci, kterou chcete použít v dialogovém okně Vložit funkci, a klepněte na tlačítko OK.

          Pokud funkce vyžaduje parametry, vyberte funkci v dialogovém okně Vložit funkci, klepněte na tlačítko OK a poté v dialogovém okně Vložit vzorec v poli Vzorec poklepejte na funkci, kterou jste přidali, a klepněte na pole nebo skupinu. Odkazy na další informace o funkcích naleznete v oddílu Viz také.

        • Chcete-li do vzorce vložit hodnotu nebo matematický operátor, zadejte hodnotu nebo symbol matematické operace do pole Vzorec.

      Operace

      Symbol

      Sčítání

      +

      Odečítání

      -

      Násobení

      *

      Dělení

      /

      • Poznámka : Pokud vzorec používá operátor dělení (/), ujistěte se, že před i za operátorem je mezera. Pokud nebude operátor dělení z obou stran oddělen mezerou, bude jej aplikace InfoPath považovat za oddělovač v umístění cesty XPath a nikoli za operátor dělení.

      • Chcete-li zkontrolovat syntaxi vzorce, v dialogovém okně Vložit vzorec klikněte na tlačítko Ověřit vzorec.

        Odkazy na články s dalšími informacemi o vzorcích naleznete v části Viz také.

      Příjemci e-mailové zprávy s daty formuláře zaslanými v příloze potřebují mít k otevření této přílohy v počítači nainstalovánu aplikaci InfoPath.

  7. Klepněte na tlačítko Další.

  8. Na další stránce průvodce zadejte do pole Zadejte název tohoto datového připojení popisný název tohoto datového připojení pro odesílání.

  9. Ověřte správnost informací v oddílu Shrnutí a klikněte na tlačítko Dokončit.

Začátek stránky

Krok 2: Povolení odesílání dat v šabloně formuláře

Po zadání potřebných vedlejších datových připojení do šablony formuláře nastavte šablonu formuláře tak, aby uživatelům povolila odesílání dat. Po dokončení tohoto kroku aplikace InfoPath přidá příkaz Odeslat do nabídky Soubor a tlačítko Odeslat na panel nástrojů Standardní, kdykoli uživatel vyplňuje tento formulář. Dále je možné nastavit akci, která bude provedena po klepnutí na tlačítko Odeslat. V tomto případě se jedná o pravidlo, které po klepnutí na příkaz Odeslat v nabídce Soubor nebo na tlačítko Odeslat na panelu nástrojů Standardní odešle data formuláře na každé datové připojení pro odesílání.

Ve stejném dialogovém okně lze nastavit možnosti odesílání.

  1. V nabídce Nástroje klikněte na Možnosti odeslání.

  2. V dialogovém okně Možnosti odeslání zaškrtněte políčko Povolit uživatelům odeslat tento formulář.

    Po zaškrtnutí tohoto políčka přidá aplikace Microsoft Office InfoPath při vyplňování formuláře na panel nástrojů Standardní tlačítko Odeslat a do nabídky Soubor přidá příkaz Odeslat.

  3. Klepněte na položku Provést vlastní akci pomocí pravidel a poté na položku Pravidla.

  4. V dialogovém okně Pravidla pro odesílání formulářů klepněte na tlačítko Přidat.

  5. Klepněte na tlačítko Přidat akci.

  6. V poli Akce klepněte na možnost Odeslat pomocí datového připojení, v seznamu Datové připojení vyberte datové připojení, které chcete pro tuto akci odesílání použít, a klepněte na tlačítko OK.

  7. Kroky 5 a 6 zopakujte pro každé datové připojení pro odesílání, které jste do šablony formuláře přidali.

  8. Po přidání podmínek pro všechna datová připojení pro odesílání do šablony formuláře klepněte dvakrát na tlačítko OK.

    1. Chcete-li změnit název tlačítka Odeslat, které se zobrazuje na panelu nástrojů Standardní a příkazu Odeslat, který se zobrazuje v nabídce Soubor, když uživatelé vyplní formulář, zadejte nový název do pole Titulek v dialogovém okně Možnosti odeslání.

      Pokud chcete k tomuto tlačítku a příkazu přiřadit klávesovou zkratku, zadejte znak ampersandu (&) před znak, který chcete použít jako klávesovou zkratku. Chcete-li k tlačítku a příkazu Odeslat přiřadit například klávesovou zkratku ALT+D, zadejte O&deslat.

  9. Chcete-li uživatelům zabránit v použití příkazu Odeslat nebo tlačítka Odeslat na panelu nástrojů Standardní během vyplňování formuláře, zrušte zaškrtnutí políčka Zobrazit položku nabídky Odeslat a tlačítko Odeslat na panelu nástrojů.

    1. Ve výchozím nastavení zůstane formulář po odeslání otevřený a aplikace InfoPath zobrazí zprávu s informacemi o tom, zda byl formulář úspěšně odeslán. Jestliže chcete toto výchozí chování změnit, klikněte na tlačítko Upřesnit a proveďte jeden z následujících kroků:

      • Chcete-li po odeslání vyplněného formuláře uživatelem formulář zavřít nebo vytvořit nový prázdný formulář, klikněte na požadovanou možnost v rozevíracím seznamu Po odeslání.

      • Chcete-li vytvořit vlastní zprávu s informacemi o tom, zda byl formulář úspěšně odeslán, zaškrtněte políčko Použít vlastní zprávy a potom zadejte požadované zprávy do polí Při úspěchu a Při neúspěchu.

        Pomocí zprávy v poli Při neúspěchu uživatelům sdělte, co je třeba provést, pokud nelze formulář odeslat. Můžete uživatelům například navrhnout, aby uložili formulář a požádali o další pokyny jinou osobu.

      • Pokud nechcete, aby se po odeslání formuláře uživateli zobrazila zpráva, zrušte zaškrtnutí políčka Zobrazit zprávy o úspěšném nebo neúspěšném provedení.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×