Odeslání dat formuláře do knihovny dokumentů

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Veškeré uživatelské formuláře můžete archivovat a uspořádávat v knihovně dokumentů na serveru podporujícím službu Microsoft Windows SharePoint Services. V knihovně dokumentů mohou uživatelé vyplňovat formuláře založené na šabloně formuláře, exportovat data z vyplněných formulářů do aplikace Microsoft Office Excel 2003 nebo do aplikace Microsoft Office Excel 2007 a slučovat data z více formulářů do jednoho.

Chcete-li uživatelům povolit odesílání formulářů založených na šabloně formuláře do knihovny dokumentů, můžete do šablony formuláře přidat vedlejší datové připojení, které data odešle. Po přidání datového připojení pro odesílání můžete nastavit šablonu formuláře tak, aby uživatelům povolila odesílání dat do knihovny dokumentů. Aplikace Microsoft Office InfoPath pak přidá na panel nástrojů Standardní tlačítko Odeslat a do nabídky formuláře Soubor přidá příkaz Odeslat. Možnosti odesílání je možné přizpůsobit následujícími způsoby:

  • Změna textu, který se zobrazuje na tlačítku Odeslat na panelu nástrojů Standardní a v příkazu Odeslat v nabídce Soubor.

  • Změna klávesové zkratky pro tlačítko Odeslat na panelu nástrojů Standardní a příkaz Odeslat v nabídce Soubor.

  • Vytvoření vlastních zpráv, které se uživateli zobrazí po odeslání formuláře.

  • Výběr z možností, zda po odeslání formulář zavřít, nechat jej otevřený nebo zda otevřít nový nevyplněný formulář.

Přidání datového připojení pro odesílání

  1. V nabídce Nástroje klikněte na Možnosti odeslání.

  2. V dialogovém okně Možnosti odeslání zaškrtněte políčko Povolit uživatelům odeslat tento formulář.

  3. Klepněte na položku Odeslat data formuláře do jednoho umístění a poté v seznamu klepněte na možnost Knihovna dokumentů služby SharePoint.

  4. Klepněte na tlačítko Přidat.

  5. V Průvodci datovým připojením zadejte do pole Knihovna dokumentů umístění knihovny dokumentů služby SharePoint.

  6. Do pole Název souboru zadejte název, který se bude používat jako identifikace formuláře v knihovně dokumentů.

    Tip : Můžete použít vzorec a zajistit tak jedinečnost názvu každého formuláře.

    Postup

    1. Klikněte na tlačítko Vložit vzorec Obrázek tlačítka .

    2. V dialogovém okně Vložit vzorec proveďte některou z následujících akcí:

      • Chcete-li ve vzorci použít pole, klepněte na položku Vložit pole nebo skupinu, vyberte pole, které chcete použít v dialogovém okně Vyberte pole nebo skupinu, a klepněte na tlačítko OK.

      • Chcete-li ve vzorci použít funkci, klepněte na položku Vložit funkci, vyberte funkci, kterou chcete použít v dialogovém okně Vložit funkci, a klepněte na tlačítko OK.

        Tip : Pokud funkce vyžaduje parametry, vyberte funkci v dialogovém okně Vložit funkci, klepněte na tlačítko OK a poté v dialogovém okně Vložit vzorec v poli Vzorec poklepejte na funkci, kterou jste přidali, a klepněte na pole nebo skupinu. Odkazy na další informace o funkcích naleznete v oddílu Viz také.

      • Chcete-li do vzorce vložit hodnotu nebo matematický operátor, zadejte hodnotu nebo symbol matematické operace do pole Vzorec.

    Operace

    Symbol

    Sčítání

    +

    Odečítání

    -

    Násobení

    *

    Dělení

    /

    • Poznámka : Pokud vzorec používá operátor dělení (/), ujistěte se, že před i za operátorem je mezera. Pokud nebude operátor dělení z obou stran oddělen mezerou, bude jej aplikace InfoPath považovat za oddělovač v umístění cesty XPath a nikoli za operátor dělení.

    • Chcete-li zkontrolovat syntaxi vzorce, v dialogovém okně Vložit vzorec klikněte na tlačítko Ověřit vzorec.

      Odkazy na články s dalšími informacemi o vzorcích naleznete v části Viz také.

  7. Chcete-li přepsat existující formuláře se stejným názvem v knihovně dokumentů, zaškrtněte políčko Povolit přepsání, pokud soubor existuje.

  8. Klepněte na tlačítko Další.

  9. Na další stránce průvodce zadejte do pole Zadejte název tohoto datového připojení popisný název tohoto datového připojení pro odesílání.

  10. Ověřte správnost informací v oddílu Shrnutí a klikněte na tlačítko Dokončit.

    1. Chcete-li změnit název tlačítka Odeslat, které se zobrazuje na panelu nástrojů Standardní a příkazu Odeslat, který se zobrazuje v nabídce Soubor, když uživatelé vyplní formulář, zadejte nový název do pole Titulek v dialogovém okně Možnosti odeslání.

      Tip : Pokud chcete k tomuto tlačítku a příkazu přiřadit klávesovou zkratku, zadejte znak ampersandu (&) před znak, který chcete použít jako klávesovou zkratku. Chcete-li k tlačítku a příkazu Odeslat přiřadit například klávesovou zkratku ALT+D, zadejte O&deslat.

  11. Pokud uživatelům při vyplňování formuláře nechcete povolit použití příkazu Odeslat ani tlačítka Odeslat na panelu nástrojů Standardní, zrušte zaškrtnutí políčka Zobrazit položku nabídky Odeslat a tlačítko Odeslat na panelu nástrojů.

    1. Ve výchozím nastavení zůstane formulář po odeslání otevřený a aplikace InfoPath zobrazí zprávu s informacemi o tom, zda byl formulář úspěšně odeslán. Jestliže chcete toto výchozí chování změnit, klepněte na tlačítko Upřesnit a proveďte jeden z následujících kroků:

      1. Chcete-li po odeslání vyplněného formuláře uživatelem formulář zavřít nebo vytvořit nový prázdný formulář, klepněte na požadovanou možnost v rozevíracím seznamu Po odeslání.

      2. Chcete-li vytvořit vlastní zprávu s informacemi o tom, zda byl formulář úspěšně odeslán, zaškrtněte políčko Použít vlastní zprávy a potom zadejte požadované zprávy do polí Při úspěchu a Při neúspěchu.

        Tip : Pomocí zprávy v poli Při neúspěchu uživatelům sdělte, co je třeba provést, pokud nelze formulář odeslat. Můžete uživatelům například navrhnout, aby uložili formulář a požádali o další pokyny jinou osobu.

      3. Pokud nechcete, aby se po odeslání formuláře uživateli zobrazila zpráva, zrušte zaškrtnutí políčka Zobrazit zprávy o úspěšném nebo neúspěšném provedení.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Byly tyto informace užitečné?

Výborně! Je ještě něco dalšího, co byste nám chtěli dát vědět?

Jak bychom ho mohli vylepšit?

Děkujeme vám za zpětnou vazbu.

×