Odeslání dat formuláře do databáze aplikace Microsoft Access

V tomto článku

Přehled

Krok 1: Povolení datového připojení pro odesílání

Krok 2: Nastavení možností odesílání

Přehled

Když navrhujete šablonu formuláře aplikace Microsoft Office InfoPath založenou na databázi Microsoft Office Access (.mdb) nebo Microsoft Office Access 2007 (.accdb), Průvodce datovým připojením vytvoří datové připojení pro odesílání do databáze, pokud jsou splněny následující podmínky:

  • Šablona formuláře je navržená tak, aby uživatelé museli formulář vyplňovat pomocí aplikace InfoPath. Pokud bude formulář vyplňovaný ve webovém prohlížeči, nemůže formulář odesílat data přímo do databáze. Když chcete šablonu formuláře kompatibilní s prohlížečem nakonfigurovat tak, aby se data odesílala do databáze, použijte datové připojení, které posílá data webové službě spolupracující s databází.

  • Primární tabulka databáze použitá v hlavním datovém připojení obsahuje primární klíč, jedinečné omezení nebo jedinečný index.

  • Jakékoli další databázové tabulky, které se používají s tímto hlavním datovým připojením, mají jednoduchou hierarchickou relaci k primární tabulce databáze.

  • Databáze neobsahuje pole, která uchovávají rozsáhlý binární datový typ, jako třeba obrázky, image, objekty OLE, souborové přílohy, datový typ Memo aplikace Office Access nebo datový typ SQL Text.

Pokud databáze splňuje tyto požadavky, vytvoří aplikace InfoPath datové připojení pro odesílání a přidá ve formuláři tlačítko Odeslat na panel nástrojů Standardní a příkaz Odeslat do nabídky Soubor.

Poznámka : Sekundární datová připojení nemůžou odesílat data do databáze. Pokud chcete datové připojení pro odesílání použít jako sekundární datové připojení, určete webovou službu, která spolupracuje s databází, a přidejte datové připojené pro odesílání k této datové službě.

Po povolení datového připojení pro odesílání můžete následujícími způsoby upravit možnosti odesílání pro šablonu formuláře:

  • Můžete změnit text, který se zobrazuje na tlačítku Odeslat na panelu nástrojů Standardní a v příkazu Odeslat v nabídce Soubor.

  • Můžete změnit klávesové zkratky pro tlačítko Odeslat na panelu nástrojů Standardní a příkaz Odeslat v nabídce Soubor.

  • Můžete vytvořit vlastní zprávy, které se uživatelům zobrazí při odeslání formulářů.

  • Můžete určit, jestli má formulář po odeslání zůstat otevřený, nebo se má zavřít, nebo se má otevřít nový prázdný formulář.

Začátek stránky

Krok 1: Povolení datového připojení pro odesílání

  1. V nabídce Nástroje klikněte na příkaz Datová připojení.

  2. V dialogovém okně Datová připojení klikněte na hlavní datové připojení a poté na tlačítko Změnit.

  3. V Průvodci datovým připojením klikněte na tlačítko Další.

  4. Na další stránce průvodce zaškrtněte políčko Povolit odesílání pro toto připojení a klikněte na tlačítko Dokončit.

Začátek stránky

Krok 2: Nastavení možností odesílání

Když povolíte datové připojení pro odesílání, aplikace InfoPath přidá tlačítko Odeslat na panel nástrojů Standardní a příkaz Odeslat do nabídky Soubor. Aplikace InfoPath taky nastaví formuláře založené na této šabloně formuláře tak, aby se uživatelům po odeslání vyplněných formulářů zobrazila zpráva. Tato zpráva informuje o tom, jestli byl formulář úspěšně odeslán. Když uživatel formulář odešle, aplikace InfoPath ho ve výchozím nastavení nechá otevřený. Chcete-li změnit text, který se zobrazí na tlačítku Odeslat, a chování formuláře po jeho odeslání uživatelem, postupujte takto:

  1. V nabídce Nástroje klikněte na Možnosti odeslání.

    1. Chcete-li změnit název tlačítka Odeslat, které se zobrazuje na panelu nástrojů Standardní, a příkazu Odeslat, který se zobrazuje v nabídce Soubor, když uživatelé vyplní formulář, zadejte nový název do pole Titulek v dialogovém okně Možnosti odeslání.

      Tip : Pokud chcete k tomuto tlačítku a příkazu přiřadit klávesovou zkratku, zadejte znak ampersandu (&) před znak, který chcete použít jako klávesovou zkratku. Chcete-li k tlačítku a příkazu Odeslat přiřadit například klávesovou zkratku ALT+D, zadejte O&deslat.

  2. Pokud uživatelům při vyplňování formuláře nechcete povolit použití příkazu Odeslat ani tlačítka Odeslat na panelu nástrojů Standardní, zrušte zaškrtnutí políčka Zobrazit položku nabídky Odeslat a tlačítko Odeslat na panelu nástrojů.

    1. Ve výchozím nastavení zůstane formulář po odeslání otevřený a aplikace InfoPath zobrazí zprávu s informacemi o tom, zda byl formulář úspěšně odeslán. Jestliže chcete toto výchozí chování změnit, klikněte na tlačítko Upřesnit a proveďte jeden z následujících kroků:

      • Chcete-li po odeslání vyplněného formuláře uživatelem formulář zavřít nebo vytvořit nový prázdný formulář, klikněte na požadovanou možnost v rozevíracím seznamu Po odeslání.

      • Chcete-li vytvořit vlastní zprávu s informacemi o tom, zda byl formulář úspěšně odeslán, zaškrtněte políčko Použít vlastní zprávy a potom zadejte požadované zprávy do polí Při úspěchu a Při neúspěchu.

        Tip : Pomocí zprávy v poli Při neúspěchu uživatelům sdělte, co je třeba provést, pokud nelze formulář odeslat. Můžete uživatelům například navrhnout, aby uložili formulář a požádali o další pokyny jinou osobu.

      • Pokud nechcete, aby se po odeslání formuláře uživateli zobrazila zpráva, zrušte zaškrtnutí políčka Zobrazit zprávy o úspěšném nebo neúspěšném provedení.

Začátek stránky

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×