Odesílání dat formuláře v e-mailové zprávě

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Do šablony formuláře, který umožňuje uživatelům odesílat data formuláře v e-mailové zprávě, můžete přidat vedlejší datová připojení pro odesílání. Pro zadání adres příjemců e-mailové zprávy, předmětu zprávy a názvu formuláře můžete použít neměnné hodnoty, hodnoty založené na datech ve formuláři nebo vzorce. Můžete si také vybrat, zda se data formuláře zobrazí přímo v textu e-mailové zprávy nebo v příloze.

Pokud nastavíte šablonu formuláře tak, aby byl formulář připojen k e-mailové zprávě jako příloha, můžete jako druhou přílohu zaslat samotnou šablonu formuláře. Zajistíte tak, že uživatelé budou moci zaslaný formulář v aplikaci Microsoft Office InfoPath otevřít i tehdy, pokud na svých počítačích nemají kopii šablony formuláře. Je třeba, aby uživatelé, kteří chtějí přílohy e-mailové zprávy otevřít, měli v počítači nainstalovánu aplikaci InfoPath.

Při odesílání dat formuláře uživatelem pomocí e-mailové zprávy vytvoří aplikace InfoPath e-mailovou zprávu s daty a zašle ji na adresy zadané při vytváření datového připojení. Pokud uživatelé, kteří obdrží vyplněné formuláře, používají aplikaci Microsoft Office Outlook 2007, mohou si vytvořit ve složce Doručená pošta dílčí složku, která bude obsahovat veškeré formuláře aplikace InfoPath, které obdrží, a tuto složku si mohou nastavit tak, že bude zobrazovat data ve formulářích přímo v aplikaci Outlook.

Po přidání datového připojení pro odesílání můžete nastavit šablonu formuláře tak, aby uživatelům povolila odesílání dat. Po dokončení tohoto kroku přidá aplikace InfoPath automaticky na panel nástrojů Standardní tlačítko Odeslat a do nabídky Soubor příkaz Odeslat. Možnosti odesílání je možné přizpůsobit následujícími způsoby:

  • Změna textu, který se zobrazuje na tlačítku Odeslat na panelu nástrojů Standardní a v příkazu Odeslat v nabídce Soubor.

  • Změna klávesové zkratky pro tlačítko Odeslat na panelu nástrojů Standardní a příkaz Odeslat v nabídce Soubor.

  • Vytvoření vlastních zpráv, které se uživateli zobrazí po odeslání formuláře.

  • Výběr z možností, zda po odeslání formulář zavřít, nechat jej otevřený nebo zda otevřít nový nevyplněný formulář.

Začátek stránky

Přidání datového připojení pro odesílání

  1. V nabídce Nástroje klikněte na Možnosti odeslání.

  2. V dialogovém okně Možnosti odeslání zaškrtněte políčko Povolit uživatelům odeslat tento formulář.

  3. Klepněte na položku Odeslat data formuláře do jednoho umístění a poté v seznamu vyberte možnost E-mail.

  4. Klepněte na tlačítko Přidat.

  5. V Průvodci datovým připojením zadejte do příslušných polí e-mailové adresy příjemců, předmět e-mailové zprávy a veškerý úvodní text, který má zpráva obsahovat, a klepněte na tlačítko Další.

    Tip : Pro vytvoření hodnot polí s výjimkou pole Úvod můžete také použít pole nebo vzorec.

    Postup

    1. Klikněte na tlačítko Vložit vzorec Obrázek tlačítka .

    2. V dialogovém okně Vložit vzorec proveďte některou z následujících akcí:

      • Chcete-li ve vzorci použít pole, klepněte na položku Vložit pole nebo skupinu, vyberte pole, které chcete použít v dialogovém okně Vyberte pole nebo skupinu, a klepněte na tlačítko OK.

      • Chcete-li ve vzorci použít funkci, klepněte na položku Vložit funkci, vyberte funkci, kterou chcete použít v dialogovém okně Vložit funkci, a klepněte na tlačítko OK.

        Tip : Pokud funkce vyžaduje parametry, vyberte funkci v dialogovém okně Vložit funkci, klepněte na tlačítko OK a poté v dialogovém okně Vložit vzorec v poli Vzorec poklepejte na funkci, kterou jste přidali, a klepněte na pole nebo skupinu. Odkazy na další informace o funkcích naleznete v oddílu Viz také.

      • Chcete-li do vzorce vložit hodnotu nebo matematický operátor, zadejte hodnotu nebo symbol matematické operace do pole Vzorec.

    Operace

    Symbol

    Sčítání

    +

    Odečítání

    -

    Násobení

    *

    Dělení

    /

    • Poznámka : Pokud vzorec používá operátor dělení (/), ujistěte se, že před i za operátorem je mezera. Pokud nebude operátor dělení z obou stran oddělen mezerou, bude jej aplikace InfoPath považovat za oddělovač v umístění cesty XPath a nikoli za operátor dělení.

    • Chcete-li zkontrolovat syntaxi vzorce, v dialogovém okně Vložit vzorec klikněte na tlačítko Ověřit vzorec.

      Odkazy na články s dalšími informacemi o vzorcích naleznete v části Viz také.

  6. Na další stránce průvodce proveďte některou z následujících akcí:

    1. Chcete-li formulář zobrazit v textu e-mailové zprávy, klepněte na položku Odeslat pouze aktivní zobrazení formuláře bez příloh.

    2. Chcete-li odeslat data formuláře jako přílohu e-mailové zprávy, klepněte na položku Odeslat data formuláře jako přílohu, zaškrtněte políčko Připojit šablonu formuláře, aby uživatelé mohli formulář otevřít a zadejte název formuláře do pole Název přílohy. Můžete rovněž vybrat pole nebo použít vzorec a zajistit tak jedinečnost názvu každého formuláře.

      Postup

      1. Klikněte na tlačítko Vložit vzorec Obrázek tlačítka .

      2. V dialogovém okně Vložit vzorec proveďte některou z následujících akcí:

        • Chcete-li ve vzorci použít pole, klepněte na položku Vložit pole nebo skupinu, vyberte pole, které chcete použít v dialogovém okně Vyberte pole nebo skupinu, a klepněte na tlačítko OK.

        • Chcete-li ve vzorci použít funkci, klepněte na položku Vložit funkci, vyberte funkci, kterou chcete použít v dialogovém okně Vložit funkci, a klepněte na tlačítko OK.

          Tip : Pokud funkce vyžaduje parametry, vyberte funkci v dialogovém okně Vložit funkci, klepněte na tlačítko OK a poté v dialogovém okně Vložit vzorec v poli Vzorec poklepejte na funkci, kterou jste přidali, a klepněte na pole nebo skupinu. Odkazy na další informace o funkcích naleznete v oddílu Viz také.

        • Chcete-li do vzorce vložit hodnotu nebo matematický operátor, zadejte hodnotu nebo symbol matematické operace do pole Vzorec.

      Operace

      Symbol

      Sčítání

      +

      Odečítání

      -

      Násobení

      *

      Dělení

      /

      • Poznámka : Pokud vzorec používá operátor dělení (/), ujistěte se, že před i za operátorem je mezera. Pokud nebude operátor dělení z obou stran oddělen mezerou, bude jej aplikace InfoPath považovat za oddělovač v umístění cesty XPath a nikoli za operátor dělení.

      • Chcete-li zkontrolovat syntaxi vzorce, v dialogovém okně Vložit vzorec klikněte na tlačítko Ověřit vzorec.

        Odkazy na články s dalšími informacemi o vzorcích naleznete v části Viz také.

      Poznámka : Uživatelé, kteří obdrží data formuláře jako přílohu e-mailové zprávy, budou moci tuto přílohu otevřít pouze tehdy, pokud mají v počítači nainstalovánu aplikaci InfoPath.

  7. Klepněte na tlačítko Další.

  8. Na další stránce průvodce zadejte do pole Zadejte název tohoto datového připojení popisný název tohoto datového připojení pro odesílání.

  9. Ověřte správnost informací v oddílu Shrnutí a klikněte na tlačítko Dokončit.

    1. Chcete-li změnit název tlačítka Odeslat, které se zobrazuje na panelu nástrojů Standardní a příkazu Odeslat, který se zobrazuje v nabídce Soubor, když uživatelé vyplní formulář, zadejte nový název do pole Titulek v dialogovém okně Možnosti odeslání.

      Tip : Pokud chcete k tomuto tlačítku a příkazu přiřadit klávesovou zkratku, zadejte znak ampersandu (&) před znak, který chcete použít jako klávesovou zkratku. Chcete-li k tlačítku a příkazu Odeslat přiřadit například klávesovou zkratku ALT+D, zadejte O&deslat.

  10. Pokud uživatelům při vyplňování formuláře nechcete povolit použití příkazu Odeslat ani tlačítka Odeslat na panelu nástrojů Standardní, zrušte zaškrtnutí políčka Zobrazit položku nabídky Odeslat a tlačítko Odeslat na panelu nástrojů.

    1. Ve výchozím nastavení zůstane formulář po odeslání otevřený a aplikace InfoPath zobrazí zprávu s informacemi o tom, zda byl formulář úspěšně odeslán. Jestliže chcete toto výchozí chování změnit, klepněte na tlačítko Upřesnit a proveďte jeden z následujících kroků:

      • Chcete-li po odeslání vyplněného formuláře uživatelem formulář zavřít nebo vytvořit nový prázdný formulář, klepněte na požadovanou možnost v rozevíracím seznamu Po odeslání.

      • Chcete-li vytvořit vlastní zprávu s informacemi o tom, zda byl formulář úspěšně odeslán, zaškrtněte políčko Použít vlastní zprávy a potom zadejte požadované zprávy do polí Při úspěchu a Při neúspěchu.

        Tip : Pomocí zprávy v poli Při neúspěchu uživatelům sdělte, co je třeba provést, pokud nelze formulář odeslat. Můžete uživatelům například navrhnout, aby uložili formulář a požádali o další pokyny jinou osobu.

      • Pokud nechcete, aby se po odeslání formuláře uživateli zobrazila zpráva, zrušte zaškrtnutí políčka Zobrazit zprávy o úspěšném nebo neúspěšném provedení.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×