Naplnění seznamu, rozevíracího seznamu nebo pole se seznamem hodnotami z databáze serveru SQL Server

Důležité informace:  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Do seznamu, rozevíracího seznamu nebo pole se seznamem lze načíst data z datového připojení dotazu k databázi Microsoft SQL Server.

V tomto článku

Základní informace

Než začnete

Krok 1: Přidání datového připojení dotazu

Krok 2: Nakonfigurujte ovládacího prvku

Přehled

Seznam, rozevírací seznam a pole se seznamem obsahuje položky, které může uživatel vybrat při vyplňování formuláře založeného na vaší šabloně formulářů. Tyto typy ovládacích prvků můžete nakonfigurovat tak, aby zobrazovaly data ze sekundárního datového připojení k databázi Microsoft SQL Server. Sekundární datové připojení je jakékoli datové připojení k externímu zdroji dat, které do šablony formulářů přidáte, aby mohli uživatelé, kteří vyplňují formuláře založené na této šabloně formulářů, získat data z externího zdroje dat (například webová služba) nebo je do tohoto zdroje odeslat.

Když přidáte sekundárního datového připojení, že získávání dat do šablony formuláře aplikace Microsoft Office InfoPath vytvoří sekundární Zdroj dat s datová pole a skupiny, které odpovídá tak, jak data uložena v databázi. Datové připojení dotazu získává data z webové služby a jejich ukládání v sekundární zdroj dat formuláře. Ve výchozím nastavení dat v sekundární zdroj dat neexistuje pouze během uživatelům připojení k síti. Můžete nakonfigurovat sekundárního datového připojení k uložení výsledků dotazu na počítačích vašich uživatelů, aby měli přístup k datům, když formuláře není připojený k síti.

Poznámka zabezpečení: Jestliže používáte sekundární datové připojení k načtení citlivých dat z externího zdroje dat nebo ze seznamu, možná budete chtít tuto funkci zakázat z důvodu ochrany dat před zneužitím v případě, že by došlo ke ztrátě nebo odcizení počítače. Pokud funkci zakážete, budou data dostupná pouze v době připojení uživatele k síti.

Vzhledem k tomu, že struktura dat v sekundárním zdroji dat musí odpovídat způsobu uložení dat v databázi, není možné měnit v sekundárním zdroji dat existující pole ani skupiny. Další informace o datových připojeních a datových zdrojích naleznete v části Viz také.

Začátek stránky

Než začnete

Před použitím hodnot z databáze serveru SQL Server k načtení do ovládacího prvku šablony formuláře je třeba získat od správce databáze následující informace:

  • Název serveru s databází, kterou budete s touto šablonou formuláře používat.

  • Název databáze, kterou budete s touto šablonou formuláře požívat.

  • Způsob ověřování požadovaný databází. Pro přístup uživatelů k databázi se používá ověřování systému Microsoft Windows nebo ověřování serveru SQL Server.

  • Název tabulky obsahující data, která chcete odeslat do formuláře. Jedná se o primární tabulku. Pokud chcete v databázi používat více tabulek, je třeba znát názvy těchto podřízených tabulek. Je také nutné znát názvy polí v podřízených tabulkách se vztahy k polím v primární tabulce.

  • Informace o tom, zda je možné bezpečně uložit výsledky dotazu v počítačích uživatelů pro použití v offline režimu.

Začátek stránky

Krok 1: Přidání datového připojení dotazu

Pokud nemáte existujícího datového připojení dotazu, které můžete použít v šabloně formuláře, přidání sekundárního datového připojení do šablony formuláře dotazů takto: Pokud šablona formuláře už sekundárního datového připojení, které můžete použít, můžete tuto část přeskočit a přejít na Krok 2: nakonfigurujte ovládací prvek.

  1. V nabídce Nástroje klikněte na příkaz Datová připojení.

  2. V dialogovém okně Datová připojení klikněte na tlačítko Přidat.

  3. V Průvodci datovým připojením klikněte na možnost Vytvořit nové připojení k, pokračujte kliknutím na příkaz Přijímat data a na tlačítko Další.

  4. Na první stránce průvodce klepněte na přepínač Databáze (pouze Microsoft SQL Server nebo Microsoft Office Access) a pak klepněte na tlačítko Další.

  5. Na další stránce průvodce klepněte na tlačítko Vybrat databázi.

  6. V dialogovém okně Vybrat zdroj dat klepněte na tlačítko Nový zdroj.

  7. V seznamu K jakému zdroji dat se chcete připojit? na další stránce průvodce klepněte na položku Microsoft SQL Server a potom klepněte na tlačítko Další.

  8. Do políčka Název serveru napište název serveru obsahujícího databázi SQL.

  9. Ve skupinovém rámečku Přihlašovací pověření proveďte některou z následujících akcí:

    • Jestliže databáze určuje, kdo má přístup na základě pověření, používaného v síti Microsoft Windows, klepněte na možnost Použít ověřování systému Windows.

    • Jestliže databáze určuje, kdo má přístup na základě určitého uživatelského jména a hesla získaného od správce databáze, klepněte na možnost Použít následující uživatelské jméno a heslo a potom napište své uživatelské jméno a heslo do políček Uživatelské jméno a Heslo.

  10. Klepněte na tlačítko Další.

  11. V seznamu Vyberte databázi obsahující požadovaná data klepněte na název databáze, kterou chcete používat. Zaškrtněte políčko Připojit ke konkrétní tabulce, klepněte na název primární tabulky a potom klepněte na tlačítko Další.

  12. Na další stránce průvodce zadejte do pole Název souboru název souboru, v němž jsou uloženy informace o datovém připojení. Nastavení uložíte klepnutím na tlačítko Dokončit.

    Jestliže budete v datovém připojení pro dotazy používat další tabulky, můžete je přidat na této stránce průvodce.

    Přidání dalších tabulek

    1. Klepněte na tlačítko Přidat tabulku.

    2. V dialogovém okně Přidat tabulku nebo dotaz klepněte na název podřízené tabulky a potom na tlačítko Další. V aplikaci InfoPath dojde k pokusu nastavit relace porovnáním názvů polí v obou tabulkách. Pokud nechcete použít navrženou relaci, vyberte ji a klepněte na tlačítko Odebrat relaci. Chcete-li relaci přidat, klepněte na tlačítko Přidat relaci. V dialogovém okně Přidat relaci klepněte na název každého souvisejícího pole v příslušném sloupci a potom klepněte na tlačítko OK.

    3. Klepněte na tlačítko Dokončit.

    4. Chcete-li přidat další podřízené tabulky, opakujte uvedené kroky.

  13. Klepněte na tlačítko Další.

  14. Chcete-li výsledky dotazu uložit se šablonou formuláře, zaškrtněte políčko Uložit kopii dat do šablony formuláře. Po zaškrtnutí tohoto políčka budou výsledky dotazu uloženy v šabloně formuláře. Vzhledem k tomu, že jsou data uložena v šabloně formuláře, budou uživatelům ve vyplňovaných formulářích k dispozici i v případě, že jejich počítače nejsou připojeny k síti.

    Poznámka zabezpečení: Zaškrtnutím tohoto políčka uložíte výsledky dotazu do šablony formuláře. Protože jsou data uložena v šabloně formuláře, jsou k dispozici ve formulářích, které uživatelé vyplňují, a to i v případě, že nemají počítače připojené k síti. Pokud z tohoto datového připojení získáváte citlivá data, budete pravděpodobně chtít tuto funkci zakázat a zabezpečit tak data pro případ ztráty nebo krádeže počítače.

  15. Klepněte na tlačítko Další.

  16. Na další stránce průvodce zadejte popisný název tohoto sekundárního datového připojení. Jestliže chcete, aby formulář při otevření načetl data automaticky, zaškrtněte políčko Automaticky načíst data při otevření formuláře.

Začátek stránky

Krok 2: Konfigurace ovládacího prvku

  1. Pokud šablona formuláře obsahuje více zobrazení, klikněte v nabídce Zobrazit na název zobrazení a tak přejděte na zobrazení obsahující ovládací prvek, ve kterém chcete zobrazit data ze sekundárního zdroje dat.

  2. Poklepejte na seznam, rozevírací seznam nebo pole se seznamem, do kterého chcete načíst hodnoty.

  3. Klepněte na kartu Data.

  4. V části Položky seznamu klepněte na možnost Vyhledat hodnoty z externího zdroje dat.

  5. V seznamu Zdroj dat klepněte na zdroj dat, který chcete použít.

  6. Klikněte na Vybrat výraz XPath  Vzhled tlačítka  vedle pole Položky.

  7. V dialogovém okně Vybrat pole nebo skupinu zadejte, jaká data se zobrazí uživateli a jaká data budou odeslána do externího zdroje dat, a to provedením jedné z následujících akcí.

    Zadejte data, která se uživateli zobrazí jsou stejná data, která uživatel odešle

    • Klepněte na pole a potom klepněte na tlačítko OK.

    Zadejte data, která se uživateli zobrazí se liší od data, která uživatel odešle

    Poznámka: V tomto scénáři data, která se uživateli zobrazí, pocházejí z jednoho z polí ve skupině a data, která uživatel odešle, jsou v jiném poli ve stejné skupině.

    1. Klepněte na skupinu a potom klepněte na tlačítko OK.

    2. V dialogovém okně Vlastnosti ovládacího prvku klikněte na Vybrat výraz XPath Vzhled tlačítka vedle pole hodnoty.

    3. V dialogovém okně Vybrat pole nebo skupinu klepněte na pole obsahující data, která uživatel odešle do externího zdroje dat, a potom klepněte na tlačítko OK.

    4. V dialogovém okně Vlastnosti ovládacího prvku klikněte na Vybrat výraz XPath Vzhled tlačítka vedle pole Zobrazovaný název.

    5. V dialogovém okně Vybrat pole nebo skupinu klepněte na pole obsahující data, která se zobrazí v ovládacím prvku, a potom klepněte na tlačítko OK.

  8. Pokud pole v poli Zobrazovaný název obsahuje hodnoty s podobnými zobrazovanými názvy a chcete zobrazit pouze jedinečné názvy, zaškrtněte políčko Zobrazit pouze položky s jedinečnými zobrazovanými názvy.

Začátek stránky

Poznámka: Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×