NE (funkce)

Funkci NE – jednu z logických funkcí – použijte tehdy, pokud se chcete ujistit, že jedna hodnota se nerovná druhé.

Příklad

Příklady použití funkce NE k převrácení argumentů  NAPŘ. =NE(1+1=2)

Funkce NE neguje hodnotu argumentu funkce.

Jedním z obvyklých způsobů použití funkce NE je rozšíření užitečnosti jiných funkcí provádějících logické testy. Funkce KDYŽ například provede logický test a vrátí jednu hodnotu, pokud je test vyhodnocen jako PRAVDA, a jinou hodnotu, pokud je test vyhodnocen jako NEPRAVDA. Pokud použijete funkci NE jako argument typu podmínka funkce KDYŽ, můžete namísto jedné podmínky testovat několik různých podmínek.

Syntaxe

NE(loghod)

Syntaxe funkce NE obsahuje následující argumenty:

  • Loghod:    Povinný argument. Jedná se o hodnotu nebo výraz, který může být vyhodnocen jako PRAVDA nebo NEPRAVDA.

Poznámky

Pokud je argument loghod NEPRAVDA, funkce NE vrátí PRAVDA. Pokud je argument loghod PRAVDA, funkce NE vrátí NEPRAVDA.

Příklady

Tady je několik obecných příkladů použití funkce NE jako samostatné funkce a ve spojení s funkcemi KDYŽ, A a NEBO.

Příklady funkce NE s funkcemi KDYŽ, A a NEBO

Vzorec

Popis

= NE(A2>100)

A2 NENÍ větší než 100

=KDYŽ(A(NE(A2>1);NE(A2<100));A2; "Hodnota je mimo interval")

50 je větší než 1 (PRAVDA) A 50 je menší než 100 (PRAVDA), takže funkce NE neguje oba argumenty na NEPRAVDA. Funkce A vyžaduje, aby oba argumenty měly hodnotu PRAVDA, takže vrátí výsledek NEPRAVDA.

=KDYŽ(NEBO(NE(A3<0);NE(A3>50));A3;"Hodnota je mimo interval")

100 není menší než 0 (NEPRAVDA) a 100 je větší než 50 (PRAVDA), takže funkce NE neguje oba argumenty na PRAVDA/NEPRAVDA. Funkce NEBO vyžaduje hodnotu PRAVDA jenom u jednoho argumentu, takže vrátí výsledek PRAVDA.

Výpočet provize z prodeje

Tady je vcelku běžný scénář, kdy je potřeba vypočítat, jestli má pracovník prodeje nárok na odměnu, pomocí funkce NE spolu s funkcemi KDYŽ a A.

Příklad výpočtu odměny za prodej pomocí funkcí KDYŽ, A a NE.  Vzorec v buňce E14 je =KDYŽ(A(NE(B14<$B$7);NE(C14<$B$5));B14*$B$8;0)
  • =KDYŽ(A(NE(B14<$B$7);NE(C14<$B$5));B14*$B$8;0)KDYŽ celkový objem prodeje NENÍ menší než cílový objem prodeje A počet zákazníků NENÍ menší než cílový počet zákazníků, potom vynásob celkový objem prodejů výší (%) provize, jinak vrať hodnotu 0.

Potřebujete další pomoc?

Kdykoli se můžete zeptat některého odborníka v technické komunitě Excelu, získat podporu v komunitě pro odpovědi, případně navrhnout novou funkci nebo vylepšení ve fóru Excel User Voice.

Příbuzná témata

Video: Pokročilé funkce KDYŽ
Naučte se, jak používat ve vzorcích vnořené funkce
Funkce KDYŽ
Funkce A
Funkce NEBO
Přehled vzorců v Excelu
Jak se vyhnout nefunkčním vzorcům
Oprava chyb ve vzorcích pomocí kontroly chyb
Klávesové zkratky v Excelu 2016 pro Windows
Klávesové zkratky v Excelu 2016 pro Mac
Logické funkce (odkazy)
Funkce aplikace Excel (podle abecedy)
Funkce aplikace Excel (podle kategorie)

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×