Návrh šablony formuláře založené na databázi serveru Microsoft SQL Server

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Můžete navrhnout šablonu formuláře, která bude používat databázi serveru Microsoft SQL Server buď pro zadávání dotazů na data, nebo pro zadávání dotazů i odesílání dat.

V tomto článku

Základní informace

Důležité informace o kompatibilitě

Než začnete

Návrh šablony formuláře

Konfigurace možností odeslat

Přehled

Formulář může obsahovat jedno primární datové připojení (označované jako hlavní datové připojení) a také jedno či více sekundárních datových připojení. V závislosti na cílech formuláře mohou být prostřednictvím datového připojení zadávány dotazy na data formuláře nebo odesílána data formuláře do externího zdroje dat, jakým je například databáze serveru Microsoft SQL Server nebo webová služba.

Při návrhu šablony formuláře, který je založený na databáze aplikace Microsoft Office InfoPath vytvoří hlavní Zdroj dat skupinám, které obsahují pole dotazu a datová pole a datového připojení dotazu jako hlavní datové připojení pro šablonu formuláře. Tato pole a skupiny odpovídají způsobu uložení dat v tabulkách v databázi. Pole dotazu s daty zadané uživatelem, chcete-li omezit výsledky dotazu na záznamy, které odpovídají data v polích dotazu. Pokud formuláře založené na této šabloně používá hlavní datové připojení, InfoPath vytvoří dotaz pomocí data v polích dotazu. InfoPath pošle dotaz prostřednictvím datového připojení dotazu. Databáze vrátí výsledek dotazu zpátky do formuláře prostřednictvím datového připojení dotazu. Výsledky dotazu se budou zobrazovat do datových polí, které lze upravovat pomocí ovládacích prvků, které jsou vázaný na těchto polí.

Pole nebo skupiny v hlavním zdroji dat není možné měnit, protože datová struktura dotazu a datová pole musí odpovídat způsobu uložení dat v databázi. V hlavním zdroji dat lze pouze přidávat pole nebo skupiny do kořenové skupiny. Odkazy na další informace týkající se zdrojů dat naleznete v části Viz také.

Data z formuláře je možné odeslat do databáze pomocí hlavního datového připojení formuláře, pokud databáze i šablona formuláře, na které je formulář založen, splňují následující požadavky:

  • Šablona formuláře není šablony formuláře kompatibilní s prohlížečem    InfoPath nevytvoří datové připojení pro odesílání hlavní datové připojení, pokud jsou návrhem šablony formuláře kompatibilní s prohlížečem. Pokud chcete povolit uživatelům odeslat data ve formátu, který je založený na šabloně formuláře kompatibilní s prohlížečem, pomocí webové služby, které funguje s databází.

  • Levá tabulka v každou dvojici souvisejících tabulek v hlavní zdroj dat obsahuje primárního klíče    Nejméně jeden relací pro každou dvojici souvisejících tabulek musí obsahovat primární klíč z levá tabulka.

  • Žádná datová pole ve zdroji dat hlavní formulář úložiště velké binární datový typ.    Aplikace InfoPath zakáže datové připojení pro odesílání, pokud dotaz obsahuje pole, která mohou být uloženy velké binární datový typ, například obrázky, obrázky, objekty OLE, příloh, datový typ memo Office Access nebo datový typ SQL Text.

Pokud aplikace InfoPath povolí datové připojení pro odesílání, mohou uživatelé odesílat data v datových polích v hlavním datovém zdroji do databáze. Povolí-li aplikace InfoPath datové připojení pro odesílání, je možné upravit možnosti odeslání pro formuláře založené na této šabloně formuláře.

Začátek stránky

Aspekty kompatibility:

Navrhujete-li šablonu formuláře založenou na databázi, existuje možnost vytvořit návrh Šablona formuláře kompatibilní s prohlížečem. Aplikace InfoPath vytvoří datové připojení pro dotazy jako hlavní datové připojení pro šablonu formuláře kompatibilní s prohlížeči. Šablony formuláře kompatibilní s prohlížeči ovšem není možné konfigurovat tak, aby umožnily uživatelům odesílání dat do databáze. Jestliže tedy navrhujete šablonu formuláře založenou na databázi serveru SQL Server a přejete si, aby uživatelé prostřednictvím hlavního datového připojení odesílali formulářová data do databáze, nemůžete tuto šablonu formuláře nastavit jako kompatibilní s prohlížečem.

Začátek stránky

Než začnete

Pokud navrhujete šablonu formuláře založenou na databázi serveru SQL Server, bude třeba od správce databáze získat následující informace:

  • Název serveru obsahujícího databázi, ke které budete připojovat šablonu formuláře.

  • Název databáze, kterou budete s touto šablonou formuláře používat.

  • Způsob ověřování požadovaný databází; pro přístup uživatelů k databázi se používá ověřování systému Microsoft Windows, nebo ověřování serveru SQL Server.

  • Název tabulky obsahující data, která chcete odesílat do formuláře, případně název tabulky, která bude přijímat data z formuláře. Jedná se o primární tabulku. Pokud budete v databázi používat více tabulek, je třeba znát názvy podřízených tabulek. Je také nutné znát názvy polí v podřízených tabulkách, které mají vazbu na pole primární tabulky.

Začátek stránky

Návrh šablony formuláře

Chcete-li navrhnout šablonu formuláře s datovým připojením pro dotazy, proveďte následující kroky:

  1. Vytvoření šablony formuláře    Pokud navrhujete šablonu formuláře založenou na databázi, aplikace InfoPath vytvoří jako hlavní datové připojení mezi šablonou formuláře a databází datové připojení pro dotazy. Tento proces automaticky vytvoří pro šablonu formuláře hlavní zdroj dat.

  2. Přidání jednoho nebo více ovládacích prvků a zobrazení výsledků dotazu    Umožňuje uživatelům zobrazit a upravit data pole v hlavním zdroji dat při otevření formuláře můžete přidat ovládacího prvku do šablony formuláře a potom ovládací prvek svázán s polem ve zdroji dat hlavní.

Krok 1: Vytvoření šablony formuláře

  1. V nabídce Soubor klikněte na příkaz Navrhnout šablonu formuláře.

  2. V dialogovém okně Navrhnout šablonu formuláře v oddílu Navrhnout nový zaškrtněte políčko Šablona formuláře.

  3. V seznamu Založený na klepněte na možnost Databáze.

  4. Jestliže navrhujete šablonu formuláře kompatibilní s prohlížečem, zaškrtněte políčko Povolit pouze funkce kompatibilní s prohlížečem.

    Poznámka : Průvodce datovým připojením nepovolí v šabloně formuláře kompatibilní s prohlížeči datové připojení pro odesílání. Přidáním sekundárního datového připojení k webové službě spolupracující s databází umožníte uživatelům odesílání dat z formulářů založených na šabloně formuláře kompatibilní s prohlížeči do databáze. Odkazy na další informace o sekundárních datových připojeních naleznete v části Viz také.

  5. Klepněte na tlačítko OK.

  6. V průvodci datovým připojením klepněte na možnost Vybrat databázi.

  7. V dialogovém okně Vybrat zdroj dat klepněte na tlačítko Nový zdroj.

  8. V seznamu K jakému zdroji dat se chcete připojit? klepněte na položku Microsoft SQL Server a potom klepněte na tlačítko Další.

  9. Do pole Název serveru napište název serveru obsahujícího databázi serveru SQL Server.

  10. V části Přihlašovací pověření proveďte jednu z následujících akcí:

    • Jestliže databáze určuje, kdo má přístup na základě pověření, používaného v síti Microsoft Windows, klepněte na možnost Použít ověřování systému Windows.

    • Jestliže databáze určuje, kdo má přístup na základě určitého uživatelského jména a hesla získaného od správce databáze, klepněte na možnost Použít následující uživatelské jméno a heslo a potom napište své uživatelské jméno a heslo do políček Uživatelské jméno a Heslo.

  11. Klepněte na tlačítko Další.

  12. V seznamu Vyberte databázi obsahující požadovaná data klepněte na název databáze, kterou chcete používat. Zaškrtněte políčko Připojit ke konkrétní tabulce, klepněte na název primární tabulky a potom klepněte na tlačítko Další.

  13. Na další stránce průvodce zadejte do pole Název souboru jméno souboru, v němž jsou uloženy informace o připojení. Nastavení uložíte klepnutím na tlačítko Dokončit.

    Jestliže budete v datovém připojení pro dotazy používat další tabulky, můžete je přidat na této stránce průvodce.

    Postup

    1. Klepněte na tlačítko Přidat tabulku.

    2. V dialogovém okně Přidat tabulku nebo dotaz klepněte na název podřízené tabulky a potom na tlačítko Další. V aplikaci InfoPath dojde k pokusu nastavit relace porovnáním názvů polí v obou tabulkách. Pokud nechcete použít navrženou relaci, vyberte ji a klepněte na tlačítko Odebrat relaci. Chcete-li relaci přidat, klepněte na tlačítko Přidat relaci. V dialogovém okně Přidat relaci klepněte na název každého souvisejícího pole v příslušném sloupci a potom klepněte na tlačítko OK.

    3. Klepněte na tlačítko Dokončit.

    4. Chcete-li přidat další podřízené tabulky, opakujte uvedené kroky.

  14. Klepněte na tlačítko Další.

  15. Na poslední stránce průvodce zadejte název datového připojení. Tento název se zobrazí v seznamu zdroje dat v podokně úloh Zdroj dat.

  16. Pokud šablony formuláře splňuje požadavky na v části základní informace , tato stránka průvodce výskyt znamená, že aplikace InfoPath povolená datového připojení pro odesílání hlavní datové připojení. Pokud chcete změnit název datového připojení pro odesílání, zadejte nový název do příslušného okna. Pokud chcete uživatelům umožnit odesílání že dat formuláře do druhého odeslat datové připojení, které přidáte do šablony formuláře později, klikněte na zrušte zaškrtnutí políčka Povolit odesílání u tohoto připojení.

    Poznámka : Pokud šablona formuláře nesplňuje požadavky v části Přehled , aplikace InfoPath zakáže datové připojení pro odesílání a textového pole Zadejte název připojení pro odesílání a zaškrtněte políčko Povolit odesílání u tohoto připojení jsou dostupné (budou zakázané). Pokud aplikace InfoPath zakáže datové připojení pro odesílání, bude mít datového připojení pro šablonu formuláře dotazu datové připojení.

Krok 2: Přidání jednoho nebo více ovládacích prvků a zobrazení výsledků dotazu

  1. Pokud není vidět podokno úloh Ovládací prvky, klikněte na Další ovládací prvky v nabídce Vložit nebo stiskněte klávesy ALT+I, C.

  2. Přetáhněte ovládací prvek do šablony formuláře.

  3. V dialogovém okně Vazba ovládací prvek vyberte skupinu nebo pole, které mají být ovládací prvek vázat.

Začátek stránky

Konfigurace možností odeslání

Pokud vaše šablona formuláře a tabulky, které jste vybrali v Průvodci datovým připojením požadavkům v části základní informace , aplikace InfoPath konfiguruje šablony formuláře odešlete data prostřednictvím datového připojení. Pokud se rozhodnete sdělit nám to datové připojení pro odesílání, InfoPath nakonfiguruje šablony formuláře tak, aby uživatelé mohli odesílat dat do databáze a přidá tlačítko Odeslat na panelu nástrojů Standardní a příkaz Odeslat nabídky soubor při vyplňování formuláře. Aplikace InfoPath také nakonfiguruje šablona formuláře tak, aby při uživatelé odesílat formuláře, zůstal tento formulář otevřený a zobrazí se zpráva s uživateli, který označuje, zda byla úspěšně odeslání formuláře. Můžete změnit text na tlačítko Odeslat a chování po odeslání formuláře.

  1. V nabídce Nástroje klikněte na Možnosti odeslání.

    1. Chcete-li změnit název tlačítka Odeslat, které se zobrazuje na panelu nástrojů Standardní, a příkazu Odeslat, který se zobrazuje v nabídce Soubor, když uživatelé vyplní formulář, zadejte nový název do pole Titulek v dialogovém okně Možnosti odeslání.

      Tip : Pokud chcete k tomuto tlačítku a příkazu přiřadit klávesovou zkratku, zadejte znak ampersandu (&) před znak, který chcete použít jako klávesovou zkratku. Chcete-li k tlačítku a příkazu Odeslat přiřadit například klávesovou zkratku ALT+D, zadejte O&deslat.

  2. Pokud uživatelům při vyplňování formuláře nechcete povolit použití příkazu Odeslat ani tlačítka Odeslat na panelu nástrojů Standardní, zrušte zaškrtnutí políčka Zobrazit položku nabídky Odeslat a tlačítko Odeslat na panelu nástrojů.

    1. Ve výchozím nastavení zůstane formulář po odeslání otevřený a aplikace InfoPath zobrazí zprávu s informacemi o tom, zda byl formulář úspěšně odeslán. Jestliže chcete toto výchozí chování změnit, klikněte na tlačítko Upřesnit a proveďte jeden z následujících kroků:

      • Chcete-li po odeslání vyplněného formuláře uživatelem formulář zavřít nebo vytvořit nový prázdný formulář, klikněte na požadovanou možnost v rozevíracím seznamu Po odeslání.

      • Chcete-li vytvořit vlastní zprávu s informacemi o tom, zda byl formulář úspěšně odeslán, zaškrtněte políčko Použít vlastní zprávy a potom zadejte požadované zprávy do polí Při úspěchu a Při neúspěchu.

        Tip : Pomocí zprávy v poli Při neúspěchu uživatelům sdělte, co je třeba provést, pokud nelze formulář odeslat. Můžete uživatelům například navrhnout, aby uložili formulář a požádali o další pokyny jinou osobu.

      • Pokud nechcete, aby se po odeslání formuláře uživateli zobrazila zpráva, zrušte zaškrtnutí políčka Zobrazit zprávy o úspěšném nebo neúspěšném provedení.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×