Návrh šablony formuláře, který je založený na databáze aplikace Microsoft Access

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Můžete navrhnout šablonu formuláře aplikace Microsoft Office InfoPath, se kterými spolupracuje databáze aplikace Microsoft Office Access pro dotazy na data, nebo k vytváření dotazů a odeslat data. Můžete navrhovat tuto šablonu formuláře založené na databázi Microsoft Office Access 2007 (ACCDB) nebo Accessové databáze uložená ve formátu starší verze (MDB).

V tomto článku

Základní informace

Důležité informace o kompatibilitě

Než začnete

Návrh šablony formuláře

Konfigurace možností odeslat

Přehled

Formulář může obsahovat jedno primární datové připojení, s názvem hlavní datové připojení a toto připojení můžete volitelně mají jeden nebo více sekundárního datového připojení. Hlavní datové připojení můžete k dotazu nebo odeslání dat formuláře do databáze aplikace Access. Můžete taky sekundárního datového připojení k vytváření dotazů a odeslání dat k externím zdrojům dat, s určitými výjimkami. Můžete třeba sekundárního datového připojení k Accessové databázi tak, aby jenom dotazu na databázi. Sekundárního datového připojení nelze přidat do formuláře, která odešle adresář dat formuláře do databáze aplikace Access.

Když návrh šablony formuláře, který je založený na databáze aplikace Access aplikace InfoPath vytvoří hlavní Zdroj dat do skupin, které obsahují pole dotazu a datových polí a také vytvoří datové připojení dotazu jako hlavní datové připojení pro šablonu formuláře. Tato pole a skupiny odpovídají způsobu uložení dat v tabulkách v databázi.

Pole dotazu obsahují data, která je zadá do formuláře uživatel omezení výsledků dotazu na záznamy, které odpovídají data v polích dotazu. Pokud formulář, který je založený na této šabloně používá hlavní datové připojení, InfoPath vytvoří dotaz pomocí data v polích dotazu. InfoPath pošle dotazu prostřednictvím datového připojení. Databáze vrátí výsledek dotazu zpátky na formuláři prostřednictvím datového připojení. Výsledky dotazu se budou zobrazovat do datových polí, které se dají upravovat pomocí ovládacích prvků ve formuláři svázané příslušných polích data.

Pole nebo skupiny v hlavním zdroji dat není možné měnit, protože datová struktura dotazu a datová pole musí odpovídat způsobu uložení dat v databázi. V hlavním zdroji dat lze pouze přidávat pole nebo skupiny do kořenové skupiny. Odkazy na další informace týkající se zdrojů dat naleznete v části Viz také.

Data z formuláře je možné odeslat do databáze pomocí hlavního datového připojení formuláře, pokud databáze i šablona formuláře, na které je formulář založen, splňují následující požadavky:

  • Šablona formuláře není šablony formuláře kompatibilní s prohlížečem    InfoPath nevytvoří datové připojení pro odesílání hlavní datové připojení, pokud jsou návrhem šablony formuláře kompatibilní s prohlížečem. Pokud chcete povolit uživatelům odeslat data ve formátu, který je založený na šabloně formuláře kompatibilní s prohlížečem, pomocí webové služby, se kterými spolupracuje databáze.

  • Levá tabulka v každou dvojici souvisejících tabulek v hlavní zdroj dat obsahuje primárního klíče    Nejméně jeden relací pro každou dvojici souvisejících tabulek musí obsahovat primární klíč z levá tabulka.

  • Žádná datová pole v hlavním zdroji dat formuláře úložiště velké binární datový typ.    Aplikace InfoPath zakáže datové připojení pro odesílání, pokud dotaz obsahuje pole, která mohou být uloženy velké binární datový typ, například obrázky, obrázky, objekty OLE, příloh, datový typ memo Office Access nebo datový typ SQL Text.

Pokud aplikace InfoPath povolí datové připojení pro odesílání, mohou uživatelé můžou odeslat data, která je uložena v datových polí do hlavního zdroje dat do databáze. Můžete přizpůsobit možnosti odeslání formuláře založené na této šabloně.

Začátek stránky

Aspekty kompatibility:

Nelze návrh šablony formuláře kompatibilní s prohlížečem podle databáze aplikace Access.

Začátek stránky

Než začnete

Před můžete úspěšně navrhnout šablonu formuláře, který je založený na databáze aplikace Access, musíte tyto informace o databáze aplikace Access:

  • Název a umístění databáze.

    Poznámka : Zajistěte, aby byl databáze v umístění v síti, která se mají uživatelé přístup.

  • Název tabulky, která se zobrazí odeslat data, pokud šablony formuláře mohou uživatelé odeslat formuláře tak, aby databázi. Při konfiguraci datového připojení pro odesílání, použije v této tabulce jako primární tabulky.

  • Název tabulky, z něhož pochází výsledků dotazu poslané na databázi, pokud šablony formuláře se jenom dotazy do databáze. V této tabulce použije jako primární tabulky při konfiguraci dotazu datové připojení.

  • Názvy jiných vyžadujících primární tabulky data z tabulek. Ve většině případů jsou už povolili relací mezi tabulkami v databázi. Pokud potřebujete k vytvoření relace mezi primární tabulky a druhou tabulku ručně, budete potřebovat názvy souvisejících polí z obou tabulek.

Začátek stránky

Návrh šablony formuláře

Návrh šablony formuláře s datovým připojením dotazu, musíte nejdřív vytvořit šablonu formuláře. Při vytváření šablony formuláře, který je založený na databázi aplikace InfoPath vytvoří datové připojení dotazu jako datového připojení mezi šabloně formuláře a databází. Tento proces automaticky vytvoří šablony formuláře hlavní zdroj dat.

Po vytvoření šablony formuláře, potřebujete přidat ovládací prvek k šabloně formuláře a potom ovládací prvek svázán s polem ve zdroji dat hlavní. To umožňuje uživatelům zobrazit výsledky dotazu ve formuláři.

Krok 1: Vytvoření šablony formuláře

  1. V nabídce Soubor klikněte na příkaz Navrhnout šablonu formuláře.

  2. V dialogovém okně Navrhnout šablonu formuláře zaškrtněte ve skupinovém rámečku Navrhnout nový, Šablona formuláře.

  3. V seznamu na základě klikněte na databázi a klikněte na OK.

    Spustí se Průvodce datovým připojením

  4. Na první stránce Průvodce datovým připojením klikněte na Vybrat databázi.

  5. V dialogovém okně Vybrat zdroj dat přejděte k umístění vaší databáze.

    Poznámka : Pokud je databáze uložená v umístění v síti, přejděte na cestu konvence UNC uvedeném místě. Není přejděte do umístění v síti prostřednictvím síťovou jednotku. Pokud používáte síťovou jednotku, uživatelé, kteří vytvářejí formuláře založené na této šabloně vyhledá tuto databázi síťovou jednotku. Pokud uživatel nemá síťovou jednotku, formuláři nenajde databáze.

  6. Klikněte na název databáze a pak klikněte na Otevřít.

  7. V dialogovém okně Vybrat tabulku klikněte na primární tabulka nebo dotaz, který chcete použít a klikněte na OK.

  8. Na další stránce průvodce zaškrtněte políčko Zobrazit sloupce tabulky.

  9. Ve výchozím nastavení všech polí v tabulce se přidá do hlavního zdroje dat šablony formuláře. Zrušte zaškrtnutí políček u polí, která nechcete zahrnout do hlavního zdroje dat.

    Přidáte další tabulky nebo dotazy, které chcete použít v dotazu datové připojení.

    Postup

    1. Klepněte na tlačítko Přidat tabulku.

    2. V dialogovém okně Přidat tabulku nebo dotaz klepněte na název podřízené tabulky a potom na tlačítko Další. V aplikaci InfoPath dojde k pokusu nastavit relace porovnáním názvů polí v obou tabulkách. Pokud nechcete použít navrženou relaci, vyberte ji a klepněte na tlačítko Odebrat relaci. Chcete-li relaci přidat, klepněte na tlačítko Přidat relaci. V dialogovém okně Přidat relaci klepněte na název každého souvisejícího pole v příslušném sloupci a potom klepněte na tlačítko OK.

    3. Klepněte na tlačítko Dokončit.

    4. Chcete-li přidat další podřízené tabulky, opakujte uvedené kroky.

  10. Klepněte na tlačítko Další.

  11. Na poslední stránce průvodce zadejte název datového připojení. Tento název se zobrazí v seznamu Zdroj dat umístěném v podokně úloh Zdroj dat.

  12. Pokud šablona formuláře splňuje požadavky na v části Přehled , části Souhrn na této stránce Průvodce označuje, že aplikace InfoPath povoleno datové připojení pro odesílání hlavní datové připojení.

  13. Pokud chcete změnit název datového připojení pro odesílání, zadejte nový název do příslušného okna.

  14. Pokud chcete povolit uživatelům odesílání že dat formuláře do druhého odeslat datové připojení, které přidáte do šablony formuláře později, zrušte zaškrtnutí políčka Povolit odesílání u tohoto připojení.

    Poznámka : Pokud šablony formuláře nesplňuje požadavky v části Přehled , aplikace InfoPath zakáže datové připojení pro odesílání a zadejte název připojení pro odesílání a zaškrtněte políčko Povolit odesílání u tohoto připojení nejsou k dispozici. Hlavní datové připojení pro šablonu formuláře aplikace InfoPath zakáže datové připojení pro odesílání, bude obsahovat pouze datového připojení dotazu.

Krok 2: Svázání ovládacího prvku s polem

  1. Pokud není vidět podokno úloh Ovládací prvky, klikněte na Další ovládací prvky v nabídce Vložit nebo stiskněte klávesy ALT+I, C.

  2. Přetáhněte ovládací prvek do šablony formuláře.

  3. V dialogovém okně Vazba ovládacího prvku vyberte pole, které mají být ovládací prvek vázat.

Začátek stránky

Konfigurace možností odeslání

Pokud vaše šablona formuláře a tabulky, které jste vybrali v Průvodci datovým připojením požadavkům v části Přehled , nakonfiguruje InfoPath šablony formuláře do odesílání dat pomocí datového připojení.

Pokud se rozhodnete sdělit nám to datové připojení pro odesílání, InfoPath nakonfiguruje šablony formuláře tak, aby uživatelé mohli odesílat dat do databáze a taky přidá tlačítko Odeslat na panelu nástrojů Standardní a příkaz Odeslat do nabídky soubor ve formuláři. Aplikace InfoPath také nastaví na šablonu formuláře tak, že když uživatelé odesílat formuláře, zůstal tento formulář otevřený a zobrazí se zpráva, která označuje, zda byla úspěšně odeslání formuláře. Můžete změnit text, který se zobrazí na tlačítko Odeslat a taky změnit chování formuláře po odeslání.

  1. V nabídce Nástroje klikněte na Možnosti odeslání.

    1. Chcete-li změnit název tlačítka Odeslat, které se zobrazuje na panelu nástrojů Standardní, a příkazu Odeslat, který se zobrazuje v nabídce Soubor, když uživatelé vyplní formulář, zadejte nový název do pole Titulek v dialogovém okně Možnosti odeslání.

      Tip : Pokud chcete k tomuto tlačítku a příkazu přiřadit klávesovou zkratku, zadejte znak ampersandu (&) před znak, který chcete použít jako klávesovou zkratku. Chcete-li k tlačítku a příkazu Odeslat přiřadit například klávesovou zkratku ALT+D, zadejte O&deslat.

  2. Pokud uživatelům při vyplňování formuláře nechcete povolit použití příkazu Odeslat ani tlačítka Odeslat na panelu nástrojů Standardní, zrušte zaškrtnutí políčka Zobrazit položku nabídky Odeslat a tlačítko Odeslat na panelu nástrojů.

    1. Ve výchozím nastavení zůstane formulář po odeslání otevřený a aplikace InfoPath zobrazí zprávu s informacemi o tom, zda byl formulář úspěšně odeslán. Jestliže chcete toto výchozí chování změnit, klikněte na tlačítko Upřesnit a proveďte jeden z následujících kroků:

      • Chcete-li po odeslání vyplněného formuláře uživatelem formulář zavřít nebo vytvořit nový prázdný formulář, klikněte na požadovanou možnost v rozevíracím seznamu Po odeslání.

      • Chcete-li vytvořit vlastní zprávu s informacemi o tom, zda byl formulář úspěšně odeslán, zaškrtněte políčko Použít vlastní zprávy a potom zadejte požadované zprávy do polí Při úspěchu a Při neúspěchu.

        Tip : Pomocí zprávy v poli Při neúspěchu uživatelům sdělte, co je třeba provést, pokud nelze formulář odeslat. Můžete uživatelům například navrhnout, aby uložili formulář a požádali o další pokyny jinou osobu.

      • Pokud nechcete, aby se po odeslání formuláře uživateli zobrazila zpráva, zrušte zaškrtnutí políčka Zobrazit zprávy o úspěšném nebo neúspěšném provedení.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×