Modely prvků rozhraní systému Windows XP

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Šablona Uživatelské rozhraní Windows XP slouží k vytvoření modelů uživatelského rozhraní s obrazci vytvořenými podle vodítek systému Microsoft Windows XP. Obrazce zahrnují prvky běžně používané v rozhraních, například prázdný formulář pro základ okna aplikace, stránky průvodce, obrazce panelů nástrojů a nabídek a obrazce prvků.

Pomocí těchto obrazců provádět všechny položky od modelu složitého okna aplikace nebo dialogové okno s kartami simple zprávou nebo jednoho tlačítka.

Co chcete udělat?

Vytvořit jediné dialogové okno

Vytvoření dialogového okna s kartami

Vytvoření okna aplikace

Vytvořit nabídky a panely nástrojů

Vytvoření jediného dialogového okna

  1. Ze vzorníku Okna a dialogová okna přetáhněte na stránku výkresu obrazec Prázdný formulář.

  2. Vyberte obrazec a zadejte název dialogového okna.

  3. Přetáhněte na pravou stranu záhlaví obrazec Tlačítka systému Windows a vyberte typ tlačítka. Obvykle je na pravé straně záhlaví okna umístěno vpravo tlačítko Zavřít a vlevo tlačítko Nápověda.

  4. Do pravého spodního rohu obrazce Prázdný formulář přidejte příkazová tlačítka, například OK, Storno a Použít.

    how

    1. Do pravého spodního rohu obrazce Prázdný formulář přetáhněte ze vzorníku Běžné ovládací prvky obrazce Příkazové tlačítko.

    2. Vždy vyberte tlačítko a zadejte jeho název.

  5. Přetáhněte na obrazec Prázdný formulář požadované ovládací prvky. Vždy klepněte na obrazec pravým tlačítkem myši a zvolte požadované možnosti.

    Chcete-li zobrazit nápovědu ke konkrétnímu obrazci ovládacího prvku, klepněte na něj pravým tlačítkem myši a klepněte na příkaz Nápověda.

    Pokud pro zadávání vlastního textu na obrazci Prázdný formulář použijete nástroj Text, formátujte text jako Tahoma 8 bodů.

  6. Seskupte příkazy do logických skupin.

  7. Chcete-li vizuálně oddělit skupiny příkazů, přetáhněte na obrazec Prázdný formulář obrazce Skupinová čára a Skupinový rámeček.

    Pro zarovnání ovládacích prvků použijte vodítka.

    Jako vhodný příklad dialogového okna obsahujícího řadu běžných prvků dialogového okna lze uvést dialogové okno Tisk v nabídce Soubor.

Začátek stránky

Vytvoření dialogového okna s kartami

  1. Ze vzorníku Okna a dialogová okna přetáhněte na stránku výkresu obrazec Prázdný formulář.

  2. Vyberte obrazec a zadejte název dialogového okna.

  3. Přetáhněte na pravou stranu záhlaví obrazec Tlačítka systému Windows a vyberte typ tlačítka. Obvykle je na pravé straně záhlaví okna umístěno vpravo tlačítko Zavřít a vlevo tlačítko Nápověda.

  4. Do pravého spodního rohu obrazce Prázdný formulář přidejte příkazová tlačítka, například OK, Storno a Použít.

    how

    1. Do pravého spodního rohu obrazce Prázdný formulář přetáhněte ze vzorníku Běžné ovládací prvky obrazce Příkazové tlačítko.

    2. Vždy vyberte tlačítko a zadejte jeho název.

  5. Na obrazec Prázdný formulář přetáhněte obrazec Ovládací prvek Karta (tělo) a nastavte jeho velikost uvnitř formuláře tak, aby ve formuláři zůstalo místo na jednotlivé karty.

  6. Přetáhněte na stránku výkresu obrazec Ovládací prvek Karta (karty) a připevněte ho k hornímu okraji obrazce Ovládací prvek Karta (tělo).

  7. Vyberte obrazec Ovládací prvek Karta (karty) a zadejte název karty.

  8. Opakujte kroky 6 a 7 pro jednotlivé karty a připevněte je jak k sobě navzájem, tak také k obrazci Ovládací prvek Karta (tělo).

  9. Pravým tlačítkem myši klepněte na kartu, kterou chcete zobrazit v popředí, klepněte na příkaz Karta v popředí a u ostatních karet nastavte možnost Karta v pozadí.

  10. Přetáhněte na obrazec Prázdný formulář požadované ovládací prvky. Vždy klepněte na obrazec pravým tlačítkem myši a zvolte požadované možnosti.

    Chcete-li zobrazit nápovědu ke konkrétnímu obrazci ovládacího prvku, klepněte na něj pravým tlačítkem myši a klepněte na příkaz Nápověda.

    Pokud pro zadávání vlastního textu na obrazci Prázdný formulář použijete nástroj Text, formátujte text jako Tahoma 8 bodů.

  11. Seskupte příkazy do logických skupin.

  12. Chcete-li vizuálně oddělit skupiny příkazů, přetáhněte na obrazec Prázdný formulář obrazce Skupinová čára a Skupinový rámeček.

    Pro zarovnání ovládacích prvků použijte vodítka.

    Jako vhodný příklad dialogového okna obsahujícího řadu běžných prvků dialogového okna lze uvést dialogové okno Vzhled stránky v nabídce Soubor.

Začátek stránky

Vytvoření okna aplikace

  1. Ze vzorníku Okna a dialogová okna přetáhněte na stránku výkresu obrazec Prázdný formulář.

  2. Vyberte obrazec a zadejte název okna aplikace.

  3. Chcete-li přidat ikonu nalevo od textu v záhlaví, klepněte pravým tlačítkem myši na obrazec Prázdný formulář a zaškrtněte políčko Místo pro ikonu.

  4. Přetáhněte obrazec Tlačítka systému Windows na pravý konec záhlaví a vyberte typ tlačítka. Obvykle jsou tlačítka tři: zleva doprava tlačítko Minimalizovat, Maximalizovat nebo Obnovit a tlačítko Zavřít.

  5. Ze šablony Panely nástrojů a nabídky přetáhněte obrazec Panel nabídek na obrazec Prázdný formulář, připevněte ho k dolní části záhlaví a přidejte položky nabídky.

    how

    1. Přetáhněte obrazec Nabídka nejvyšší úrovně na stránku a připevněte ho k levému okraji v nabídce Panel nabídek.

      Nalevo od první položky nabídky je možné umístit ikonu.

    2. Vyberte obrazec a zadejte název nabídky. Pokud k výběru nabídky existuje klávesová zkratka, podtrhněte příslušné písmeno.

    3. Podle potřeby opakujte kroky 1 a 2.

      Chcete-li zobrazit nápovědu k obrazci, klepněte na něj pravým tlačítkem myši a klepněte na příkaz Nápověda.

      Chcete-li skrýt spojovací body Vzhled spojovacího bodu – modrý křížek , klepněte v nabídce Zobrazit na příkaz Spojovací body.

      Šířka všech položek ve sloupci by měla odpovídat šířce nejširšího z nich.

    Chcete-li na levé straně panelu nabídek zobrazit tečky označující úchyt, klepněte pravým tlačítkem myši na obrazec a zrušte zaškrtnutí u příkazu Zamknout panel nabídek.

  6. Ze šablony Panely nástrojů a nabídky přetáhněte obrazec Panel nástrojů na obrazec Prázdný formulář, připevněte ho k dolní části panelu nabídek a potom přidejte tlačítka panelu nástrojů.

    how

    1. Přetáhněte jeden z obrazců Tlačítka panelu nástrojů na stránku a připevněte ho k levému okraji obrazce Panel nástrojů.

    2. V dialogovém okně Data obrazce zvolte požadovaný typ tlačítka. Pokud budete chtít později změnit vlastnosti tlačítka, klepnete na obrazec pravým tlačítkem myši a klepnutím na příkaz Nastavit typ tlačítka znovu otevřete dialogové okno Data obrazce.

    3. Přetáhněte další obrazce Tlačítka panelu nástrojů a Oddělovač tlačítek podle potřeby a připevněte je k sobě.

      Chcete-li zobrazit nápovědu k obrazci, klepněte na něj pravým tlačítkem myši a klepněte na příkaz Nápověda.

      Chcete-li skrýt spojovací body Vzhled spojovacího bodu – modrý křížek , klepněte v nabídce Zobrazit na příkaz Spojovací body.

    Chcete-li na levé straně nabídky zobrazit tečky označující úchyt, klepněte pravým tlačítkem myši na obrazec a zrušte zaškrtnutí u příkazu Zamknout panel nástrojů.

  7. Ze šablony Běžné ovládací prvky přetáhněte vodorovné a svislé posuvníky podle potřeby na pravý nebo levý okraj obrazce Prázdný formulář.

  8. Klepněte pravým tlačítkem myši na posuvníky a vyberte možnost Nastavit velikost miniatury, abyste mohli označit, jak daleko je možné se v okně posouvat.

    Chcete-li označit, že je vidět pouze malá část dokumentu, bude velikost miniatury malá. Chcete-li označit, že bude vidět větší část dokumentu, bude velikost miniatury velká.

  9. Přetáhněte obrazec Stavový řádek na dolní okraj okna aplikace a zformátujte ho.

    how

    1. Přetáhněte obrazec Dělicí čára stavového řádku na stránku a připevněte ho k ovládacímu úchytu obrazce Stavový řádek Ovládací úchyt .

      Ovládací úchyty představují místo, kde je možné připevnit obrazec Dělicí čára stavového řádku k obrazci Stavový řádek nebo k jinému obrazci Dělicí čára stavového řádku.

      Jestliže obrazec Dělicí čára stavového řádku není po připevnění k obrazci Stavový řádek zobrazený, vyberte obrazec Stavový řádek a v nabídce Obrazec přejděte na příkaz Pořadí a klepněte na položku Přenést dál.

    2. Chcete-li označit, že je aktuálně možné změnit velikost okna, přetáhněte obrazec Změna velikosti okna na pravý konec stavového řádku.

Začátek stránky

Vytvoření nabídek a panelů nástrojů

Obrazce systému Windows XP lze použít k vytvoření jednoduchých nabídek, rozevíracích seznamů a panelů nástrojů.

Vytvoření nabídky

  1. Ze vzorníku Panely nástrojů a nabídky přetáhněte na stránku výkresu obrazec Panel nabídek. Chcete-li na levé straně panelu nabídek zobrazit tečky označující úchyt, klepněte pravým tlačítkem myši na obrazec a zrušte zaškrtnutí u příkazu Zamknout panel nabídek.

  2. Přetáhněte ze vzorníku na stránku výkresu obrazec Nabídka nejvyšší úrovně a připevněte jej na levou stranu obrazce Panel nabídek.

    Tip : Nalevo od názvu první nabídky lze umístit ikonu.

  3. Vyberte obrazec a zadejte název nabídky. Pokud k výběru nabídky existuje klávesová zkratka, podtrhněte příslušné písmeno.

  4. Podle potřeby opakujte krok 2 a 3.

    Chcete-li zobrazit nápovědu k obrazci, klepněte na něj pravým tlačítkem myši a klepněte na příkaz Nápověda.

    Chcete-li skrýt spojovací body Vzhled spojovacího bodu – modrý křížek , klepněte v nabídce Zobrazit na příkaz Spojovací body.

    Šířka všech položek ve sloupci by měla odpovídat šířce nejširšího z nich.

Vytvoření rozevírací nabídky

  1. Přetáhněte na stránku výkresu obrazec Nabídka nejvyšší úrovně.

  2. Vyberte obrazec a zadejte název nabídky. Pokud k výběru nabídky existuje klávesová zkratka, podtrhněte příslušné písmeno.

  3. Přetáhněte na stránku výkresu obrazec Rozevírací nabídka a připevněte jej na spodní stranu obrazce Nabídka nejvyšší úrovně.

  4. Opakujte krok 3 pro všechny položky rozevírací nabídky ve sloupci.

  5. Změňte šířku všech položek rozevíracích nabídek podle nejširší položky.

  6. Klepněte vždy na obrazec Rozevírací nabídka pravým tlačítkem myši, klepněte na příkaz Vlastnosti nabídky a vyberte příslušné možnosti.

    Chcete-li zobrazit nápovědu k obrazci, klepněte na něj pravým tlačítkem myši a klepněte na příkaz Nápověda.

    Chcete-li skrýt spojovací body Vzhled spojovacího bodu – modrý křížek , klepněte v nabídce Zobrazit na příkaz Spojovací body.

Vytvoření panelu nástrojů

  1. Ze vzorníku Panely nástrojů a nabídky přetáhněte na stránku výkresu obrazec Panel nástrojů. Chcete-li na levé straně nabídky zobrazit tečky označující úchyt, klepněte pravým tlačítkem myši na obrazec a zrušte zaškrtnutí u příkazu Zamknout panel nástrojů.

  2. Přetáhněte na stránku výkresu obrazec Tlačítka panelu nástrojů a připevněte jej na levý okraj obrazce Panel nástrojů.

  3. V dialogovém okně Data obrazce zvolte požadovaný typ tlačítka. Pokud budete chtít později změnit vlastnosti tlačítka, klepnete na obrazec pravým tlačítkem myši a klepnutím na příkaz Nastavit typ tlačítka znovu otevřete dialogové okno Data obrazce.

  4. Podle potřeby přetáhněte na stránku výkresu další obrazce Tlačítka panelu nástrojů a Oddělovač tlačítek a připevněte je k sobě.

    Chcete-li zobrazit nápovědu k obrazci, klepněte na něj pravým tlačítkem myši a klepněte na příkaz Nápověda.

    Chcete-li skrýt spojovací body Vzhled spojovacího bodu – modrý křížek , klepněte v nabídce Zobrazit na příkaz Spojovací body.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Sdílení Facebook Facebook Twitter Twitter E-mail E-mail

Byly tyto informace užitečné?

Výborně! Je ještě něco dalšího, co byste nám chtěli dát vědět?

Jak bychom ho mohli vylepšit?

Děkujeme vám za zpětnou vazbu.

×