Měření výkonu a využití webu pomocí sestav

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Pokud jste zodpovědní za správu webu, pravděpodobně dostáváte v souvislosti s webem některé běžné otázky, například:

  • Kolik uživatelů web navštěvuje?

  • Jak se během doby měnil přenos dat na webu?

  • Kdo jsou nejčastější uživatelé webu?

  • Odkud přichází přenos dat na webu?

  • Jaké stránky a prostředky na webu jsou nejčastěji používané?

  • Jak lze zjistit, kde se v našem procesu pracovního postupu nacházejí dokumenty a další prostředky?

Zároveň můžete mít jako správce webu určité otázky, na které obvykle potřebujete znát odpověď, například:

  • Obsahuje web nějaké prostředky, které by bylo možné odebrat, protože se nepoužívají nebo jsou zastaralé?

  • Jak lze zjistit potíže s webem (například nepropojené soubory, pomalé stránky a přerušené hypertextové odkazy) před tím, než si jich všimnou uživatelé a ohlásí je?

Na všechny tyto otázky získáte díky aplikaci Microsoft Office SharePoint Designer 2007 a webu Windows SharePoint Services 3.0 nebo Microsoft Office SharePoint Server 2007 snadno odpovědi prostřednictvím sestav aplikace Office SharePoint Designer 2007. V tomto článku se dozvíte, jak pomocí sestav zjišťovat výkon a využití webu.

Důležité : Data pro sestavy generované aplikací Office SharePoint Designer 2007 se ukládají na serveru, který je hostitelem webu. Správce serveru může udělit nebo odepřít přístup k těmto sestavám. Pokud sestavy, které požadujete, neobsahují žádná data, požádejte o pomoc správce serveru. Abyste mohli sestavy využití spustit, je nutné, abyste měli oprávnění Zobrazit údaje o používání a aby správce serveru na serveru zapnul shromažďování údajů o používání. Ve výchozím nastavení je shromažďování údajů o používání na serveru vypnuto.

Co chcete udělat?

Zobrazení Sestava Souhrn webu

Zobrazení sestav o zjišťování souborů

Zobrazení sestav o zjišťování sdíleného obsahu

Zobrazení sestav o zjišťování problémů

Zobrazení Sestava Souhrn využití

Zobrazení podrobných sestav využití

Graf výsledky použití dat

Seřazení sestavy

Filtrování sestavy

Kopírovat zprávu

Uložení sestavy

Zobrazení sestavy Souhrn webu

Sestava Souhrn webu obsahuje souhrnný přehled o vašem webu a také odkazy na podrobnější sestavy. Můžete například vygenerovat podobnou sestavu Souhrn webu jako na následujícím obrázku.

Sestava Souhrn webu

Vygenerování sestavy Souhrn webu pro váš web:

  1. Otevřete web, pro který chcete v aplikaci Office SharePoint Designer 2007 spustit sestavu.

  2. V nabídce Web přejděte na příkaz Zprávy a potom klepněte na příkaz Souhrn serveru.

    Sestava je vygenerována.

Poznámka : Klepnutím na hypertextové odkazy ve sloupci Název můžete přejít na podrobnější sestavy. Klepnutím na možnost Přerušené hypertextové odkazy můžete například přejít přímo do sestavy Přerušené hypertextové odkazy.

Začátek stránky

Zobrazení sestav o souborech

Můžete vygenerovat sestavy zobrazující všechny soubory, nedávno přidané soubory, nedávno změněné soubory nebo starší soubory. Pokud chcete například zvýraznit nový obsah na domovské stránce webu nebo v bulletinu propagujícím váš web, můžete pomocí sestavy Nedávno přidané soubory rychle identifikovat nový obsah. Můžete také pomocí sestavy Starší soubory identifikovat obsah, který je tak starý, že je nutné, aby prošel revizí a zjistilo se, zda není nutné ho aktualizovat nebo odebrat.

Před spuštěním sestav o souborech je nejprve nutné zadat definice pro nejnovější a starší soubory a také zadat, kolik měsíců se má zobrazit v sestavách podle měsíců:

  1. Otevřete web, pro který chcete v aplikaci Office SharePoint Designer 2007 spustit sestavu.

  2. V nabídce Nástroje klepněte na příkaz Možnosti aplikace.

  3. Klepnete na kartu Zobrazení Zprávy.

    Dialogové okno Možnosti aplikace s kartou Zobrazení Zprávy

  4. Do pole Poslední soubory jsou méně než zadejte počet dní, které identifikují relativně novou stránku.

  5. Do pole Starší soubory jsou více než zadejte počet dní, které identifikují starší stránku.

  6. Do pole Počet zobrazených měsíců zadejte počet měsíců, které se mají zobrazit v sestavách podle měsíců.

  7. Klepněte na tlačítko OK.

    Nyní je vše připraveno ke spuštění sestav.

  8. V nabídce Web přejděte na příkaz Zprávy, na příkaz Soubory a potom klepněte na sestavu, kterou chcete spustit:

    • Všechny soubory:     Zobrazí seznam všech souborů na webu.

    • Nedávno přidané soubory:     Zobrazí seznam souborů, které byly na web přidány během počtu dnů zadaných v kroku 4.

    • Nedávno změněné soubory:     Zobrazí seznam souborů, které byly na webu změněny během počtu dnů zadaných v kroku 4.

    • Starší soubory:     Zobrazí seznam souborů, které jsou považovány za starší, přičemž tuto vlastnost určuje počet dní zadaných v kroku 5.

    • Stav rezervace:     Zobrazí seznam souborů na webu společně s aktuálním stavem rezervace každého souboru. (Tato sestava také zahrnuje sloupce dat Rezervoval, Verze a Datum uzamčení.)

      V zobrazení Zprávy u sestav pro soubory můžete klepnutím na možnosti v seznamu rychle změnit nastavení pro starší nebo nedávné soubory.

      Zobrazení Zprávy s nabídkou filtru stáří souborů

Začátek stránky

Zobrazení sestav o sdíleném obsahu

Sdíleným obsahem mohou být například stránky předloh, přizpůsobené a další stránky zahrnuté v definici webu a odkazy na šablony stylů. Office SharePoint Designer 2007 usnadňuje vyhledávání sdíleného obsahu. Pokud chcete například změnit logo na všech stránkách na webu a k určování formátování stránek používáte stránky předloh, můžete pomocí sestavy Stránky předlohy najít všechny stránky předlohy, na kterých by bylo potřeba logo změnit. Můžete také použít sestavu Odkazy na šablony stylů k vyhledání všech šablon stylů, které je potřeba aktualizovat, aby se projevila změna písma nebo formátování, kterou chcete použít v rámci celého webu.

  1. Otevřete web, pro který chcete v aplikaci Office SharePoint Designer 2007 spustit sestavu.

  2. V nabídce Web přejděte na příkaz Zprávy, přejděte na příkaz Sdílený obsah a potom klepněte na sestavu, kterou chcete spustit:

    • Šablony DWT:     Zobrazí seznam všech stránek na webu se sloupcem Šablona DWT označujícím, zda je každá stránka připojena k šabloně DWT (a pokud ano, ke které).

    • Stránky předlohy:     Zobrazí seznam všech stránek na webu se sloupcem Stránka předlohy označujícím, zda je každá stránka připojena ke stránce předlohy (a pokud ano, ke které).

    • Přizpůsobené stránky:     Zobrazí seznam všech stránek na webu se sloupcem Vlastní označujícím, zda byla některá stránka, která je založena na definici webu, přizpůsobena.

    • Odkazy na šablony stylů:     Zobrazí seznam všech stránek na webu se sloupcem Odkazy na šablony stylů označujícím, zda je každá stránka připojena k šabloně stylů.

      Poznámka : Odkazy na šablony stylů se zobrazují jako statické odkazy na šablony stylů (značky <odkaz>). Dynamické odkazy na šablony stylů generované ovládacími prvky Microsoft ASP.NET (například <SharePoint:CssLink>) nejsou do této sestavy zahrnuty.

Začátek stránky

Zobrazení sestav o potížích

Sestavy aplikace Office SharePoint Designer 2007 o potížích vám mohou pomoci předcházet potenciálním potížím a odstraňovat je ještě dříve, než negativně ovlivní práci uživatelů. Pomocí takových sestav můžete například identifikovat pomalé stránky, najít přerušené hypertextové odkazy a vyhledat soubory, které by bylo možné odstranit, protože nejsou propojeny na žádné jiné soubory. Chcete-li spustit sestavy Potíže, je třeba nejdříve nastavením předvoleb zadat definici pomalých stránek.

  1. Otevřete web, pro který chcete v aplikaci Office SharePoint Designer 2007 spustit sestavu.

  2. V nabídce Nástroje klepněte na příkaz Možnosti aplikace.

  3. Klepnete na kartu Zobrazení Zprávy.

    Dialogové okno Možnosti aplikace s kartou Zobrazení Zprávy

  4. Do pole Pomalé stránky se načítají nejméně zadejte počet sekund, které definují, jak dlouho se stahuje pomalá stránka.

  5. Do pole Předpokládat rychlost připojení zadejte počet kilobitů za sekundu (kb/s) průměrné rychlosti připojení uživatele.

  6. Klepněte na tlačítko OK.

    Nyní je vše připraveno ke spuštění sestav.

  7. V nabídce Web přejděte na příkaz Zprávy, přejděte na příkaz Potíže a klepněte na sestavu, kterou chcete spustit:

    • Nepropojené soubory:     Zobrazí seznam všech souborů na webu, ke kterým nejsou nastaveny žádné odkazy. Pomocí tohoto seznamu můžete vyhledat nepoužívané soubory, které je potřeba odebrat z webu. Poznámka: Tato sestava nebere v úvahu odkazy generované ovládacími prvky ASP.NET, například webovou částí Obsah na webech Office SharePoint Server 2007.

    • Pomalé stránky:     Zobrazí seznam stránek na webu, které jsou identifikovány jako pomalu načítané na základě definice zadané v kroku 3 a průměrné rychlosti připojení zadané v kroku 4. Poznámka: V této sestavě se neprojeví čas potřebný k načtení kódu stránky. Nebere v úvahu dynamický obsah generovaný ovládacími prvky ASP.NET.

    • Hypertextové odkazy:     Zobrazí seznam všech hypertextových odkazů na webu. Po spuštění této sestavy se zobrazí dialogové okno s dotazem, zda chcete ověřit hypertextové odkazy na webu. Na možnost Ano klepněte v případě, že chcete, aby aplikace Office SharePoint Designer 2007 automaticky postupně prošla a ověřila všechny hypertextové odkazy. Výsledkem tohoto procesu je seznam hypertextových odkazů, ve kterém je každý odkaz označen jako OK nebo Přerušeno. Chcete-li některý z přerušených odkazů upravit, klepněte na odkaz v sestavě a potom klepněte na možnost Upravit hypertextový odkaz na panelu nástrojů, který se zobrazí v pravém horním rohu okna dokumentu v zobrazení Zprávy.

      Poznámka :  Dialogové okno Upravit hypertextový odkaz

    • Chyby komponent:     Zobrazí seznam všech komponent, například Interaktivní tlačítka nebo čítač přístupů (všechny dříve a genericky známé jako webbot nebo bot), které v dané době generují chyby. Seznam webových komponent můžete zobrazit klepnutím na příkaz Webová komponenta v nabídce Vložit.

Začátek stránky

Zobrazení sestavy Souhrn využití

Pomocí sestav využití webu lze získat odpovědi na některé důležité otázky, které mohou vlastníci webu mít v souvislosti se svým webem, například kolik uživatelů web využívá, které prostředky jsou nejoblíbenější, kdo nejvíce web využívá a odkud návštěvníci na web přicházejí. Sestava Souhrn využití obsahuje souhrn celkového počtu návštěv, počtu přístupů na stránku, počtu stažených bajtů a další informace.

Sestava Souhrn využití

Chcete-li spustit sestavu Souhrn využití, postupujte takto:

  1. Otevřete web, pro který chcete v aplikaci Office SharePoint Designer 2007 spustit sestavu.

  2. V nabídce Web přejděte na příkaz Zprávy, přejděte na příkaz Využití a klepněte na možnost Souhrn využití.

    Sestava je vygenerována. Klepnutím na některou z položek v podobě hypertextového odkazu ve sloupci Název můžete zobrazit podrobné sestavy.

Začátek stránky

Zobrazení podrobných sestav využití

Spuštěním podrobných sestav využití lze získat odpovědi na otázky týkající se způsobu, jakým uživatelé přistupují k vašemu webu. Přestože například sestava Souhrn využití generovaná v předchozí části zobrazuje celkový počet přístupů na stránku, sestava Počet přístupů na stránku za měsíc obsahuje podrobné informace o tom, kolik přístupů bylo napočítáno pro každou stránku na webu. Následuje postup ke spuštění podrobných sestav využití:

  1. Otevřete web, pro který chcete v aplikaci Office SharePoint Designer 2007 spustit sestavu.

  2. V nabídce Web přejděte na příkaz Zprávy, přejděte na příkaz Využití a potom klepněte na sestavu, kterou chcete spustit:

    • Měsíční souhrn:     Shrnuje počet návštěv a přístupů, celkový počet přístupů a velikost stažených souborů na vašem webu za měsíc.

    • Týdenní souhrn:     Shrnuje počet návštěv a přístupů, celkový počet přístupů a velikost stažených souborů na vašem webu za týden.

    • Denní souhrn:     Shrnuje počet návštěv a přístupů, celkový počet přístupů a velikost stažených souborů na vašem webu za den.

    • Počet přístupů na stránku za měsíc:     Shrnuje celkový počet přístupů a počet přístupů za měsíc pro každou stránku na webu.

    • Počet přístupů na stránku za týden:     Shrnuje celkový počet přístupů a počet přístupů za týden pro každou stránku na webu.

    • Počet přístupů na stránku za den:     Shrnuje celkový počet přístupů a počet přístupů za den pro každou stránku na webu.

    • Návštěvníci:     Shrnuje počet návštěvníků a jejich procento z celku pro vybraný měsíc.

    • Operační systémy:     Shrnuje počet operačních systémů návštěvníků a jejich procento z celku pro vybraný měsíc.

    • Prohlížeče:     Shrnuje počet prohlížečů návštěvníků a jejich procento z celku pro vybraný měsíc.

    • Odkazované domény:     Shrnuje počet návštěv, které pocházejí z konkrétní domény, a také jejich procento z celku pro vybraný měsíc.

    • Odkazované adresy URL:     Shrnuje počet návštěv, které pocházejí z konkrétní adresy URL, a také jejich procento z celku pro vybraný měsíc.

    • Hledané řetězce:     Zobrazí seznam počtu hledaných řetězců zadaných do pole pro hledání na webu a také jejich procento z celku pro vybraný měsíc.

Začátek stránky

Znázornění výsledků dat využití v grafu

Podle potřeby můžete snadno vytvořit graf znázorňující data využití v grafické podobě, což umožňuje snadno zjistit trendy a různé způsoby používání.

  1. V nabídce Web přejděte na příkaz Zprávy, přejděte na příkaz Využití a potom klepněte na sestavu, kterou chcete spustit.

  2. Na panelu nástrojů v pravém horním rohu okna dokumentu klepněte v seznamu Graf na typ grafu, který chcete vytvořit, například Sloupcový graf.

    Panel nástrojů v zobrazení Zprávy se seznamem grafů

    Sestava se otevře v novém okně.

    Graf dat využití

    Poznámka : Ve výchozím nastavení jsou data grafu generována společně se sestavami využití. Pokud při pokusu o spuštění sestavy nenajdete data grafu, klepněte v nabídce Nástroje na příkaz Možnosti aplikace, klepněte na kartu Zobrazení Zprávy a potom zaškrtněte políčko Uložit zprávu o využití i s grafem.

Začátek stránky

Seřazení sestavy

V zobrazení Zprávy můžete sestavu seřadit klepnutím na záhlaví sloupců.

Začátek stránky

Filtrování sestavy

Výsledky sestavy lze omezit tak, aby se zobrazily pouze požadované informace. Podle potřeby můžete buď filtrovat pouze jeden sloupec nebo více sloupců a vytvořit progresivní filtr.

  1. V nabídce Web přejděte na příkaz Zprávy a potom klepněte na sestavu, kterou chcete spustit.

  2. Klepněte na šipku vedle záhlaví sloupce, podle kterého chcete data filtrovat, a potom klepněte na data, která chcete vyfiltrovat.

    Například při filtrování podle typu souboru můžete klepnout na šipku vedle záhlaví sloupce Typ a potom klepnutím na možnost bmp zobrazit pouze soubory rastrových obrázků v sestavě.

    Sloupec Typ s nabídkou filtru

  3. Pokud chcete data filtrovat podle více sloupců, opakujte pro každý sloupec krok 2.

  4. Chcete-li u sloupce vytvořit vlastní filtr, klepněte na šipku vedle záhlaví sloupce a potom klepněte na možnost (Vlastní). Zadejte kritéria hledání a potom klepněte na tlačítko OK.

    Pomocí vlastního autofiltru můžete například identifikovat všechny soubory s obrázky ve formátu BMP nebo GIF na vašem webu.

    Dialogové okno Vlastní automatický filtr

  5. Chcete-li vymazat filtr u některého sloupce, klepněte na šipku vedle záhlaví daného sloupce a potom klepněte na možnost (Vše).

Poznámka : Aktuálně použité nastavení filtru je při zavření webu uloženo. Pokud nemůžete najít soubory v nově spuštěné sestavě, je možné, že jsou díky filtrům, které jste použili v předchozí relaci, tyto soubory skryty.

Chcete-li ze sestavy odebrat všechny filtry, klepněte pravým tlačítkem myši na záhlaví sloupce a v místní nabídce potom klepněte na příkaz Odebrat filtry.

Začátek stránky

Kopírování sestavy

Po spuštění sestavy můžete výsledky zkopírovat a vložit je do e-mailové zprávy nebo do jiného dokumentu (například list aplikace Microsoft Office Excel). Zkopírovat lze libovolnou sestavu kromě sestavy Souhrn serveru.

  1. Pravým tlačítkem myši klepněte na libovolné záhlaví sloupce v sestav, kterou jste spustili, a v místní nabídce potom klepněte na příkaz Kopírovat zprávu.

    Nabídka sloupce Název s vybraným příkazem Kopírovat zprávu

  2. Vložte data do dokumentu nebo do zprávy.

Začátek stránky

Uložení sestavy

Pokud chcete použít aplikaci Microsoft Office Excel 2007 k zobrazení a analýze výsledků nebo k vytvoření vlastních diagramů nebo grafů z těchto výsledků, můžete sestavy uložit.

  1. V nabídce Web přejděte na příkaz Zprávy a potom klepněte na sestavu, kterou chcete spustit.

  2. V nabídce Soubor klepněte na příkaz Uložit. Můžete také stisknout klávesy CTRL+S.

  3. Do pole Název souboru zadejte název sestavy a pak klepněte na tlačítko Uložit. Sestava je uložena jako soubor HTM na vašem webu.

    Sestava otevřená v aplikaci Excel

  4. Chcete-li sestavu otevřít, poklepejte na ni.

    Sestava se otevře v aplikaci Office Excel 2007.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×