Krok 4 – Sdílení makra s ostatními

Při sdílení maker je důležité si uvědomit, že se ukládají v souboru Office, takže tento soubor musíte sdílet s ostatními. Pokud jste vytvořili makro ve Wordu, budete soubor muset sdílet jako wordovou šablonu s podporou maker (.docm) nebo wordový dokument s podporou maker (.dotm). Pokud jste vytvořili makro v Excelu, budete soubor muset sdílet jako excelovou šablonu s podporou maker (.xlsm) nebo excelový dokument s podporou maker (.xltm).

Pokud jste vytvořili wordové makro, jde zde několik kroků navíc, které je třeba provést, abyste mohli makro sdílet:

Vytvoření prázdné wordové šablony

  1. Otevřete nový wordový dokument.

  2. V nabídce Soubor klikněte na příkaz Uložit jako.

  3. Nazvěte soubor global_macros.dotm.

  4. V rozevíracím seznamu Formát vyberte jako Formát možnost Šablona aplikace Word s podporou maker (*.dotm).

  5. Zvolte místo, kam chcete uložit soubor v síti.

  6. Klikněte na Uložit a zavřete šablonu.

Export wordového makra z dokumentu

S využitím makra nahraného v Kroku 1 proveďte export makra pomocí následujících kroků:

  1. Otevřete dokument nebo šablonu obsahující makro, které chcete exportovat.

  2. V nabídce Nástroje přejděte na Makro a potom klikněte na Makra.

  3. Vyberte makro, které chcete exportovat, a potom klikněte na Upravit. Vyberte exportované makro

  4. Ve Visual Basic Editoru klikněte na Soubor > Export souboru.

  5. Uložte makro do stejné složky jako šablonu s podporou maker global_macros.dotm.

Import wordového makra do nové prázdné šablony

  1. Otevřete soubor global_macros.dotm a pak klikněte na Nástroje > Makro > Visual Basic Editor.

  2. Pokud chcete makro importovat, klikněte na Soubor > Importovat soubor, přejděte do složky, kam jste exportovali makra, vyberte požadovaný soubor a potom klikněte na Otevřít.

  3. Uložte modul, ukončete program Visual Basic Editor a potom ukončete Word.

Nyní můžete sdílet makro s ostatními a informovat je, aby ho nainstalovali do počítače podle postupu uvedeného níže.

Instalace šablony: nastavení Wordu k používání makra

  1. Umístěte soubor global_macro.dotm do tohoto umístění:

    • Word for Mac 2011: Macintosh HD: Uživatelé: Uživatelské jméno: Knihovna: Podpora aplikace: Microsoft: Office: Uživatelské šablony: Moje šablony

    • Word 2003 ve Windows nebo novější: C:\Documents and Settings\Username\Application Data\Microsoft\Word\STARTUP

      Poznámka:  Uživatelské jméno je přihlašovací jméno uživatele.

  2. Ve Wordu, klikněte na Word > Předvolby....

Předvolby Wordu

  1. V části Osobní nastavení klikněte na Umístění souboru

  2. Vyberte možnost Po spuštění ze seznamu Umístění souborů a potom klikněte na Upravit....

Umístění souborů

  1. Ověřte, jestli Word používá jako složku Po spuštění stejnou složku, do které jste umístili soubor global_macro.dotm.

  2. Kliknutím na Zvolit zavřete dialog Zvolte složku a pak kliknutím na OK zavřete dialogové okno Umístění souborů.

Vaším posledním krokem je sdělit Wordu, aby po spuštění používal soubor global_macros.dotm.

  1. Ve Wordu klikněte na Nástroje > Šablony a doplňky....

  2. Zaškrtněte na seznamu soubor global_macros.dotm a klikněte na OK.

    Tip:  Pokud se vaše šablona v seznamu nezobrazuje, není soubor global_macros.dotm umístěný ve složce Wordu s položkami používanými po spuštění. Přejděte zpět ke kroku 1 v této části a ověřte, jestli je složka Po spuštění stejná složka jako ta, do které jste zkopírovali soubor global_macros.dotm.

Nastavení globální šablony ve Wordu

 Krok 1 – Zahájení nahrávání makra

Krok 2 – Čtení a pochopení kódu

Krok 3 – Seznámení se základy programování

Krok 4 – Sdílení makra s ostatními

Krok 5 – Reálné příklady

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×