Kopírování vzorce přetažením úchytu v Excelu 2016 pro Mac

Pomocí úchytu můžete rychle zkopírovat vzorce do sousedních buněk.

Úchyt

Když se úchyt přetáhne do jiných buněk, Excel zobrazí pro každou buňku jiný výsledek.

Kopírování vzorce přetažením úchytu

  1. Vyberte buňku obsahující vzorec, kterým chcete vyplnit sousední buňky.

  2. Přesuňte kurzor do pravého dolního rohu, aby se změnil na znaménko plus (+):

    Kurzor na úchytu

  3. Přetáhněte úchyt dolů, nahoru nebo přes buňky, které chcete vyplnit. V tomto příkladu přetahujeme úchyt dolů:

    Kurzor přetahující úchyt dolů

  4. Po uvolnění se vzorec automaticky vyplní do ostatních buněk:

    Hodnoty zobrazené ve vyplněných buňkách

  5. Pokud chcete změnit způsob vyplnění buněk, klikněte na tlačítko Možnosti automatického vyplnění Tlačítko Možnosti automatického vyplnění , které se zobrazí, když dokončíte přetahování, a vyberte požadovanou možnost.

Další informace o kopírování vzorců najdete v tématu Kopírování a vložení vzorce do jiné buňky nebo listu.

Tipy : 

  • Vyplnit vzorcem buňky ve sloupci směrem dolů můžete taky stisknutím CONTROL + D. Nejdřív vyberte buňku obsahující vzorec, kterým chcete buňky vyplnit, a pak vyberte buňky pod ní a stiskněte CONTROL + D.

  • Vyplnit vzorcem buňky v řádku doprava můžete taky stisknutím CONTROL + R. Nejdřív vyberte buňku obsahující vzorec, kterým chcete buňky vyplnit, a pak vyberte buňky vpravo od ní a stiskněte CONTROL + R.

Pokud vyplňování nefunguje

Někdy vyplnění buňky funguje dobře, ale jindy nefunguje očekávaným způsobem. Proto je důležité zkontrolovat odkazy na buňky v první buňce.

Odkazy na buňky prostě odkazují na jiné buňky. Řekněme třeba, že první buňka obsahuje tento vzorec:


=SUMA(A1;B1)


A1 a B1 jsou relativní odkazy. To znamená, že když vzorcem vyplníte buňky směrem dolů, odkazy se postupně změní z A1, B1 na A2, B2 a tak dále:

=SUMA(A1;B1)

=SUMA(A2;B2)

=SUMA(A3;B3)

Někdy nechcete, aby se odkazy na jiné buňky měnily. Řekněme třeba, že byste chtěli, aby první odkaz A1 zůstal stejný, a odkaz B1 se přetažením úchytu měnil. V takovém případě zadejte do prvního odkazu znaky dolaru: =SUMA($A$1;B1). Znaky dolaru přinutí Excel, aby při vyplnění dalších buněk dál odkazoval na A1. Vypadalo by to takto:

=SUMA($A$1;B1)

=SUMA($A$1;B2)

=SUMA($A$3;B3)

Odkazy se znaky dolaru ($) se nazývají absolutní odkazy. Při vyplňování směrem dolů zůstane odkaz na A1 stejný, ale Excel změní odkaz B1 na B2 a B3.

Máte potíže se zobrazením úchytu?

Pokud úchyt nevidíte, je možné, že je skrytý. Znova ho zobrazíte takto:

  1. V nabídce Excel klikněte na Předvolby.

  2. Klikněte na Upravit.

  3. V části Možnosti úprav zaškrtněte políčko Povolit úchyt a přetahování buněk.

Pokud není v sešitu zapnutý automatický výpočet, vzorce se po vyplnění buněk nebudou přepočítávat. Takto to v případě potřeby zapnete:

  1. V nabídce Excel klikněte na Předvolby.

  2. Klikněte na Výpočet.

  3. V části Možnosti výpočtu se podívejte, jestli je zaškrtnutá možnost Automaticky.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×