Jednotné načíst a transformovat prostředí

Důležité informace:  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Excel 2016 zavádí výkonné sadu nástrojů s názvem načíst a transformovat. Tyto nástroje založené na technologii Power Query, umožňují snadno připojit, kombinovat a přizpůsobovat dat pocházejících z různých zdrojů. Následující načíst a transformovat kurz vás provede základní informace.

Oznamujeme ohlaste další hlavní aktualizace k importu dat a tvarování funkce v aplikaci Excel – jednotné načíst a transformovat dojít. Březen 2017 aktualizace Office 365 jsme rozšířené funkce importu dat aplikace Excel a měnit uspořádání tlačítek na kartě Data tak, aby bylo jednodušší než někdy chcete využít celou načíst a transformovat funkce.

Načíst a transformovat možnosti na kartě Data

S jednotné načíst a transformovat zkušenosti můžete využívat dobře integrované a moderní soubor importu dat a přizpůsobení možností aplikace Excel. Můžete snadno připojit a načtení dat z různých zdrojů dat Oblíbené například soubory databáze, služby Azure a Online a další. A přizpůsobování tato data výkonné způsoby řazení, změně datových typů, rozdělení sloupce shromažďování dat a tak dále. Neustále Kvetoucí nabízející nové spojnice a snadno provést transformací jsou co zkontrolujte načíst a transformovat velmi užitečné v případě a ušetřit čas nástroj v každodenní práci.

Zadejte poznámku, že nové prostředí nahradí data starší, starší verze importovat průvodci, které byly k dispozici v části Data > Načíst externí Data. Ale budou pořád přístupné požadovaná. Viz: způsob obnovení starší verze možnosti Načíst externí Data?

Poznámka: Tato funkce je dostupná v aplikaci Excel, pouze pokud máte předplatné Office 365. Pokud jste si předplatné Office 365, Zkontrolujte, jestli že máte nejnovější verzi Office.

Jak získat data z oblíbených zdrojů, jako jsou soubory CSV nebo webu

Nám vědět, že uživatelé, kteří importovat data jako mít snadno dostupné nejoblíbenější spojnic, je na pásu karet. V této aktualizaci pokusili sledovat tuto zásadu jsme možnosti k dispozici konzistentní s se používají k. Teď můžete najít následující horní tři spojnice k dispozici v části načíst a transformovat dat na kartě Data: Z Text/CSV, Z webu a Od Tabulka/oblast.

Z Text/CSV

Pomocí této spojnice můžete snadno importovat data z text (TXT), hodnotami oddělenými čárkami (CSV) nebo soubory formátovaný text (soubor s příponou PRN). Tato moderní spojnice je založený na technologii Power Query a nahradí starší verze Průvodce z textu.

Import dat pomocí konektoru nový, opakovaně klikněte Data > z Text/CSV, zvolte zdrojový soubor a potom klikněte na OK. Spojnice Z Text/CSV nové a vylepšené analyzuje struktura souboru zadávání a automaticky použije nastavení relevantní importu. Ho můžete rozdělení sloupce pomocí oddělovače, zvýšení úrovně prvního řádku na použít jako záhlaví sloupců a další.

Možnosti načíst a transformovat z textu

Není-li náhled požadovaným způsobem, můžete nakonfigurovat nastavení základní importu například původ souboru, oddělovače nebo datový typ logika zjišťování rovnou. Na základě vašeho výběru, náhled dat se automaticky aktualizuje.

Můžete pak klikněte na načíst do přímo data načítáte do listu nebo klikněte na šipku vedle načíst do data načítáte do datového modelu. Pokud chcete použít další data transformace v editoru dotazů, klikněte na Upravit.

Z webu

Pomocí této spojnice je můžete "scrape" data ze stránky HTML. Toto je jiné moderní spojnice založenou na technologii Power Query a nahradí starší verze Průvodce z webu.

Začít s ním pracovat, klikněte na Data > Z webu, zadejte cílovou adresu URL stránky a klikněte na tlačítko OK. V dialogu navigátor je zobrazený seznam všech tabulek na stránce. Máte možnost interakce s webovou stránku v Zobrazení tabulky nebo Zobrazení webové stránky. Zobrazení tabulky prvním kliknutí na název tabulky vlevo a data z této tabulky, se zobrazí na pravé straně. Pomocí zobrazení webové stránky můžete buď klikněte na tabulku ze seznamu tabulky nebo z podokna náhledu zobrazení webové stránky. Výběr více tabulek v obou zobrazení.

Možnosti načíst a transformovat z webu

Z Tabulka/oblast

Pomocí této spojnici můžete vytvořit nový dotaz, který je propojený s tabulkou nebo pojmenovanou oblast na listu aplikace Excel. Můžete vylepšit dat a použít další transformace v okně Editoru dotazů.

Možnosti načíst a transformovat z tabulky

Jak získat data z dalších zdrojů jako soubor XML nebo Microsoft SQL Server?

Můžete vytvořit nový dotaz, který import dat z jednoho zdroje dat, jako jsou databáze aplikace Microsoft Access nebo OData kanálu nebo importem dat z více textových souborů ve složce v celém dokumentu.

Po kliknutí na Data > Načíst Data dostupné zdroje dat se zobrazují v rozevírací nabídce. Zdroje, které možnosti se seřazenými do kategorií, včetně souborů jako Excelových sešitů, soubory ve formátu XML nebo celé složky databáze ATP SQL serveru nebo Oracle, Azure služeb, jako je HDInsight úložiště objektů Blob, Online služby, jako třeba seznam služby SharePoint Online nebo služby Salesforce a řadu dalších zdrojů, jako je OData nebo ODBC.

Roste neustále seznam dostupných spojnice.

Možnosti načíst a transformovat z databáze

S tuto aktualizaci jsme odebraly také následující průvodci starší verze, která byla dřív k dispozici v části načíst externí Data na kartě Data: Z aplikace Access, z webu, z textu, ze serveru SQL Server, z datového kanálu OData, z importu dat XML a od datové připojení Průvodce. Pokud z nějakého důvodu nastavíte pomocí některého průvodce odebrané starší, přečtěte si článek: způsob obnovení starší verze možnosti Načíst externí Data?

Ale existují dva Oblíbené a úplně jedinečné průvodců, které jsou součástí funkci staré načíst externí Data a zůstanou v nové prostředí: Ze služby Analysis Services a Z aplikace Microsoft Query. Najdete v části Data > Z databáze a Data > Z jiných zdrojů kategorie v novém prostředí v tomto pořadí.

Jak využít načíst a transformovat funkce vyčistit a přizpůsobovat Moje data?

Načíst a transformovat umožňuje vyčistit a přizpůsobovat dat jako základní krok pro analýzu dat robustní. Odebrání sloupců, filtrovat řádky, změna datových typů sloupců, můžete nahradit hodnoty a další. To je vyhrazený okno Editoru dotazů, který usnadňuje a zobrazí všechny transformace dat pomocí.

Přejděte na kartu Data na pásu karet, klikněte na Načíst Data, připojení ke zdroji požadovaná data (například souboru nebo databáze) jeden z dostupných spojnic a zobrazit náhled dat v okně Tabulka.

Služ a transformace Navigátor

Potom vyberte tabulky, které chcete importovat a klikněte na tlačítko Upravit pro spuštění okno Editoru dotazů.

Získání a transformace editoru dotazů

Pomocí široké kolekce příkazy k dispozici na pásu karet v okně Editoru dotazů. Můžete požádat výkonné transformace řazení a filtrování dat, převod datových typů, rozdělení nebo sloučení sloupců, shromažďování dat a dalších.

Všechny kroky transformace, které se vztahují na datech jsou zaznamenány a jsou uloženy v rámci dotazu. Nahrané transformace můžete pozorovanými a spravuje přes Použitý postup oddílu do okna Editor dotazů a znovu použije se vaše data pokaždé, když aktualizaci dotazu.

Jak získat data z naposledy použitých zdrojů, soubory databáze připojení ODC (Office), jiných připojení sešitu nebo tabulky

Nejoblíbenější scénáře v oblasti importu dat je připojení a získání dat z nedávné zdroje. Uživatelé často vytvořit sadu často používané zdroje, které se připojit k importu dat obsahujících data.

Připojení a vytvoření dotazu z jedné z nedávným zdrojům dat, klikněte na Data > Nedávné zdroje. Můžete pak procházet naposledy propojených zdrojů, vyberte jednu a pak klikněte na Připojit pokračujte v importu tok.

Podokno načíst a transformovat nedávné zdroje

Jiné Oblíbené scénář je import dat z existující připojení nebo tabulky v sešitu. Můžete například vytvořit nové kontingenční tabulky založené na sešit dříve vytvořené připojení. Nebo můžete chtít připojit a import ze zdroje dat pomocí souboru databáze připojení ODC (Office), která byla definována tak, že někdo ve vaší organizaci.

Díky této aktualizaci bude moct exportovat definice svoje dotazy do soubor ODC, a pak ho nasdílejte ve vašich sešitech nebo spolu s dalšími lidmi. Chcete-li exportovat definice dotazu do soubor ODC, klikněte pravým tlačítkem myši na dotaz v podokně úloh dotazy a připojení a zvolte Export souboru připojení. Vytvořený soubor ODC bude obsahovat definice dotazu s všechny závislosti, včetně pokynů připojení zdroje dat a transformace kroky nepoužijí s daty. Další způsob, jak exportovat definice dotazu je prostřednictvím dialogového okna Vlastností dotazu, která se dá otevřít klepnutím na příkaz Vlastnosti v místní nabídka pro pole dotazu.

Jakmile dostanete soubor ODC, budete moct používat ho a importovat definice dotazu do sešitu. Import dat prostřednictvím mechanismus ODC, klikněte na Data >Existující připojení. Zobrazí se dialogové okno Existující připojení a pak můžete importovat z dostupných ODC souborů, existující připojení sešitu nebo tabulky.

Vyberte z existující připojení nebo dotazů

Pokud je potřeba vytvořit soubor ODC, které bude potřeba jinou aplikací, jako je Visio nebo Excelu 2013 a starší, můžete to udělat, pomocí následujících konektorů: Z databáze systému SQL Server, Z databáze aplikace Microsoft Access, z datového kanálu OData , Ze služby Analysis Services, Z aplikace Microsoft Query nebo starší verze Z Průvodce datovým připojením. Je důležité vědět, že pokud používáte soubor ODC z jiné aplikace, že aplikace bude opakovaně používat pouze podle pokynů ODC připojení a nesmí obsahovat žádné transformace kroky, které mohou obsahovat původní dotazu. Pokud potřebujete obnovení starší verze Accessu z, podívejte se na ze serveru SQL Server, z datového kanálu OData spojnic: způsob obnovení starší verze možnosti Načíst externí Data?

Jak můžu spravovat existující dotazy sešitu a připojení?

Když jsme zavádí načíst a transformovat do aplikace Excel 2016, jsme zavádí dvě metodiky importu dat: první byl nové prostředí načíst a transformovat které něco v ní pomocí dotazů (a také závisí na připojení sešitu na pozadí pro aktualizace a načíst do prvků sešitu). Druhý byl prostředí starší, starší verze, které využívá připojení sešitu. Správa dotazů sešitu a připojení také platné samostatně. Dotazy sešitu byly spravovat prostřednictvím vyhrazené podokně dotazy při připojení byly spravované prostřednictvím dialogu připojení sešitu. Důvodem zavádějící naše uživatele.

S tuto aktualizaci jsme adresovaná tomuto problému. Teď můžete zpřístupnit a spravovat svoje dotazy sešitu a připojení z vyhrazené bočním podokně dotazy a připojení. Na bočním podokně spustíte kliknutím na Data > tlačítko dotazů a připojení.

Načíst a transformovat, podokno Dotazy a připojení

Po kliknutí na kartu dotazy v horní části podokna umožňuje procházet a spravovat dotazy k dispozici v sešitu. Klikněte pravým tlačítkem myši na dotaz pro přístup k dotazu kontextové nabídky, která umožňuje provádět další akce. Třeba aktualizovat data dotazu z podkladového zdroje, zkopírovat a vložit dotazu, upravte dotaz transformace editoru dotazů a dalšími.

Můžeme mít taky zjednodušená správa dotazu a jeho základní připojení prostřednictvím nové dialogové okno Vlastností dotazu. V současné době pokaždé, když vytvoříte nový dotaz v sešitu, nové základní entity připojení se automaticky vytvoří na pozadí a je přidružený k tomuto dotazu. Při připojení ke zdroji dat a použití transformací požadovaná data sobě dotazu role základní připojení ovládací prvky, kde jsou data je načteno (například listě nebo datovém modelu), jakož i nastavení aktualizace pro dotaz na data, jako aktualizace četnosti. S nové dialogové okno Vlastností dotazu můžete snadno upravit všechny vlastnosti dotazu, třeba jeho název nebo transformace pokyny a základní vlastnosti připojení, například nastavení aktualizace centralizovaným způsobem. Chcete-li otevřít nový dialog Vlastnosti dotazu, klikněte na příkaz Vlastnosti z dotazu kontextové nabídky na bočním podokně dotazy a připojení.

Po kliknutí na kartu připojení v horní části bočním podokně umožňuje procházet a spravovat dostupná starší připojení v sešitu, které jsou přidružené k některého průvodce starší například Z textu, Ze služby Analysis Services nebo Z aplikace Microsoft Query. Klikněte pravým tlačítkem myši připojení pro přístup k místní nabídky. Tam si budete moct provádět další akce, jako je aktualizovat připojení data ze zdroje, odstranit připojení nebo spravovat vlastnosti připojení prostřednictvím dialogového okna dobře známé Vlastnosti připojení.

Jak obnovit starší verze, na které narazit načíst externí Data?

Nové prostředí načíst a transformovat je nadřazené z hlediska spojnic nabízející a transformace funkcí ve srovnání s starší průvodci. Jsou tu ale i přesto čas, kdy je vhodné k importu dat použijte jeden z průvodci staré. Například, pokud chcete uložit přihlašovací údaje zdroje dat jako součást sešitu. (Poznámka: Tato metoda není v souladu s standardy moderní zabezpečení a jako takové není podporováno v nové prostředí načíst a transformovat).

Nebo můžete přistupovat starší spojnice tak, že přizpůsobení pásu karet, můžete vrátit a zobrazit své data starší verze import Průvodce přímo pod Data > načíst Data rozevírací nabídka prostřednictvím nový a snadno nastavení v dialogovém okně Možnosti aplikace Excel.

Přejděte na soubor > Možnosti > Data > Průvodce importem dat starších zobrazit a vyberte průvodci starší verze, kterou chcete použít:

Obrázek možností načíst a transformovat Průvodce starší verze ze souboru > Možnosti > Data.

Otevřít Data > načíst Data rozevírací nabídky a spouštění jednu dříve vybraná data starší verze importovat průvodců v kategorii vyhrazené starší průvodci:

Možnosti načíst a transformovat nabídka starší verze

Další informace o načíst a transformovat

Pokud chcete se dozvědět víc o funkcích načíst a transformovat je vhodným místem pro spuštění Aplikace Microsoft Power Query pro Excel Nápověda.

Potřebujete další pomoc?

Kdykoli se můžete zeptat některého odborníka v technické komunitě Excelu, získat podporu v komunitě pro odpovědi, případně navrhnout novou funkci nebo vylepšení ve fóru Excel User Voice.

Poznámka: Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×