Jak opravit chybu #ODKAZ!

Chyba #ODKAZ! se zobrazí, když vzorec odkazuje na buňku, která není platná. To se nejčastěji stává, když se buňky, na které vzorce odkazují, odstraní nebo se do nich vloží něco jiného.

Příklad chyby #ODKAZ!, kterou způsobilo odstranění sloupce

Následující příklad používá ve sloupci E vzorec =SUMA(B2;C2;D2).

Vzorec, který používá explicitní odkazy na buňky, jako je třeba =SUMA(B2;C2;D2), může při odstranění sloupce způsobit chybu #ODKAZ!.

Kdybyste sloupec B, C nebo D odstranili, způsobilo by to chybu #ODKAZ!. V tomto případě odstraníme sloupec C (Prodeje v roce 2007) a vzorec bude vypadat takto: =SUMA(B2;#ODKAZ!;C2). Když používáte explicitní odkazy (na každou buňku odkazujete jednotlivě a oddělujete je středníkem) a odstraníte řádek nebo sloupec, na který odkazujete, Excel si s tím nedokáže poradit, takže vám vrátí chybu #ODKAZ!. Toto je hlavní důvod, proč se použití explicitních odkazů ve funkcích nedoporučuje.

Příklad chyby #ODKAZ!, která byla způsobená odstraněním sloupce

Řešení

  • Pokud jste odstranili řádky nebo sloupce omylem, můžete okamžitě kliknout na tlačítko Zpět na panelu nástrojů Rychlý přístup (nebo stisknout kombinaci kláves CTRL+Z) a obnovit je.

  • Upravte vzorec tak, aby používal odkaz na oblast místo odkazu na jednotlivé buňky, jako =SUMA(B2:D2). Když teď odstraníte kterýkoli sloupec z této oblasti, Excel vzorec automaticky upraví. Pro součet řádků můžete použít =SUMA(B2:B5).

Příklad funkce SVYHLEDAT s odkazy na nesprávné oblasti

V následujícím příkladu vrátí vzorec =SVYHLEDAT(A8;A2:D5;5;NEPRAVDA) chybu #ODKAZ!, protože hledá hodnotu v pátém sloupci, ale oblast, na kterou vzorec odkazuje je A:D, což jsou jen čtyři sloupce.

Příklad vzorce SVYHLEDAT s nesprávnou oblastí  Vzorec je =SVYHLEDAT(A8;A2:D5;5;NEPRAVDA).  V oblasti funkce SVYHLEDAT neexistuje pátý sloupec, takže číslo 5 způsobí chybu #ODKAZ!.

Řešení

Buď zvětšete oblast nebo zmenšete vyhledávací hodnotu sloupce tak, aby odpovídala odkazované oblasti. Vzorec =SVYHLEDAT(A8;A2:E5;5;NEPRAVDA) by byl platný odkaz, stejně jako vzorec =SVYHLEDAT(A8;A2:D5;4;NEPRAVDA).

Příklad funkce INDEX se špatným odkazem na řádek nebo sloupec

V tomto příkladu vrátí vzorec =INDEX(B2:E5;5;5) chybu #ODKAZ!, protože oblast funkce INDEX jsou čtyři řádky na čtyři sloupce, ale vzorec požaduje vrátit informaci z pátého řádku a pátého sloupce.

Příklad vzorce INDEX s neplatným odkazem na oblast  Vzorec je =INDEX(B2:E5;5;5), ale oblast je pouze 4 řádky na 4 sloupce.

Řešení

Upravte odkazy na řádky nebo sloupce tak, aby patřily do prohledávané oblasti funkce INDEX. Vzorec =INDEX(B2:E5;4;4) by vrátil platný výsledek.

Příklad funkce NEPŘÍMÝ.ODKAZ odkazující na uzavřený sešit

V následujícím příkladu se funkce NEPŘÍMÝ.ODKAZ pokouší odkázat na sešit, který je zavřený, což způsobilo chybu #ODKAZ!.

Příklad chyby #ODKAZ!, která byla způsobená NEPŘÍMÝM odkazováním na zavřený sešit

Řešení

Sešit, na který funkce odkazuje, otevřete.

Problémy s OLE/DDE

Pokud jste použili odkaz technologie OLE (Object Linking and Embedding), který vrací chybu #ODKAZ!, spusťte program, na který se odkaz odvolává.

Poznámka: OLE je technologie, kterou můžete použít ke sdílení informací mezi programy.

Pokud jste použili téma DDE (Dynamic Data Exchange), které vrací chybu #ODKAZ!, ujistěte se, že odkazujete na správné téma.

Poznámka: DDE je zavedený protokol pro výměnu dat mezi programy Microsoftu, které jsou určené pro Windows.

Problémy s makry

Pokud makro na listu zadává funkci, která odkazuje na buňku nad funkcí, a buňka obsahující tuto funkci je v řádku 1, vrátí funkce chybu #ODKAZ!, protože nad řádkem 1 žádné buňky nejsou. Zkontrolujte funkci a přesvědčte se, jestli některý argument neodkazuje na buňku nebo oblast buněk, která není platná. Může to vyžadovat úpravu makra v programu Visual Basic Editor (VBE), aby se s touto situací počítalo.

Máte konkrétní otázku k funkci?

Zadejte dotaz do komunitního fóra Excelu.

Pomozte nám vylepšit Excel

Máte nějaké návrhy na zlepšení dalších verzí Excelu? Pokud ano, podívejte se prosím na témata v části Názor uživatele Excelu.

Viz taky

Přehled vzorců v Excelu

jak se vyhnout nefunkčním vzorcům

Oprava chyb ve vzorcích pomocí kontroly chyb

Funkce Excelu (podle abecedy)

Funkce Excelu (podle kategorie)

Sdílení Facebook Facebook Twitter Twitter E-mail E-mail

Byly tyto informace užitečné?

Výborně! Je ještě něco dalšího, co byste nám chtěli dát vědět?

Jak bychom ho mohli vylepšit?

Děkujeme vám za zpětnou vazbu.

×