Import nebo propojení dat z databáze SQL Serveru

Import nebo propojení dat z databáze SQL Serveru

Můžete propojit nebo importovat data z SQL Database, což je výkonná spravovaná databáze používaná pro důležité aplikace. Další informace najdete na stránkách SQL Serveru 2016.

  • Při propojení dat vytvoří Access dvousměrné připojení, které synchronizuje změny dat v Accessu a v SQL Database.

  • Při importu dat vytvoří Access jednorázovou kopii dat. Změny dat v Accessu a v SQL Database se proto nesynchronizují.

Přehled připojení Accessu k SQL Serveru

Než začnete

Chcete, aby šlo všechno hladce? Udělejte proto před propojením nebo importem tyto přípravy:

  • Vyhledejte název databázového serveru SQL Server, identifikujte nezbytné informace o připojení a zvolte metodu ověřování (Windows nebo SQL Server). Další informace o metodách ověřování najdete v tématech Připojení k serveru (databázovému stroji) a Zabezpečení databáze.

  • Identifikujte tabulky nebo zobrazení, které chcete propojit nebo importovat, a pole propojených tabulek s jedinečnými hodnotami. Během jedné operace můžete propojit nebo importovat několik tabulek nebo zobrazení.

  • Vezměte v úvahu počet sloupců v každé tabulce nebo zobrazení. Access nepodporuje více než 255 polí v tabulce, takže může propojit nebo importovat jenom prvních 255 sloupců. Toto omezení můžete obejít tak, že vytvoříte v databázi SQL Serveru zobrazení, které umožní přístup ke sloupcům nad tímto limitem.

  • Určete celkový objem importovaných dat. Maximální velikost databáze Accessu jsou dva gigabajty zmenšené o prostor potřebný pro systémové objekty. Pokud databáze SQL Serveru obsahuje velké tabulky, může se stát, že je nebude možné importovat všechny do jedné databáze Accessu. V takovém případě zvažte propojení dat místo jejich importu.

  • Zabezpečte databázi Accessu a informace o připojení v ní obsažené použitím důvěryhodného umístění a hesla databáze Accessu. Zvlášť důležité to je v případě, pokud se rozhodnete uložit heslo SQL Serveru v Accessu.

  • Naplánujte si vytvoření dalších relací. Access na konci operace importu nevytvoří automaticky relace mezi souvisejícími tabulkami. Relace mezi novými a stávajícími tabulkami musíte vytvořit ručně pomocí okna Relace. Další informace najdete v článcích Co je okno Relace a Vytvoření, úprava nebo odstranění relace.

1. fáze: Začínáme

  1. Vyberte Externí data > Nový zdroj dat > Z databáze > Z SQL Serveru.

  2. V dialogovém okně Načíst externí data – Databáze ODBC proveďte jednu z následujících akcí:

    • Pokud chcete data importovat, vyberte Importovat zdrojová data do nové tabulky v aktuální databázi.

    • Pokud chcete data propojit, vyberte Vytvořit odkaz na zdroj dat vytvořením propojené tabulky.

  3. Vyberte OK.

2. fáze: Vytvoření nebo opětovné použití souboru DSN

Můžete vytvořit nový soubor DSN nebo znovu použít existující soubor. Soubor DSN použijte, když chcete využít stejné informace o připojení pro různé operace propojení a importu nebo sdílet s jinou aplikací, která také používá soubory DSN. Soubor DSN můžete vytvořit přímo pomocí Správce datových připojení. Další informace najdete v článku Správa zdrojů dat ODBC.

I když můžete dál používat předchozí verze ovladače SQL ODBC, doporučujeme používat verzi 13.1, která má mnoho vylepšení a podporuje nové funkce SQL Serveru 2016. Další informace najdete v tématu Ovladač Microsoft ODBC pro SQL Server ve Windows.

  1. Proveďte jednu z následujících akcí:

    • Pokud soubor DSN, který chcete použít, už existuje, vyberte ho v seznamu.

      Dialog Vybrat zdroj dat

      Možná budete muset znovu zadat heslo. Závisí to na tom, jakou metodu ověřování jste zadali v informacích o připojení.

    • Pokud chcete vytvořit nový soubor DSN:

      1. Vyberte Nový.

        Dialogové okno Vytvořit nový zdroj dat
      2. Vyberte Ovladač ODBC 13 pro SQL Server a pak vyberte Další.

      3. Zadejte název souboru DSN nebo klikněte na Procházet (pokud chcete soubor vytvořit v jiném umístění).

  2. Klikněte na Další, zkontrolujte souhrnné informace a klikněte na Dokončit.

3. fáze: Použití průvodce Vytvořit nový zdroj dat pro SQL Server

V průvodci Vytvořit nový zdroj dat pro SQL Server postupujte takto:

  1. Na první stránce zadejte identifikační informace:

    • Do pole Popis můžete zadat dokumentační informace o souboru DSN.

    • Do pole Server zadejte název SQL Serveru. Neklikejte na šipku dolů.

  2. Na druhé stránce vyberte jednu z těchto metod ověřování:

    • S integrovaným ověřováním systému Windows:    Připojení přes účet uživatele Windows. Volitelně můžete zadat Hlavní název služby (SPN). Další informace najdete v tématu Hlavní názvy služeb (SPN) u připojení klientů (ODBC).

    • S ověřováním serveru SQL Server:    Připojení pomocí přihlašovacích údajů nastavených v databázi zadáním přihlašovacího ID a hesla.

  3. Na třetí a čtvrté stránce vyberte různé možnosti pro přizpůsobení připojení. Další informace o těchto možnostech najdete v tématu Ovladač Microsoft ODBC pro SQL Server.

  4. Zobrazí se obrazovka pro ověření vašich nastavení. Výběrem možnosti Test zdroje dat ověříte připojení.

  5. Možná se budete muset přihlásit k databázi. V dialogovém okně Přihlášení k serveru SQL Server zadejte přihlašovací ID a heslo. Pokud chcete změnit další nastavení, vyberte Možnosti.

4. fáze: Výběr tabulek k propojení nebo importu

  1. V dialogovém okně Propojit tabulky nebo Import objektů vyberte v části Tabulky všechny tabulky nebo zobrazení, které chcete propojit nebo importovat, a potom klikněte na OK.

    Seznam tabulek k propojení nebo importu
  2. Při operaci propojení se rozhodněte, jestli chcete vybrat možnost Uložit heslo.

    Zabezpečení:    Když vyberete tuto možnost, nebudete muset při každém otevření Accessu a přístupu k datům zadávat přihlašovací údaje. Přitom se ale v databázi Access uloží nezašifrované heslo. Lidé, kteří můžou získat přístup ke zdrojovému obsahu, tak můžou zobrazit uživatelské jméno a heslo. Pokud tuto možnost vyberete, důrazně doporučujeme uložit databázi Accessu v důvěryhodném umístění a vytvořit heslo databáze Accessu. Další informace najdete v článcích Rozhodnutí o důvěryhodnosti databáze a Šifrování databáze pomocí hesla databáze.

5. fáze: Vytvoření specifikací a úkolů (jenom při importu)

Výsledky

Až operace propojení nebo importu skončí, tabulky se objeví v navigačním podokně s názvem, který je kombinací tabulky nebo zobrazení SQL Serveru a jména vlastníka. Pokud například název v SQL je dbo.Product, bude název v Accessu mít podobu dbo_Product. Pokud se tento název už používá, připojí Access k novému názvu tabulky „1“ – například dbo_Product1. Pokud se název dbo_Product1 už také používá, vytvoří Access název dbo_Product2 – a tak dál. Tabulky ale můžete přejmenovat, aby měly smysluplnější názvy.

Při operaci importu Access nepřepíše žádnou tabulku v databázi. Data SQL Serveru sice nemůžete přímo připojit k existující tabulce, data z podobných tabulek ale můžete importovat a pak vytvořit přidávací dotaz pro přidání dat.

Pokud jsou sloupce v tabulce SQL Serveru při operaci propojení jen pro čtení, jsou jen pro čtení i v Accessu.

Tip:    Pokud chcete zobrazit připojovací řetězec, přejděte myší na tabulku v navigačním podokně Accessu.

Aktualizace návrhu propojené tabulky

V propojené tabulce nemůžete přidávat, odstraňovat ani upravovat sloupce nebo měnit datové typy. Pokud chcete udělat změny návrhu, udělejte to v databázi SQL Serveru. Aby se změny návrhu zobrazily v Accessu, aktualizujte propojené tabulky:

  1. Vyberte Externí data > Správce propojených tabulek.

  2. Vyberte všechny propojené tabulky, které chcete aktualizovat, vyberte OK a potom vyberte Zavřít.

Porovnání datových typů

Datové typy Accessu mají jiné názvy než datové typy SQL Serveru. Například sloupec SQL Serveru s datovým typem bit se do Accessu naimportuje nebo propojí jako sloupec s datovým typem Ano/ne. Následující tabulka obsahuje porovnání datových typů SQL Serveru a Accessu.

Datový typ SQL Serveru

Datový typ Accessu

Velikost pole Accessu

bigint

Velké číslo

Podívejte se na článek Použití datového typu Velké číslo.

binary (velikost pole)

Binární

Stejná jako velikost pole SQL Serveru

bit

Ano/ne

char (velikost pole), když je velikost pole menší nebo rovna 255

Text

Stejná jako velikost pole SQL Serveru

char (velikost pole), když je velikost pole větší než 255

Memo

datetime

Datum a čas

decimal (přesnost, měřítko)

Číslo

Desetinné číslo (vlastnosti Accessu Přesnost a Měřítko odpovídají přesnosti a měřítku SQL Serveru)

float

Číslo

Dvojitá přesnost

image

Objekt OLE

int

Číslo

Dlouhé celé číslo

money

Měna

nchar (velikost pole), když je velikost pole menší nebo rovna 255

Text

Stejná jako velikost pole SQL Serveru

nchar (velikost pole), když je velikost pole větší než 255

Memo

ntext

Memo

numeric (přesnost, měřítko)

Číslo

Desetinné číslo (vlastnosti Accessu Přesnost a Měřítko odpovídají přesnosti a měřítku SQL Serveru)

nvarchar (velikost pole), když je velikost pole menší nebo rovna 255

Text

Stejná jako velikost pole SQL Serveru

nvarchar (velikost pole), když je velikost pole větší než 255

Memo

nvarchar (MAX)

Memo

real

Číslo

Jednoduchá přesnost

smalldatetime

Datum a čas

smallint

Číslo

Celé číslo

smallmoney

Měna

sql_variant

Text

255

text

Memo

timestamp

Binární

8

tinyint

Číslo

Bajt

uniqueidentifier

Číslo

Replikační identifikátor

varbinary

Binární

Stejná jako velikost pole SQL Serveru

varbinary (MAX)

Objekt OLE

varchar (velikost pole), když je velikost pole menší nebo rovna 255

Text

Stejná jako velikost pole SQL Serveru

varchar (velikost pole), když je velikost pole větší než 255

Memo

varchar (MAX)

Memo

xml

Memo

S daty uloženými na SQL Serveru se dá pracovat tak, že je propojíte nebo naimportujete do databáze Accessu. Propojení je lepší volbou v případě, kdy data sdílíte s dalšími osobami, protože jsou uložená v jednom centrálním úložišti a vy tak můžete zobrazit aktuální hodnoty dat, přidávat nebo upravovat záznamy a spouštět dotazy a sestavy v Accessu.

Poznámka :  Tento článek se nevztahuje na aplikace pro Access (to je nový druh databází, které se navrhují v Accessu a publikují online). Další informace najdete v tématu Vytvoření aplikace pro Access.

Krok 1: Příprava na propojení

  1. Vyhledejte databázi systému SQL Server, kterou chcete připojit. Informace o připojení si v případě potřeby vyžádejte od správce databáze.

  2. Určete tabulky a zobrazení, ke kterým chcete v databázi SQL vytvořit propojení. V rámci jedné operace lze vytvořit propojení k několika objektům.

Zkontrolujte zdrojová data a mějte na paměti následující požadavky:

  • Access podporuje nejvíce 255 polí v tabulce, takže propojená tabulka bude obsahovat pouze prvních 255 polí propojeného objektu.

  • Sloupce, které jsou v tabulce SQL Serveru určené jen pro čtení, budou určené jen pro čtení taky v Accessu

  1. Postup vytvoření propojené tabulky v nové databázi: Klikněte na Soubor > Nový>Prázdná databáze. Pokud chcete vytvořit propojené tabulky ve stávající databázi Accessu, zkontrolujte, jestli máte nezbytná oprávnění pro přidávání dat do databáze.

    Poznámka :  Propojená tabulka ve stávající databázi Accessu bude mít stejný název jako zdrojový objekt. Pokud již tabulka s tímto názvem existuje, bude k názvu nové tabulky přidána číslice „1“  – například Kontakty1. (A pokud by již existovala tabulka Kontakty1, Access vytvoří tabulku Kontakty2 atd.)

Krok 2: Propojení dat

Při propojení tabulky nebo zobrazení v databázi systému SQL Server vytvoří Access novou tabulku (označovanou jako propojená tabulka), do které se promítne struktura a obsah zdrojové tabulky. Data pak můžete měnit buď v systému SQL Server, nebo v zobrazení Datový list či Formulář v Accessu. Změny dat, které provedete na jednom místě, se projeví na druhém. Jakékoli strukturální změny propojených tabulek, například odebrání nebo změna sloupců, je však nutné provést v databázi systému SQL Server, ne v Accessu.

  1. Otevřete cílovou databázi Accessu.

  2. Na kartě Externí data klikněte na Databáze ODBC.

  3. Klikněte na Vytvořit odkaz na zdroj dat vytvořením propojené tabulky > OK a postupujte podle pokynů v průvodci. Pokud už v dialogovém okně Vybrat zdroj dat existuje soubor .dsn, který chcete použít, klikněte v seznamu na tento soubor.

    Vytvoření nového souboru .dsn:

    V seznamu Vybrat zdroj dat klikněte na Nový> SQL Server > Další.

    1. Zadejte název souboru .dsn nebo klikněte na Procházet.

      Poznámka : U složky, do které chcete soubor .dsn uložit, musíte mít oprávnění k zápisu.

    2. Klikněte na Další, zkontrolujte souhrnné informace a klikněte na Dokončit.

      Postupujte podle pokynů v průvodci Vytvořit nový zdroj dat pro SQL Server.

  4. Klikněte na OK a v části Tabulky klikněte na všechny tabulky nebo zobrazení, které chcete importovat. Pak klikněte na tlačítko OK.

Když se zobrazí dialogové okno Volba jedinečného identifikátoru záznamu, nebyla Access schopen určit, která pole slouží k jedinečné identifikaci každého řádku zdrojových dat. V takovém případě vyberte pole nebo kombinaci polí, která jsou pro každý řádek jedinečná. Pokud si nejste jisti, požádejte o pomoc správce databáze systému SQL Server.

Po dokončení propojení uvidíte novou propojenou tabulku (nebo tabulky) v navigačním podokně.

Použití nejnovější struktury objektu SQL Serveru

Při otevření propojené tabulky nebo zdrojového objektu se zobrazí nejnovější data. Strukturální změny provedené u objektu SQL Serveru se však v propojené tabulce neprojevují automaticky, musíte propojenou tabulku aktualizovat.

  1. Klikněte pravým tlačítkem myši na tabulku v navigačním podokně a poté klikněte na příkaz Správce propojených tabulek v místní nabídce.

  2. Zaškrtněte políčko vedle každé propojené tabulky, kterou chcete aktualizovat, nebo kliknutím na možnost Vybrat vše vyberte všechny propojené tabulky.

  3. Klikněte na OK > Zavřít.

Poznámka : Datové typy Accessu jsou jiné než datové typy SQL Serveru, a proto si Access pro každý sloupec zvolí nejbližší odpovídající datový typ. Přiřazené datové typy můžete v Accessu jen číst, nemůžete je změnit.

Další informace najdete v článku o způsobech sdílení databáze Access v klientských počítačích.

Začátek stránky

Pokud vaše oddělení nebo pracovní skupina používá k ukládání dat Microsoft SQL Server, budete pravděpodobně muset pracovat s některými daty SQL Serveru v Accessu.

Data z objektů SQL Serveru (tabulek nebo zobrazení) je možné přenést do Accessu dvěma způsoby – importem nebo propojením. Rozdíl mezi těmito dvěma procesy je následující:

  • Při importu dat Access vytvoří kopii dat SQL Serveru a žádné pozdější změny provedené s daty v databázi Accessu se neprojeví v databázi SQL Serveru. Stejně tak se žádné pozdější změny provedené v tabulce nebo v zobrazení SQL Serveru neprojeví v Accessu.

  • Když se připojíte k datům SQL Serveru, připojujete se přímo ke zdrojovým datům, takže jakékoli změny dat provedené později v Accessu se projeví v SQL Serveru a naopak.

Tento článek popisuje, jak importovat nebo jak se připojit k datům SQL Serveru.

Rozhodování mezi importem a propojením

Situace, kdy je vhodný import

Data SQL Serveru se obvykle importují do databáze Accessu z těchto důvodů:

  • Pokud chcete trvale přesunout data SQL Serveru do databáze Accessu, protože už nepotřebujete mít data v databázi SQL Serveru. Po importu dat do Accessu je můžete odstranit z databáze SQL Serveru.

  • Vaše oddělení nebo pracovní skupina používá Access, ale občas jste odkázáni na databázi SQL Serveru obsahující další data, která je nutné sloučit do jedné z vašich databází Accessu.

Vzhledem k tomu, že import dat SQL Serveru vytvoří kopii dat v databázi Accessu, během procesu importu určíte tabulky nebo zobrazení, které chcete zkopírovat.

Situace, kdy je vhodné propojení

K datům SQL Serveru se obvykle připojujete z těchto důvodů:

  • Pokud se chcete připojit přímo ke zdrojovým datům, abyste mohli zobrazit nebo upravovat nejnovější informace v databázi SQL Serveru i v databázi Accessu.

  • Databáze SQL Serveru obsahuje mnoho velkých tabulek a nebude možné je importovat všechny do jednoho souboru .accdb. Maximální velikost databáze Accessu jsou 2 gigabajty zmenšené o prostor potřebný pro systémové objekty.

  • Připojení z SQL Serveru zvažte v případě, když chcete spouštět dotazy a generovat sestavy založené na datech z SQL Serveru, aniž byste museli vytvářet kopii dat.

  • Ve vašem oddělení nebo pracovní skupině používáte Access k vytváření sestav a zadávání dotazů a SQL Server k ukládání dat. Jednotlivé týmy mohou vytvářet tabulky a zobrazení SQL Serveru pro centralizované úložiště, ale často je nutné data přenést do desktopových aplikací za účelem agregace a vytváření sestav. K těmto účelům je vhodné použít propojení, protože umožňuje přidávat a aktualizovat data uživatelům databáze SQL Serveru i uživatelům databáze Accessu a zajišťuje aktuálnost dat.

  • Jste uživatelem Accessu, který teprve nedávno začal používat SQL Server. Po migraci několika databází na SQL Server tvoří většinu tabulek v těchto databázích propojené tabulky. Od této chvíle nebudete vytvářet tabulky Accessu, ale tabulky a zobrazení v SQL Serveru, ke kterým se potom připojíte ze svých databází Accessu.

  • Dál chcete ukládat seznamy na SQL Serveru, ale chcete také používat aktuální data v Accessu ke spouštění dotazů a tisku sestav navržených v Accessu.

Začátek stránky

Import dat z SQL Serveru

Příprava na import

Během operace importu Access vytvoří tabulku a potom do ní zkopíruje data z databáze SQL Serveru. Na konci operace importu můžete uložit podrobnosti operace importu jako specifikaci.

Poznámka : Specifikace importu pomáhá v budoucnu zopakovat stejnou operaci importu, aniž by bylo nutné pokaždé procházet všemi kroky průvodce importem.

  1. Vyhledejte databázi SQL Serveru obsahující data, která chcete importovat. Kontaktujte správce databáze a požádejte ho o informace o připojení.

  2. Určete, které tabulky nebo zobrazení chcete importovat. V jedné operaci importu můžete importovat více objektů.

  3. Zkontrolujte zdrojová data a mějte na paměti následující požadavky:

    • Access nepodporuje více než 255 polí v tabulce, takže může importovat jenom prvních 255 sloupců.

    • Maximální velikost databáze Accessu jsou 2 gigabajty zmenšené o prostor potřebný pro systémové objekty. Pokud databáze SQL Serveru obsahuje mnoho velkých tabulek, může se stát, že je nebude možné importovat všechny do jednoho souboru .accdb. V takovém případě zvažte propojení dat do databáze Accessu.

    • Access na konci operace importu nevytváří automaticky relace mezi souvisejícími tabulkami. Relace mezi různými novými a stávajícími tabulkami je nutné vytvořit ručně pomocí možností v okně Relace. Okno Relace zobrazíte takto:

      • Klikněte na kartu Soubor a potom na kartě Informace klikněte na Relace.

  4. Určete databázi Accessu, do které chcete data SQL Serveru importovat.

    Zkontrolujte, že máte potřebná oprávnění k přidávání dat do databáze Accessu. Pokud data nechcete uložit do žádné z existujících databází, vytvořte prázdnou databázi kliknutím na kartu Soubor a potom na kartě Nový kliknutím na Prázdná databáze.

  5. Zkontrolujte tabulky v databázi Accessu, pokud nějaké existují.

    Operace importu vytvoří tabulku se stejným názvem, jako má objekt SQL Serveru. Pokud se tento název už používá, Access k novému názvu tabulky připojí číslici 1 – například Kontakty1. (Pokud se už název Kontakty1 používá, Access vytvoří tabulku Kontakty2 atd.)

    Poznámka : Access při operaci importu nikdy nepřepíše tabulku v databázi ani nemůžete ke stávající tabulce připojit data SQL Serveru.

Import dat

  1. Otevřete cílovou databázi.

    Na kartě Externí data klikněte ve skupině Importovat a propojit na Databáze ODBC.

  2. Klikněte na přepínač Importovat zdrojová data do nové tabulky v aktuální databázi a klikněte na OK.

  3. Pokud už soubor .dsn, který chcete použít, existuje, klikněte v dialogovém okně Vybrat zdroj dat na soubor v seznamu.

    Potřebuji vytvořit nový soubor .dsn

    Poznámka : Kroky v tomto postupu se můžou mírně lišit podle softwaru, který máte nainstalovaný na počítači.

    1. Kliknutím na Nový vytvořte nový název zdroje dat.

      Otevře se průvodce vytvořením nového zdroje dat.

    2. V průvodci vyberte ze seznamu ovladačů SQL Server a pak klikněte na Další.

    3. Zadejte název souboru .dsn. Pokud chcete soubor uložit do jiného umístění, klikněte na Procházet.

      Poznámka : U složky, do které chcete soubor .dsn uložit, musíte mít oprávnění k zápisu.

    4. Klikněte na Další, zkontrolujte souhrnné informace a kliknutím na Dokončit dokončete průvodce.

      Zobrazí se dialogové okno Vytvořit nový zdroj dat pro SQL Server.

    5. Do pole Popis zadejte popis zdroje dat. Tento krok je nepovinný.

    6. V části Ke kterému serveru SQL Server se chcete připojit v poli Server zadejte nebo vyberte název SQL Serveru, ke kterému chcete připojit, a potom pokračujte kliknutím na Další.

    7. Je možné, že budete potřebovat informace od správce databáze SQL Serveru, například jestli použít ověřování systému Microsoft Windows NT nebo ověřování SQL Serveru. Pokračujte kliknutím na Další.

    8. Pokud se chcete připojit ke konkrétní databázi, musí být zaškrtnuté políčko Změnit výchozí databázi na. Potom vyberte databázi, se kterou chcete pracovat, a klikněte na Další.

    9. Klikněte na Dokončit.

    10. Zkontrolujte souhrnné informace a klikněte na Test zdroje dat.

    11. Prohlédněte si výsledky testu a potom kliknutím na OK zavřete dialogové okno.

      Pokud test proběhl úspěšně, klikněte znovu na OK nebo klikněte na Zrušit a změňte nastavení.

  4. Kliknutím na OK zavřete dialogové okno Vybrat zdroj dat.

    Access zobrazí dialogové okno Importovat objekty.

  5. V části Tabulky klikněte na všechny tabulky nebo zobrazení, které chcete importovat. Pak klikněte na OK.

  6. Když se zobrazí dialogové okno Vybrat identifikátor jedinečných záznamů, nebyl Access schopen určit, která pole slouží k jedinečné identifikaci každého řádku konkrétního objektu. V takovém případě vyberte pole nebo kombinaci polí, která jsou pro každý řádek jedinečná, a pak klikněte na OK. Pokud si nejste jisti, požádejte o pomoc správce databáze SQL Serveru.

    Access naimportuje data. Pokud máte v úmyslu operaci importu později opakovat, můžete uložit kroky importu jako specifikaci importu a později snadno znovu spustit stejné kroky importu. Abyste mohli vytvořit úkol, musíte mít na počítači nainstalovaný Microsoft Office Outlook.

  7. V dialogovém okně Načíst externí data – Databáze ODBC v části Uložit kroky importu klikněte na Zavřít. Access dokončí operaci importu a zobrazí novou tabulku nebo tabulky v navigačním podokně.

Pokud chcete uložit import jako úkol pro opakované použití, pokračujte k další části.

Začátek stránky

Uložení a použití nastavení importu

Poznámka : Abyste mohli vytvořit úkol, musíte mít nainstalovaný Microsoft Office Outlook.

  1. V části Uložit kroky importu v dialogovém okně Načíst externí data – Databáze ODBC zaškrtněte políčko Uložit kroky importu. Zobrazí se další ovládací prvky.

  2. Do pole Uložit jako zadejte název specifikace importu.

  3. Do pole Popis napište popis. Tento krok je nepovinný.

  4. Pokud chcete operaci provádět v pravidelných intervalech (například každý týden nebo měsíc), zaškrtněte políčko Vytvořit úkol aplikace Outlook. Tím vytvoříte úkol v aplikaci Microsoft Outlook 2010, pomocí kterého můžete specifikaci spustit.

  5. Klikněte na tlačítko Uložit import.

Pokud není Outlook nainstalovaný, Access po kliknutí na Uložit import zobrazí chybovou zprávu.

Poznámka : Pokud není Outlook 2010 správně nakonfigurovaný, spustí se Průvodce spuštěním aplikace Microsoft Outlook 2010. Podle pokynů v průvodci Outlook nakonfigurujte.

Volitelně můžete vytvořit úkol Outlooku. Vytvořit úkol v Outlooku může být užitečné, pokud chcete spouštět operaci importu v pravidelných nebo opakujících se intervalech. Access ale specifikaci uloží i v případě, že úkol nevytvoříte.

Vytvoření úkolu aplikace Outlook

Pokud jste zaškrtli políčko Vytvořit úkol aplikace Outlook, Access spustí Office Outlook 2010 a zobrazí se nový úkol. Pokud chcete úkol konfigurovat, postupujte takto:

Poznámka : Pokud není Outlook nainstalovaný, zobrazí Access chybovou zprávu. Pokud Outlook není správně nakonfigurovaný, spustí se Průvodce konfigurací aplikace Outlook. Nakonfigurujte aplikaci Outlook podle pokynů v průvodci.

  1. Zkontrolujte a upravte nastavení úkolu, například polí Datum zahájení, Termín splnění a Připomenutí.

    Pokud chcete nastavit úkol importu jako opakovanou událost, klikněte na Opakování a vyplňte příslušné informace.

  2. Klikněte na Uložit a zavřít.

Spuštění uloženého úkolu

  1. V navigačním podokně aplikace Outlook klikněte na tlačítko Úkoly a potom poklikejte na úkol, který chcete spustit.

  2. Ve skupině Microsoft Access na kartě Úkol klikněte na Spustit import.

  3. Přejděte zpátky do okna Accessu a stisknutím klávesy F5 aktualizujte navigační podokno.

  4. Poklikáním na importovanou tabulku ji otevřete v zobrazení Datový list.

  5. Zkontrolujte, že se naimportovala všechna pole a záznamy a že v nich nejsou žádné chyby.

  6. Klikněte pravým tlačítkem myši na naimportovanou tabulku v navigačním podokně a potom v místní nabídce klikněte na Návrhové zobrazení. Zkontrolujte datové typy polí a další vlastnost polí.

Začátek stránky

Propojení s daty SQL Serveru

Vzhledem k tomu, že jsou data uložená v tabulkách, vytvoří Access po tom, co se připojíte k tabulce nebo zobrazení v databázi SQL Serveru, novou tabulku (často se jí říká také propojená tabulka), která zachovává strukturu a obsah zdrojového objektu. Data můžete změnit na SQL Serveru nebo v Accessu v zobrazení Datový list nebo ve Formulářovém zobrazení. Změny, které jste v datech udělali na jednom místě, se projeví i na druhém místě. Pokud ale chcete provést změny struktury, například odebrat nebo změnit sloupce, musíte to udělat v databázi SQL Serveru nebo v projektu Accessu, který je připojený k této databázi. Při práci v Accessu není možné přidávat, odstraňovat ani měnit pole v propojené tabulce.

Příprava na propojení

  1. Vyhledejte databázi SQL Serveru obsahující data, která chcete propojit. Informace o připojení si vyžádejte od správce databáze.

  2. Určete tabulky a zobrazení, ke kterým se chcete připojit. V jedné operaci připojení se můžete připojit k více objektům.

  3. Zkontrolujte zdrojová data a mějte na paměti následující požadavky:

    • Access nepodporuje více než 255 polí v tabulce, takže propojená tabulka bude obsahovat jenom prvních 255 polí propojeného objektu.

    • Sloupce, které jsou v objektu SQL Serveru určeném jen pro čtení, budou nadále určené jen pro čtení také v Accessu.

    • Nebudete moct přidávat, odstraňovat nebo měnit sloupce propojené tabulky v Accessu.

  4. Určete databázi Accessu, ve které chcete vytvořit propojené tabulky. Zkontrolujte, že máte potřebná oprávnění k přidávání dat do databáze. Pokud nechcete data ukládat do žádné ze stávajících databází, vytvořte novou prázdnou databázi kliknutím na kartu Soubor a potom na kartě Nový kliknutím na Prázdná databáze.

  5. Prohlédněte si vytvořené tabulky v databázi Accessu. Když se připojujete k tabulce nebo zobrazení SQL Serveru, Access vytvoří propojenou tabulku, která bude mít stejný název jako zdrojový objekt. Pokud už se tento název používá, Access připojí k názvu nové tabulky číslici 1 – například Kontakty1. (Pokud se už používá i název Kontakty1, Access vytvoří tabulku Kontakty2 atd.)

  6. Pokud chcete vytvořit propojení s daty, otevřete cílovou databázi.

  7. Na kartě Externí data klikněte ve skupině Importovat a propojit na Databáze ODBC.

  8. Klikněte na Vytvořit odkaz na zdroj dat vytvořením propojené tabulky a potom klikněte na OK.

  9. V dialogovém okně Vybrat zdroj dat klikněte na soubor .dsn, který chcete použít, nebo kliknutím na Nový vytvořte nový název zdroje dat.

  10. Pokud už soubor .dsn, který chcete použít, existuje, klikněte v dialogovém okně Vybrat zdroj dat na soubor v seznamu.

    Potřebuji vytvořit nový soubor .dsn

    Poznámka : Kroky v tomto postupu se můžou mírně lišit podle softwaru, který máte nainstalovaný na počítači.

    1. Kliknutím na Nový vytvořte nový název zdroje dat.

      Otevře se průvodce vytvořením nového zdroje dat.

    2. V průvodci vyberte ze seznamu ovladačů SQL Server a pak klikněte na Další.

    3. Zadejte název souboru .dsn. Pokud chcete soubor uložit do jiného umístění, klikněte na Procházet.

      Poznámka : U složky, do které chcete soubor .dsn uložit, musíte mít oprávnění k zápisu.

    4. Klikněte na Další, zkontrolujte souhrnné informace a kliknutím na Dokončit dokončete průvodce Vytvořit nový zdroj dat.

      Spustí se průvodce Vytvořit nový zdroj dat pro SQL Server.

    5. V průvodci zadejte do pole Popis popis zdroje dat. Tento krok je nepovinný.

    6. V části Ke kterému SQL Serveru se chcete připojit v poli Server zadejte nebo vyberte název počítače SQL Serveru, ke kterému chcete připojit, a potom pokračujte kliknutím na Další.

    7. Je možné, že na této stránce průvodce budete potřebovat informace od správce databáze SQL Serveru, například jestli použít ověřování systému Windows NT nebo ověřování SQL Serveru. Pokračujte kliknutím na Další.

    8. Na další stránce průvodce možná budete potřebovat získat další informace od správce databáze SQL Serveru. Pokud se chcete připojit ke konkrétní databázi, musí být zaškrtnuté políčko Změnit výchozí databázi na. Vyberte databázi SQL serveru, se kterou chcete pracovat, a potom klikněte na Další.

    9. Klikněte na Dokončit. Zkontrolujte souhrnné informace a potom klikněte na Test zdroje dat.

    10. Prohlédněte si výsledky testu a potom kliknutím na OK zavřete dialogové okno Test zdroje dat ODBC SQL Serveru.

      Pokud test proběhl úspěšně, dalším kliknutím na OK dokončete průvodce nebo se kliknutím na Zrušit vraťte do průvodce a změňte nastavení.

  11. Klikněte na OK.

    Access zobrazí dialogové okno Propojit tabulky.

  12. V části Tabulky klikněte na všechny tabulky nebo zobrazení, které chcete propojit. Pak klikněte na OK.

    1. Pokud se zobrazí dialogové okno Vybrat identifikátor jedinečných záznamů, nebyl Access schopen určit, která pole slouží k jedinečné identifikaci každého řádku zdrojových dat. V takovém případě vyberte pole nebo kombinaci polí, která jsou pro každý řádek jedinečná, a pak klikněte na OK. Pokud si nejste jisti, požádejte o pomoc správce databáze SQL Serveru.

Access dokončí operaci propojení a zobrazí novou propojenou tabulku nebo tabulky v navigačním podokně.

Důležité : Při každém otevření propojené tabulky nebo zdrojového objektu v nich uvidíte zobrazená nejnovější data. Strukturální změny provedené u objektu SQL Serveru se ale v propojené tabulce automaticky neprojeví.

Aktualizace propojené tabulky použitím nejnovější struktury objektu SQL Serveru

  1. Klikněte pravým tlačítkem myši na tabulku v navigačním podokně a poté klikněte na příkaz Správce propojených tabulek v místní nabídce.

  2. Zaškrtněte políčko vedle každé propojené tabulky, kterou chcete aktualizovat, nebo kliknutím na možnost Vybrat vše vyberte všechny propojené tabulky.

  3. Klikněte na OK.

    Pokud je aktualizace úspěšná, Access zobrazí příslušnou zprávu. V opačném případě Access zobrazí chybovou zprávu.

  4. Kliknutím na Zavřít zavřete Správce propojených tabulek.

Začátek stránky

Jak Access rozpoznává datové typy SQL Serveru

Protože se datové typy Accessu liší od datových typů SQL Serveru, musí Access určit svůj nejbližší odpovídající datový typ, který použijte pro všechny sloupce v každé tabulce nebo zobrazení SQL Serveru, kterou naimportujete nebo propojíte. Například sloupec SQL Serveru s datovým typem bit se do Accessu naimportuje nebo propojí jako sloupec s datovým typem Ano/Ne. Jiný příklad: Sloupec SQL Serveru datového typu nvarchar(255) (nebo menší) se naimportuje nebo propojí s datovým typem Text, ale sloupec datového typu nvarchar(256) (nebo větší) se naimportuje jako accessové pole Memo. Po dokončení operace importu nebo propojení můžete tabulku otevřít v návrhovém zobrazení a zkontrolovat, jaké datové typy Access přiřadil jejím polím. Datové typy polí v importovaných tabulkách můžete změnit. Nejde ale změnit datové typy polí v propojených tabulkách, kromě toho, že je můžete změnit v samotné databázi SQL Serveru nebo v projektu Accessu, který je připojený k této databázi.

V následující tabulce jsou uvedeny hlavní datové typy SQL Serveru. V druhém a třetím sloupci můžete vidět, jak Access jednotlivé typy interpretuje.

Datový typ SQL Serveru

Datový typ Accessu

Velikost pole Accessu

bigint

Text

255

binary( velikost pole )

Binary

Stejná jako velikost pole SQL Serveru

bit

Ano/Ne

char( velikost pole ), když je velikost pole menší nebo rovna 255

Text

Stejná jako velikost pole SQL Serveru

char( velikost pole ), když je velikost pole větší než 255

Memo

datetime

Datum a čas

decimal ( přesnost , měřítko )

Číslo

Desetinné číslo (vlastnosti Accessu Přesnost a Měřítko odpovídají přesnosti a měřítku SQL Serveru)

float

Číslo

Dvojitá přesnost

image

Objekt OLE

int

Číslo

Dlouhé celé číslo

money

Měna

nchar( velikost pole ), když je velikost pole menší nebo rovna 255

Text

Stejná jako velikost pole SQL Serveru

nchar( velikost pole ), když je velikost pole větší než 255

Memo

ntext

Memo

numeric( přesnost , měřítko )

Číslo

Desetinné číslo (vlastnosti Accessu Přesnost a Měřítko odpovídají přesnosti a měřítku SQL Serveru)

nvarchar( velikost pole ), když je velikost pole menší nebo rovna 255

Text

Stejná jako velikost pole SQL Serveru

nvarchar( velikost pole ), když je velikost pole větší než 255

Memo

nvarchar(MAX)

Memo

real

Číslo

Jednoduchá přesnost

smalldatetime

Datum a čas

smallint

Číslo

Celé číslo

smallmoney

Měna

sql_variant

Text

255

text

Memo

timestamp

Binary

8

tinyint

Číslo

Bajt

uniqueidentifier

Číslo

Replikační identifikátor

varbinary

Binary

Stejná jako velikost pole SQL Serveru

varbinary(MAX)

Objekt OLE

varchar( velikost pole ), když je velikost pole menší nebo rovna 255

Text

Stejná jako velikost pole SQL Serveru

varchar( velikost pole), když je velikost pole větší než 255

Memo

varchar(MAX)

Memo

xml

Memo

Začátek stránky

Pokud vaše oddělení nebo pracovní skupina používá k ukládání dat Microsoft SQL Server, můžete se setkat se scénáři, kdy budete muset pracovat s některými daty SQL Serveru v aplikaci Microsoft Office Access 2007.

Pokud SQL Server neznáte a chcete se dozvědět víc, navštivte domovskou stránku Microsoft SQL Serveru. Postupujte podle odkazu v části Viz také tohoto článku.

Data z objektů SQL Serveru (tabulek nebo zobrazení) je možné přenést do aplikace Office Access 2007 dvěma způsoby – importem nebo propojením. Pokud data importujete, kopírujete je do databáze Accessu. Všechny následně provedené změny dat v Accessu se neprojeví v databázi SQL Serveru. Stejně tak se žádné následné změny provedené v tabulce nebo v zobrazení SQL Serveru neprojeví v tabulce Accessu. Pokud naopak vytvoříte propojení s daty SQL Serveru, data zůstávají na počítači SQL Serveru a Access udržuje připojení k těmto datům. Všechny následné změny dat, které uděláte v Accessu, se projeví u dat SQL Serveru a všechny změny provedené v databázi SQL Serveru se projeví v propojené tabulce v Accessu.

Tento článek popisuje postup importu i propojení s daty SQL Serveru do aplikace Access 2007.

Import dat SQL Serveru

Import dat SQL Serveru vytvoří kopii dat v databázi Accessu. Při operaci importu zadáte tabulky nebo zobrazení, které chcete kopírovat.

Operace importu vytvoří tabulku v Accessu a potom do ní zkopíruje data z databáze SQL Serveru. Odkazy na další informace o tabulkách a strukturování databáze najdete v části Viz také.

Na konci importu můžete vybrat, že chcete podrobnosti o importu uložit jako specifikaci. Specifikace importu vám pomůže operaci později zopakovat, aniž byste museli pokaždé znovu procházet průvodce importem.

Nejčastější scénáře importu tabulky SQL Serveru do Accessu

Data SQL Serveru se obvykle importují do databáze Accessu z těchto důvodů:

  • Chcete trvale přesunout data SQL Serveru do databáze Accessu, protože už nepotřebujete mít data v databázi SQL Serveru. Data můžete importovat do Accessu a potom je odstranit z databáze SQL Serveru.

  • Vaše oddělení nebo pracovní skupina používá Access, ale občas jste odkázáni na databázi SQL Serveru obsahující další data, která je nutné sloučit do jedné z vašich databází Accessu.

Import dat SQL Serveru do databáze Accessu popisují následující kroky.

Příprava na operaci importu

  1. Vyhledejte databázi SQL Serveru obsahující data, která chcete zkopírovat. Kontaktujte správce databáze a požádejte ho o informace o připojení.

  2. Určete, které tabulky nebo zobrazení chcete zkopírovat do databáze Accessu. V jedné operaci importu můžete importovat více objektů.

  3. Zkontrolujte zdrojová data a mějte na paměti následující požadavky:

    • Access nepodporuje více než 255 polí v tabulce, takže může importovat jenom prvních 255 sloupců.

    • Maximální velikost databáze Accessu jsou 2 gigabajty zmenšené o prostor potřebný pro systémové objekty. Pokud databáze SQL Serveru obsahuje mnoho velkých tabulek, může se stát, že je nebude možné importovat všechny do jednoho souboru .accdb. V takovém případě zvažte propojení dat do databáze Accessu.

    • Access na konci operace importu nevytváří automaticky relace mezi souvisejícími tabulkami. Relace mezi různými novými a stávajícími tabulkami je nutné vytvořit ručně pomocí možností na kartě Relace. Zobrazení karty Relace:
      Na kartě Databázové nástroje klikněte ve skupině Zobrazit/Skrýt na tlačítko Relace. Obrázek tlačítka

  4. Určete databázi Accessu, do které chcete data SQL Serveru importovat.

    Zkontrolujte, že máte potřebná oprávnění k přidávání dat do databáze Accessu. Pokud data nechcete uložit do žádné z existujících databází, vytvořte prázdnou databázi kliknutím na tlačítko Microsoft Office Obrázek tlačítka Office a potom kliknutím na Nový .

  5. Zkontrolujte tabulky v databázi Accessu, pokud nějaké existují.

    Operace importu vytvoří tabulku se stejným názvem, jako má objekt SQL Serveru. Pokud se tento název už používá, Access k novému názvu tabulky připojí číslici 1 – například Kontakty1. (Pokud se už název Kontakty1 používá, Access vytvoří tabulku Kontakty2 atd.)

    Poznámka : Access při operaci importu nikdy nepřepíše tabulku v databázi ani nemůžete ke stávající tabulce připojit data SQL Serveru.

Import dat

  1. Otevřete cílovou databázi.

    Na kartě Externí data ve skupině Import klikněte na Více.

  2. Klikněte na Databáze ODBC Obrázek tlačítka .

  3. Klikněte na přepínač Importovat zdrojová data do nové tabulky v aktuální databázi a klikněte na OK.

  4. Pokud už soubor .dsn, který chcete použít, existuje, klikněte v dialogovém okně Vybrat zdroj dat na soubor v seznamu.

    Potřebuji vytvořit nový soubor .dsn

    Poznámka : Kroky v tomto postupu se můžou mírně lišit podle softwaru, který máte nainstalovaný na počítači.

    1. Kliknutím na Nový vytvořte nový název zdroje dat.
      Otevře se průvodce vytvořením nového zdroje dat.

    2. V průvodci vyberte ze seznamu ovladačů SQL Server a pak klikněte na Další.

    3. Zadejte název souboru .dsn. Pokud chcete soubor uložit do jiného umístění, klikněte na Procházet.

      Poznámka : U složky, do které chcete soubor .dsn uložit, musíte mít oprávnění k zápisu.

    4. Klikněte na Další, zkontrolujte souhrnné informace a kliknutím na Dokončit dokončete průvodce.
      Spustí se průvodce Vytvořit nový zdroj dat pro SQL Server.

    5. V průvodci zadejte do pole Popis popis zdroje dat. Tento krok je nepovinný.

    6. V části Ke kterému serveru SQL Server se chcete připojit v poli Server zadejte nebo vyberte název SQL Serveru, ke kterému chcete připojit, a potom pokračujte kliknutím na Další.

    7. Je možné, že na této stránce průvodce budete potřebovat informace od správce databáze SQL Serveru, například k určení, jestli použít ověřování systému Microsoft Windows NT nebo ověřování SQL Serveru. Pokračujte kliknutím na Další.

    8. Na další stránce průvodce možná budete potřebovat získat další informace od správce databáze SQL Serveru, abyste mohli pokračovat. Pokud se chcete připojit ke konkrétní databázi, musí být zaškrtnuté políčko Změnit výchozí databázi na. Potom vyberte databázi, se kterou chcete pracovat, a klikněte na Další.

    9. Klikněte na Dokončit. Zkontrolujte souhrnné informace a potom klikněte na Test zdroje dat.

    10. Prohlédněte si výsledky testu a potom kliknutím na OK zavřete dialogové okno Test zdroje dat ODBC SQL Serveru.

      Pokud test proběhl úspěšně, dalším kliknutím na OK dokončete průvodce nebo se kliknutím na Zrušit vraťte do průvodce a změňte nastavení.

  5. Kliknutím na OK zavřete dialogové okno Vybrat zdroj dat.

    Access zobrazí dialogové okno Importovat objekty.

  6. V části Tabulky klikněte na všechny tabulky nebo zobrazení, které chcete importovat. Pak klikněte na OK.

  7. Když se zobrazí dialogové okno Vybrat identifikátor jedinečných záznamů, nebyl Access schopen určit, která pole slouží k jedinečné identifikaci každého řádku konkrétního objektu. V takovém případě vyberte pole nebo kombinaci polí, která jsou pro každý řádek jedinečná, a pak klikněte na OK. Pokud si nejste jisti, požádejte o pomoc správce databáze SQL Serveru.

Access naimportuje data. Pokud máte v úmyslu operaci importu později opakovat, můžete uložit kroky importu jako specifikaci importu a později snadno znovu spustit stejné kroky importu. Přejděte na další části tohoto článku a dokončete tento úkol. Pokud podrobnosti o specifikaci importu nechcete uložit, v dialogovém okně Načíst externí data – Databáze ODBC, klikněte v části Uložit kroky importu na Zavřít. Access dokončí operaci importu a zobrazí novou tabulku (nebo tabulky) v navigačním podokně.

Uložení kroků importu jako specifikace

  1. V části Uložit kroky importu v dialogovém okně Načíst externí data – Databáze ODBC zaškrtněte políčko Uložit kroky importu.

    Zobrazí se další ovládací prvky.

  2. Do pole Uložit jako zadejte název specifikace importu.

  3. Do pole Popis napište popis. Tento krok je nepovinný.

  4. Pokud chcete operaci provádět v pravidelných intervalech (například každý týden nebo měsíc), zaškrtněte políčko Vytvořit úkol aplikace Outlook. Tím vytvoříte úkol v aplikaci Microsoft Office Outlook 2007, pomocí kterého můžete specifikaci spustit.

  5. Klikněte na tlačítko Uložit import.

Konfigurace úkolu v Outlooku

Pokud jste v předchozím postupu zaškrtli políčko Vytvořit úkol aplikace Outlook, Access spustí aplikaci Office Outlook 2007 a zobrazí se nový úkol. Pokud chcete úkol konfigurovat, použijte následující postup.

Poznámka : Pokud není Outlook nainstalovaný, zobrazí Access chybovou zprávu. Pokud Outlook není správně nakonfigurovaný, spustí se Průvodce konfigurací aplikace Outlook. Nakonfigurujte aplikaci Outlook podle pokynů v průvodci.

  1. V okně úkolů Outlooku zkontrolujte a upravte nastavení úkolu, například polí Termín splnění a Připomenutí.

    Pokud chcete úkol nastavit jako opakovaný, klikněte na Opakování a vyplňte požadované informace.

    Tento obrázek znázorňuje plánovač úkolů s některými typickými nastaveními.

    Plánovač úkolů aplikace Outlook

    Informace o plánování úkolů v Outlooku najdete v článku Naplánování operace importu nebo exportu.

  2. Jakmile budete mít úkoly v Outlooku nastavené, klikněte na kartě Úkol ve skupině Akce na Uložit a zavřít.

Spuštění uloženého úkolu

  1. V navigačním podokně aplikace Outlook klikněte na tlačítko Úkoly a potom poklikejte na úkol, který chcete spustit.

  2. Ve skupině Microsoft Office Access na kartě Úkol klikněte na Spustit import Obrázek tlačítka .

  3. Přejděte zpátky do okna Accessu a stisknutím klávesy F5 aktualizujte navigační podokno.

  4. Poklikáním na importovanou tabulku ji otevřete v zobrazení Datový list.

  5. Zkontrolujte, že se naimportovala všechna pole a záznamy a že v nich nejsou žádné chyby.

  6. Klikněte pravým tlačítkem myši na naimportovanou tabulku v navigačním podokně a potom v místní nabídce klikněte na Návrhové zobrazení. Zkontrolujte datové typy polí a další vlastnost polí.

Začátek stránky

Propojení s daty SQL Serveru

Propojení vám umožňuje připojit se k datům bez nutnosti tyto informace importovat, takže můžete zobrazit a upravovat nejnovější data v databázi SQL Serveru i ve vaší databázi Accessu bez vytváření a udržování kopie dat v Accessu. Pokud nechcete kopírovat data SQL Serveru do accessové databáze, ale místo toho chcete data používat ke spouštění dotazů a generování sestav založených na těchto datech, měli byste místo importu použít propojení.

Když se připojíte k tabulce nebo zobrazení v databázi SQL Serveru, Access vytvoří novou tabulku (často se jí říká také propojená tabulka), která zachovává strukturu a obsah zdrojového objektu. Data můžete změnit na SQL Serveru nebo v Accessu v zobrazení Datový list nebo ve Formulářovém zobrazení. Změny, které jste v datech udělali na jednom místě, se projeví i na druhém místě. Pokud ale chcete provést změny struktury, například odebrat nebo změnit sloupce, musíte to udělat v databázi SQL Serveru nebo v projektu Accessu, který je připojený k této databázi. Při práci v Accessu není možné přidávat, odstraňovat ani upravovat pole v propojené tabulce.

Pokud databáze SQL Serveru obsahuje velké množství dat, měli byste místo importu použít spíš propojení, protože maximální velikost databáze Accessu jsou 2 gigabajty (zmenšené o prostor potřebný pro systémové objekty). Při importu mnoha velkých tabulek nebo zobrazení může dojít k překročení tohoto omezení, zatímco připojení k datům velikost vaší accessové databáze příliš nezvětší.

Obvyklé scénáře propojení s daty SQL Serveru

K tabulce nebo zobrazení SQL Serveru se připojujete z databáze Accessu obvykle z těchto důvodů:

  • Ve vašem oddělení nebo pracovní skupině používáte Access k vytváření sestav a zadávání dotazů a SQL Server k ukládání dat. Jednotlivé týmy mohou vytvářet tabulky a zobrazení SQL Serveru pro centralizované úložiště, ale často je nutné data přenést do desktopových aplikací za účelem agregace a vytváření sestav. K těmto účelům je vhodné použít propojení, protože umožňuje přidávat a aktualizovat data uživatelům databáze SQL Serveru i uživatelům databáze Accessu a zajišťuje aktuálnost dat.

  • Jste uživatelem Accessu, který teprve nedávno začal používat SQL Server. Po migraci několika databází na SQL Server tvoří většinu tabulek v těchto databázích propojené tabulky. Od této chvíle nebudete vytvářet tabulky Accessu, ale tabulky a zobrazení v SQL Serveru, ke kterým se potom připojíte ze svých databází Accessu.

  • Dál chcete ukládat seznamy na SQL Serveru, ale chcete také používat aktuální data v Accessu ke spouštění dotazů a tisku sestav navržených v Accessu.

Příprava na propojení tabulky SQL serveru

  1. Vyhledejte databázi SQL Serveru obsahující data, která chcete propojit. Informace o připojení si vyžádejte od správce databáze.

  2. Určete tabulky a zobrazení, ke kterým se chcete připojit. V jedné operaci připojení se můžete připojit k více objektům.

  3. Zkontrolujte zdrojová data a mějte na paměti následující požadavky:

    • Access nepodporuje více než 255 polí v tabulce, takže propojená tabulka bude obsahovat jenom prvních 255 polí propojeného objektu.

    • Sloupce, které jsou v objektu SQL Serveru určeném jen pro čtení, budou nadále určené jen pro čtení také v Accessu.

    • Nebudete moct přidávat, odstraňovat nebo měnit sloupce propojené tabulky v Accessu.

  4. Určete databázi Accessu, ve které chcete vytvořit propojené tabulky. Zkontrolujte, že máte potřebná oprávnění k přidávání dat do databáze. Pokud nechcete data ukládat do žádné ze stávajících databází, vytvořte novou prázdnou databázi pomocí následujícího příkazu:

    Klikněte na tlačítko Microsoft Office Obrázek tlačítka Office a potom klikněte na Nový.

  5. Prohlédněte si vytvořené tabulky v databázi Accessu. Když se připojujete k tabulce nebo zobrazení SQL Serveru, Access vytvoří propojenou tabulku, která bude mít stejný název jako zdrojový objekt. Pokud už se tento název používá, Access připojí k názvu nové tabulky číslici 1 – například Kontakty1. (Pokud se už používá i název Kontakty1, Access vytvoří tabulku Kontakty2 atd.)

Propojení s daty

  1. Otevřete cílovou databázi.

  2. Na kartě Externí data ve skupině Import klikněte na Více.

  3. Klikněte na Databáze ODBC.

  4. Klikněte na Vytvořit odkaz na zdroj dat vytvořením propojené tabulky a potom klikněte na OK.

  5. V dialogovém okně Vybrat zdroj dat klikněte na soubor .dsn, který chcete použít, nebo kliknutím na Nový vytvořte nový název zdroje dat.

  6. Pokud už soubor .dsn, který chcete použít, existuje, klikněte v dialogovém okně Vybrat zdroj dat na soubor v seznamu.

    Potřebuji vytvořit nový soubor .dsn

    Poznámka : Kroky v tomto postupu se můžou mírně lišit podle softwaru, který máte nainstalovaný na počítači.

    1. Kliknutím na Nový vytvořte nový název zdroje dat.
      Otevře se průvodce vytvořením nového zdroje dat.

    2. V průvodci vyberte ze seznamu ovladačů SQL Server a pak klikněte na Další.

    3. Zadejte název souboru .dsn. Pokud chcete soubor uložit do jiného umístění, klikněte na Procházet.

      Poznámka : U složky, do které chcete soubor .dsn uložit, musíte mít oprávnění k zápisu.

    4. Klikněte na Další, zkontrolujte souhrnné informace a potom kliknutím na Dokončit dokončete průvodce Vytvořit nový zdroj dat.
      Spustí se průvodce Vytvořit nový zdroj dat pro SQL Server.

    5. V průvodci zadejte do pole Popis popis zdroje dat. Tento krok je nepovinný.

    6. V části Ke kterému SQL Serveru se chcete připojit v poli Server zadejte nebo vyberte název počítače SQL Serveru, ke kterému chcete připojit, a potom pokračujte kliknutím na Další.

    7. Je možné, že na této stránce průvodce budete potřebovat informace od správce databáze SQL Serveru, například jestli použít ověřování systému Windows NT nebo ověřování SQL Serveru. Pokračujte kliknutím na Další.

    8. Na další stránce průvodce možná budete potřebovat získat další informace od správce databáze SQL Serveru. Pokud se chcete připojit ke konkrétní databázi, musí být zaškrtnuté políčko Změnit výchozí databázi na. Vyberte databázi SQL serveru, se kterou chcete pracovat, a potom klikněte na Další.

    9. Klikněte na Dokončit. Zkontrolujte souhrnné informace a potom klikněte na Test zdroje dat.

    10. Prohlédněte si výsledky testu a potom kliknutím na OK zavřete dialogové okno Test zdroje dat ODBC SQL Serveru.

      Pokud test proběhl úspěšně, dalším kliknutím na OK dokončete průvodce nebo se kliknutím na Zrušit vraťte do průvodce a změňte nastavení.

  7. Klikněte na OK.
    Access zobrazí dialogové okno Propojit tabulky.

  8. V části Tabulky klikněte na všechny tabulky nebo zobrazení, které chcete propojit. Pak klikněte na OK.

  9. Pokud se zobrazí dialogové okno Vybrat identifikátor jedinečných záznamů, nebyl Access schopen určit, která pole slouží k jedinečné identifikaci každého řádku zdrojových dat. V takovém případě vyberte pole nebo kombinaci polí, která jsou pro každý řádek jedinečná, a pak klikněte na OK. Pokud si nejste jisti, požádejte o pomoc správce databáze SQL Serveru.

Access dokončí operaci propojení a zobrazí novou propojenou tabulku (nebo tabulky) v navigačním podokně.

Důležité : Při každém otevření propojené tabulky nebo zdrojového objektu v nich uvidíte zobrazená nejnovější data. Strukturální změny provedené u objektu SQL Serveru se ale v propojené tabulce automaticky neprojeví.


Aktualizace propojené tabulky použitím nejnovější struktury objektu SQL Serveru:

  1. Klikněte pravým tlačítkem myši na tabulku v navigačním podokně a poté klikněte na příkaz Správce propojených tabulek v místní nabídce.

  2. Zaškrtněte políčko vedle každé propojené tabulky, kterou chcete aktualizovat, nebo kliknutím na možnost Vybrat vše vyberte všechny propojené tabulky.

  3. Klikněte na OK.

    Pokud je aktualizace úspěšná, Access zobrazí příslušnou zprávu. V opačném případě Access zobrazí chybovou zprávu.

  4. Kliknutím na Zavřít zavřete Správce propojených tabulek.

Začátek stránky

Zjistěte, jak Access interpretuje datové typy SQL Serveru

Protože se datové typy Accessu liší od datových typů SQL Serveru, musí Access určit svůj nejbližší odpovídající datový typ, který použijte pro všechny sloupce v každé tabulce nebo zobrazení SQL Serveru, kterou naimportujete nebo propojíte. Například sloupec SQL Serveru s datovým typem bit se do Accessu naimportuje nebo propojí jako sloupec s datovým typem Ano/Ne. Jiný příklad: Sloupec SQL Serveru datového typu nvarchar(255) (nebo menší) se naimportuje nebo propojí do Accessu s datovým typem Text, ale sloupec datového typu nvarchar(256) (nebo větší) se do Accessu přenese jako pole Memo. Po dokončení operace importu nebo propojení byste měli tabulku otevřít v návrhovém zobrazení a zkontrolovat, jaké datové typy Access přiřadil jejím polím. Datové typy polí v importovaných tabulkách můžete měnit. V propojených tabulkách ale měnit nejdou. Můžete je změnit jenom v databázi SQL Serveru nebo v projektu Accessu, který je připojený k této databázi.

V následující tabulce jsou uvedeny hlavní datové typy SQL Serveru. V druhém a třetím sloupci můžete vidět, jak Access jednotlivé typy interpretuje.

Datový typ SQL Serveru

Datový typ Accessu

Velikost pole Accessu

bigint

Text

255

binary( velikost pole )

Binary

Stejná jako velikost pole SQL Serveru

bit

Ano/Ne

char( velikost pole ), když je velikost pole menší nebo rovna 255

Text

Stejná jako velikost pole SQL Serveru

char( velikost pole ), když je velikost pole větší než 255

Memo

datetime

Datum a čas

decimal ( přesnost , měřítko )

Číslo

Desetinné číslo (vlastnosti Accessu Přesnost a Měřítko odpovídají přesnosti a měřítku SQL Serveru)

float

Číslo

Dvojitá přesnost

image

Objekt OLE

int

Číslo

Dlouhé celé číslo

money

Měna

nchar ( velikost pole ), když je velikost pole menší nebo rovna 255

Text

Stejná jako velikost pole SQL Serveru

nchar ( velikost pole ), když je velikost pole větší než 255

Memo

ntext

Memo

numeric( přesnost , měřítko )

Číslo

Desetinné číslo (vlastnosti Accessu Přesnost a Měřítko odpovídají přesnosti a měřítku SQL Serveru)

nvarchar ( velikost pole ), když je velikost pole menší nebo rovna 255

Text

Stejná jako velikost pole SQL Serveru

nvarchar ( velikost pole ), když je velikost pole větší než 255

Memo

nvarchar (MAX)

Memo

real

Číslo

Jednoduchá přesnost

smalldatetime

Datum a čas

smallint

Číslo

Celé číslo

smallmoney

Měna

sql_variant

Text

255

text

Memo

timestamp

Binary

8

tinyint

Číslo

Bajt

uniqueidentifier

Číslo

Replikační identifikátor

varbinary

Binary

Stejná jako velikost pole SQL Serveru

varbinary (MAX)

Objekt OLE

varchar ( velikost pole ), když je velikost pole menší nebo rovna 255

Text

Stejná jako velikost pole SQL Serveru

varchar ( velikost pole), když je velikost pole větší než 255

Memo

varchar (MAX)

Memo

xml

Memo

Začátek stránky

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×