Import dat XML

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Pokud máte z dřívějška vytvořené mapování XML, můžete ho použít k importu dat XML do buněk, které jsou namapované. Existuje ale řada metod a příkazů, které vám umožní naimportovat data XML bez mapování XML.

Pokud máte mapování XML, naimportujete data XML do namapovaných buněk takto:

  1. V mapování XML vyberte jednu z namapovaných buněk.

  2. Klikněte na Vývojář > Import.

    Pokud se vám karta Vývojář nezobrazuje, přečtěte si téma Zobrazení karty Vývojář.

  3. V dialogovém okně Importovat XML vyhledejte a vyberte datový soubor XML (.xml), který chcete naimportovat, a klikněte na Importovat.

Další způsoby, jak naimportovat data XML

Další informace o problémech najdete v části Běžné problémy s importem dat XML na konci tohoto článku.

Naimportování datového souboru XML jako tabulky XML

  1. Klikněte na Vývojář > Import.

    Pokud se vám karta Vývojář nezobrazuje, přečtěte si téma Zobrazení karty Vývojář.

  2. V dialogovém okně Importovat XML vyhledejte a vyberte datový soubor XML (.xml), který chcete naimportovat, a klikněte na Importovat.

    Pokud datový soubor XML neodkazuje na schéma, Excel schéma odvodí z datového souboru XML.

  3. V dialogovém okně Importovat data udělejte jednu z těchto věcí:

    1. Možnost Tabulka XML v existujícím listu vyberte, když budete chtít naimportovat obsah z datového souboru XML do tabulky XML v listu na zadaném místě (určeném konkrétní buňkou).

    2. Možnost Tabulka XML v novém listu vyberte, když budete chtít naimportovat obsah souboru do tabulky XML na novém listu počínaje buňkou A1. V podokně úloh Zdroj XML se zobrazí schéma datového souboru XML.

  4. Pokud datový soubor XML neodkazuje na schéma, odvodí ho Excel z datového souboru XML.

  5. Pokud budete chtít nastavit chování dat XML (například vazby dat, formátování a rozložení), klikněte na možnost Vlastnosti, která zobrazí dialogové okno Vlastnosti mapování XML. Ve výchozím nastavení se například při importu dat přepíší stávající data v mapovaném rozsahu, můžete to ale změnit.

Naimportování několika datových souborů XML

  1. Vyberte namapovanou buňku pro import více souborů XML do jedné sady mapovaných buněk.

    Pokud chcete importovat více souborů XML do více sad mapovaných buněk, klikněte kdekoli na listu na buňku, která není namapovaná.

  2. Klikněte na Vývojář > Import.

    Pokud se vám karta Vývojář nezobrazuje, přečtěte si téma Zobrazení karty Vývojář.

  3. V dialogovém okně Importovat XML vyhledejte a vyberte datový soubor XML (.xml), který chcete naimportovat.

    • Pokud jsou tyto soubory hned pod sebou, stiskněte Shift a klikněte na první a poslední soubor v seznamu. Naimportují se všechna data ze souborů XML a připojí se k namapovaným buňkám.

    • Pokud soubory nejsou hned pod sebou, stiskněte a podržte Ctrl a klikněte na jednotlivé soubory v seznamu, které chcete naimportovat.

  4. Klikněte na Importovat.

    Pokud jste vybrali soubory, které nejsou v seznamu přímo pod sebou, zobrazí se dialogové okno Import <název_souboru>.xml . Vyberte mapování XML odpovídající datovému souboru XML, který pro jednotlivé soubory importujete.

    Pokud chcete pro všechny vybrané soubory, které ještě nejsou naimportované, použít jednoho mapování, klikněte na Použít toto mapování XML pro všechny vybrané soubory tohoto schématu.

Naimportování několika datových souborů XML jako externích dat

Pokud chcete naimportovat více souborů XML, které používají stejný obor názvů, ale rozdílná schémata XML, můžete použít příkaz Z importu dat XML. Excel pro každý datový soubor XML, který importujete, vytvoří jedinečné mapování XML.

Poznámka : Pokud importujete více souborů XML, které nedefinují obor názvů, zpracovávají se tyto soubory XML tak, jako kdyby používaly stejný obor názvů.

  1. Klikněte na Data > Z jiných zdrojů a potom klikněte na Z importu dat XML.

  2. Přejděte na disk, složku nebo umístění na internetu, kde je datový soubor XML (.xml), který chcete naimportovat.

  3. Vyberte požadovaný soubor a klikněte na tlačítko Otevřít.

  4. V dialogovém okně Importovat data udělejte jednu z těchto věcí:

    • Tabulka XML v existujícím listu:    Obsah souboru se naimportuje do nové tabulky XML v novém listu. Pokud datový soubor XML neodkazuje na schéma, Excel schéma odvodí z datového souboru XML.

    • Existující list:    Data XML se naimportují v podobě dvourozměrné tabulky s řádky a sloupci, ve které se jako záhlaví sloupců zobrazují značky XML a pod záhlavími sloupců se zobrazují data v řádcích. První element (kořenový uzel) se používá jako název a zobrazí se v zadaném umístění (určeném buňkou). Zbývající značky jsou seřazené podle abecedy ve druhém řádku. V tomto případě Excel schéma neodvodí a nebudete moct mapování XML použít.

    • Nový list:    Excel přidá do sešitu nový list a automaticky vloží data XML do levého horního rohu nového listu. Pokud datový soubor XML neodkazuje na schéma, Excel schéma odvodí z datového souboru XML.

  5. Pokud budete chtít nastavit chování dat XML (například vazby dat, formátování a rozložení), klikněte na možnost Vlastnosti, která zobrazí dialogové okno Vlastnosti mapování XML. Ve výchozím nastavení se například při importu dat přepíší stávající data v mapovaném rozsahu, můžete to ale změnit.

Otevření datového souboru XML pro naimportování dat, která obsahuje

  1. Klikněte na Soubor > Otevřít.

    Pokud používáte Excel 2007, klikněte na tlačítko Microsoft Office Obrázek tlačítka > Otevřít.

  2. V dialogovém okně Otevřít klikněte na disk, složku nebo umístění na internetu obsahující soubor, který chcete otevřít.  

  3. Vyberte požadovaný soubor a klikněte na tlačítko Otevřít.

  4. Pokud se zobrazí dialogové okno Importovat XML, odkazuje soubor, který jste otevřeli, na jednu nebo více šablon stylů XSL (Extensible Stylesheet Language), takže můžete kliknout na jednu z následujících možností:

    • Otevřít soubor bez použití šablony stylů:    Data XML se naimportují v podobě dvourozměrné tabulky s řádky a sloupci, ve kterých se jako záhlaví sloupců zobrazují značky XML a pod záhlavími sloupců se zobrazují data v řádcích. První element (kořenový uzel) se používá jako název a zobrazí se v zadaném umístění (určeném buňkou). Zbývající značky jsou seřazené podle abecedy ve druhém řádku. V tomto případě Excel schéma neodvodí a nebudete moct mapování XML použít.

    • Otevřít soubor s následující šablonou stylů (vyberte jednu předlohu):    Vyberte šablonu stylů, kterou chcete použít, a potom klikněte na OK. Data XML se naformátují podle šablony stylů, kterou jste vybrali.

      Poznámka : Data XML se v Excelu otevřou jen pro čtení, abyste omylem neuložili původní zdrojový soubor ve formátu souboru Sešit Excelu s podporou maker (.xlsm). V tomto případě Excel schéma neodvodí a nebudete moct mapování XML použít.

  5. Pokud se zobrazí dialogové okno Otevřít XML, znamená to, že soubor XML neobsahuje odkazy na žádné šablony stylů XSLT. Když budete chtít otevřít soubor, klikněte na jednu z následujících možností:

    • Na možnost Jako tabulku XML klikněte, když budete chtít vytvořit tabulku XML v novém sešitě.

      Obsah souboru se naimportuje do tabulky XML. Pokud datový soubor XML neodkazuje na schéma, Excel schéma odvodí z datového souboru XML.

    • Klikněte na Jako sešit jen pro čtení.

      Data XML se naimportují v podobě dvourozměrné tabulky s řádky a sloupci, ve které se jako záhlaví sloupců zobrazují značky XML a pod záhlavími sloupců se zobrazují data v řádcích. První element (kořenový uzel) se používá jako název a zobrazí se v zadaném umístění (určeném buňkou). Zbývající značky jsou seřazené podle abecedy ve druhém řádku. V tomto případě Excel schéma neodvodí a nebudete moct mapování XML použít.

      Data XML se v Excelu otevřou jen pro čtení, abyste omylem neuložili původní zdrojový soubor ve formátu souboru Sešit Excelu s podporou maker (.xlsm). V tomto případě Excel schéma neodvodí a nebudete moct mapování XML použít.

    • Klikněte na Použít podokno úloh Zdroj XML.

      V podokně úloh Zdroj XML se zobrazí schéma datového souboru XML. Potom můžete elementy schématu přetáhnout na list a pak tyto elementy na list namapovat.

      Pokud datový soubor XML neodkazuje na schéma, Excel schéma odvodí z datového souboru XML.

Běžné problémy s importem dat XML

Pokud Excel nemůže ověřit data podle mapování XML, zobrazí dialogové okno Chyba importu XML. V tomto dialogovém okně si kliknutím na Podrobnosti zobrazte další informace o jednotlivých chybách. Následující tabulka obsahuje některé z chyb, ke kterým při importu běžně dochází:

Chyba

Co se stalo

Ověření schématu se nezdařilo.

Když jste v dialogovém okně Vlastnosti mapování XML klikli na Ověřovat data vůči schématu pro import a export, data se naimportovala, ale neověřila se podle zadaného mapování XML.

Některá data byla importována jako text.

Některá nebo všechna data, která jste importovali, se převedla z jejich deklarovaného datového typu na text. Aby bylo možné tato data použít ve výpočtu, budete je muset převést z textu na čísla nebo kalendářní data. Například hodnota kalendářního data převedená na text nebude fungovat očekávaným způsobem ve funkci ROK, dokud ji nepřevedete na datový typ Datum. Excel převede data na text v těchto případech:

  • Data jsou ve formátu, který Excel nepodporuje.

  • Data nejsou kompatibilní s interní reprezentaci datového typu XSD v Excelu. Tento problém můžete vyřešit tak, že v jednotlivých deklaracích datového typu zkontrolujete, že jsou data XML platná podle schématu XML.

Chyba analýzy XML

Analyzátor XML nemůže otevřít zadaný soubor XML. Zkontrolujte, že v souboru XML nejsou syntaktické chyby a že je tento kód XML správně vytvořený.

Nebylo nalezeno mapování XML odpovídající těmto datům.

K tomuto problému může dojít, když pro import vyberete více než jeden datový soubor XML a aplikace Excel nemůže pro jeden ze souborů najít odpovídající mapování XML. Pro soubor, jehož název se zobrazuje v záhlaví dialogového okna, nejdříve naimportujte odpovídající schéma a pak zkuste soubor naimportovat znovu.

Velikost tabulky XML nelze změnit tak, aby obsahovala všechna požadovaná data.

Pokoušíte se přidat řádky naimportováním nebo přidáním dat do tabulky XML, na listu ale není místo pro rozšíření tabulky. Tabulka XML se může rozšířit jedině v dolní části směrem dolů. Přímo pod tabulkou XML může být nějaký objekt (například obrázek nebo jiná tabulka), který rozšíření tabulky XML brání. Nebo se může stát, že aby bylo možné tabulku XML rozšířit, musel by se překročit maximální limit počtu řádků v Excelu, který je 1 048 576. Tento problém můžete vyřešit tak, že změníte uspořádání tabulek a objektů na listu, aby se mohla tabulka XML dole rozšířit směrem dolů.

Zadaný zdroj dat XML neodkazuje na schéma.

Soubor XML, který se pokoušíte otevřít, neodkazuje na schéma XML. Aby bylo možné pracovat s daty XML, která jsou v souboru, bude Excel potřebovat schéma podle obsahu souboru XML. Pokud toto schéma není správné nebo je nedostatečné, odeberte ho ze sešitu. Potom vytvořte soubor schématu XML a upravte datový soubor XML tak, aby na schéma odkazoval. Další informace najdete v části Mapování elementů XML na buňky v mapování XML.

Poznámka : Schéma odvozené Excelem nemůžete vyexportovat jako samostatný datový soubor schématu XML (.xsd). Existují sice editory schémat XML a další metody pro vytváření souborů schémat XML, nebudou ale nejspíš snadno dostupné nebo byste nemuseli vědět, jak je použít.

Tímto postupem si schéma, které Excel vytvořil, odeberete ze sešitu:

  1. Klikněte na Vývojář > Zdroj.

    Příkazy XML na kartě Vývojář

    Pokud se vám karta Vývojář nezobrazuje, přečtěte si téma Zobrazení karty Vývojář.

  2. V podokně úloh Zdroj XML klikněte na Mapování XML.

  3. V dialogovém okně Mapování XML klikněte na mapování XML, které Excel vytvořil, a klikněte na Odstranit.

Import více souborů XML, které používají stejný obor názvů, ale různá schémata, nefunguje podle očekávání

V případě, že zpracováváte více datových souborů a schémat XML, obvykle vytvoříte mapování XML pro každé schéma, namapujete požadované elementy a pak každý datový soubor XML naimportujete do příslušného mapování XML. Když budete chtít pomocí příkazu Import otevřít více souborů XML se stejným oborem názvů, můžete použít jenom jedno schéma XML. Když tento příkaz použijete k otevření více souborů XML, které používají stejný obor názvů, ale různá schémata, může to vést k neočekávaným výsledkům. Můžou se například přepsat data nebo se soubory nemusí otevřít.

Pokud chcete naimportovat více souborů XML, které používají stejný obor názvů, ale rozdílná schémata XML, zkuste použít příkaz Z importu dat XML (klikněte na Data > Z jiných zdrojů). Tento příkaz umožňuje pro více souborů XML se stejným oborem názvů používat více schémat XML. Excel pro každý datový soubor XML, který chcete naimportovat, vytvoří jedinečné mapování XML.

Poznámka : Pokud importujete více souborů XML, které nedefinují obor názvů, zpracovávají se tyto soubory XML tak, jako kdyby používaly stejný obor názvů.

Zobrazení karty Vývojář

Pokud se vám karta Vývojář nezobrazuje, udělejte tohle:

  • V Excelu 2013 a Excelu 2010:

    1. Klikněte na Soubor > Možnosti.

    2. Klikněte na kategorii Přizpůsobit pás karet.

    3. V části Hlavní karty zaškrtněte políčko Vývojář a klikněte na OK.

  • V Excelu 2007:

    1. Klikněte na tlačítko Microsoft Office Obrázek tlačítka > Možnosti aplikace Excel.

    2. Klikněte na kategorii Oblíbené.

    3. V části Nejpoužívanější možnosti při práci s aplikací Excel zaškrtněte políčko Zobrazit na pásu kartu Vývojář a klikněte na OK.

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Viz taky

Přehled jazyka XML v Excelu

Mapování elementů XML na buňky v mapování XML

Export dat XML

Sdílení Facebook Facebook Twitter Twitter E-mail E-mail

Byly tyto informace užitečné?

Výborně! Je ještě něco dalšího, co byste nám chtěli dát vědět?

Jak bychom ho mohli vylepšit?

Děkujeme vám za zpětnou vazbu.

×