Import a propojení dat ze sešitu aplikace Excel

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Přenést data z Excelového sešitu do databáze aplikace Access mnoha různými způsoby. Můžete kopírovat data z otevřeného listu a vložte je do datového listu aplikace Access, import listu do nové nebo existující tabulky nebo propojení listu v databázi aplikace Access.

Toto téma podrobně vysvětluje, jak importovat nebo propojit data aplikace Excel z desktopové databáze Accessu.

  • Tento článek se nevztahuje na webových aplikací pro Access 2013. Další informace najdete v tématu Import dat do Accessové databáze.

  • Data nemůžete importovat během spuštění webové databáze Accessu 2010 v prohlížeči. Pokud chcete importovat data do webové databáze, musíte nejdřív otevřít webovou databázi pomocí Accessu.

  • Propojené tabulky nejsou kompatibilní s webovými databázemi Accessu 2010. Abyste mohli používat externí data ve webové databázi, musíte je importovat, ne propojit. Další informace o webových databázích najdete v článku Vytvoření accessové databáze pro sdílení na webu.

V tomto článku

Princip importu dat z Excelu

Import dat z Excelu:

Odstranění potíží s chybějícími nebo nesprávnými hodnotami

Propojení dat aplikace Excel

Odstranění potíží s hodnotou #ČÍSLO! a jinými nesprávnými hodnotami v propojené tabulce

Princip importu dat z aplikace Excel

Pokud je vaším cílem uložit některá nebo všechna data z jednoho nebo více listů aplikace Excel do aplikace Access, měli byste obsah listu naimportovat do nové nebo existující databáze aplikace Access. Aplikace Access vytvoří při importu dat kopii těchto dat v nové nebo existující tabulce, aniž by změnila zdrojový list aplikace Excel.

Obvyklé scénáře importu dat aplikace Excel do aplikace Access

  • Jste dlouhodobým uživatelem aplikace Excel, ale postupem času chcete pro práci s těmito daty používat aplikaci Access. Data na listech aplikace Excel chcete přesunout do jedné nebo více nových databází aplikace Access.

  • Vaše oddělení nebo pracovní skupina používá aplikaci Access, ale občas obdrží data ve formátu aplikace Excel, která je nutné sloučit s databází aplikace Access. Jakmile tyto listy aplikace Excel obdržíte, chcete je naimportovat do databáze.

  • Aplikaci Access používáte ke správě dat, ale týdenní zprávy získané od ostatních členů týmu jsou v podobě sešitů aplikace Excel. Rádi byste proces importu zefektivnili, abyste zajistili, že data se budou do databáze importovat každý týden v určenou dobu.

Před prvním importem dat z aplikace Excel

  • Neexistuje způsob, jak uložit sešit aplikace Excel jako databázi aplikace Access. Aplikace Excel neobsahuje funkci vytvoření databáze aplikace Access přímo z dat aplikace Excel.

  • Při otevření sešitu Excelu v Accessu (v dialogovém okně Otevřít vyberte v rozevíracím seznamu Soubory typu položku Soubory Microsoft Office Excel a vyberte požadovaný soubor) neprovede Access import dat ze sešitu, ale vytvoří propojení se sešitem. Propojení se sešitem se od importu listu do databáze podstatně liší. Další informace týkající se propojení najdete v části Propojení na data v Excelu uvedené dále v tomto článku.

Začátek stránky

Import dat z aplikace Excel

Postupy uvedené v této části popisují přípravu na operaci importu, spuštění této operace a uložení nastavení importu jako specifikace pro další použití. Při provádění těchto postupů je třeba mít na paměti, že data lze importovat vždy pouze z jednoho listu. Není možné najednou importovat všechna data z celého sešitu.

Příprava listu

  1. Zdrojový soubor vyhledejte a vyberte list obsahující data, která chcete importovat do aplikace Access. Pokud chcete importovat jenom část listu, můžete definovat pojmenovanou oblast, která obsahuje pouze buňky, které chcete importovat.

    Definování pojmenované oblasti (volitelné)   

    1. Přejděte do Excelu a otevřete list, který obsahuje data, která chcete importovat.

    2. Vyberte oblast buněk obsahující data, která chcete importovat.

    3. Pravým tlačítkem myši klikněte dovnitř vybrané oblasti a potom klikněte na příkaz Pojmenovat rozsah nebo Definovat název.

    4. V dialogovém okně Nový název zadejte do pole Název název pojmenované oblasti a klikněte na tlačítko OK.

      Nezapomeňte, že během operace importu lze importovat vždy jen jeden list. Chcete-li importovat data z více listů, opakujte operaci importu pro každý list.

  2. Prohlédněte si zdrojová data a proveďte akce popsané v následující tabulce.

Prvek

Popis

Počet sloupců

Počet zdrojových sloupců, které chcete importovat, nesmí překročit číslo 255, protože aplikace Access podporuje maximálně 255 polí v tabulce.

Vynechání sloupců a řádků

Je vhodné zahrnout pouze řádky a sloupce, které chcete naimportovat ze zdrojového listu nebo pojmenované oblasti.

Řádky:    Během operace importu nelze řádky filtrovat nebo vynechávat.

Sloupce:    Jestliže se rozhodnete přidávat data do existující tabulky, nemůžete v průběhu operace vynechávat sloupce.

Formát tabulky

Přesvědčte se, zda jsou buňky ve formátu tabulky. Pokud list nebo pojmenovaná oblast obsahuje sloučené buňky, bude obsah těchto buněk umístěn do pole odpovídajícího sloupci zcela vlevo a ostatní pole zůstanou prázdná.

Prázdné sloupce, řádky a buňky

Odstraňte všechny nepotřebné prázdné sloupce a prázdné řádky na listu nebo v oblasti. V případě, že list nebo oblast buněk obsahuje prázdné buňky, pokuste se přidat chybějící data. Pokud plánujete připojit k existující tabulce záznamy, přesvědčte se, zda lze do odpovídajícího pole v tabulce zadat hodnoty Null (chybějící nebo neznámé hodnoty). Do pole lze zadávat hodnoty Null, pokud je vlastnost Je nutno zadat tohoto pole nastavena na hodnotu Ne a nastavení vlastnosti .Podmínkaplatnosti umožňuje jejich použití.

Chybové hodnoty

Pokud jedna nebo víc buněk na listu nebo v oblasti obsahuje chybové hodnoty, třeba #ČÍSLO! a #DĚLENÍ_NULOU!, je třeba je před zahájením operace importu opravit. Pokud zdrojový list nebo oblast obsahuje chybové hodnoty, umístí Access do odpovídajících polí v tabulce hodnotu Null. Další informace o způsobech opravy těchto chyb najdete v části Odstranění potíží s chybějícími nebo nesprávnými hodnotami uvedené dále v tomto článku.

Datový typ

Chcete-li předejít chybám během importu, přesvědčte se, zda každý zdrojový sloupec obsahuje v každém řádku stejný typ dat. Aplikace Access projde prvních osm zdrojových řádků a určí datový typ polí v tabulce. Doporučujeme zajistit, aby v prvních osmi zdrojových řádcích kteréhokoli sloupce nebyly namíchány hodnoty představující různé typy dat. Aplikace Access by v opačném případě nemusela ke sloupci přiřadit správný typ dat.

Před začátkem operace importu je také vhodné naformátovat každý zdrojový sloupec v aplikaci Excel a každému sloupci přiřadit určitý datový formát. Formátování je zvláště doporučeno v případě, že sloupec obsahuje hodnoty různých datových typů. Sloupec ČísloLetu na listu může obsahovat číselné a textové hodnoty, jako například 871, AA90 a 171. Chcete-li předejít chybějícím nebo nesprávným hodnotám, postupujte následujícím způsobem:

  1. Klikněte pravým tlačítkem na záhlaví sloupce a potom na Formát buněk.

  2. Na kartě Číslo ve skupinovém rámečku Kategorie vyberte formát. Pro sloupec ČísloLetu byste pravděpodobně zvolili formát Text.

  3. Klikněte na tlačítko OK.

Pokud jsou zdrojové sloupce naformátované, ale pořád obsahují kombinované hodnoty v dalších řádcích, můžou být tyto hodnoty během importu vynechané nebo nesprávně převedené. Informace o odstraňování problémů najdete v části Odstranění potíží s chybějícími nebo nesprávnými hodnotami.

První řádek

Pokud první řádek na listu nebo v pojmenované oblasti obsahuje názvy sloupců, můžete určit, aby aplikace Access považovala tato data v prvním řádku během importu za názvy polí. Pokud zdrojový list nebo oblast neobsahuje názvy, je před zahájením importu vhodné názvy ke zdroji přidat.

Poznámka : Pokud plánujete připojit data k existující tabulce, přesvědčte se, zda názvy všech sloupců odpovídají názvům příslušných polí. Pokud se název sloupce liší od názvu odpovídajícího pole v tabulce, dojde k chybě operace importu. Názvy polí se zobrazí po otevření tabulky v návrhovém zobrazení v aplikaci Access.

  1. Pokud je zdrojový sešit otevřený, zavřete jej. Zůstane-li zdrojový soubor otevřený, může během operace importu dojít k chybám převodu dat.

Příprava cílové databáze

  1. Otevřete databázi aplikace Access, do které chcete uložit importovaná data. Přesvědčte se, zda databáze není určena jen pro čtení a zda máte oprávnění k provádění změn v databázi.

    – nebo –

    Pokud nechcete data ukládat do žádné z existujících databází, vytvořte prázdnou databázi. Postupujte následujícím způsobem:

    Klikněte na kartu Soubor, klikněte na možnost Nový a potom klikněte na položku Prázdná databáze nebo Prázdná webová databáze.

    Další informace o webových databázích najdete v článku Vytvoření accessové databáze pro sdílení na webu.

  2. Před zahájením importu se rozhodněte, zda chcete data uložit do nové nebo do existující tabulky.

    Vytvoření nové tabulky:    Pokud se rozhodnete data uložit do nové tabulky, aplikace Access vytvoří tabulku a přidá do ní importovaná data. Pokud tabulka s určeným názvem již existuje, bude obsah této tabulky přepsán importovanými daty.

    Připojení k existující tabulce:    Pokud se rozhodnete data přidat do existující tabulky, budou řádky z listu aplikace Excel připojeny k určené tabulce.

    Mějte na paměti, že nejčastější příčinou chyb během operací připojení bývá to, že zdrojová data neodpovídají struktuře a nastavení polí cílové tabulky. Chcete-li tomu zabránit, otevřete cílovou tabulku v návrhovém zobrazení a zkontrolujte následující skutečnosti:

    • První řádek:    Pokud první řádek zdrojového listu nebo pojmenované oblasti neobsahuje záhlaví sloupců, přesvědčte se, zda umístění a datové typy jednotlivých sloupců ve zdrojovém listu odpovídají příslušným polím v tabulce. Jestliže první řádek obsahuje záhlaví sloupců, není nutné, aby pořadí sloupců odpovídalo pořadí polí, ale názvy a datové typy jednotlivých sloupců musí přesně odpovídat názvům a datovým typům příslušných polí.

    • Chybějící nebo nadbytečná pole:    Pokud v cílové tabulce neexistuje jedno či více polí zdrojového listu, je třeba tato pole před zahájením importu přidat. Jestliže však tabulka obsahuje pole, která neexistují ve zdroji, není nutné tato pole z tabulky odstraňovat, pokud mohou obsahovat hodnoty Null.

      Tip : Pole může obsahovat hodnoty Null, pokud je vlastnost Je nutno zadat tohoto pole nastavena na hodnotu Ne a nastavení vlastnosti .Podmínkaplatnosti umožňuje jejich použití.

    • Primární klíč:    Obsahuje-li tabulka pole s primárním klíčem, musí zdrojový list nebo oblast obsahovat sloupec s hodnotami kompatibilními s polem s primárním klíčem a importované klíčové hodnoty musí být jedinečné. Pokud importovaný záznam obsahuje hodnotu primárního klíče, která již v cílové tabulce existuje, zobrazí se zpráva o chybě operace importu.

    • Indexovaná pole:    Pokud je vlastnost .Indexovat pro pole v tabulce nastavena na hodnotu ano (bez duplicity), musí odpovídající sloupec na zdrojovém listu nebo v oblasti obsahovat jedinečné hodnoty.

      Chcete-li spustit operaci importu, přejděte k dalším krokům.

Spuštění operace importu

  1. Na kartě Externí data klikněte ve skupině Importovat a propojit na položku Aplikace Excel.

    Poznámka : Karta Externí data je k dispozici, pouze pokud je databáze otevřena.

  2. V dialogovém okně Načíst externí data – Tabulka aplikace Excel zadejte do pole Název souboru název souboru aplikace Excel obsahujícího data, která chcete importovat.

    – nebo –

    Klikněte na tlačítko Procházet a pomocí dialogového okna Otevřít soubor vyhledejte soubor, který chcete importovat.

  3. Určete, jakým způsobem chcete importovaná data uložit.

    Chcete-li data uložit do nové tabulky, klikněte na přepínač Importovat zdrojová data do nové tabulky v aktuální databázi. K zadání názvu tabulky budete vyzváni později.

    Chcete-li data připojit k existující tabulce, klikněte na přepínač Připojit kopii záznamů k tabulce a vyberte v rozevíracím seznamu požadovanou tabulku. Pokud databáze neobsahuje tabulky, není tento přepínač k dispozici.

    Pokud chcete vytvořit propojení se zdrojem dat vytvořením propojené tabulky, najdete potřebné informace v části Propojení dat Excelu uvedené dále v tomto článku.

  4. Klikněte na tlačítko OK.

    Bude spuštěn Průvodce importem z tabulkového kalkulátoru, který vás provede procesem importu. Přejděte k dalším krokům.

Použití Průvodce importem z tabulkového kalkulátoru

  1. Na první stránce průvodce vyberte list obsahující data, která chcete importovat, a potom klikněte na tlačítko Další.

  2. Na druhé stránce průvodce klikněte na přepínač Zobrazit tabulky nebo na přepínač Zobrazit oblasti, vyberte list nebo pojmenovanou oblast, kterou chcete importovat, a potom klikněte na tlačítko Další.

  3. Obsahuje-li první řádek zdrojového listu nebo oblasti názvy polí, zaškrtněte políčko První řádek obsahuje hlavičky sloupců a potom klikněte na tlačítko Další.

    Pokud importujete data do nové tabulky, použije aplikace Access tato záhlaví sloupců k pojmenování polí v tabulce. Tyto názvy můžete změnit v průběhu operace importu nebo po jejím dokončení. V případě, že připojujete data k existující tabulce, zkontrolujte, zda záhlaví sloupů ve zdrojovém listu přesně odpovídají názvům polí v cílové tabulce.

    Připojujete-li data k existující tabulce, přejděte přímo ke kroku 6. Pokud přidáváte data do nové tabulky, postupujte podle zbývajících kroků.

  4. Průvodce vás vyzve ke kontrole vlastností polí. Vlastnosti jednotlivých polí lze zobrazit kliknutím na příslušný sloupec v dolní polovině stránky. Můžete také provést některou z následujících akcí:

    • Zkontrolujte a v případě potřeby změňte název a datový typ cílového pole.

      Access zkontroluje prvních osm řádků v každém sloupci a navrhne datový typ pro odpovídající pole. Pokud prvních osm řádků sloupce na listu obsahuje různé typy hodnot (třeba textové a číselné hodnoty), navrhne průvodce datový typ, který je kompatibilní se všemi hodnotami ve sloupci – nejčastěji datový typ Text. Přestože jde vybrat jiný datový typ, nezapomeňte, že hodnoty, které nejsou kompatibilní s vybraným datovým typem, se v průběhu procesu importu ignorují nebo nesprávně převedou. Další informace o tom, jak jde opravit chybějící nebo nesprávné hodnoty, najdete v části Odstranění potíží s chybějícími nebo nesprávnými hodnotami dále v tomto článku.

    • Chcete-li u pole vytvořit index, vyberte v rozevíracím seznamu Indexované položku ano.

    • Chcete-li zdrojový sloupec zcela vynechat, zaškrtněte políčko Neimportovat pole (přeskočit).

      Po výběru požadovaných možností klikněte na tlačítko Další.

  5. Na další obrazovce zadejte primární klíč pro danou tabulku. Kliknete-li na přepínač Primární klíč přidá aplikace Access, přidá aplikace Access do cílové tabulky jako první pole typu Automatické číslo a automaticky je vyplní jedinečnými hodnotami ID (počínaje číslem 1). Klikněte na tlačítko Další.

  6. Na poslední obrazovce průvodce zadejte název cílové tabulky. Do pole Importovat do tabulky zadejte název tabulky. Pokud již tabulka existuje, zobrazí aplikace Access dotaz, zda chcete stávající obsah tabulky přepsat. Pokračujte kliknutím na tlačítko Ano, nebo klikněte na tlačítko Ne a zadejte jiný název cílové tabulky. Potom kliknutím na tlačítko Dokončit proveďte import dat.

    Pokud Access bylo možno import některých nebo všech dat, Průvodce zobrazí na stránku, která se zobrazí stav operace importu. Kromě toho můžete uložení podrobností o operaci pro budoucí použití jako specifikace. Naopak pokud operace importu nezdaří, aplikace Access zobrazí zprávu došlo k chybě importovat soubor .

  7. Kliknutím na tlačítko Ano uložíte podrobnosti operace pro další použití. Při uložení podrobností můžete operaci později zopakovat, aniž byste museli pokaždé procházet všemi kroky průvodce.

Uložení nastavení importu jako specifikace

  1. Zadejte do pole Uložit jako název specifikace importu. Do pole Popis můžete zadat popis.

  2. Pokud chcete tuto operaci provádět v pravidelných intervalech, například týdně nebo měsíčně, zaškrtněte políčko Vytvořit úkol aplikace Outlook. Tím vytvoříte úkol aplikace Outlook, který vám umožní spustit specifikaci později.

  3. Klikněte na tlačítko Uložit import.

    Pokud jste v kroku 2 nezaškrtnuli políčko Vytvořit úkol aplikace Outlook, postup jste tímto dokončili. Pokud jste jej zaškrtnuli, otevře aplikace Access úkol aplikace Outlook. Pokračujte kroky 4 a 5.

    Poznámka : Není-li aplikace Outlook nainstalována, zobrazí aplikace Access chybovou zprávu. Pokud aplikace Outlook není správně nakonfigurována, spustí se Průvodce spuštěním aplikace Outlook. Nakonfigurujte aplikaci Outlook podle pokynů v průvodci.

  4. V aplikaci Outlook zkontrolujte a upravte nastavení úkolu, například polí Termín splnění a Připomenutí.

    Chcete-li vytvořit opakovaný úkol, klikněte na tlačítko Opakování a nastavte požadované možnosti.

  5. Klikněte na tlačítko Uložit a zavřít.

Spuštění uloženého úkolu

  1. V navigačním podokně aplikace Outlook klikněte na tlačítko Úkoly a potom poklikejte na úkol, který chcete spustit.

  2. Ve skupině Microsoft Access na kartě Úkol klikněte na tlačítko Spustit import a potvrďte kliknutím na tlačítko OK.

  3. Otevřete cílovou tabulku v zobrazení Datový list. Porovnejte data v tabulce se zdrojovým listem a přesvědčte se, zda jsou zobrazena správně.

    Pokud zjistíte, že některá data chybí nebo jsou nesprávná, přečtěte si následující část týkající se odstranění potíží.

Spuštění uloženého importu

  1. Na kartě Externí údaje klikněte ve skupině Importovat a propojit na položku Uložené importy.

  2. V dialogovém okně Úlohy správy dat klikněte na uložený import, který chcete spustit, a poté klikněte na příkaz Spustit.

Začátek stránky

Odstranění potíží s chybějícími nebo nesprávnými hodnotami

Pokud dostanete zprávu došlo k chybě importovat soubor , import operace úplně se nezdařila. Pokud operace importu zobrazí dialogové okno s výzvou k uložení podrobností o operaci, nebudou bylo možno importovat všechny nebo jenom některé dat operace. Stavová zpráva rovněž uveden název tabulky protokolu chyb, který obsahuje popis chybách, ke kterým došlo k během operace importu.

Důležité : Než tabulku začnete používat, zkontrolujte její obsah a strukturu a přesvědčte se, zda jsou všechna data zobrazena správně, a to i v případě, že je operace ve zprávě o stavu označena jako zcela úspěšná.

  • Otevřete cílovou tabulku v zobrazení Datový list a ověřte, zda byla všechna data přidána do tabulky.

  • Otevřete tabulku v návrhovém zobrazení a zkontrolujte nastavení datového typu a dalších vlastností polí.

V následující tabulce je popsán postup, pomocí kterého lze opravit chybějící nebo nesprávné hodnoty.

Tip : Pokud během odstraňování potíží s výsledky najdete pouze několik chybějících hodnot, můžete je ručně přidat do tabulky. Jestliže však chybí nebo byly nesprávně importovány celé sloupce či větší počet hodnot, měli byste problém odstranit ve zdrojovém souboru. Po odstranění všech zjištěných problémů operaci importu opakujte.

Problém

Řešení

Grafické prvky

Grafické prvky, například loga, grafy a obrázky, nelze naimportovat. Přidejte je do databáze ručně po dokončení operace importu.

Počítané hodnoty

Výsledky počítaných sloupců nebo buněk jsou importovány bez příslušného vzorce. Během importu můžete určit datový typ kompatibilní s výsledky vzorce, například typ Číslo.

Hodnoty TRUE nebo FALSE a hodnoty -1 nebo 0

Pokud zdrojový list nebo oblast zahrnuje sloupec obsahující pouze hodnoty TRUE nebo FALSE, aplikace Access pro tento sloupec vytvoří pole typu Ano/Ne a vloží do tohoto pole hodnotu -1 nebo 0. Pokud však zdrojový list nebo oblast zahrnuje sloupec obsahující pouze hodnoty -1 nebo 0, aplikace Access ve výchozím nastavení vytvoří pro tento sloupec číselné pole. Chcete-li tomuto problém předejít, můžete během importu změnit datový typ pole na typ Ano/Ne.

Vícehodnotová pole

Při importu dat do nové tabulky nebo přidání dat do existující tabulky není podporováno více hodnot v jednom poli, a to ani v případě, že zdrojový sloupec obsahuje seznam hodnot oddělených středníkem (;). Seznam hodnot je považován za jednu hodnotu a je umístěn do textového pole.

Neúplná data

Pokud jsou zobrazená data ve sloupci tabulky aplikace Access zkrácena, pokuste se v zobrazení Datový list zvětšit šířku sloupce. Pokud tímto způsobem problém nevyřešíte, jsou data v číselném sloupci aplikace Excel příliš velká s ohledem na velikost cílového pole v aplikaci Access. Cílové pole může mít v databázi aplikace Access nastavenou vlastnost Velikost pole na hodnotu bajt, ale zdrojová data obsahují hodnotu větší než 255. Opravte hodnoty ve zdrojovém souboru a import opakujte.

Formát zobrazení

Nastavením vlastnosti Formát určitých polí v návrhovém zobrazení zajistíte, aby se hodnoty správně zobrazovaly v zobrazení Datový list. Například:

  • Po dokončení importu zobrazuje pole typu Ano/Ne v zobrazení Datový list hodnoty -1 a 0. Chcete-li tento problém odstranit, nastavte po dokončení importu vlastnost pole Formát na hodnotu Ano/Ne, aby se zobrazovala zaškrtávací políčka.

  • Dlouhá a středně dlouhá data se v aplikaci Access mohou zobrazovat jako krátká data. Chcete-li tento problém odstranit, otevřete cílovou tabulku v návrhovém zobrazení v aplikaci Access a nastavte vlastnost pole data Formát na hodnotu datum (dlouhé) nebo datum (střední).

Poznámka : Pokud zdrojový list obsahuje formát RTF, například tučné formátování písma, podtržení nebo kurzívu, bude text naimportován, ale formátování textu bude ztraceno.

Duplicitní hodnoty (chyba narušení klíče)

Importované záznamy mohou obsahovat duplicitní hodnoty, které nelze uložit v poli primárního klíče v cílové tabulce nebo v polích, pro která je vlastnost .Indexovat nastavena na hodnotu ano (bez duplicity). Odstraňte ve zdrojovém souboru duplicitní hodnoty a import opakujte.

Hodnoty kalendářních dat posunuté o 4 roky

Pole kalendářních dat, která jsou importována z listu aplikace Excel, mohou být posunuta o čtyři roky. Aplikace Excel systému Windows používá kalendářní systém 1900 (v němž mají pořadová čísla rozsah od 1 do 65 380), který odpovídá datům od 1. ledna 1900 až do 31. prosince 2078. Aplikace Excel pro počítače Macintosh však používá kalendářní systém 1904 (v němž mají pořadová čísla rozsah od 0 do 63 918), který odpovídá datům od 1. ledna 1904 až do 31. prosince 2078.

Před zahájením importu dat změňte systém kalendářních dat sešitu aplikace Excel nebo po připojení dat proveďte aktualizační dotaz používající výraz [název pole kalendářního data] + 1462 k opravení hodnot kalendářních dat.

Hodnoty Null

Na konci operace importu se může zobrazit chybová zpráva týkající se odstraněných nebo ztracených dat v průběhu operace nebo po otevření tabulky v zobrazení Datový list se mohou některé hodnoty polí zobrazit prázdné. Pokud nejsou zdrojové sloupce v aplikaci Excel formátovány nebo pokud prvních osm zdrojových řádků obsahuje hodnoty různých datových typů, otevřete zdrojový list a proveďte následující akci:

  • Formátujte zdrojové sloupce.

  • Přesuňte řádky tak, aby prvních osm řádků v každém sloupci neobsahovalo hodnoty různých datových typů.

  • Během importu vyberte pro každé pole příslušný datový typ. Pokud není vybrán správný datový typ, je možné, že se po dokončení importu v celém sloupci zobrazí hodnoty Null nebo nesprávné hodnoty.

Pomocí předchozích kroků je možné minimalizovat výskyt hodnot Null. V následující tabulce jsou uvedeny případy, ve kterých budou hodnoty Null nadále zobrazeny:

Typ chybějících hodnot

Cíl importu

Typ cílového pole

Řešení

Otočení

Nová tabulka

Datum

Nahraďte všechny textové hodnoty hodnotami kalendářních dat a akci importu opakujte.

Otočení

Existující tabulka

Číslo nebo datum

Nahraďte všechny textové hodnoty hodnotami, které odpovídají datovému typu cílového pole a akci importu opakujte.

Hodnoty kalendářních dat nahrazeny číselnými hodnotami

V následujících situacích budou místo správných hodnot kalendářních dat zobrazena zdánlivě náhodná pětimístná čísla:

  • Zdrojový sloupec na listu obsahuje v prvních osmi řádcích pouze číselné hodnoty, v následujících řádcích však obsahuje i hodnoty kalendářních dat. Tyto hodnoty kalendářních dat budou nesprávně převedeny.

  • Zdrojový sloupec obsahuje v některých z prvních osmi řádků hodnoty kalendářních dat a vy jste se tato data pokusili importovat do číselného pole. Tyto hodnoty kalendářních dat budou nesprávně převedeny.

    Chcete-li této situaci předejít, nahraďte ve zdrojovém sloupci hodnoty kalendářních dat číselnými hodnotami a import opakujte.

    V některých případech, kdy sloupec obsahující převážně hodnoty kalendářních dat obsahuje také několik textových hodnot, se mohou všechny hodnoty kalendářních dat zobrazovat jako zdánlivě náhodná pětimístná čísla. Chcete-li této situaci předejít, nahraďte textové hodnoty hodnotami kalendářních dat a akci importu opakujte.

Číselné hodnoty nahrazeny hodnotami kalendářních dat

V následujících situacích se budou místo správných číselných hodnot zobrazovat zdánlivě náhodné hodnoty kalendářních dat:

  • Zdrojový sloupec obsahuje v prvních osmi řádcích pouze hodnoty kalendářních dat, v následujících řádcích však obsahuje i číselné hodnoty. Tyto číselné hodnoty budou nesprávně převedeny.

  • Zdrojový sloupec obsahuje v některých z prvních osmi řádků číselné hodnoty a vy jste se tato čísla pokusili importovat do pole kalendářních dat. Tyto číselné hodnoty budou nesprávně převedeny.

Chcete-li této situaci předejít, nahraďte ve zdrojovém sloupci číselné hodnoty hodnotami kalendářních dat a import opakujte.

Navíc můžete na poslední stránce průvodce zobrazit v zobrazení Datový list tabulku s protokolem chyb. Tato tabulka obsahuje tři pole: Chyba, Pole a Řádek. Každý řádek obsahuje informace o konkrétní chybě a v poli Chyba jsou uvedeny informace, které vám pomohou při jejím odstraňování. 

Chybové řetězce a pokyny k odstranění potíží

Chyba

Popis

Oříznutí pole

Hodnota v souboru je pro nastavení vlastnosti .Velikostpole pro dané pole příliš velká.

Chyba při převodu typu

Datový typ hodnoty v listu je pro dané pole chybný. Hodnota v cílovém poli může být zobrazena nesprávně nebo může chybět. Další informace o řešení tohoto problému naleznete v předchozí tabulce.

Narušení klíče

Hodnota primárního klíče daného záznamu je duplicitní – tabulka již tuto hodnotu obsahuje.

Chyba ověřovacího pravidla

Hodnota je v rozporu s pravidlem nastaveným pomocí vlastnosti .Podmínkaplatnosti pro dané pole nebo tabulku.

Hodnota Null v povinném poli

V daném poli není povolena hodnota Null, protože vlastnost Je nutno zadat pro toto pole je nastavena na hodnotu Ano.

Hodnota Null v poli typu Automatické číslo

Importovaná data obsahují hodnotu Null, kterou jste se pokusili přidat do pole typu Automatické číslo.

Neanalyzovatelný záznam

Textová hodnota obsahuje znak oddělovače textu (obvykle dvojité uvozovky). Obsahuje-li hodnota znak oddělovače, je nutné tento znak v textovém souboru opakovat dvakrát; například:

Průměr 4 1/2""

Začátek stránky

Propojení dat aplikace Excel

Díky propojení databáze aplikace Access s daty v jiné aplikaci můžete využívat nástroje pro vytváření dotazů a sestav poskytované aplikací Access, aniž byste museli uchovávat v databázi kopii dat aplikace Excel.

Při propojení s listem nebo pojmenovanou oblastí aplikace Excel se v aplikaci Access vytvoří nová tabulka, která je propojena se zdrojovými buňkami. Všechny změny provedené ve zdrojových buňkách v aplikaci Excel se zobrazí v propojené tabulce. Obsah příslušné tabulky však nelze upravovat v aplikaci Access. Chcete-li přidat, upravit nebo odstranit data, je nutné změny provést ve zdrojovém souboru.

Obvyklé scénáře propojení listu aplikace Excel z aplikace Access

Propojení s listem aplikace Excel (namísto importu souboru) se obvykle vytváří z následujících důvodů:

  • Chcete nadále uchovávat data v listech aplikace Excel, ale chcete být schopni využívat výkonných funkcí vytváření dotazů a sestav aplikace Access.

  • Vaše oddělení nebo pracovní skupina používá aplikaci Access, avšak data z externích zdrojů, která používáte, jsou uložena v listech aplikace Excel. Nechcete udržovat kopie externích dat, ale chcete být schopni pracovat s těmito daty v aplikaci Access.

Před prvním propojením s listem aplikace Excel

  • Propojení s databází aplikace Access nelze vytvořit z aplikace Excel.

  • Při propojení se souborem aplikace Excel je v aplikaci Access vytvořena nová tabulka, často označovaná jako propojená tabulka. Tabulka zobrazuje data zdrojového listu nebo pojmenované oblasti, která však ve skutečnosti nejsou uložena v databázi.

  • Data aplikace Excel nelze propojit s existující tabulkou v databázi. To znamená, že pomocí operace propojení nelze připojit data k existující tabulce.

  • Databáze může obsahovat více propojených tabulek.

  • Všechny změny dat provedené v aplikaci Excel se automaticky projeví v propojené tabulce. Obsah a struktura propojené tabulky v aplikaci Access jsou však jen pro čtení.

  • Při otevření sešitu aplikace Excel v aplikaci Access (v dialogovém okně Otevřít z nabídky Soubor vyberte v seznamu Soubory typu položku Microsoft Excel a vyberte požadovaný soubor) vytvoří aplikace Access prázdnou databázi a automaticky spustí Průvodce propojením s tabulkovým kalkulátorem.

Příprava dat aplikace Excel

  1. Vyhledání souboru aplikace Excel a listu nebo oblasti, která obsahuje data, která chcete vytvořit odkaz. Pokud nechcete odkaz na celý list, zvažte možnost definování pojmenované oblasti obsahující pouze buňky, které chcete vytvořit odkaz.

    Vytvoření pojmenované oblasti v Excelu (volitelné – užitečné, pokud chcete vytvořit propojení na některá data na listu)   

    1. Přejděte do Excelu a zobrazte list, ve kterém chcete definovat pojmenovanou oblast.

    2. Vyberte oblast buněk obsahující data, která chcete propojit.

    3. Pravým tlačítkem myši klikněte dovnitř vybrané oblasti a potom klikněte na příkaz Pojmenovat rozsah nebo Definovat název.

    4. V dialogovém okně Nový název zadejte do pole Název název pojmenované oblasti a klikněte na tlačítko OK.

      Během operace propojení lze vytvořit propojení pouze s jedním listem nebo oblastí. Chcete-li propojit data ve více umístěních v sešitu, opakujte operaci propojení pro každý list nebo každou oblast.

  2. Prohlédněte si zdrojová data a proveďte akce popsané v následující tabulce:

Prvek

Popis

Formát tabulky

Přesvědčte se, zda jsou buňky ve formátu tabulky. Pokud oblast obsahuje sloučené buňky, bude obsah těchto buněk umístěn do pole odpovídajícího sloupci zcela vlevo a ostatní pole zůstanou prázdná.

Vynechání sloupců a řádků

Během operace propojení nelze vynechat zdrojové sloupce a řádky. Po dokončení importu do aplikace Access však můžete skrýt pole a filtrovat záznamy otevřením propojené tabulky v zobrazení Datový list.

Počet sloupců

Počet zdrojových sloupců nesmí překročit číslo 255, protože aplikace Access podporuje maximálně 255 polí v tabulce.

Prázdné sloupce, řádky a buňky

Odstraňte všechny nepotřebné prázdné sloupce a prázdné řádky na listu nebo v oblasti aplikace Excel. V případě prázdných buněk zkuste přidat chybějící data.

Chybové hodnoty

Pokud jedna nebo více buněk na listu nebo v oblasti obsahuje chybové hodnoty, opravte tyto hodnoty před začátkem operace importu. Pokud zdrojový list nebo oblast obsahuje chybové hodnoty, vloží aplikace Access do odpovídajících polí tabulky hodnotu Null.

Datový typ

V propojené tabulce nelze změnit datový typ nebo velikost polí. Před zahájením operace propojení je nutné ověřit, zda každý sloupec obsahuje data určeného typu.

Formátování sloupce se doporučuje zejména v případě, že sloupec obsahuje hodnoty různých datových typů. Sloupec ČísloLetu na listu může například obsahovat číselné a textové hodnoty, jako například 871, AA90 a 171. Chcete-li předejít chybějícím nebo nesprávným hodnotám, postupujte následujícím způsobem:

  1. Klikněte pravým tlačítkem na sloupec a potom na Formát buněk.

  2. Na kartě Číslo ve skupinovém rámečku Kategorie vyberte formát.

  3. Klikněte na tlačítko OK.

První řádek

Pokud první řádek na listu nebo v pojmenované oblasti obsahuje názvy sloupců, můžete určit, aby aplikace Access považovala tato data v prvním řádku během importu za názvy polí. Pokud list neobsahuje žádné názvy sloupců nebo pokud určitý název sloupce porušuje pravidla pojmenovávání polí v aplikaci Access, přiřadí aplikace Access každému odpovídajícímu poli platný název.

  1. Pokud je zdrojový soubor otevřen, zavřete jej.

Příprava cílové databáze

  1. Otevřete databázi, ve které chcete vytvořit propojení. Přesvědčte se, zda databáze není určena jen pro čtení a zda máte potřebná oprávnění k provádění změn v databázi.

  2. Pokud nechcete propojení ukládat v žádné ze stávajících databází, vytvořte prázdnou databázi: klikněte na kartu Soubor, na možnost Nové a poté na položku Prázdná databáze nebo Prázdná webová databáze.

  3. Další informace o webových databázích najdete v článku Vytvoření accessové databáze pro sdílení na webu.

Nyní lze spustit operaci propojení.

Vytvoření propojení

  1. Na kartě Externí data klikněte ve skupině Importovat a propojit na položku Aplikace Excel.

    Poznámka : Karta Externí data je k dispozici, pouze pokud je databáze otevřena.

  2. V dialogovém okně Načíst externí data – Tabulka aplikace Excel zadejte do pole Název souboru název zdrojového souboru aplikace Excel.

  3. Klikněte na přepínač Vytvořit odkaz na zdroj dat vytvořením propojené tabulky a potom klikněte na tlačítko OK.

    Bude spuštěn Průvodce propojením s tabulkovým kalkulátorem, který vás provede procesem propojování.

  4. Na první stránce průvodce vyberte list nebo pojmenovanou oblast a klikněte na tlačítko Další.

  5. Obsahuje-li první řádek zdrojového listu nebo oblasti názvy polí, zaškrtněte políčko První řádek obsahuje záhlaví sloupců. Aplikace Access použije tato záhlaví sloupců k pojmenování polí v tabulce. Pokud název sloupce obsahuje určité speciální znaky, nemůže být použit jako název pole v aplikaci Access. V takovém případě se zobrazí chybová zpráva oznamující, že aplikace Access přiřadí poli platný název. Pokračujte kliknutím na tlačítko Ano.

  6. Na poslední stránce průvodce zadejte název propojené tabulky a potom klikněte na tlačítko Dokončit. Pokud již tabulka s tímto názvem existuje, zobrazí se dotaz, zda chcete existující tabulku nebo dotaz přepsat. Pokud chcete tabulku nebo dotaz přepsat, klikněte na tlačítko Ano. V opačném případě klikněte na tlačítko Ne a zadejte jiný název.

    Aplikace Access se pokusí vytvořit propojenou tabulku. Pokud je operace úspěšná, zobrazí aplikace Access zprávu Propojení tabulky je dokončeno. Otevřete propojenou tabulku a zkontrolujte, zda jsou ve všech polích zobrazena správná data.

    Pokud jsou zobrazeny chybové hodnoty nebo nesprávná data, bude potřeba odstranit potíže se zdrojovými daty. Další informace týkající se postupu při odstraňování potíží s chybovými a nesprávnými hodnotami naleznete v následující části.

Začátek stránky

Odstranění potíží s hodnotou #ČÍSLO! a jinými nesprávnými hodnotami v propojené tabulce

I v případě zobrazení zprávy Propojení tabulky je dokončeno otevřete tabulku v zobrazení Datový list a ověřte, zda jsou v řádcích a sloupcích zobrazena správná data.

Pokud tabulka obsahuje chyby nebo nesprávná data, proveďte opravnou akci popsanou v následující tabulce a potom propojení opakujte. Nezapomeňte, že hodnoty nelze přidávat přímo do propojené tabulky, protože tato tabulka je určena jen pro čtení.

Problém

Řešení

Grafické prvky

Grafické prvky na listu aplikace Excel, například loga, grafy a obrázky, nemohou být propojeny s aplikací Access.

Formát zobrazení

Nastavením vlastnosti Formát určitých polí v návrhovém zobrazení zajistíte, aby se hodnoty správně zobrazovaly v zobrazení Datový list.

Počítané hodnoty

Výsledky počítaného sloupce nebo buněk jsou zobrazeny v odpovídajícím poli, ale příslušný vzorec (nebo výraz) nelze v aplikaci Access zobrazit.

Zkrácené textové hodnoty

V zobrazení Datový list zvětšete šířku sloupce. Pokud stále není zobrazena celá hodnota, může být důvodem hodnota delší než 255 znaků. Aplikace Access může propojit pouze prvních 255 znaků, proto byste tato data měli místo propojení importovat.

Chybová zpráva o přetečení číselného pole

Propojená tabulka se může zdát zobrazena správně, ale pokud později spustíte v tabulce dotaz, může se zobrazit chybová zpráva Přetečení číselného pole. Tento problém může být způsoben konfliktem mezi datovým typem pole v propojené tabulce a typem dat uložených v tomto poli.

Hodnoty TRUE nebo FALSE a hodnoty -1 nebo 0

Pokud zdrojový list nebo oblast zahrnuje sloupec obsahující pouze hodnoty TRUE nebo FALSE, vytvoří aplikace Access pro tento sloupec v propojené tabulce pole typu Ano/Ne. Pokud však zdrojový list nebo oblast zahrnuje sloupec obsahující pouze hodnoty -1 nebo 0, vytvoří aplikace Access ve výchozím nastavení pro tento sloupec číselné pole a datový typ odpovídajícího pole tabulky nebudete moci změnit. Pokud chcete, aby propojená tabulka obsahovala pole typu Ano/Ne, přesvědčte se, zda zdrojový sloupec obsahuje hodnoty TRUE a FALSE.

Vícehodnotová pole

Aplikace Access nepodporuje více hodnot v jednom poli ani v případě, kdy zdrojový sloupec obsahuje seznam hodnot oddělených středníkem (;). Seznam hodnot bude považován za jednu hodnotu a bude umístěn do textového pole.

#ČÍSLO!

V následujících situacích zobrazuje aplikace Access v poli chybovou hodnotu #ČÍSLO! místo vlastních dat:

  • Pokud zdrojový sloupec obsahující převážně textové hodnoty obsahuje i několik číselných hodnot nebo hodnot kalendářních dat, číselné hodnoty a hodnoty kalendářních dat nebudou importovány.

  • Pokud zdrojový sloupec obsahující převážně číselné hodnoty obsahuje i několik textových hodnot, nebudou textové hodnoty importovány.

  • Pokud zdrojový sloupec obsahující převážně hodnoty kalendářních dat obsahuje i několik textových hodnot, nebudou textové hodnoty importovány.

Pomocí následujícího postupu minimalizujte výskyt hodnoty Null v tabulce:

  1. Ujistěte se, že zdrojový sloupec neobsahuje hodnoty různých datových typů.

  2. Na listu aplikace Excel naformátujte sloupce.

  3. Během propojování vyberte pro každé pole správný datový typ. V případě nesprávného datového typu mohou být ve všech řádcích dat ve výsledném sloupci zobrazeny pouze hodnoty #ČÍSLO!.

Číselné hodnoty místo hodnot kalendářních dat

Pokud je v poli zobrazeno zdánlivě náhodné pětimístné číslo, zkontrolujte, zda zdrojový sloupec obsahující převážně číselné hodnoty obsahuje i několik hodnot kalendářních dat. Hodnoty kalendářních dat zobrazené v číselných sloupcích budou nesprávně převedeny na čísla. Nahraďte hodnoty kalendářních dat číselnými hodnotami a akci propojení opakujte.

Hodnoty kalendářních dat místo číselných hodnot

Pokud je v poli zobrazena zdánlivě náhodná hodnota kalendářního data, zkontrolujte, zda zdrojový sloupec obsahující převážně hodnoty kalendářních dat obsahuje i několik číselných hodnot. Číselné hodnoty zobrazené ve sloupcích kalendářních dat budou nesprávně převedeny na kalendářní data. Nahraďte číselné hodnoty hodnotami kalendářních dat a akci propojení opakujte.


Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Byly tyto informace užitečné?

Výborně! Je ještě něco dalšího, co byste nám chtěli dát vědět?

Jak bychom ho mohli vylepšit?

Děkujeme vám za zpětnou vazbu.

×