Import a export textových souborů (.txt nebo .csv)

Import a export textových souborů (.txt nebo .csv)

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Existují dva způsoby importu dat z textového souboru pomocí Excelu: můžete textový soubor otevřít v Excelu nebo ho můžete importovat jako oblast externích dat. Pokud chcete exportovat data z Excelu do textového souboru, použijte příkaz Uložit jako a změňte typ souboru v rozevírací nabídce.

Existují dva běžně používané formáty textových souborů:

  • textové soubory s oddělovači (soubory formátu TXT), ve kterých je každé pole textu obvykle odděleno tabulátorem (kód znaku ASCII 009),

  • textové soubory s hodnotami oddělenými čárkou (soubory formátu CSV), ve kterých čárka (,) obvykle odděluje každé pole textu.

Znak oddělovače v souborech s oddělovači i v textových souborech CSV lze změnit. Je to vhodné například v situacích, kdy je třeba se ujistit, že operace importu nebo exportu proběhne požadovaným způsobem.

Poznámka : Importovat nebo exportovat lze až 1 048 576 řádků a 16 384 sloupců.

Import textového souboru jeho otevřením v Excelu

Textový soubor vytvořený v jiné aplikaci můžete otevřít v aplikaci Excel pomocí příkazu Otevřít. Po otevření v aplikaci Excel se nezmění formát textového souboru – můžete se o tom přesvědčit v záhlaví aplikace Excel, kde se v názvu souboru zachovává stejná přípona (například TXT nebo CSV).

  1. Přejděte na Soubor > Otevřít.

    Pokud používáte Excel 2007, klikněte na tlačítko Microsoft Office Obrázek tlačítka Office a potom klikněte na Otevřít.

  2. V dialogovém okně Otevřít vyberte možnost Textové soubory.

  3. Vyhledejte textový soubor, který chcete otevřít, a poklikejte na něj.

    • Jestliže se jedná o textový soubor (TXT), Excel spustí Průvodce importem textu. Po provedení požadovaných kroků dokončete operaci importu kliknutím na tlačítko Dokončit.

    • Podívejte se na článek o importu dat pomocí Průvodce importem textu, ve kterém najdete další informace o oddělovačích a rozšířených možnostech.

    • Jestliže se jedná o soubor formátu CSV, aplikace Excel textový soubor automaticky otevře a zobrazí data v novém sešitu.

      Poznámka : Po otevření souboru CSV v aplikaci Excel použije aplikace Excel stávající výchozí nastavení formátu dat pro určení způsobu importu jednotlivých sloupců dat. Pokud chcete mít větší flexibilitu při převodu sloupců na různé formáty dat, můžete použít Průvodce importem textu. Například jsou data ve sloupci v souboru CSV ve formátu měsíc-den-rok, ale výchozí formát dat aplikace Excel je rok-měsíc-den, nebo chcete převést sloupec čísel obsahujících počáteční nuly na text, aby bylo možné počáteční nuly zachovat. Chcete-li, aby aplikace Excel spustila Průvodce importem textu, můžete před otevřením souboru změnit jeho příponu z CSV na TXT nebo můžete importovat textový soubor tím, že se k němu připojíte.

Data z textového souboru lze do existujícího listu importovat jako Oblast externích dat:

  1. Klikněte na buňku, kam chcete vložit data z textového souboru.

  2. Na kartě Data ve skupině Načíst externí data klikněte na Z textu/CSV.

    Možnosti načtení a transformace na kartě Data

  3. Vyhledejte textový soubor, který chcete importovat, a poklikejte na něj.

    Postupujte podle pokynů v Průvodci importem textu. Další informace o používání Průvodce importem textu můžete získat, když na libovolné stránce průvodce kliknete na tlačítko Nápověda obrázek tlačítka . Až kroky průvodce provedete, dokončete operaci importu kliknutím na tlačítko Dokončit.

  4. V dialogovém okně Importovat data proveďte toto:

    • Můžete kliknout na Vlastnosti a nastavit tak možnosti aktualizace, formátování a rozložení importovaných dat.

    • Ve skupinovém rámečku Umístění dat proveďte jednu z následujících akcí:

      • Když chcete data vložit na vybrané místo, klikněte na Existující list.

      • Pokud chcete data vložit na nový list do levého horního rohu, klikněte na přepínač Nový list.

  5. Klikněte na tlačítko OK.

    Aplikace Excel umístí oblast externích dat do umístění, které zadáte.

Jestliže aplikace Excel nepřevede sloupec dat na požadovaný formát, můžete data převést po importu. Další informace najdete v článcích Převod čísel uložených jako text na čísla a Převod dat uložených jako text na kalendářní data.

Sešit aplikace Excel lze převést na textový soubor pomocí příkazu Uložit jako.

  1. Přejděte na Soubor > Uložit jako.

    Pokud používáte Excel 2007, klikněte na tlačítko Microsoft Office Obrázek tlačítka Office a potom klikněte na Uložit jako.

  2. Zobrazí se dialogové okno Uložit jako.

  3. V poli Uložit jako typ vyberte formát textového souboru pro list.

    • Například klikněte na položku Text (oddělený tabulátory) nebo Formát CSV (oddělený středníkem).

    • Poznámka : Různé formáty podporují různé sady funkcí. Další informace o sadách funkcí podporovaných různými formáty textových souborů najdete v článku Formáty souborů, které jsou podporované v Excelu.

  4. Přejděte do místa, kam chcete uložit nový textový soubor, a klikněte na Uložit.

  5. Zobrazí se dialogové okno s upozorněním, že do nového souboru bude uložen pouze aktuální list. Pokud jste si jisti, že aktuální list je tím, který chcete uložit jako textový soubor, klikněte na tlačítko OK. Další listy lze uložit jako samostatné textové soubory opakováním tohoto postupu pro každý z nich.

  6. Zobrazí se druhé dialogové okno s upozorněním, že list může obsahovat funkce, které nejsou podporovány formáty textových souborů. Chcete-li pouze uložit data listu do nového textového souboru, klikněte na možnost Ano. Pokud si nejste jisti a chcete získat další informace o funkcích aplikace Excel, které nejsou podporovány formáty textových souborů, klikněte na možnost Nápověda.

Další informace o ukládání souborů v jiných formátech najdete v článku uložení sešitu v jiném formátu souboru.

Použijete-li pro import textového souboru Průvodce importem textu, můžete v kroku 2 tohoto průvodce změnit oddělovač použitý u souboru s odděleným textem ze znaku TAB na jiný znak. V tomto kroku lze také změnit způsob zpracování posloupností oddělovačů, například posloupností uvozovek.

Podívejte se na článek o importu dat pomocí Průvodce importem textu, ve kterém najdete další informace o oddělovačích a rozšířených možnostech.

  1. V Microsoft Windows klikněte na tlačítko Start a potom na Ovládací panely.

  2. Otevřete dialogové okno, ve kterém můžete změnit místní a jazykové nastavení.

  3. Do pole Oddělovač seznamu zadejte nový oddělovač.

  4. Dvakrát klikněte na tlačítko OK.

Poznámka : Změníte-li znak oddělovače v počítači, bude nový znak používán všemi aplikacemi. Stejným postupem lze znak změnit zpět na znak výchozí.

Potřebujete další pomoc?

Kdykoli se můžete zeptat některého odborníka v technické komunitě Excelu, získat podporu v komunitě pro odpovědi, případně navrhnout novou funkci nebo vylepšení ve fóru Excel User Voice.

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Viz taky

Přehled vzorců v Excelu

Jak se vyhnout nefunkčním vzorcům

Nalezení a oprava chyb ve vzorcích

Klávesové zkratky a funkční klávesy v Excelu

Funkce aplikace Excel (podle abecedy)

Funkce aplikace Excel (podle kategorie)

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×