Vzorce a funkce

Funkce SUMA

Funkce SUMA

Poznámka: Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady.

Funkce SUMA , jedna z matematických a trigonometrických funkcí, sčítá hodnoty. Můžete přidat jednotlivé hodnoty nebo odkazů na buňky nebo oblasti kombinaci všechny tři.

Příklady:

  • =SUMA(A2:A10)

  • =SUMA(A2:A10;C2:C10)

Váš prohlížeč nepodporuje video. Nainstalujte si Microsoft Silverlight, Adobe Flash Player nebo Internet Explorer 9.

SUMA(číslo1;[číslo2];...)

Název argumentu

Popis

číslo1    (povinné)

První číslo, které budete chtít sčítat. Může to být číslo, například 4, Odkaz na buňku jako třeba B6 nebo Oblast buněk, například B2:B8.

číslo2–255    (volitelné)

Toto je druhé číslo, které chcete sečíst. Tímto způsobem můžete zadat až 255 čísel.

Tato část popisuje některé osvědčené postupy pro práci s funkcí Součet. Velkou část to se dají použít k práci s jinými funkcemi stejně.

Metoda =1+2 nebo =A+B. Když zadáte =1+2+3 nebo =A1+B1+C2, dostanete samozřejmě přesný výsledek. Tato metoda je ale náchylná k chybám, a to z několika důvodů:

  1. Překlepy – představte si, že chcete zadat víc hodnot nebo mnohem vyšší hodnoty, například:

    • =14598,93+65437,90+78496,23

    Pak se pokusíte ověřte správnost položky. Je jednodušší a umístění tyto hodnoty v jednotlivých buňkách pomocí vzorce SUMA. Kromě toho můžete formátovat hodnoty při budou do buněk a jejich mnohem čitelnější a jsou ve vzorci.

    Místo abyste hodnoty ve vzorcích zadávali ručně, použijte funkci SUMA.  Vzorec v buňce D5 je =SUMA(D2:D4).
  2. Chyba #HODNOTA! při odkazování na text místo na čísla.

    Pokud použijete vzorce, jako je třeba:

    • =A1+B1+C1 nebo =A1+A2+A3

    Příklad špatné konstrukce vzorce.  Vzorec v buňce D2 je =A2+B2+C2.

    Vzorce můžete zrušit, pokud jsou všechny hodnoty, není číselného typu (text) v odkazované buňky, které vrátí chybu #VALUE!. došlo k chybě. Součet ignorovat textové hodnoty a poskytují součet pouze číselné hodnoty.

    Správná konstrukce vzorců.  Místo =A2+B2+C2 je v buňce D2 tento vzorec: =SUMA(A2:C2).
  3. Chyba #REF! způsobená odstraněním řádků nebo sloupců

    Chyba #REF! způsobená odstraněním sloupce.  Vzorec se změnil na =A2+#REF!+B2.

    Pokud odstraníte řádek nebo sloupec, vzorec se neaktualizuje tak, aby odstraněné buňky vynechal, a vrátí chybu #REF!, zatímco funkce SUMA se aktualizuje automaticky.

    Funkce SUMA se automaticky přizpůsobí vloženým nebo odstraněným řádkům a sloupcům.
  4. Při vložení řádků nebo sloupců vzorce neaktualizují odkazy

    Když přidáte řádky, vzorce =A+B+C se neaktualizují.

    Pokud vložíte řádek nebo sloupec, vzorec neaktualizují zahrnout přidané řádku, kde funkce SUMA se automaticky aktualizuje (Pokud je mimo rozsah vzorec odkazuje ještě nejste). To je zvlášť důležité Pokud očekáváte vzorec aktualizovat a ne, jak ho můžete ponechá s neúplné výsledky, které nemusí zachytit.

    Příklad znázorňuje automatické rozšíření vzorce součtu ze =SUMA(A2:C2) na =SUMA(A2:D2) při vložení sloupce.
  5. SUMA s individuálními odkazy na buňky vs. Oblasti

    Použití vzorce, jako je:

    • =SUMA(A1;A2;A3;B1;B2;B3)

    Je rovněž chyba chybám při vkládání nebo odstraňování řádků v odkazované oblasti stejných důvodů. Je mnohem lepší používat jednotlivých oblastí, třeba:

    • =SUMA(A1:A3;B1:B3)

    Po přidání nebo odstranění řádků se tento vzorec aktualizuje.

Problém

Co je špatně

Moje funkce SUMA místo výsledku zobrazuje #####.

Zaškrtněte políčko šířky sloupců. ### obecně znamená, že sloupec je příliš úzký zobrazíte výsledek vzorce.

Moje funkce SUMA zobrazuje místo výsledku vzorec jako text.

Zkontrolujte, že na buňku není formátovaná jako text. Vyberte buňku nebo oblast a otevře se dialogové okno Formát buněk a pak klikněte na kartu Číslo a vyberte požadovaný formát stisknutím kláves Ctrl + 1 . Pokud buňka formátované jako text a nezmění po změně formátu, můžete zkusit použít F2 > Enter vynutit formát chcete změnit.

Moje funkce SUMA se neaktualizuje.

Ujistěte se, že výpočtu je nastavena na automaticky. Na kartě vzorce přejděte na Možnosti výpočtů. Můžete taky F9 vynutit listu pro výpočet.

Ujistěte se, že výpočet je nastavený na Automaticky.  Na kartě Vzorec přejděte na Možnosti výpočtů.

Některé hodnoty se nesečetly.

Přičítají se jenom číselné hodnoty, které jsou v odkazu nebo oblasti funkce. Prázdné buňky, logické hodnoty (třeba PRAVDA) nebo text se ignorují.

Místo očekávaného výsledku se zobrazí chyba #NAME?.

Obvykle to znamená, že je vzorec špatně napsaný, například jako =sume(A1:A10) místo = SUMA(A1:A10).

Moje funkce SUMA ukazuje výsledek v celých číslech, ale měla by ukazovat desetinná místa.

Zkontrolujte formátování buněk, jestli máte nastaveno zobrazování desetinných míst. Vyberte příslušnou buňku nebo oblast buněk a pomocí kombinace klávesCtrl+1 vyvolejte dialogové okno Formát buněk, klikněte na kartu Číslo a vyberte požadovaný formát. Zvolte přitom požadovaný počet desetinných míst.

  1. Chci jenom sečíst/odečíst/vynásobit/vydělit čísla – Podívejte se na videa Základní výpočty v Excelu nebo Použití Excelu místo kalkulačky.

  2. Jak zobrazit více nebo méně desetinných míst? Můžete změnit formát čísla. Vyberte buňku nebo oblast a otevře se dialogové okno Formát buněk a pak klikněte na kartu Číslo a vyberte formát, který budete potřebovat, jak zajistit pro určení počtu desetinných míst, který chcete stisknutím kláves Ctrl + 1 .

  3. Jak sčítat nebo odčítat časy? Časy můžete sčítat a odčítat několika různými způsoby. Například pro účely výpočtu mezd můžete získat rozdíl mezi 8:00:00 a 12:00 takto: =("12:00"-"8:00")*24, zadejte nejdřív koncový čas a od něho pak odečtěte počáteční čas. Všimněte si, že Excel počítá čas jako zlomek dne, takže ho musíte vynásobit číslem 24, pokud chcete výsledek zobrazil jako počet hodin. V prvním příkladu používáme vzorec =((B2-A2)+(D2-C2))*24 a získáme tak počet hodin od začátku do konce směny minus přestávka na oběd (celkově 8,50 hodin).

    Pokud jen sčítáte hodiny a minuty a chcete je také tak zobrazit, pak je můžete jenom rychle sečíst a není potřeba výsledek násobit číslem 24. Takže ve druhém příkladu použijeme pro součet funkci =SUMA(A6:C6) a výsledek je ve formátu hodin a minut (5:36, neboli 5 hodin a 36 minut).

    Výpočet času

    Další informace najdete tady: Sčítání a odčítání časových hodnot.

  4. Jak se dostanu rozdíl mezi kalendářními daty? Stejně jako u časy, můžete přidat a odečíst kalendářní data. Tady je velmi Běžným příkladem počtu dní mezi dvěma daty. Je jednoduchá – stačí = B2 A2. Klíč k práci s daty a časem je s koncového data/času zahájení a odečtěte počáteční datum/čas.

    Výpočet doby mezi dvěma daty

    Další způsoby práce s kalendářními daty najdete tady: Výpočet počtu dní mezi dvěma daty.

  5. Jak se sečíst jenom viditelné buňky? Někdy můžete ručně nebo automatickým filtrem skrýt řádky, aby byla zobrazena pouze určitá data, a potom chtít sečíst jenom viditelné buňky. Můžete použít funkci SUBTOTAL. Pokud v tabulce Excelu používáte řádek souhrnů, všechny funkce, které vyberete z rozevírací nabídky, budou automaticky zadány jako mezisoučet (SUBTOTAL). Další informace najdete v tématu Součty dat v tabulce aplikace Excel.

Potřebujete další pomoc?

Kdykoli se můžete zeptat některého odborníka v technické komunitě Excelu, získat podporu v komunitě pro odpovědi, případně navrhnout novou funkci nebo vylepšení ve fóru Excel User Voice.

Viz taky

Další informace o součet

Funkce SUMIF sečte jenom hodnoty, které splňují jedno kritérium

Funkce SUMIFS sečte jenom hodnoty, které odpovídají více kritériím.

Funkce COUNTIF spočítá pouze hodnoty, které splňují jedno kritérium

Funkce COUNTIFS spočítá pouze hodnoty, které odpovídají více kritériím.

Přehled vzorců v Excelu

Jak se vyhnout nefunkčním vzorcům

Nalezení a oprava chyb ve vzorcích

Klávesové zkratky v Excelu pro Windows

Klávesové zkratky v Excelu for Mac

Matematické a trigonometrické funkce

Funkce Excelu (podle abecedy)

Funkce aplikace Excel (podle kategorie)

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×