Funkce SOUČIN.SKALÁRNÍ

Tento článek popisuje syntaxi vzorce a použití funkce SOUČIN.SKALÁRNÍ v Microsoft Excelu.

Popis

Vynásobí odpovídající položky daných matic a vrátí součet násobků jednotlivých položek.

Syntaxe

SOUČIN.SKALÁRNÍ(matice1;[matice2];[matice3];...)

Syntaxe funkce SOUČIN.SKALÁRNÍ obsahuje následující argumenty:

  • Matice1:     Povinný argument. Jedná se o první argument ve formě matice, jejíž jednotlivé položky chcete násobit a poté sečíst.

  • Matice2;matice3;...:     Nepovinný argument. Jedná se o 2. až 255. argument ve formě matic, jejichž jednotlivé položky chcete násobit a poté sečíst.

Poznámky

  • Matice zadané jako argumenty funkce musí být stejně velké. V opačném případě vrátí funkce SOUČIN.SKALÁRNÍ chybovou hodnotu #HODNOTA!.

  • Položky matice, které nejsou číselného typu, zpracovává funkce SOUČIN.SKALÁRNÍ jako nuly.

Příklad

Zkopírujte vzorová data v následující tabulce a vložte je do buňky A1 nového excelového sešitu. Aby vzorce zobrazily výsledky, vyberte je, stiskněte F2 a potom stiskněte Enter. Pokud potřebujete, můžete přizpůsobit šířky sloupců a zobrazit si všechna data.

Matice 1

Matice 2

3

4

2

7

8

6

6

7

1

9

5

3

Vzorec

Popis

Výsledek

=SOUČIN.SKALÁRNÍ(A2:B4;D2:E4)

Vynásobí všechny položky dvou matic a sečte násobky. Postup výpočtu je následující: 3*2 + 4*7 + 8*6 + 6*7 + 1*5 + 9*3 (156).

156

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×