Funkce POČET

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Funkce POČET určuje počet buněk, které obsahují čísla, a počet čísel v seznamu argumentů. Pomocí funkce POČET můžete získat počet položek v číselném poli, které je v nějaké oblasti nebo matici čísel. Zadáním následujícího vzorce například určíte počet čísel v oblasti A1:A20: =POČET(A1:A20). Pokud pět buněk v tomto příkladu obsahuje čísla, bude výsledek 5.

Váš prohlížeč nepodporuje video. Nainstalujte si Microsoft Silverlight, Adobe Flash Player nebo Internet Explorer 9.

Syntaxe

POČET(hodnota1; [hodnota2]; ...)

Syntaxe funkce POČET má následující argumenty:

  • Hodnota1:    Povinný argument. První položka, odkaz na buňku nebo oblast, ve které chcete spočítat čísla.

  • Hodnota2; ...:    Nepovinný argument. Až 255 dalších položek, odkazů na buňky nebo oblastí, ve kterých chcete spočítat čísla.

Poznámka : Argumenty mohou obsahovat různé typy dat nebo na ně odkazovat. Počítají se však pouze čísla.

Poznámky

  • Počítají se argumenty, které jsou vyjádřeny čísly, kalendářními daty nebo čísly formátovanými jako text (jako jsou čísla uzavřená do uvozovek, například "1").

  • Je možné používat logické hodnoty a čísla formátovaná jako text zadaná přímo do seznamu argumentů.

  • Argumenty typu chybová hodnota nebo text, který nelze převést na číslo, nejsou počítány.

  • Pokud je argumentem matice nebo odkaz, jsou započítána pouze čísla uvedená v dané matici nebo v odkazovaných buňkách. Prázdné buňky, logické hodnoty, text nebo chybové hodnoty nejsou počítány.

  • Chcete-li počítat logické hodnoty, text nebo chybové hodnoty, použijte funkci POČET2.

  • Chcete-li počítat pouze čísla splňující určitá kritéria, použijte funkci COUNTIF nebo COUNTIFS.

Příklad

Zkopírujte vzorová data v následující tabulce a vložte je do buňky A1 nového excelového sešitu. Aby vzorce zobrazily výsledky, vyberte je, stiskněte F2 a potom stiskněte Enter. Pokud potřebujete, můžete přizpůsobit šířky sloupců a zobrazit si všechna data.

Data

08.12.08

19

22,24

PRAVDA

#DIV/0!

Vzorec

Popis

Výsledek

=POČET(A2:A7)

Vrátí počet buněk obsahujících čísla z oblasti A2 až A7.

3

=POČET(A5:A7)

Vrátí počet buněk obsahujících čísla z oblasti A5 až A7.

2

=POČET(A2:A7;2)

Vrátí součet buněk obsahujících čísla z oblasti A2 až A7 a hodnoty 2.

4

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Viz taky

Funkce COUNTIF (počítá buňky, které splňují určité kritérium)

Funkce POČET2 (počítá neprázdné buňky v oblasti)

Sdílení Facebook Facebook Twitter Twitter E-mail E-mail

Byly tyto informace užitečné?

Výborně! Je ještě něco dalšího, co byste nám chtěli dát vědět?

Jak bychom ho mohli vylepšit?

Děkujeme vám za zpětnou vazbu.

×