Funkce NEBO

Pomocí funkce NEBO – jedné z logických funkcí – můžete určit, jestli mají některé z testovaných podmínek hodnotu PRAVDA.

Příklad

Příklady použití funkce NEBO

Funkce NEBO vrátí hodnotu PRAVDA, pokud je některý z jejích argumentů vyhodnocen jako PRAVDA, a vrátí hodnotu NEPRAVDA, pokud jsou všechny argumenty vyhodnoceny jako NEPRAVDA.

Jedním z obvyklých způsobů použití funkce NEBO je rozšíření užitečnosti jiných funkcí provádějících logické testy. Funkce KDYŽ například provede logický test a vrátí jednu hodnotu, pokud je test vyhodnocen jako PRAVDA, a jinou hodnotu, pokud je test vyhodnocen jako NEPRAVDA. Pokud použijete funkci NEBO jako argument typu podmínka funkce KDYŽ, můžete namísto jedné podmínky testovat několik různých podmínek.

Syntaxe

NEBO(logická1; [logická2]; ...)

Syntaxe funkce NEBO obsahuje následující argumenty:

Argument

Popis

Logická1

Povinný argument. První podmínka, kterou chcete testovat a která může být vyhodnocena jako PRAVDA nebo NEPRAVDA.

Logická2; ...

Nepovinný argument. Další podmínky, které chcete testovat a které mohou být vyhodnoceny jako PRAVDA nebo NEPRAVDA. Lze použít nejvýše 255 podmínek.

Poznámky

  • Argumenty se musí vyhodnocovat na logické hodnoty jako PRAVDA nebo NEPRAVDA, nebo v polích na odkazy, které obsahují logické hodnoty.

  • Jestliže je argumentem matice nebo odkaz a příslušná oblast obsahuje text nebo prázdné buňky, jsou tyto hodnoty ignorovány.

  • Pokud daná oblast neobsahuje žádné logické hodnoty, vrátí funkce NEBO chybovou hodnotu #HODNOTA!.

  • Pomocí maticového vzorce NEBO můžete zjistit, zda se v dané matici nachází hodnota. Maticový vzorec lze zadat stisknutím kombinace kláves CTRL+SHIFT+ENTER.

Příklady

Tady je několik obecných příkladů použití funkce NEBO jako samostatné funkce a ve spojení s funkcí KDYŽ.

Příklady použití funkce NEBO s funkcí KDYŽ


Vzorec

Popis

=NEBO(A2>1;A2<100)

Zobrazí hodnotu PRAVDA, když je A2 větší než 1 NEBO menší než 100, jinak zobrazí hodnotu NEPRAVDA.

=KDYŽ(NEBO(A2>1;A2<100);A3;"Hodnota je mimo interval")

Když je hodnota větší než 1 NEBO menší než 100, zobrazí hodnotu v buňce A3, jinak zobrazí zprávu "Hodnota je mimo interval".

=KDYŽ(NEBO((A2<0;A2>50);A2;"Hodnota je mimo interval")

Když je hodnota menší než 0 NEBO větší než 50, zobrazí hodnotu v buňce A2, jinak zobrazí zprávu.

Výpočet provize z prodeje

Tady je vcelku běžný scénář, kdy je potřeba vypočítat, jestli má pracovník prodeje nárok na provizi, pomocí funkcí KDYŽ a NEBO.

Příklady použití funkcí KDYŽ a NEBO k výpočtu provize z prodeje
  • =KDYŽ(NEBO(B14>=$B$4;C14>=$B$5);B14*$B$6;0)KDYŽ je celkový objem prodeje větší než nebo roven (>=) cílovému objemu prodeje NEBO je počet zákazníků větší než nebo roven (>=) cílovému počtu zákazníků, potom vynásob celkový objem prodeje výší (%) komise, jinak vrať hodnotu 0.

Máte konkrétní otázku k funkci?

Zadejte dotaz do komunitního fóra Excelu

Pomozte nám vylepšit Excel

Máte nějaké návrhy na zlepšení dalších verzí Excelu? Pokud ano, podívejte se prosím na témata v části Názor uživatele Excelu.

Viz taky

Podívejte se na video o tom, jak používat funkci KDYŽ

Naučte se, jak používat ve vzorcích vnořené funkce

Funkce KDYŽ

Funkce A

Funkce NE

Přehled vzorců v aplikaci Excel

Jak se vyhnout nefunkčním vzorcům

Použijte funkci zjišťování chyb ve vzorcích v Excelu 2016 pro Windows

Klávesové zkratky v Excelu 2016 pro Windows

Klávesové zkratky v Excelu 2016 pro Mac

Logické funkce (odkazy)

Funkce aplikace Excel (podle abecedy)

Funkce aplikace Excel (podle kategorie)

Sdílení Facebook Facebook Twitter Twitter E-mail E-mail

Byly tyto informace užitečné?

Výborně! Je ještě něco dalšího, co byste nám chtěli dát vědět?

Jak bychom ho mohli vylepšit?

Děkujeme vám za zpětnou vazbu.

×