Funkce KDYŽ

Jednou z nejoblíbenějších funkcí Excelu je funkce KDYŽ, která umožňuje logicky porovnávat hodnotu s očekáváním. V nejjednodušší podobě funkce KDYŽ říká:

  • KDYŽ(je něco pravda; udělej něco; jinak udělej něco jiného)

To znamená, že příkaz KDYŽ může mít dva výsledky. První výsledek platí, pokud je výsledkem porovnání pravda, a druhý výsledek platí v případě nepravdy.

Pokud chcete přeskočit k práci s více příkazy KDYŽ, přejděte na téma Pokročilé funkce KDYŽ – práce s vnořenými vzorci a předcházení problémům.

Funkce KDYŽ, jedna z logických funkcí, vrátí jednu hodnotu, pokud se zadaná podmínka vyhodnotí jako Pravda, a jinou hodnotu, pokud se vyhodnotí jako Nepravda.

Syntaxe

KDYŽ(podmínka;ano;ne)

Příklady:

  • =KDYŽ(A2>B2;"Překročil se rozpočet.";"OK")

  • =KDYŽ(A2=B2;B4-A4;"")

Název argumentu

Popis

Podmínka    (povinné)

Podmínka, kterou chcete testovat

Ano    (povinné)

Hodnota, která se má vrátit, pokud se podmínka vyhodnotí jako PRAVDA

Ne    (volitelné)

Hodnota, která se má vrátit, pokud se podmínka vyhodnotí jako NEPRAVDA

Jednoduché příklady funkce KDYŽ

Buňka D2 obsahuje vzorec =KDYŽ(C2="Ano";1;2)
  • =KDYŽ(C2="Ano";1;2)

Buňka D2 v předchozím příkladu říká: KDYŽ(C2 = Ano; vrátit hodnotu 1; jinak vrátit hodnotu 2).

Buňka D2 obsahuje vzorec =KDYŽ(C2=1;"ANO";"NE")
  • =KDYŽ(C2=1;"Ano";"Ne")

V tomto příkladu vzorec v buňce D2 říká: KDYŽ(C2 = 1; vrátit Ano; jinak vrátit Ne)

Jak je vidět, můžete funkci KDYŽ použít k vyhodnocení textu i hodnot. Můžete ji taky použít k vyhodnocení chyb. Ověřování není omezené jenom na to, jestli se něco něčemu rovná, aby se vrátil jediný výsledek. Můžete použít i matematické operátory a provádět další výpočty založené na kritériích. Pokud do sebe vnoříte více funkcí KDYŽ, můžete provádět i vícenásobné porovnání.

Poznámka : Pokud používáte ve vzorcích text, musíte ho dát do uvozovek (např. "Text"). Jedinou výjimkou je použití hodnot PRAVDA a NEPRAVDA, kterým Excel rozumí automaticky.

Jak začít

Nejlepší způsob, jak začít psát příkaz KDYŽ, je napřed si rozmyslet, co chcete udělat. Co chcete porovnat? Často je napsání příkazu KDYŽ jenom otázkou logické úvahy o tom, co se má stát při splnění podmínky a co se má stát při jejím nesplnění. Vždycky si dejte pozor na to, aby vaše kroky sledovaly nějaký logický vývoj, jinak vzorec nebude fungovat tak, jak má. Zvlášť důležité to je, když vytváříte složité (vnořené) příkazy KDYŽ.

Další příklady funkce KDYŽ

Vzorec v buňce D2 je =KDYŽ(C2>B2;"Překročení rozpočtu";"V rámci rozpočtu")
  • =KDYŽ(C2>B2;"Rozpočet překročen";"V rámci rozpočtu")

V předchozím příkladu funkce KDYŽ v buňce D2 říká KDYŽ(C2 je větší než B2; vrať hodnotu "Rozpočet překročen"; jinak vrať hodnotu "V rámci rozpočtu").

Vzorec v buňce E2 je =KDYŽ(C2>B2;C2-B2;"")
  • =KDYŽ(C2>B2;C2-B2;0)

Předchozí příklad vrátí místo textového výsledku matematický výpočet. Vzorec v buňce E2 říká KDYŽ(skutečná částka je větší než plánovaná částka; odečti plánovanou částku od skutečné částky; jinak nevracej nic).

Vzorec v buňce F7 je KDYŽ(E7="Ano";F5*0,0825;0)
  • =KDYŽ(E7="Ano";F5*0,0825;0)

V tomto příkladu vzorec v buňce F7 říká: KDYŽ(E7 = "Ano"; vypočítej celkovou částku jako součin F5 * 8,25 %; jinak se žádná daň neplatí a vrať hodnotu 0).

Doporučené postupy pro konstanty

V posledním příkladu jsou vidět přímo ve vzorci zadané hodnoty Ano a sazba prodejní daně (0,0825). Obecně se ale nedoporučuje zadávat konstanty literálů (tj. hodnoty, které se občas mění) přímo do vzorců, protože se pak špatně hledají a mění. Mnohem lepší je dát konstanty do vlastních buněk, kde jsou vidět a můžete je jednoduše najít i změnit. V uvedeném příkladu to nevadí, protože máme jenom jednu funkci KDYŽ a sazba prodejní daně se mění jen málokdy. A i když se změní, můžete ji ve vzorci jednoduše změnit.

Výpočetní operátory

Pokud chcete získat další informace o různých výpočetních operátorech, které můžete použít ve vzorcích (< menší než, > větší než, = rovná se, <> nerovná se atd.), přečtěte si článek Výpočetní operátory a jejich priorita.

Použití funkce KDYŽ ke kontrole, jestli je buňka prázdná

Někdy je potřeba zkontrolovat, jestli je buňka prázdná, obvykle proto, že nechcete, aby vzorec zobrazoval výsledek bez vstupních hodnot.

Vzorec v buňce E2 je =KDYŽ(D2=1;"Ano";KDYŽ(D2=2;"Ne";"Možná"))

V tomto případě používáme funkci KDYŽ v kombinaci s funkcí JE.PRÁZDNÉ:

  • =KDYŽ(JE.PRÁZDNÉ(D2);"Prázdné";"Není prázdné")

Tento vzorec říká KDYŽ(buňka D2 je prázdná; vrať hodnotu "Prázdné"; jinak vrať hodnotu "Není prázdné"). Stejně snadno můžete pro podmínku "Není prázdné" použít i vlastní vzorec. V dalším příkladu používáme místo funkce JE.PRÁZDNÉ výraz prázdného řetězce: "". Výraz "" v zásadě znamená „nic“.

Kontrola, jestli není buňka prázdná: Vzorec v buňce E2 je =KDYŽ(JE.PRÁZDNÉ(D2);"Prázdné";"Není prázdné")
  • =KDYŽ(D3="";"Prázdné";"Není prázdné")

Tento vzorec říká KDYŽ(buňka D3 nemá žádný obsah; vrať hodnotu "Prázdné"; jinak vrať hodnotu "Není prázdné"). Tady je příklad velmi běžného způsobu použití výrazu "" k tomu, aby se zabránilo výpočtu vzorce v případě, že je závislá buňka prázdná:

  • =KDYŽ(D3="";"";VášVzorec())

    KDYŽ(buňka D3 nemá žádný obsah; nevracej nic; jinak vypočti zadaný vzorec).

Příklad vnořeného příkazu KDYŽ

Jednoduchá funkce KDYŽ má jenom dva výsledky (pravda nebo nepravda), ale vnořené funkce KDYŽ jich můžou mít 3 až 64.

Použití "" ke kontrole prázdných buněk – vzorec v buňce E3 je =KDYŽ(D3="";"Prázdné";"Není prázdné")
  • =KDYŽ(D2=1;"ANO";KDYŽ(D2=2;"Ne";"Možná"))

V předchozím příkladu vzorec v buňce E2 říká: KDYŽ(D2 je rovno 1; vrať hodnotu „Ano“; jinak KDYŽ(D2 je rovno 2; vrať hodnotu „Ne“; jinak vrať hodnotu „Možná“)). Všimněte si, že na konci vzorce jsou dvě pravé závorky. Ty jsou potřebné k zakončení obou funkcí KDYŽ. Pokud zkusíte zadat vzorec bez obou pravých závorek, Excel se ho pokusí automaticky opravit.

Upozornění

Excel sice umožňuje vnořit do sebe až 64 různých funkcí KDYŽ, ale v žádném případě se to nedoporučuje. Proč?

  • Protože několikanásobné příkazy KDYŽ se špatně promýšlejí a jsou náročné na sestavení, abyste si byli jistí správnou logikou výpočtu každé podmínky až do konce příkazu. Pokud příkazy KDYŽ nevnoříte na 100 % přesně, může vzorec fungovat v 75 % případů, ale ve 25 % případů může vrátit nečekané výsledky. Pravděpodobnost, že těch 25 % případů zachytíte, je bohužel malá.

  • Údržba vícenásobných příkazů KDYŽ může být velmi obtížná. Platí to zejména tehdy, když se k příkazu vrátíte po nějaké době a snažíte se přijít na to, co jste se vy (nebo v horším případě někdo jiný) pokoušeli udělat.

  • Vícenásobné příkazy KDYŽ můžou vyžadovat hodně levých a pravých závorek, které ve složitých vzorcích asi nebude snadné správně umístit.

Běžné problémy

Problém

Co je špatně

0 (nula) v buňce

Argument ano ani argument ne neměl žádné argumenty. Aby se vrátila správná hodnota, přidejte do obou argumentů text argumentu, nebo do argumentu přidejte hodnotu PRAVDA nebo NEPRAVDA.

Chyba #NÁZEV? v buňce

Většinou to znamená, že je špatně napsaný vzorec.

Potřebujete další pomoc?

Kdykoli se můžete zeptat některého odborníka v technické komunitě Excelu, získat podporu v komunitě pro odpovědi, případně navrhnout novou funkci nebo vylepšení ve fóru Excel User Voice.

Viz také

Video: Pokročilé funkce KDYŽ

Funkce IFS (Office 365, Excel 2016 a novější)

Funkce KDYŽ – jak se vyhnout nástrahám při použití vnořených vzorců

Školicí videa: Pokročilé funkce KDYŽ

Funkce COUNTIF spočítá hodnoty podle jednoho kritéria

Funkce COUNTIFS spočítá hodnoty podle více kritérií

Funkce SUMIF sečte hodnoty podle jednoho kritéria

Funkce SUMIFS sečte hodnoty podle více kritérií

Funkce A

Funkce NEBO

Funkce SVYHLEDAT

Přehled vzorců v Excelu

Jak se vyhnout nefunkčním vzorcům

Zjišťování chyb ve vzorcích pomocí kontroly chyb

Logické funkce

Funkce Excelu (podle abecedy)

Funkce Excelu (podle kategorie)

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×