Funkce A

Tento článek popisuje syntaxi vzorce a použití funkce A v Microsoft Excelu.

Popis

Vrátí hodnotu PRAVDA, pokud jsou všechny argumenty vyhodnoceny jako PRAVDA. Vrátí hodnotu NEPRAVDA, pokud je alespoň jeden z argumentů vyhodnocen jako NEPRAVDA.

Jedním z obvyklých způsobů použití funkce A je rozšíření užitečnosti jiných funkcí provádějících logické testy. Funkce KDYŽ například provede logický test a vrátí jednu hodnotu, pokud je test vyhodnocen jako PRAVDA, a jinou hodnotu, pokud je test vyhodnocen jako NEPRAVDA. Použijete-li funkci A jako argument podmínka funkce KDYŽ, můžete namísto jedné podmínky testovat několik různých podmínek.

Syntaxe

A(logická1;[logická2];...)

Syntaxe funkce A má následující argumenty:

  • Logická1    Povinný argument. První podmínka, kterou chcete testovat a která může být vyhodnocena jako PRAVDA nebo NEPRAVDA.

  • Logická2; ...    Nepovinný argument. Další podmínky, které chcete testovat a které mohou být vyhodnoceny jako PRAVDA nebo NEPRAVDA. Lze použít nejvýše 255 podmínek.

Poznámky

  • Argumenty musí být vyhodnotitelné jako logické hodnoty PRAVDA nebo NEPRAVDA nebo se musí jednat o matici nebo odkazy na buňky, které obsahují logické hodnoty.

  • Jestliže je argumentem matice nebo odkaz a příslušná oblast obsahuje text nebo prázdné buňky, jsou tyto hodnoty ignorovány.

  • Pokud zadaná oblast neobsahuje žádné logické hodnoty, vrátí funkce A chybovou hodnotu #HODNOTA!.

Příklady

Zkopírujte vzorová data v následující tabulce a vložte je do buňky A1 nového excelového sešitu. Aby vzorce zobrazily výsledky, vyberte je, stiskněte F2 a potom stiskněte Enter. Pokud potřebujete, můžete přizpůsobit šířky sloupců a zobrazit si všechna data.

Vzorec

Popis

Výsledek

=A(PRAVDA;PRAVDA)

Všechny argumenty jsou PRAVDA.

PRAVDA

=A(PRAVDA;NEPRAVDA)

Jeden argument je NEPRAVDA.

NEPRAVDA

=A(2+2=4;2+3=5)

Všechny argumenty jsou vyhodnoceny jako PRAVDA.

PRAVDA

Příklad 2

Data

50

104

Vzorec

Popis

Výsledek

=A(1<A2;A2<100)

Vrátí hodnotu PRAVDA, pokud je číslo v buňce A2 větší než 1 a menší než 100. V opačném případě vrátí hodnotu NEPRAVDA.

PRAVDA

=KDYŽ(A(1<A3;A3<100);A3;"Hodnota je mimo interval.")

Zobrazí číslo v buňce A3, pokud spadá do rozsahu 1 až 100. V opačném případě zobrazí zprávu Hodnota je mimo interval.

Hodnota je mimo rozsah.

=KDYŽ(A(1<A2; A2<100); A2; "Hodnota je mimo interval.")

Zobrazí číslo v buňce A2, pokud spadá do rozsahu 1 až 100. V opačném případě zobrazí zprávu.

50

Sdílení Facebook Facebook Twitter Twitter E-mail E-mail

Byly tyto informace užitečné?

Výborně! Je ještě něco dalšího, co byste nám chtěli dát vědět?

Jak bychom ho mohli vylepšit?

Děkujeme vám za zpětnou vazbu.

×