Funkce A

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Pomocí funkce A (jedné z logických funkcí) můžete určit, jestli mají všechny testované podmínky hodnotu PRAVDA.

Příklad

Příklady funkce A

Funkce A vrátí hodnotu PRAVDA, pokud jsou všechny argumenty vyhodnoceny jako PRAVDA. Vrátí hodnotu NEPRAVDA, pokud je alespoň jeden z argumentů vyhodnocen jako NEPRAVDA.

Jedním z obvyklých způsobů použití funkce A je rozšíření užitečnosti jiných funkcí provádějících logické testy. Funkce KDYŽ například provede logický test a vrátí jednu hodnotu, pokud je test vyhodnocen jako PRAVDA, a jinou hodnotu, pokud je test vyhodnocen jako NEPRAVDA. Použijete-li funkci A jako argument podmínka funkce KDYŽ, můžete namísto jedné podmínky testovat několik různých podmínek.

Syntaxe

A(logická1;[logická2];...)

Syntaxe funkce A má následující argumenty:

Argument

Popis

Logická1

Povinný argument. První podmínka, kterou chcete testovat a která může být vyhodnocena jako PRAVDA nebo NEPRAVDA.

Logická2; ...

Nepovinný argument. Další podmínky, které chcete testovat a které mohou být vyhodnoceny jako PRAVDA nebo NEPRAVDA. Je možné použít maximálně 255 podmínek.

Poznámky

  • Argumenty musí být vyhodnotitelné jako logické hodnoty PRAVDA nebo NEPRAVDA nebo se musí jednat o matici nebo odkazy na buňky, které obsahují logické hodnoty.

  • Jestliže je argumentem matice nebo odkaz a příslušná oblast obsahuje text nebo prázdné buňky, jsou tyto hodnoty ignorovány.

  • Pokud zadaná oblast neobsahuje žádné logické hodnoty, vrátí funkce A chybu #HODNOTA!.

Příklady

Tady je několik obecných příkladů použití funkce A jako samostatné funkce a ve spojení s funkcí KDYŽ.

Příklady použití funkce KDYŽ s funkcí A

Vzorec

Popis

=A(A2>1;A2<100)

Zobrazí hodnotu PRAVDA, když je hodnota v buňce A2 větší než 1 A menší než 100, jinak zobrazí hodnotu NEPRAVDA.

=KDYŽ(A(A2<A3;A2<100);A2;”Hodnota je mimo rozsah”)

Když je hodnota menší než hodnota v buňce A3 A menší než 100, zobrazí hodnotu v buňce A2, jinak zobrazí zprávu, že je hodnota mimo rozsah.

=KDYŽ(A(A3>1;A3<100);A3;"Hodnota je mimo rozsah.")

Když je hodnota v buňce A3 větší než 1 A menší než 100, zobrazí hodnotu z buňky A3, jinak zobrazí zprávu. Text zprávy můžete nahradit zprávou podle vlastního výběru.

Výpočet bonusu

Představujeme vcelku běžný scénář, kdy je potřeba vypočítat, jestli má pracovník prodeje nárok na odměnu, pomocí funkce KDYŽ a A.

Příklad výpočtu odměny za prodej pomocí funkcí KDYŽ a A.  Vzorec v buňce E14 je =KDYŽ(A(B14>=$B$7;C14>=$B$5);B14*$B$8;0)
  • =KDYŽ(A(B14>=$B$7;C14>=$B$5);B14*$B$8;0)KDYŽ je celkový objem prodeje větší nebo roven (>=) cílovému objemu prodeje A počet zákazníků je větší nebo roven (>=) cílovému počtu zákazníků, potom se má celkový objem prodeje vynásobit % bonusu, jinak se má vrátit hodnota 0.

Potřebujete další pomoc?

Kdykoli se můžete zeptat některého odborníka v technické komunitě Excelu, získat podporu v komunitě pro odpovědi, případně navrhnout novou funkci nebo vylepšení ve fóru Excel User Voice.

Příbuzná témata

Video: Pokročilé funkce když
informace o používání vnořených funkcí ve vzorci
funkce když
Funkce OR
funkce ne
Přehled vzorců v Excelu
Jak se vyhnout nefunkčním vzorcům
kontroly zjišťování chyb ve vzorcích použít chyb
klávesové zkratky v Excelu 2016 pro Windows
klávesové zkratky v Excelu 2016 pro Mac
Logické funkce (odkazy)
funkce Excelu (podle abecedy)
funkcí aplikace Excel (podle kategorie)

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×