Exportovat XML data v aplikaci Excel 2016

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Po tom, co jste naimportovali XML data, namapovali je na buňky v listu a udělali v nich změny, často chcete data vyexportovat nebo uložit do XML souboru.

Důležité :  Při vytváření mapování XML a exportu dat z Excelu do datových souborů XML existuje limit pro počet řádků, které je možné vyexportovat. Při exportu z Excelu do XML se uloží maximálně 65 536 řádků. Pokud soubor obsahuje víc než 65 536 řádků, můžete udělat jednu z těchto věcí:

  • Vyexportovat data ve formátu souboru XLSX.

  • Uložit soubor ve formátu Tabulka XML (.xml), ve kterém se mapování ztratí.

  • Odstranit všechny řádky pod řádkem 65 536 a potom data znova vyexportovat, čímž se mapování zachová, ale ztratí se data na konci souboru.

Export XML dat z listu s počtem řádků nepřesahujícím 65 536 řádků

  1. Na kartě Vývojář klikněte ve skupině XML na tlačítko Export.

    Pokud se vám karta Vývojář nezobrazuje, přečtěte si téma Zobrazení karty Vývojář.

  2. Pokud se zobrazí malé dialogové okno Exportovat XML, klikněte na mapování XML, které chcete použít, a pak klikněte na OK.

    Toto dialogové okno se zobrazí, jenom pokud některá tabulka XML není vybraná a pokud sešit obsahuje víc než jedno mapování XML.

  3. Ve velkém dialogovém okně Exportovat XML zadejte do pole Název souboru název datového souboru XML.

  4. Klikněte na tlačítko Exportovat.

    Poznámka : Pokud list obsahuje nadpisy nebo popisky, které se liší od názvů elementů XML v mapování XML, Excel při exportu nebo uložení dat XML z listu použije názvy elementů XML.

Export XML dat z listu s počtem řádků přesahujícím 65 536 řádků

  1. Odečtěte 65537 od celkového počtu řádků v souboru.

    To vám dá počet řádků x.

  2. Odstraňte x řádků od začátku excelového listu.

  3. Vyexportujte list jako datový soubor XML.

  4. Klikněte na Zavřít a pak znovu otevřete excelový list.

  5. Odstraňte všechny položky od součtu x a potom soubor vyexportujte jako datový soubor XML.

    Tímto postupem dostanete zbytek řádků. V tomto okamžiku budete mít dva vyexportované soubory XML, které můžete zkombinovat a vytvořit tak kopii původního listu.

Uložení dat XML v mapovaných buňkách do datového souboru XML

Z důvodu zpětné kompatibility s původními funkcemi XML můžete chtít soubor uložit do datového souboru XML (.xml) místo použití příkazu Exportovat.

  1. Uložte soubor stisknutím kombinace kláves Ctrl+S.

    Tento krok zajistí, že se s uložením sešitu jako datového souboru XML neztratí žádné provedené změny.

  2. Klikněte na Soubor, klikněte na Uložit jako a pak vyberte umístění, kam chcete soubor uložit.

  3. Do pole Název souboru zadejte název datového souboru XML.

  4. V rozevíracím seznamu Uložit jako typ klikněte na Datové soubory ve formátu XML a pak klikněte na Uložit.

  5. Pokud se zobrazí zpráva oznamující, že při uložení souboru ve formátu XML dat může dojít ke ztrátě funkcí, klikněte na Pokračovat.

  6. Pokud se zobrazí malé dialogové okno Exportovat XML, klikněte na mapování XML, které chcete použít, a pak klikněte na OK.

    Toto dialogové okno se zobrazí, jenom pokud některá tabulka XML není vybraná a sešit obsahuje víc než jedno mapování XML.

  7. Ve velkém dialogu Exportovat XML zadejte do pole Název souboru název datového souboru XML.

  8. Klikněte na Exportovat.

Poznámka : Pokud list obsahuje nadpisy nebo popisky, které se liší od názvů elementů XML v mapování XML, Excel při exportu nebo uložení dat XML z listu použije názvy elementů XML.

Běžné problémy s exportem dat XML

Při exportu dat XML se vám můžou zobrazit zprávy, jako jsou ty následující.

Mapování XML je možné vyexportovat, ale některé povinné elementy nejsou namapované

Tato zpráva se může zobrazit z několika důvodů:

  • Mapování XML, které je přidružené k této tabulce XML, obsahuje jeden nebo víc povinných elementů, které nejsou namapované na tabulku XML.

    Hierarchický seznam elementů v podokně úloh Zdroj XML označuje povinné elementy umístěním červené hvězdičky do pravého horního rohu ikony nalevo u každého elementu. Pokud chcete namapovat požadovaný element, přetáhněte ho do místa na listu, kde se má zobrazit.

  • Element je rekurzivní struktura.

    Běžným příkladem rekurzivní struktury je hierarchie zaměstnanců a manažerů, ve které jsou stejné elementy XML vnořené do několika úrovní. I když jste možná v podokně úloh Zdroj dat XML namapovali všechny elementy, Excel nepodporuje rekurzivní struktury do hloubky více než jedna úroveň, takže nemůže namapovat všechny elementy.

  • Tabulka XML obsahuje smíšený obsah.

    Smíšený obsah nastane, když má element podřízený element a jednoduchý text mimo podřízený element. Běžným případem je použití formátovacích značek (například značek pro tučné písmo ) k označení dat v rámci elementu. Přestože podřízený element může být zobrazený (pokud ho Excel podporuje), po importu dat bude textový obsah ztracený, a protože není k dispozici během exportu dat, není možné tento problém obejít.

Mapování XML v sešitu není možné exportovat

Mapování XML není možné vyexportovat, pokud není možné zachovat vztah mapovaného elementu s jinými elementy. Tento vztah se nemusí zachovat z následujících důvodů:

  • Definice schématu mapovaného elementu je obsažená v posloupnosti s následujícími atributy:

    • Atribut maxoccurs se nerovná 1.

    • Posloupnost obsahuje víc než jeden definovaný přímý podřízený element nebo má jiný kompozitor jako přímý podřízený element.

  • Neopakující se elementy na stejné úrovni se stejným opakujícím se nadřazeným elementem jsou namapované na různé tabulky XML.

  • Několik opakujících se elementů je namapovaných na stejnou tabulku XML a opakování není definované nadřazeným elementem.

  • Podřízené elementy různých nadřízených elementů jsou namapované na stejnou tabulku XML.

Mapování XML navíc není možné vyexportovat, pokud obsahuje následující konstrukty schématu XML:

  • Seznam seznamů:    Seznam položek obsahuje druhý seznam položek.

  • Nenormalizovaná data:    XML tabulka obsahuje element, který má ve schématu definovaný jeden výskyt (atribut maxoccurs je nastavený na hodnotu 1). Pokud takový element přidáte do tabulku XML, Excel vyplní do sloupce tabulky víc instancí elementu.

  • Volba:    Mapovaný element je součástí konstrukce schématu <volba>.

Excel nemůže uložit sešit, protože nemá žádnou mapovanou oblast

Excel nemůže uložit sešit v datovém souboru XML, dokud nevytvoříte jednu nebo několik mapovaných oblastí.

Pokud jste přidali mapování XML k sešitu, pomocí následujícího postupu namapujte elementy XML na list:

  1. Na kartě Vývojář klikněte ve skupině XML na Zdroj.

    Příkazy XML na kartě Vývojář

    Pokud se vám karta Vývojář nezobrazuje, přečtěte si téma Zobrazení karty Vývojář.

  2. V podokně úloh Zdroj dat XML vyberte elementy, které chcete namapovat na list.

    Pokud chcete vybrat nesousedící elementy, klikněte na jeden element, podržte stisknutou klávesu CTRL a pak postupně klikněte na další jednotlivé elementy.

  3. Vybrané elementy přetáhněte do místa na listu, kde je chcete zobrazit.

Pokud jste do sešitu nepřidali mapování XML nebo pokud vaše data nejsou v tabulce XML, uložte sešit jako Sešit Excelu s podporou maker (.xlsm).

Zobrazení karty Vývojář

  1. Klikněte na kartu Soubor a potom na položku Možnosti.

  2. Klikněte na kategorii Přizpůsobit pás karet.

  3. V oblasti Hlavní karty zaškrtněte políčko Vývojář a klikněte na tlačítko OK.

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Sdílení Facebook Facebook Twitter Twitter E-mail E-mail

Byly tyto informace užitečné?

Výborně! Je ještě něco dalšího, co byste nám chtěli dát vědět?

Jak bychom ho mohli vylepšit?

Děkujeme vám za zpětnou vazbu.

×