Digitální podpis projektu maker

V tomto článku se popisuje, jak se Projekt maker dá digitálně podepsat pomocí Certifikát. Pokud digitální certifikát ještě nemáte, je nutné ho získat. Pro testování projektů maker ve vlastním počítači můžete pomocí nástroje Selfcert.exe vytvořit vlastní certifikát podepsaný svým držitelem.

Digitální certifikát můžete získat od komerční certifikační autority nebo od svého interního správce zabezpečení nebo pracovníka oddělení informačních technologií.

Informace o certifikačních autoritách, které nabízejí služby pro produkty Microsoftu, najdete v seznamu členů programu Microsoft Root Certificate Program.

Začátek stránky

Vzhledem k tomu, že digitální certifikát, který si sami vytvoříte, není vystavený důvěryhodnou certifikační autoritou, označují se projekty maker digitálně podepsané pomocí takového certifikátu jako projekty podepsané svým držitelem. Microsoft Office důvěřuje certifikátu podepsanému svým držitelem jenom v počítači, ve kterém je certifikát podepsaný svým držitelem přidaný do složky Důvěryhodné kořenové certifikační autority v úložišti Certifikáty – aktuální uživatel.

Informace o vytvoření certifikátu podepsaného svým držitelem najdete v dalším oddílu.

  1. Přejděte do umístění C:\Program Files (x86)\Microsoft Office\root\.

  2. Klikněte na SelfCert.exe. Zobrazí se okno Vytvořit digitální certifikát.

  3. Do pole Název vašeho certifikátu zadejte popisný název certifikátu.

  4. Klikněte na tlačítko OK.

  5. Když se zobrazí zpráva SelfCert - úspěch, klikněte na tlačítko OK.

  1. Přejděte do umístění C:\Program Files\Microsoft Office\<verze Office>\.

  2. Klikněte na SelfCert.exe. Zobrazí se okno Vytvořit digitální certifikát.

  3. Do pole Název vašeho certifikátu zadejte popisný název certifikátu.

  4. Klikněte na tlačítko OK.

  5. Když se zobrazí zpráva SelfCert - úspěch, klikněte na tlačítko OK.

  1. Klikněte na tlačítko Start, přejděte na Všechny programy a klikněte na Microsoft Office, Nástroje systému Microsoft Office a potom na Digitální certifikát pro projekty v jazyce VBA.
    Zobrazí se okno Vytvořit digitální certifikát.

  2. Do pole Název vašeho certifikátu zadejte popisný název certifikátu.

  3. Klikněte na tlačítko OK.

  4. Když se zobrazí zpráva SelfCert - úspěch, klikněte na tlačítko OK.

Dialogové okno Vytvořit digitální certifikát

Chcete-li certifikát zobrazit v úložišti osobních certifikátů, postupujte takto:

  1. Spusťte aplikaci Internet Explorer.

  2. V nabídce Nástroje klikněte na příkaz Možnosti sítě Internet a potom na kartu Obsah.

  3. Klikněte na tlačítko Certifikáty a pak na kartu Osobní.

Začátek stránky

  1. Otevřete soubor s projektem maker, který chcete podepsat.

  2. Na kartě Vývojář klikněte ve skupině Kód na možnost Visual Basic.

    Poznámka : Pokud není karta Vývojář k dispozici: Klikněte na kartu Soubor. Klikněte na položku Možnosti. Klikněte na položku Přizpůsobit pás karet. V seznamu Přizpůsobit pás karet klikněte na položku Vývojář a potom na tlačítko OK.

  3. V editoru jazyka Visual Basic klikněte v nabídce Tools (Nástroje) na příkaz Digital Signature (Digitální podpis).

  4. Zobrazí se dialogové okno Digitální podpis.

  5. Vyberte certifikát a klikněte na tlačítko OK

    Poznámka : Pokud jste dosud nevybrali digitální certifikát nebo chcete použít jiný, klikněte na tlačítko Zvolit. Vyberte certifikát a pak klikněte na tlačítko OK.

    Poznámky : 

    • Doporučujeme makra podepisovat pouze po podrobení projektu maker testům a jeho připravenosti k distribuci. Provedení jakýchkoli úprav v podepsaném projektu maker vede k odebrání jeho digitálního podpisu. Pokud je však v místním počítači nainstalován platný digitální certifikát, který byl předtím použit k podepsání daného projektu maker, bude projekt maker při uložení automaticky znovu podepsán.

    • Pokud chcete uživatelům vašeho řešení zabránit v tom, aby projekt maker omylem změnili a zneplatnili tím váš podpis, uzamkněte projekt maker před podepsáním. Digitální podpis jenom znamená, že ručíte za to, že po vašem podpisu do projektu nikdo nezasáhl. Nedokazuje, že jste autorem projektu. Uzamknutí projektu maker tedy nezabrání jinému uživateli nahradit digitální podpis jiným podpisem. Správci podnikové sítě můžou znovu podepsat šablony a doplňky, aby mohli určovat, které prvky budou uživatelé na svých počítačích spouštět.

    • Jestliže vytvoříte doplněk, který slouží k přidání kódu k projektu maker, měl by váš kód určovat, zda je projekt maker digitálně podepsán, a měl by uživatele upozornit na důsledky úprav podepsaného projektu dříve, než budou pokračovat v práci.

    • Při digitálním podpisu maker je důležité použít časové razítko, jímž ostatním uživatelům umožníte ověřit váš podpis i v případě, že vypršela platnost certifikátu k danému podpisu nebo byl certifikát po podpisu odvolán. Podepíšete-li makra bez časového razítka, bude podpis platný jen po dobu platnosti vašeho certifikátu.

Začátek stránky

Digitální certifikát můžete získat od komerční certifikační autority nebo od svého správce zabezpečení.

Informace o certifikačních autoritách, které nabízejí služby pro produkty Microsoftu, najdete v seznamu členů programu Microsoft Root Certificate Program.

Začátek stránky

Vzhledem k tomu, že digitální certifikát, který si sami vytvoříte, není vystavený formální certifikační autoritou, označují se projekty maker podepsané pomocí takového certifikátu jako projekty podepsané svým držitelem. Microsoft Office důvěřuje certifikátu podepsanému svým držitelem jenom na počítači, na kterém se tento certifikát nachází v úložišti osobních certifikátů.

  1. Klikněte na tlačítko Start, přejděte na Všechny programy a klikněte na Microsoft Office, Nástroje systému Microsoft Office a potom na Digitální certifikát pro projekty v jazyce VBA. Do pole Název vašeho certifikátu zadejte popisný název certifikátu.

  2. Když se zobrazí potvrzovací zpráva certifikátu, klikněte na OK.

Chcete-li certifikát zobrazit v úložišti osobních certifikátů, postupujte takto:

  1. Spusťte aplikaci Internet Explorer.

  2. V nabídce Nástroje klikněte na příkaz Možnosti sítě Internet a potom na kartu Obsah.

  3. Klikněte na tlačítko Certifikáty a pak na kartu Osobní.

Začátek stránky

  1. Klikněte na tlačítko Start, potom přejděte na položky Všechny programy, Microsoft Office, Nástroje sady Microsoft Office a pak klikněte na Digitální certifikát pro projekty v jazyce VBA. Do pole Název vašeho certifikátu zadejte popisný název certifikátu.

  2. Když se zobrazí potvrzovací zpráva certifikátu, klikněte na OK.

Pokud chcete certifikát zobrazit v úložišti osobních certifikátů, postupujte takto:

  1. Spusťte Windows Internet Explorer 7.

  2. V nabídce Nástroje klikněte na příkaz Možnosti sítě Internet a potom na kartu Obsah.

  3. Klikněte na tlačítko Certifikáty a pak na kartu Osobní.

Začátek stránky

  1. Otevřete soubor s projektem maker, který chcete podepsat.

    • Na kartě Vývojář klikněte ve skupině Kód na tlačítko Visual Basic.

      Pokud není karta Vývojář dostupná, klikněte na tlačítko Microsoft Office Obrázek tlačítka Office a potom na Možnosti aplikace Excel. Klikněte na Oblíbené a zaškrtněte políčko Zobrazit na pásu kartu Vývojář.

      Poznámka : Pás karet je součástí rozhraní Fluent systému Microsoft Office.

  2. V okně Visual Basic Project Explorer (Prohlížeč projektu ve Visual Basicu) vyberte projekt, který chcete podepsat.

  3. V nabídce Tools (Nástroje) klikněte na Digital Signature (Digitální podpis).

  4. Udělejte jednu z těchto věcí:

    • Pokud jste zatím nevybrali digitální certifikát nebo chcete použít jiný, klikněte na Choose (Zvolit), vyberte certifikát a klikněte dvakrát na OK.

    • Pokud chcete použít aktuální certifikát, klikněte na OK.

      Poznámky : 

      • Podepisujte makra vždycky až po tom, co je řešení otestované a připravené k distribuci, protože provedení jakýchkoli úprav v podepsaném projektu maker vede k odebrání jeho digitálního podpisu. Pokud je však v místním počítači nainstalovaný platný digitální certifikát, který se předtím používal k podepsání daného projektu maker, při uložení se tento projekt maker automaticky znovu podepíše.

      • Pokud chcete uživatelům vašeho řešení zabránit v tom, aby projekt maker omylem změnili a zneplatnili tím váš podpis, uzamkněte projekt maker před podepsáním. Digitální podpis jenom znamená, že ručíte za to, že po vašem podpisu do projektu nikdo nezasáhl. Nedokazuje, že jste autorem projektu. Uzamknutí projektu maker tedy nezabrání jinému uživateli nahradit digitální podpis jiným podpisem. Správci podnikové sítě můžou znovu podepsat šablony a doplňky, aby mohli přesně určovat, které položky můžou uživatelé na svých počítačích spouštět.

      • Jestliže vytvoříte doplněk, který slouží k přidání kódu k projektu maker, měl by váš kód určovat, zda je projekt maker digitálně podepsán, a měl by uživatele upozornit na důsledky úprav podepsaného projektu dříve, než budou pokračovat v práci.

      • Při digitálním podpisu maker je důležité použít časové razítko, jímž ostatním uživatelům umožníte ověřit váš podpis i v případě, že vypršela platnost certifikátu k danému podpisu. Pokud podepíšete makra bez časového razítka, bude podpis platný jenom po dobu platnosti vašeho certifikátu.

  1. Otevřete soubor s projektem maker, který chcete podepsat.

    • V nabídce Nástroje přejděte na Makro a potom klikněte na Visual Basic Editor.

  2. V okně Visual Basic Project Explorer (Prohlížeč projektu ve Visual Basicu) vyberte projekt, který chcete podepsat.

  3. V nabídce Tools (Nástroje) klikněte na Digital Signature (Digitální podpis).

  4. Udělejte jednu z těchto věcí:

    • Pokud jste zatím nevybrali digitální certifikát nebo chcete použít jiný, klikněte na Choose (Zvolit), vyberte certifikát a klikněte dvakrát na OK.

    • Pokud chcete použít aktuální certifikát, klikněte na OK.

      Poznámky : 

      • Podepisujte makra vždycky až po tom, co je řešení otestované a připravené k distribuci, protože provedení jakýchkoli úprav v podepsaném projektu maker vede k odebrání jeho digitálního podpisu. Pokud je však v místním počítači nainstalovaný platný digitální certifikát, který se předtím používal k podepsání daného projektu maker, při uložení se tento projekt maker automaticky znovu podepíše.

      • Pokud chcete uživatelům vašeho řešení zabránit v tom, aby projekt maker omylem změnili a zneplatnili tím váš podpis, uzamkněte projekt maker před podepsáním. Digitální podpis jenom znamená, že ručíte za to, že po vašem podpisu do projektu nikdo nezasáhl. Nedokazuje, že jste autorem projektu. Uzamknutí projektu maker tedy nezabrání jinému uživateli nahradit digitální podpis jiným podpisem. Správci podnikové sítě můžou znovu podepsat šablony a doplňky, aby mohli přesně určovat, které položky můžou uživatelé na svých počítačích spouštět.

      • Jestliže vytvoříte doplněk, který slouží k přidání kódu k projektu maker, měl by váš kód určovat, zda je projekt maker digitálně podepsán, a měl by uživatele upozornit na důsledky úprav podepsaného projektu dříve, než budou pokračovat v práci.

      • Při digitálním podpisu maker je důležité použít časové razítko, jímž ostatním uživatelům umožníte ověřit váš podpis i v případě, že vypršela platnost certifikátu k danému podpisu. Pokud podepíšete makra bez časového razítka, bude podpis platný jenom po dobu platnosti vašeho certifikátu.

Začátek stránky

  1. Otevřete soubor s projektem maker, který chcete podepsat.

    • Na kartě Vývojář klikněte ve skupině Kód na možnost Visual Basic.

      Pokud není karta Vývojář dostupná, klikněte na tlačítko Microsoft Office Obrázek tlačítka Office a potom na Možnosti aplikace PowerPoint. Klikněte na Oblíbené a zaškrtněte políčko Zobrazit na pásu kartu Vývojář.

      Poznámka : Pás karet je součástí rozhraní Fluent systému Microsoft Office.

  2. V okně Visual Basic Project Explorer (Prohlížeč projektu ve Visual Basicu) vyberte projekt, který chcete podepsat.

  3. V nabídce Tools (Nástroje) klikněte na Digital Signature (Digitální podpis).

  4. Udělejte jednu z těchto věcí:

    • Pokud jste zatím nevybrali digitální certifikát nebo chcete použít jiný, klikněte na Choose (Zvolit), vyberte certifikát a klikněte dvakrát na OK.

    • Pokud chcete použít aktuální certifikát, klikněte na OK.

      Poznámky : 

      • Podepisujte makra vždycky až po tom, co je řešení otestované a připravené k distribuci, protože provedení jakýchkoli úprav v podepsaném projektu maker vede k odebrání jeho digitálního podpisu. Pokud je však v místním počítači nainstalovaný platný digitální certifikát, který se předtím používal k podepsání daného projektu maker, při uložení se tento projekt maker automaticky znovu podepíše.

      • Pokud chcete uživatelům vašeho řešení zabránit v tom, aby projekt maker omylem změnili a zneplatnili tím váš podpis, uzamkněte projekt maker před podepsáním. Digitální podpis jenom znamená, že ručíte za to, že po vašem podpisu do projektu nikdo nezasáhl. Nedokazuje, že jste autorem projektu. Uzamknutí projektu maker tedy nezabrání jinému uživateli nahradit digitální podpis jiným podpisem. Správci podnikové sítě můžou znovu podepsat šablony a doplňky, aby mohli přesně určovat, které položky můžou uživatelé na svých počítačích spouštět.

      • Jestliže vytvoříte doplněk, který slouží k přidání kódu k projektu maker, měl by váš kód určovat, zda je projekt maker digitálně podepsán, a měl by uživatele upozornit na důsledky úprav podepsaného projektu dříve, než budou pokračovat v práci.

      • Při digitálním podpisu maker je důležité použít časové razítko, jímž ostatním uživatelům umožníte ověřit váš podpis i v případě, že vypršela platnost certifikátu k danému podpisu. Pokud podepíšete makra bez časového razítka, bude podpis platný jenom po dobu platnosti vašeho certifikátu.

Začátek stránky

  1. Otevřete soubor s projektem maker, který chcete podepsat.

    • V nabídce Nástroje přejděte na Makro a potom klikněte na Visual Basic Editor.

  2. V okně Visual Basic Project Explorer (Prohlížeč projektu ve Visual Basicu) vyberte projekt, který chcete podepsat.

  3. V nabídce Tools (Nástroje) klikněte na Digital Signature (Digitální podpis).

  4. Udělejte jednu z těchto věcí:

    • Pokud jste zatím nevybrali digitální certifikát nebo chcete použít jiný, klikněte na Choose (Zvolit), vyberte certifikát a klikněte dvakrát na OK.

    • Pokud chcete použít aktuální certifikát, klikněte na OK.

      Poznámky : 

      • Podepisujte makra vždycky až po tom, co je řešení otestované a připravené k distribuci, protože provedení jakýchkoli úprav v podepsaném projektu maker vede k odebrání jeho digitálního podpisu. Pokud je však v místním počítači nainstalovaný platný digitální certifikát, který se předtím používal k podepsání daného projektu maker, při uložení se tento projekt maker automaticky znovu podepíše.

      • Pokud chcete uživatelům vašeho řešení zabránit v tom, aby projekt maker omylem změnili a zneplatnili tím váš podpis, uzamkněte projekt maker před podepsáním. Digitální podpis jenom znamená, že ručíte za to, že po vašem podpisu do projektu nikdo nezasáhl. Nedokazuje, že jste autorem projektu. Uzamknutí projektu maker tedy nezabrání jinému uživateli nahradit digitální podpis jiným podpisem. Správci podnikové sítě můžou znovu podepsat šablony a doplňky, aby mohli přesně určovat, které položky můžou uživatelé na svých počítačích spouštět.

      • Jestliže vytvoříte doplněk, který slouží k přidání kódu k projektu maker, měl by váš kód určovat, zda je projekt maker digitálně podepsán, a měl by uživatele upozornit na důsledky úprav podepsaného projektu dříve, než budou pokračovat v práci.

      • Při digitálním podpisu maker je důležité použít časové razítko, jímž ostatním uživatelům umožníte ověřit váš podpis i v případě, že vypršela platnost certifikátu k danému podpisu. Pokud podepíšete makra bez časového razítka, bude podpis platný jenom po dobu platnosti vašeho certifikátu.

Začátek stránky

  1. Otevřete soubor s projektem maker, který chcete podepsat.

    • V nabídce Nástroje přejděte na Makro a potom klikněte na Visual Basic Editor.

  2. V okně Visual Basic Project Explorer (Prohlížeč projektu ve Visual Basicu) vyberte projekt, který chcete podepsat.

  3. V nabídce Tools (Nástroje) klikněte na Digital Signature (Digitální podpis).

  4. Udělejte jednu z těchto věcí:

    • Pokud jste zatím nevybrali digitální certifikát nebo chcete použít jiný, klikněte na Choose (Zvolit), vyberte certifikát a klikněte dvakrát na OK.

    • Pokud chcete použít aktuální certifikát, klikněte na OK.

      Poznámky : 

      • Podepisujte makra vždycky až po tom, co je řešení otestované a připravené k distribuci, protože provedení jakýchkoli úprav v podepsaném projektu maker vede k odebrání jeho digitálního podpisu. Pokud je však v místním počítači nainstalovaný platný digitální certifikát, který se předtím používal k podepsání daného projektu maker, při uložení se tento projekt maker automaticky znovu podepíše.

      • Pokud chcete uživatelům vašeho řešení zabránit v tom, aby projekt maker omylem změnili a zneplatnili tím váš podpis, uzamkněte projekt maker před podepsáním. Digitální podpis jenom znamená, že ručíte za to, že po vašem podpisu do projektu nikdo nezasáhl. Nedokazuje, že jste autorem projektu. Uzamknutí projektu maker tedy nezabrání jinému uživateli nahradit digitální podpis jiným podpisem. Správci podnikové sítě můžou znovu podepsat šablony a doplňky, aby mohli přesně určovat, které položky můžou uživatelé na svých počítačích spouštět.

      • Jestliže vytvoříte doplněk, který slouží k přidání kódu k projektu maker, měl by váš kód určovat, zda je projekt maker digitálně podepsán, a měl by uživatele upozornit na důsledky úprav podepsaného projektu dříve, než budou pokračovat v práci.

      • Při digitálním podpisu maker je důležité použít časové razítko, jímž ostatním uživatelům umožníte ověřit váš podpis i v případě, že vypršela platnost certifikátu k danému podpisu. Pokud podepíšete makra bez časového razítka, bude podpis platný jenom po dobu platnosti vašeho certifikátu.

  1. Otevřete soubor s projektem maker, který chcete podepsat.

    • Na kartě Vývojář klikněte ve skupině Kód na možnost Visual Basic.

      Pokud není karta Vývojář dostupná, klikněte na tlačítko Microsoft Office Obrázek tlačítka Office a potom na Možnosti aplikace Word. Klikněte na Oblíbené a zaškrtněte políčko Zobrazit na pásu kartu Vývojář.

      Poznámka : Pás karet je součástí rozhraní Fluent systému Microsoft Office.

  2. V okně Visual Basic Project Explorer (Prohlížeč projektu ve Visual Basicu) vyberte projekt, který chcete podepsat.

  3. V nabídce Tools (Nástroje) klikněte na Digital Signature (Digitální podpis).

  4. Udělejte jednu z těchto věcí:

    • Pokud jste zatím nevybrali digitální certifikát nebo chcete použít jiný, klikněte na Choose (Zvolit), vyberte certifikát a klikněte dvakrát na OK.

    • Pokud chcete použít aktuální certifikát, klikněte na OK.

      Poznámky : 

      • Podepisujte makra vždycky až po tom, co je řešení otestované a připravené k distribuci, protože provedení jakýchkoli úprav v podepsaném projektu maker vede k odebrání jeho digitálního podpisu. Pokud je však v místním počítači nainstalovaný platný digitální certifikát, který se předtím používal k podepsání daného projektu maker, při uložení se tento projekt maker automaticky znovu podepíše.

      • Pokud chcete uživatelům vašeho řešení zabránit v tom, aby projekt maker omylem změnili a zneplatnili tím váš podpis, uzamkněte projekt maker před podepsáním. Digitální podpis jenom znamená, že ručíte za to, že po vašem podpisu do projektu nikdo nezasáhl. Nedokazuje, že jste autorem projektu. Uzamknutí projektu maker tedy nezabrání jinému uživateli nahradit digitální podpis jiným podpisem. Správci podnikové sítě můžou znovu podepsat šablony a doplňky, aby mohli přesně určovat, které položky můžou uživatelé na svých počítačích spouštět.

      • Jestliže vytvoříte doplněk, který slouží k přidání kódu k projektu maker, měl by váš kód určovat, zda je projekt maker digitálně podepsán, a měl by uživatele upozornit na důsledky úprav podepsaného projektu dříve, než budou pokračovat v práci.

      • Při digitálním podpisu maker je důležité použít časové razítko, jímž ostatním uživatelům umožníte ověřit váš podpis i v případě, že vypršela platnost certifikátu k danému podpisu. Pokud podepíšete makra bez časového razítka, bude podpis platný jenom po dobu platnosti vašeho certifikátu.

Začátek stránky

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×