Digitální podpis projektu maker

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Tento článek vysvětluje, jak můžete digitálně podepsat soubor nebo Projekt maker pomocí Certifikát. Pokud ještě nemáte digitálního certifikátu, je nutné získat. Chcete-li otestovat projekty maker ve vašem počítači, můžete vytvořit vlastní certifikát pomocí nástroje Selfcert.exe.

Blog k systému Office

V tomto článku:

Získání digitálního certifikátu pro podpis

Vytvoření vlastního digitálního certifikátu s automatickým podpisem

Digitální podpis projektu maker

Získání digitálního certifikátu pro podpis

Digitální certifikát můžete získat od komerční certifikační autority (CA) nebo od správce zabezpečení.

Informace o certifikačních autoritách, které nabízejí služby pro produkty Microsoftu, najdete v seznamu členů programu Microsoft Root Certificate Program.

Začátek stránky

Vytvoření vlastního digitálního certifikátu s automatickým podpisem

Vzhledem k tomu, že digitální certifikát, který sami vytvoříte, není vydán certifikační autoritou, nazýváme projekty maker digitálně podepsané pomocí takového certifikátu termínem projekty s automatickým podpisem. Sada Microsoft Office důvěřuje certifikátu podepsanému samotným vlastníkem (automatickým podpisem) pouze v počítači, který má tento certifikát v úložišti osobních certifikátů.

Vytvoření vlastního certifikátu

Který operační systém používáte?

Windows Vista

Windows XP

Windows Vista

  1. Klepněte na tlačítko Start, přejděte na položku Všechny programy, klepněte na položku Microsoft Office, potom na položku Nástroje sady Microsoft Office a poté klepněte na příkaz Digitální certifikát pro projekty VBA. Do pole Název vašeho certifikátu zadejte popisný název certifikátu.

  2. Když se zobrazí zpráva s potvrzením o vytvoření certifikátu, klepněte na tlačítko OK.

Chcete-li certifikát zobrazit v úložišti osobních certifikátů, postupujte takto:

  1. Spusťte aplikaci Windows Internet Explorer.

  2. V nabídce Nástroje klepněte na příkaz Možnosti sítě Internet a potom na kartu Obsah.

  3. Klepněte na tlačítko Certifikáty a pak na kartu Osobní.

Začátek stránky

Windows XP

  1. Klepněte na tlačítko Start, přejděte na položku Všechny programy, potom na položku Microsoft Office a položku Nástroje sady Microsoft Office a poté klepněte na příkaz Digitální certifikát pro projekty VBA. Do pole Název vašeho certifikátu zadejte popisný název certifikátu.

  2. Když se zobrazí zpráva s potvrzením o vytvoření certifikátu, klepněte na tlačítko OK.

Chcete-li certifikát zobrazit v úložišti osobních certifikátů, postupujte takto:

  1. Spusťte aplikaci Windows Internet Explorer.

  2. V nabídce Nástroje klepněte na příkaz Možnosti sítě Internet a potom na kartu Obsah.

  3. Klepněte na tlačítko Certifikáty a pak na kartu Osobní.

Začátek stránky

Digitální podpis projektu

Kterou aplikaci systému Microsoft Office 2007 používáte?

Aplikace Excel

Excel

  1. Otevřete soubor obsahující maker, které chcete Pokud se chcete odhlásit.

    • Na kartě Vývojář klikněte ve skupině Kód na tlačítko Visual Basic.

      Pokud není k dispozici karta Vývojář, klikněte na Tlačítko Microsoft Office Obrázek tlačítka a potom klikněte na Možnosti aplikace Excel. Klikněte na populární a potom zaškrtněte políčko Zobrazit kartu Vývojář na pásu karet.

      Poznámka : Pás karet je součástí rozhraní Fluent systému Microsoft Office.

  2. V podokně Project Explorer (Prohlížeč projektů) jazyka Visual Basic vyberte projekt, který chcete podepsat.

  3. V nabídce Tools (Nástroje) klepněte na příkaz Digital Signature (Digitální podpis).

  4. Proveďte jednu z následujících akcí:

    • Pokud jste předtím nevybrali digitální certifikát nebo chcete použít jiný, klepněte na tlačítko Choose (Zvolit), vyberte certifikát a poté dvakrát klepněte na tlačítko OK.

    • Chcete-li použít aktuální certifikát, klepněte na tlačítko OK.

      Poznámky : 

      • Makra podepište teprve poté, co byl projekt maker podroben testům a je připraven k distribuci, protože provedení jakýchkoli úprav v podepsaném projektu maker vede k odstranění digitálního podpisu projektu. Pokud je však v místním počítači nainstalován platný digitální certifikát, který byl předtím použit k podepsání projektu maker, bude projekt maker při uložení automaticky znovu podepsán.

      • Chcete-li uživatelům vašeho řešení zabránit v tom, aby projekt maker omylem upravili a znehodnotili váš podpis, potom projekt před podepsáním uzamkněte. Digitální podpis pouze znamená, že ručíte za to, že po vašem podpisu do projektu nikdo nezasáhl. Nedokazuje, že jste autorem tohoto projektu. Uzamknutí projektu maker tedy nezabrání jinému uživateli nahradit digitální podpis jiným podpisem. Správce podnikové sítě může například znovu podepsat šablony a doplňky, aby mohl přesně určovat, které prvky mohou uživatelé ve svých počítačích spouštět.

      • Jestliže vytvoříte doplněk, který slouží k přidání kódu k projektu maker, měl by váš kód určovat, zda je projekt maker digitálně podepsán, a měl by uživatele upozornit na důsledky úprav podepsaného projektu dříve, než budou pokračovat v práci.

      • Při digitálním podpisu maker je důležité použít časové razítko, jímž ostatním uživatelům umožníte ověřit váš podpis i po vypršení platnosti certifikátu k danému podpisu. Podepíšete-li makra bez časového razítka, podpis bude platný jen po dobu platnosti vašeho certifikátu.

Začátek stránky

Outlook

  1. Otevřete soubor s projektem maker, který chcete podepsat.

    • V nabídce Nástroje přejděte na příkaz Makro a pak klepněte na příkaz Editor jazyka Visual Basic.

  2. V podokně Project Explorer (Prohlížeč projektů) jazyka Visual Basic vyberte projekt, který chcete podepsat.

  3. V nabídce Tools (Nástroje) klepněte na příkaz Digital Signature (Digitální podpis).

  4. Proveďte jednu z následujících akcí:

    • Pokud jste předtím nevybrali digitální certifikát nebo chcete použít jiný, klepněte na tlačítko Choose (Zvolit), vyberte certifikát a poté dvakrát klepněte na tlačítko OK.

    • Chcete-li použít aktuální certifikát, klepněte na tlačítko OK.

      Poznámky : 

      • Podepsání makra pouze po řešení Testováno a je připraven k rozdělení, protože žádným způsobem změně kódu podepsaný makra je digitální podpis se odebere. Ale pokud máte platný digitální certifikát, který dříve používal pro podpis projektu ve vašem počítači, maker je automaticky znovu podepsán při uložení.

      • Chcete-li uživatelům vašeho řešení zabránit v tom, aby projekt maker omylem upravili a znehodnotili váš podpis, potom projekt před podepsáním uzamkněte. Digitální podpis pouze znamená, že ručíte za to, že po vašem podpisu do projektu nikdo nezasáhl. Nedokazuje, že jste autorem tohoto projektu. Uzamknutí projektu maker tedy nezabrání jinému uživateli nahradit digitální podpis jiným podpisem. Správce podnikové sítě může například znovu podepsat šablony a doplňky, aby mohl přesně určovat, které prvky mohou uživatelé ve svých počítačích spouštět.

      • Jestliže vytvoříte doplněk, který slouží k přidání kódu k projektu maker, měl by váš kód určovat, zda je projekt maker digitálně podepsán, a měl by uživatele upozornit na důsledky úprav podepsaného projektu dříve, než budou pokračovat v práci.

      • Při digitálním podpisu maker je důležité použít časové razítko, jímž ostatním uživatelům umožníte ověřit váš podpis i po vypršení platnosti certifikátu k danému podpisu. Podepíšete-li makra bez časového razítka, podpis bude platný jen po dobu platnosti vašeho certifikátu.

Začátek stránky

PowerPoint

  1. Otevřete soubor s projektem maker, který chcete podepsat.

    • Na kartě Vývojář klepněte ve skupinovém rámečku Kód na položku Jazyk Visual Basic.

      Pokud není k dispozici karta Vývojář, klikněte na Tlačítko Microsoft Office Obrázek tlačítka a potom klikněte na Možnosti aplikace PowerPoint. Klikněte na populární a potom zaškrtněte políčko Zobrazit kartu Vývojář na pásu karet.

      Poznámka : Pás karet je součástí rozhraní Fluent systému Microsoft Office.

  2. V podokně Project Explorer (Prohlížeč projektů) jazyka Visual Basic vyberte projekt, který chcete podepsat.

  3. V nabídce Tools (Nástroje) klepněte na příkaz Digital Signature (Digitální podpis).

  4. Proveďte jednu z následujících akcí:

    • Pokud jste předtím nevybrali digitální certifikát nebo chcete použít jiný, klepněte na tlačítko Choose (Zvolit), vyberte certifikát a poté dvakrát klepněte na tlačítko OK.

    • Chcete-li použít aktuální certifikát, klepněte na tlačítko OK.

      Poznámky : 

      • Makra podepište teprve poté, co byl projekt maker podroben testům a je připraven k distribuci, protože provedení jakýchkoli úprav v podepsaném projektu maker vede k odstranění digitálního podpisu projektu. Pokud je však v místním počítači nainstalován platný digitální certifikát, který byl předtím použit k podepsání projektu maker, bude projekt maker při uložení automaticky znovu podepsán.

      • Pokud chcete uživatelům vašeho řešení zabránit omylem změna projekt maker a zrušili platnost vašeho podpisu, maker zamknout, než se přihlásit. Digitální podpis s textem jenom zaručit, že projekt nebyla zfalšován jste podepsali. Digitální podpis není prokážete, že jste sami napsali projektu. Proto zamykání projekt maker nezabrání jinému uživateli nahradit digitální podpis s jiným podpisem. Podnikové Správci můžete změnit podpis šablon a doplňky tak, aby řídit přesně co uživatelé můžete spustit na svém počítači.

      • Jestliže vytvoříte doplněk, který slouží k přidání kódu k projektu maker, měl by váš kód určovat, zda je projekt maker digitálně podepsán, a měl by uživatele upozornit na důsledky úprav podepsaného projektu dříve, než budou pokračovat v práci.

      • Při digitálním podpisu maker je důležité použít časové razítko, jímž ostatním uživatelům umožníte ověřit váš podpis i po vypršení platnosti certifikátu k danému podpisu. Podepíšete-li makra bez časového razítka, podpis bude platný jen po dobu platnosti vašeho certifikátu.

Začátek stránky

Publisher

  1. Otevřete soubor s projektem maker, který chcete podepsat.

    • V nabídce Nástroje přejděte na příkaz Makro a pak klepněte na příkaz Editor jazyka Visual Basic.

  2. V podokně Project Explorer (Prohlížeč projektů) jazyka Visual Basic vyberte projekt, který chcete podepsat.

  3. V nabídce Tools (Nástroje) klepněte na příkaz Digital Signature (Digitální podpis).

  4. Proveďte jednu z následujících akcí:

    • Pokud jste předtím nevybrali digitální certifikát nebo chcete použít jiný, klepněte na tlačítko Choose (Zvolit), vyberte certifikát a poté dvakrát klepněte na tlačítko OK.

    • Chcete-li použít aktuální certifikát, klepněte na tlačítko OK.

      Poznámky : 

      • Makra podepište teprve poté, co byl projekt maker podroben testům a je připraven k distribuci, protože provedení jakýchkoli úprav v podepsaném projektu maker vede k odstranění digitálního podpisu projektu. Pokud je však v místním počítači nainstalován platný digitální certifikát, který byl předtím použit k podepsání projektu maker, bude projekt maker při uložení automaticky znovu podepsán.

      • Chcete-li uživatelům vašeho řešení zabránit v tom, aby projekt maker omylem upravili a znehodnotili váš podpis, potom projekt před podepsáním uzamkněte. Digitální podpis pouze znamená, že ručíte za to, že po vašem podpisu do projektu nikdo nezasáhl. Nedokazuje, že jste autorem tohoto projektu. Uzamknutí projektu maker tedy nezabrání jinému uživateli nahradit digitální podpis jiným podpisem. Správce podnikové sítě může například znovu podepsat šablony a doplňky, aby mohl přesně určovat, které prvky mohou uživatelé ve svých počítačích spouštět.

      • Jestliže vytvoříte doplněk, který slouží k přidání kódu k projektu maker, měl by váš kód určovat, zda je projekt maker digitálně podepsán, a měl by uživatele upozornit na důsledky úprav podepsaného projektu dříve, než budou pokračovat v práci.

      • Při digitálním podpisu maker je důležité použít časové razítko, jímž ostatním uživatelům umožníte ověřit váš podpis i po vypršení platnosti certifikátu k danému podpisu. Podepíšete-li makra bez časového razítka, podpis bude platný jen po dobu platnosti vašeho certifikátu.

Začátek stránky

Visio

  1. Otevřete soubor s projektem maker, který chcete podepsat.

    • V nabídce Nástroje přejděte na příkaz Makro a pak klepněte na příkaz Editor jazyka Visual Basic.

  2. V vizuální Základní Průzkumník projektu, vyberte projekt, který chcete podepsat.

  3. V nabídce Tools (Nástroje) klepněte na příkaz Digital Signature (Digitální podpis).

  4. Proveďte jednu z následujících akcí:

    • Pokud jste předtím nevybrali digitální certifikát nebo chcete použít jiný, klepněte na tlačítko Choose (Zvolit), vyberte certifikát a poté dvakrát klepněte na tlačítko OK.

    • Chcete-li použít aktuální certifikát, klepněte na tlačítko OK.

      Poznámky : 

      • Makra podepište teprve poté, co byl projekt maker podroben testům a je připraven k distribuci, protože provedení jakýchkoli úprav v podepsaném projektu maker vede k odstranění digitálního podpisu projektu. Pokud je však v místním počítači nainstalován platný digitální certifikát, který byl předtím použit k podepsání projektu maker, bude projekt maker při uložení automaticky znovu podepsán.

      • Chcete-li uživatelům vašeho řešení zabránit v tom, aby projekt maker omylem upravili a znehodnotili váš podpis, potom projekt před podepsáním uzamkněte. Digitální podpis pouze znamená, že ručíte za to, že po vašem podpisu do projektu nikdo nezasáhl. Nedokazuje, že jste autorem tohoto projektu. Uzamknutí projektu maker tedy nezabrání jinému uživateli nahradit digitální podpis jiným podpisem. Správce podnikové sítě může například znovu podepsat šablony a doplňky, aby mohl přesně určovat, které prvky mohou uživatelé ve svých počítačích spouštět.

      • Jestliže vytvoříte doplněk, který slouží k přidání kódu k projektu maker, měl by váš kód určovat, zda je projekt maker digitálně podepsán, a měl by uživatele upozornit na důsledky úprav podepsaného projektu dříve, než budou pokračovat v práci.

      • Při digitálním podpisu maker je důležité použít časové razítko, jímž ostatním uživatelům umožníte ověřit váš podpis i po vypršení platnosti certifikátu k danému podpisu. Podepíšete-li makra bez časového razítka, podpis bude platný jen po dobu platnosti vašeho certifikátu.

Začátek stránky

Word

  1. Otevřete soubor s projektem maker, který chcete podepsat.

    • Na kartě Vývojář klepněte ve skupinovém rámečku Kód na položku Jazyk Visual Basic.

      Pokud není k dispozici karta Vývojář, klikněte na Tlačítko Microsoft Office Obrázek tlačítka a potom klikněte na Možnosti aplikace Word. Klikněte na populární a potom zaškrtněte políčko Zobrazit kartu Vývojář na pásu karet.

      Poznámka : Pás karet je součástí rozhraní Fluent systému Microsoft Office.

  2. V podokně Project Explorer (Prohlížeč projektů) jazyka Visual Basic vyberte projekt, který chcete podepsat.

  3. V nabídce Tools (Nástroje) klepněte na příkaz Digital Signature (Digitální podpis).

  4. Proveďte jednu z následujících akcí:

    • Pokud jste předtím nevybrali digitální certifikát nebo chcete použít jiný, klepněte na tlačítko Choose (Zvolit), vyberte certifikát a poté dvakrát klepněte na tlačítko OK.

    • Chcete-li použít aktuální certifikát, klepněte na tlačítko OK.

      Poznámky : 

      • Podepsání makra až po řešení otestování a je připraven k rozdělení, protože žádným způsobem změně kódu podepsaný makra je digitální podpis se odebere. Ale pokud máte platný digitální certifikát, který dříve používal podepsat projekt ve vašem počítači maker je automaticky znovu podepsán, když ji uložíte.

      • Chcete-li uživatelům vašeho řešení zabránit v tom, aby projekt maker omylem upravili a znehodnotili váš podpis, potom projekt před podepsáním uzamkněte. Digitální podpis pouze znamená, že ručíte za to, že po vašem podpisu do projektu nikdo nezasáhl. Nedokazuje, že jste autorem tohoto projektu. Uzamknutí projektu maker tedy nezabrání jinému uživateli nahradit digitální podpis jiným podpisem. Správce podnikové sítě může například znovu podepsat šablony a doplňky, aby mohl přesně určovat, které prvky mohou uživatelé ve svých počítačích spouštět.

      • Jestliže vytvoříte doplněk, který slouží k přidání kódu k projektu maker, měl by váš kód určovat, zda je projekt maker digitálně podepsán, a měl by uživatele upozornit na důsledky úprav podepsaného projektu dříve, než budou pokračovat v práci.

      • Při digitálním podpisu maker je důležité použít časové razítko, jímž ostatním uživatelům umožníte ověřit váš podpis i po vypršení platnosti certifikátu k danému podpisu. Podepíšete-li makra bez časového razítka, podpis bude platný jen po dobu platnosti vašeho certifikátu.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Sdílení Facebook Facebook Twitter Twitter E-mail E-mail

Byly tyto informace užitečné?

Výborně! Je ještě něco dalšího, co byste nám chtěli dát vědět?

Jak bychom ho mohli vylepšit?

Děkujeme vám za zpětnou vazbu.

×